COPA. Шаблоны кода 1С

Опубликовал - - (komradz) в раздел Программирование - Инструментарий

Программа, позволяющая сохранять части кода, для дальнейшего использования при разработке. Форк CopyPaster1C на python.

Выполняя рутинные разработки, периодически пользовался замечательной программой CopyPaster1C , даже уже не помню какой из старых версий. Программа очень понравилась, и изучая python, решил написать свой аналог (в связи с тем , что исходники CopyPaster1C были закрыты).

Немного расширил ее функционал. Исходники открыты, любой желающий может ее дописать\изменить под свои нужды.

Программа работает со старой базой sqlite от CopyPaster1C.

Установки программа не требует, достаточно распаковать файлы из архива, и можно пользоваться. Установки интерпретатора python также не требуется, все упаковано в *.exe. Вы просто сохраняете куски кода, пишете ключевые слова через пробел или просто тему, для того, чтобы в дальйнешем можно было удобно найти интересуюший вас код и вставить в проект.

Программа сворачивается в трей, имеется поиск по темам, тексту кода, а также горячие клавиши для поиска и выхода.

В архиве база уже минимально наполнена кусками кода.

Скачать файлы

Наименование Файл Версия Размер
Copa
.zip 25,20Mb
22.03.17
57
.zip 25,20Mb 57 Скачать

См. также

Комментарии
1. Sergey (chursinov.s) 22.03.17 10:29 Сейчас в теме
Привет, спасибо попробую. Походу полезная штука :).
3. Алексей Ларин (roofless) 19 23.03.17 14:42 Сейчас в теме
4. - - (komradz) 51 23.03.17 15:14 Сейчас в теме
(3) На здоровье, пользуйтесь))
5. Evgeniy Nikolaenko (DrBlack) 17 23.03.17 15:26 Сейчас в теме
эмм, а чем лучше штатного механизма шаблонов кода?
а то я не вкурил что-то... О_о
Craig; nikita0832; TreeDogNight; Nelli_A86; sulfur17; JohnConnor; +6 Ответить 2
6. - - (komradz) 51 23.03.17 17:05 Сейчас в теме
(5) Я думаю это вопрос предпочтений, ну и обсуждение этого вопроса есть в старой публикации.
8. - - (komradz) 51 24.03.17 08:47 Сейчас в теме
(7) в чем собственно вопрос?
9. Sergey Andreev (starik-2005) 964 24.03.17 11:58 Сейчас в теме
(5)
а чем лучше штатного механизма шаблонов кода
А чем он в принципе хорош? Поиска там нет толкового (где хештеги?), вызывается чорд знает как. Что-то не видел масс, которые бы пользовались штатным механизмом - так, отдельные персонажи.

С другой стороны, толку в таких утилитах не вижу - предпочитаю код писать с нуля. Да, вот такой я крутой программер ))

С третьей стороны, пишешь ключевое слово и нажимаешь Ctrl+Q, после чего выбираешь нужный код. Что-то в этом есть.
10. Evgeniy Nikolaenko (DrBlack) 17 24.03.17 13:44 Сейчас в теме
(9)
Что-то не видел масс, которые бы пользовались штатным механизмом
А кто у нас в массах-то? Случайно открывшие конфигуратор бухгалтера? Студет из франча?
Тру программисты как раз используют шаблоны (или их аналоги как у ТС), вот пару моих:
УЗ -> Ctrl+Q
// УЗ № 524 "Комментарий" Николаенко Е.В. НАЧАЛО

// УЗ № 524 "Комментарий" Николаенко Е.В. КОНЕЦ

УЗк -> Ctrl+Q
// УЗ № 524 "Комментарий" Николаенко Е.В.

Отл -> Ctrl+Q
#Если _ Тогда

#КонецЕсли

ЗЫ - третий вариант рекомендую всем, внутри данной обертки нужно привести входящие переменные к необходимым типам, что позволяет... ;)
11. Роман Ложкин (webester) 22 24.03.17 15:30 Сейчас в теме
(10)
#Если _ Тогда

#КонецЕсли

Как то проще Если 1 = 2 Тогда .... КонецЕсли;
Мне нравятся шаблоны чистова очень удобные. Ставим в параметрах "автозамена включить с подсказкой" и через какое то время типовые конструкции сами из под курсора прыгают. Ctrl + Q не удобно. Все работает само.
Craig; Yakud3a; TreeDogNight; +3 Ответить 1
12. Роман Ложкин (webester) 22 24.03.17 15:41 Сейчас в теме
(8)Не увидел ссылку, присмотрелся, рассмотрел.
13. Владимир Чаклин (vec435) 15 31.03.17 13:49 Сейчас в теме
если из этой базы будет вывод в
1) тот же самый шаблон 1С
2) любой другой формат (chm.pdf,html)

- цены не будет
14. Леонид (leosoft) 79 19.05.17 10:43 Сейчас в теме
Для меня в CopyPaster1C шрифт мелковат... А у Вас его можно менять?
Не могли бы Вы на git выложить exe-шник? А то у меня sm закончились.
15. Василий Казьмин (awk) 672 19.05.17 12:46 Сейчас в теме
(11) На последних релизах не работает. Вызывает ошибку компиляции...
16. Роман Ложкин (webester) 22 19.05.17 16:54 Сейчас в теме
(15)Что не работает на последних релизах? "Если 1 = 2 Тогда"? на 8.3.9.2170 еще работало. Я как-то уже переключился на "Если Ложь Тогда".
17. Василий Казьмин (awk) 672 22.05.17 10:35 Сейчас в теме
(16) Не работает
#Если _ Тогда
.
18. Олег Афанасьев (DAL) 22.05.17 10:44 Сейчас в теме
А я вообще на макро-кеях работаю. Мне так удобнее)))
19. Evgeniy Nikolaenko (DrBlack) 17 22.05.17 11:09 Сейчас в теме
(17) На каких именно? У нас 8.3.9.1850, полет нормальный...
(16) Ваша конструкция компилируется, а "#Если _ Тогда" нет, что является более тру-решением :)
20. Василий Казьмин (awk) 672 22.05.17 12:27 Сейчас в теме
(19) У вас режим совместимости стоит. Если не ошибаюсь, то с 8.3.8 началось (могу ошибаться)...
21. Evgeniy Nikolaenko (DrBlack) 17 22.05.17 14:25 Сейчас в теме
(20) У нас УПП, стоял режим совместимости (уж забыл какой он там по умолчанию, но древний факт), провели работы по снятию режима совместимости, т.е. совсем отключили, платформа была 8.3.8.х, сейчас 8.3.9.х., также используем тонкий и web-клиент.

Собственно к чему я, во всех вариантах данный комментарий работал и продолжает работать, может быть используете как-то неправильно?

#Если _ Тогда
    СсылкаНаОбъект = Справочники.Номенклатура.ПустаяСсылка();
    ТЗ = Новый ТаблицаЗначений;
#КонецЕсли
...Показать Скрыть
22. Василий Казьмин (awk) 672 22.05.17 17:38 Сейчас в теме
(21) Функциональность Как стало Как было Результат изменения
Встроенный язык.
При компиляции текстов на встроенном языке генерируется ошибка, если используется отсутствующая директива компиляции.
В режиме совместимости с версией 8.3.8 поведение не изменилось.
При использовании неизвестной директивы компиляции не генерировалось ошибки при компиляции модуля. Повышен контроль за исходными текстами. Уменьшено количество сложно обнаруживаемых проблем (когда используемая директива компиляции незначительно отличается от настоящей).

Источник: http://downloads.v8.1c.ru/content//Platform/8_3_9_2233/1cv8upd.htm#35122c67-e9bf-11e5-a3f7-0050569f678a
23. Evgeniy Nikolaenko (DrBlack) 17 23.05.17 08:53 Сейчас в теме
(22) Платформа 8.3.9.х, режим совместимости: "Не использовать", всё работает, что я делаю не так?

upd

Сорян, не увидел сразу, у нас 8.3.9.1850, а проблемы начнутся как перейдем на 8.3.9.2233 или выше.
Придется выпиливать данные комментарии :(
24. Василий Казьмин (awk) 672 23.05.17 11:09 Сейчас в теме
(23) Ошибся я. Я перепутал директивы компиляции и директивы препроцессора. Но задуматься о использовании стоит. Так как на 1С после такого надежи никакой....
25. Алексей 1 (AlX0id) 25.05.17 10:57 Сейчас в теме
(9)
А чего там искать? )
У меня, например, чуть более сложные механизмы хранятся в вики на редмайн-сервере.
Простые и частоиспользуемые шаблоны - в шаблонах текста.
Соответственно, сам файлик шаблона хранится на bitbucket - оттуда его можно притащить к любому клиенту или на любой свой комп в пару кликов. Ну или актуализировать без особых проблем.
Оставьте свое сообщение