gifts2017

Статья о том, как облегчить перевод основных средств в бюджетных учреждениях с внебюджета на бюджет

Опубликовал Денис Денисовский (апостол) в раздел Программирование - Практика программирования

Данная статья не предлагает создания универсальной обработки, но поможет облегчить эту работу.

Решил написать небольшую статью о том, как облегчить перевод основных средств в бюджетных учреждениях с внебюджета на бюджет, поскольку было так много вопросов  на эту тему. 

Для примера будем рассматривать перевод библиотечного фонда.

Пункт 1 Необходимо списать основные средства с внебюджета.  Делаем  это документом «Списание литературы».

Пункт 2 После того, как мы выполнили Пункт 1, нам необходимо в справочнике «Основные средства» поменять данные у списанных объектов с внебюджетных на бюджетные.

Пункт 3 Принимаем основные средства.  Делаем  это документом «Безвозмездное получение ОС, НМА,НПА»

Пункт 4 Принять к учету основные средства.

Упростим себе работу на пункте 3.

Принятие основных средств документом «Безвозмездное получение ОС, НМА, НПА, при заполнении табличной части, происходит вручную в пошаговом режиме, долго.

Я предлагаю в этот документ вставить кнопочку «заполнить», при нажатии на которую откроется «справочник Основные средства». В этом справочнике мы сможем выбрать сразу все основные средства, которые необходимо принять к учету. При данном варианте заполнения, автоматически заполнятся и строки табличной части, такие как: КБК, ОКОФ, Количество, Сумма.

Кто-то может сказать, а зачем это надо? Ну, если не надо, то не надо. Но, я думаю, что найдется немало пользователей, которым этот способ пригодится.

Приступим к практической части реализации проекта.

Сразу оговорюсь, ничего глобального мы переделывать не будем, мы лишь слегка изменим существующий модуль документа.

Открываем  конфигуратор.

Находим в ветке «Документы» (рис 1) документ под названием «ОС_БезвПоступление»  (рис 2.).

Открываем вкладку форма (рис 3).

Далее на панели инструментов выбираем кнопочку «Слои» (рис 4) и на ней видимым оставляем только два слоя: Основной и Таблица.

Создадим кнопку «Подбор». В свойствах этой кнопки на вкладке «Дополнительно» укажем то, что изображено на рисунке 5.

Также следует  вызвать контекстное меню нашей кнопки и в разделе «Поместить», выбрать поместить в основной слой (рис 6).

После описанных выше процедур,  откроем закладку «Модуль» , и напишем следующий код:

 

 

Процедура Подбор()                                                                     
  ОткрытьПодбор("Справочник.ОсновныеСредства","ФормаСписка",,1)
 КонецПроцедуры         

                                                                                        

Функция МожноДобавить  (Эл)                                                                                      
  Можно=1;
  ВыбратьСтроки();
  Пока ПолучитьСтроку()=1 Цикл   
  Если ВнеоборотныйАктив=Эл Тогда     
  Можно=0 ;                                          
  Прервать;
  КонецЕсли;                                                                                               
  КонецЦикла;                                                                                                                     
  Возврат Можно;                                                                                               
  КонецФункции

                                                     

Процедура ОбработкаПодбора(Эл)
Если МожноДобавить(Эл)=1 Тогда                                                                                        
НоваяСтрока();                                                                                        
ВнеоборотныйАктив=Эл;
ПриВыбореВнеобортногоАктива(); 
Иначе                                                                                                  
Предупреждение("Данный товар уже выбран");                           
КонецЕсли;                                                                                                     
КонецПроцедуры 

                                                                                 

Маленькое замечание: описанные процедуры помещаем сразу за процедурой «ПриВыбореВнеобортногоАктива». Теперь в процедуру «ПриВыбореВнеобортногоАктива» добавим следующие строчки:

ОКОФ=ВнеоборотныйАктив.ОКОФ;                                                                         
ФКР=ВнеоборотныйАктив.КБКУчета;
Сумма=ВнеоборотныйАктив.ПервоначальнаяСтоимость;                                                       
Если ВнеоборотныйАктив.КоличественныйУчет=1 Тогда                                       
Количество="";                                                                                  
Иначе                                                                 
Количество=1;
КонецЕсли;  

Они нужны для автоматического заполнение соответствующих колонок в табличной части документа.

Ну, вот и все. Все необходимые изменения произведены. Сохраняем и работаем.

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Епрст (Ёпрст) 16.11.09 08:50
Какое отношение ЭТО имеет к 1с++ ??????????
2. Денис Денисовский (апостол) 16.11.09 08:53
извини, не в тот раздел поместил сейчас исправлю
3. Александр (dalexv) 20.11.09 10:49
А еще можно документ Безвозмездное поступление ОС сделать на основании Списания ОС (колич.учет). Тоже самое касается и перевода МЗ с в/б на бюджет
4. Дмитрий (zbug) 02.12.09 17:05
Огорчу Вас, дорогой автор. Перевод ОС с внебюджета на бюджет делается прекрасно и без какой-либо правки документов списания и безвозмездного поступления ОС.
Совершенно достаточно списать - и это ОЧЕНЬ ВАЖНО - на 241 статью.
И потом оприходовать на бюджет документом, как вы правильно заметили, "Безвозмездное поступление ОС" - и это ОЧЕНЬ ВАЖНО - со 180 статьи. И все.
Кстати, при проведении документ "Безвозмездное поступление ОС" сам прекрасно запишет в справочник ОС новые реквизиты - номера счетов, КБК и источник финансирования. Так что в Вашей второй статье вообще нет необходимости. Посмотрите, ради интереса, код в "Модуле документа".
Кстати, а еще неплохо было бы ознакоvиться с некоторыми стандартными инструментами программиста: SetAttr.ert и UChoice.ert
5. Денис Денисовский (апостол) 03.12.09 03:42
(4) Уважаемый я и не спорю что при проведении Документа безвозмездное поступление, все реквизиты подставиться автоматически. Но хочу заметить, что в конфигурации 1с Бухгалтерия бюджетного учреждения, Документ Безвозмездное поступление заполняется построчно, т.е. каждый раз необходимо добавлять строку и выбирать ос из справочника. В этой статье я всего лишь предложил, добавить процедуру подбора, чтобы можно было вести группой ввод сразу всех выбранных ос и тем самым облегчить себе работу вот и все. И как правильно заметил товарищ Dalexv этот документ нужно сделать и на основании документа списания. И еще одно замечание, а вы не забываете, про изменение реквизитов в справочнике ос у списанных объектов. И как вы говорите если бы все было легко и просто, то таких вопросов бы и не возникало. И напоследок я же написал тем, кому это ненадо не читайте, но есть много людей, которым это может быть полезным.
6. Дмитрий (zbug) 03.12.09 10:26
Ну если в Вашем учреждении библиотечный фонд внесен в справочник по наименованиям, могу Вам только посочувствовать. Если же на 10107 десяток-два позиций, то в любом случае конечному пользователю проще набить руками, чем лезть в конфигуратор.
Если это (перевод с внебюджета на бюджет) - не разовая работа, а часто выполняемая, то, влезая в типовую конфигурацию, Вы обрекаете себя на ковыряние в ней при каждом обновлении.
А если уж всерьез думать об облегчении для пользователя, то надо не ковырять типовые документы, а сделать специальный документ для перевода ОС с внебюджета на бюджет, который бы сам и списывал, и приходовал, и реквизиты в справочнике менял.