gifts2017

Статистика T-57 (форма 2009 г.)

Опубликовал Елена (Elena_Mosh) в раздел Печать - Статистики

Форма T-57 - сведение о зарплате по профессиям и должностям (форма 2009 г.)

За основу взята разработка http://infostart.ru/public/15286/

В ней, кроме формы, внесены исправления -

1.В полностью отработавших сотрудниках не учитывались те, которые были в командировках

2.В выплатах по районному регулированию учитывался только РК, и не учитывалась СН

3. Добавлена возможность формирования по выбранному подразделению (списку подразделений) - это нужно при наличии обособленных подразделений

ну и так немного по мелочи

23.11.2009 исправлено - в разделе II выводится стаж работы на предприятии, а не страховой

P.S. Всем проголосовавшим - если нужен исправленный файл и нет возможности закачать второй раз из-за рейтинга - стучитесь в личку

24.11.2009 добавлен отчет для тех, у кого список категорий не типовой - в начале модуля есть функция ОпределитьКатегорию() - в ней настройте ваше соответствие. В случае если категория в этом перечне не найдена, сотрудник относится к рабочим

26.11.2009 из видов расчетов, учитываемых в доплатах, убраны оплата по табелю и оплата по тарифу (чтобы лишний раз галочки не снимать)

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.rar 42,43Kb
06.03.13
327
.rar 42,43Kb 327 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Vladimir (Boroda) 20.11.09 19:06
Спасибо! Молодец! Только вот небольшое замечаньице: стаж в разделе II теперь считается не общий или страховой, а стаж работы на предприятии.
2. Борис Найманов (poligon) 21.11.09 20:36
Спасибо!
К сожаленью, не получил все результаты по отчету. Дело в том, что категории сотрудников в нашей конторе отличаются от стандартного набора. К примеру, имеются "Рабочие основные" и "Рабочие вспомогательные" и т.п.
Скажите, есть ли возможность изменить отчет так, чтобы "неизвестные категории" воспринимались как стандартные.

3. Елена (Elena_Mosh) 23.11.09 06:43
(1) точно? проверила еще раз - стаж страховой печатается, т.е. тот, котрый указан у сотрудника в поле "Страховой стаж"
4. Елена (Elena_Mosh) 23.11.09 06:47
(2) только рабочие у вас нестандартные? можно сделать, чтобы если категория не из списка, то все попадали в рабочие. Так пойдет?
5. Елена (Elena_Mosh) 23.11.09 08:34
(1) извините, я думала, что печатает не страховой, а нужно страховой - точно, нужно на предприятии, не доглядела, сейчас исправлю:)
6. Елена (Phel) 23.11.09 13:26
У нас есть ещё категории НаучныеИПедагогические - пришлось добавить к вашим, и военнослужащие, поэтому когда вы проверяете ПриказОПриеме.ВидРаботы выдает ош, лучше использовать Сотрудник.ОсновнойЭлемент для выявления внутр. совместителей
7. Елена (Elena_Mosh) 23.11.09 13:56
(6) не знаю, у нас есть внутренние совместители - никаких ошибок не выдало. Может, напишите код ошибки?
8. Елена (Phel) 23.11.09 14:03
да внутр.-то у нас тоже полно, но у военнослужащих другой приказ о приеме на работу и там нет реквизита ВидРаботы, поэтому ош - не находит реквизит, но т.к. они тоже должны войти в отчет, то я проверяю
Если Сотрудник.ОсновнойЭлемент<>Сотрудник
Продолжить;
КонецЕсли;
если у вас нет военных, то вам это и не мешает и все будет нормально
9. Елена (Elena_Mosh) 23.11.09 14:21
(8) точно:( я про это знала, но военных нет и из памяти выветрилось:( я так понимаю, вы уже переделали, а через 4 дня отчет уже будет неактуален - закончится срок сдачи:( если еще кто-то попросит, переделаю, спасибо за подсказку:)
10. Борис Найманов (poligon) 24.11.09 01:11
(4) Категории сотрудников остались с прошлых лет:
Научные и научно-педагогические работники
Прочие служащие
Рабочие
Руководители
Специалисты
РабочиеОсновные
РабочиеВспомогательные
РуководителиАдмин
СпециалистыАдминистр
Из них используются: Прочие служащие, Руководители, Специалисты, РабочиеОсновные, РабочиеВспомогательные
11. Ifa Jlov (hwwnw) 24.11.09 01:12
я извиняюсь может я чего то непонемаю...
поставил отчет ваш экономисты принесли мне данный и говорят что у них Работников гораздо больше отработавших полный месяц 324 а отчет показывает 190 почему то... может условия непрвавельное которое осущетвляет проверку по дням ? если и такие кто отработал в месяц 23 дня из 22 дней что можно с этим сделать ?
12. Борис Найманов (poligon) 24.11.09 01:12
(4) Получается, что только "рабочие" у нас нестандартные
13. Елена (Elena_Mosh) 24.11.09 06:18
(11) посмотрите расшифровку - там есть список отработавших полностью, пусть кадровики хотя бы одного человека не попавшего в список, дадут, посмотрите, почему не попал, кто в месяц 23 из 22 - должны попадать - в отчете условие что если рабочих дней больше, чем отработанных, тогда не включать. В отработанные дни попадают оплата по табелю (окладу, дням, часам) + командировки
14. Ifa Jlov (hwwnw) 24.11.09 07:04
просто есть такие кто отработал больше чем 22 дня тоесть 23 дня переработки и они туда не попадают ((( почему то...
или так и должно быть ?
15. Елена (Elena_Mosh) 24.11.09 07:27
(14) должны вообще-то, условие в отчете не на равно:

Если ТЗОтработавших.РабочихДней > ТЗОтработавших.ОтработаноРабочихДней Тогда
ТЗОтработавших.УдалитьСтроку();
КонецЕсли;
попробуйте закомментарить эти строки и посмотреть по расшифровке (выведутся все работавшие)- сколько у не попавших рабочих дней по календарю и фактически отработано
16. Ifa Jlov (hwwnw) 24.11.09 08:37
вы не поняли... ставит календарных дне больше работниками не которым какая то проблема в календарях не могу разобраться почему
17. Елена (Phel) 24.11.09 12:18
в "справочно", там где полностью отработавшие попадают внешние совместители. Нужно в "среднесписочной", когда формируете СписокСотров сразу убрать НеОсновных
18. Елена (Phel) 24.11.09 12:21
(16) "дне больше работниками не которым" трудно вообще понять о чем речь
19. Елена (Elena_Mosh) 24.11.09 12:28
(17) да, если шел выбор не по всем, а по подразделению - было такое:( исправила, отчет перезалила
20. Vladimir (Boroda) 24.11.09 12:44
(3) Я и говорю, что страховой. А надо - стаж работы на предприятии (посмотрите саму таблицу II в приказе). Это не одно и то же. У сотрудник стаж страховой может быть 20 лет, а на данном предприятии всего 2 года.
Я, например, скорректировал ваш модуль, добавив функцию:
///=========================================================­================================
Функция ОпределитьСтаж(Человек)

НаДату = КонМесяца(ДатаКон);
СтажПредпр = глСтажРаботыНаПредприятии(Человек,НаДату);
// маловероятно, конечно, но всё ж...
Если ПустоеЗначение(СтажПредпр) = 0 Тогда
Стаж = глРазложить(СтажПредпр," ");

Годиков = Стаж.ПолучитьЗначение(1);
Месяцев = Число(Стаж.ПолучитьЗначение(3));
МесВДесятке = Окр((Месяцев*10)/12,0);
Стажж = ""+Годиков+"."+МесВДесятке+"";
Иначе
Сообщить("А "+Человек+" работает на предприятии??");
Стажж = "Н"
КонецЕсли;

Возврат Стажж;

КонецФункции // ОпределитьСтаж
21. Vladimir (Boroda) 24.11.09 12:47
(2) Господи, какие проблемы-то?! У меня тоже вспомогательныеи основные. Замените в модуле "Рабочие" на "Рабочие основные" и "Рабочие вспомогательные", если понимаете, конечно, где и что надо менять. Ну, и перечисления соответствующие вставьте.... И всё будет работать нормально.
22. Елена (Elena_Mosh) 24.11.09 13:18
23. Алексей Лапицкий (Lapitskiy) 25.11.09 17:10
У меня в сумму надбавок попадает оклад, и сумма всего получается больше, на сумму оклада....
24. Елена (Elena_Mosh) 26.11.09 06:16
(23) вид расчета оплата по окладу? а когда готовим данные для 2 раздела он там есть?
25. Алексей Лапицкий (Lapitskiy) 26.11.09 06:44
Да есть.
И получается, что оклад/тариф попадает и в 9 колонку, и в 11. соответственно, в колонке 8 сумма больше на величину оклада. И это я проверил на 2 разных базах.
26. Елена (Elena_Mosh) 26.11.09 06:55
в процедуре подготовитьданные() нужно добавить оплату по тарифу и оплату по табелю - или снять галочки у этих видов расчета в форме- кстати, за основу я брала вашу форму:) попробуйте, напишите, прошло или нет - не могу попробовать, у нас только по окладу оплата
27. Алексей Лапицкий (Lapitskiy) 26.11.09 11:30
Ну я-то исправил у себя: там, где идет выборка Надбавок, я вставил проверку на основной вид заработка, командировку и т.п., как строчками выше. И все.
28. Владимир Мартьянов (valde) 28.11.11 16:19
А нет новой формы от 20 июля 2011 года?
29. Елена (Elena_Mosh) 29.11.11 06:05
к сожалению, все - перешла на 8:( так цифры можно взять отсюда и забить в новую форму - это же не каждый месяц делать
30. Наталья Константиновна (bnk72) 11.12.13 15:52
Спасибо, пригодилась. Не знала с какой стороны подойти, да еще "надо было еще вчера", а тут все готово. Немного 6 графу сгруппировали по-новому, а в остальном - отличие 2013 от 2009 в паре слов...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа