gifts2017

Цветной журнал документов

Опубликовал Андрей Михайлов (Svetozor) в раздел Обработки - Обработка документов

Разработка, которая поможет вам скрасить вашу жизнь и сохранить зрение. Создан журнал документов с возможностью их цветового выделения по определенному реквизиту (организации, складу, контрагенту и т. д.).

Журнал документов с возможностью их цветового выделения по определенному реквизиту. Например, если у вас ведётся учет по нескольким организациям, то можно визуально разделить документы по каждой организации.

Обработка работает на любой конфигурации 1С:Предприятие 8.1.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
CDJ.zip
.zip 19,33Kb
23.11.09
659
.zip 19,33Kb 659 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. дед Мазай (Mazaloff) 23.11.09 08:49
2. mirco brons (mirco) 23.11.09 09:38
(1) Ага, ерунда, но красиво получается. За это плюс.У меня есть знакомые руководители, которые брали 8.х скорее всего из-за красоты и финтифлюшек. Так, что наверно им понавиться. :D
3. Артур Аюханов (artbear) 23.11.09 10:12
(0) Подробнее опиши у себя в описании, каким образом формируются цвета.
Например, я выберу раскраску по контрагентам, а у меня их в журнале, например, штук 50, как это будет выглядеть?
есть ли возможность раскрасить только часть контрагентов по какому-то условию?
4. Rusk (Rusk51) 23.11.09 11:27
(2) Верно мыслишь, товарищь. А шефу можно сказать , что сам сделал.И недели две на доработку ещё надо. :) А там и лето 8-)
И сайт не забыченый. Плюс одним словом.
5. Анатолий Ситников (acsent) 23.11.09 16:05
6. Сергей (Che) Коцюра (CheBurator) 23.11.09 16:13
Обычно все эти "финтифлюшки" - когда "сами не знают чего хотят"...
;-)
7. Эстер Коган (e.kogan) 23.11.09 18:30
Спасибо за идею, наверно, сделаю что-то похожее у себя в универсальном журнале...
8. Александр Крынецкий (echo77) 23.11.09 18:35
Не стоит недооценивать значение цвета - я сам для удобства поиска инетерсующих значений в большой таблице использую условное форматирование с раскрашиванием - т.к. это позволяет легко найти "деревья среди леса"
9. Алексей Прилепский (IamAlexy) 23.11.09 18:42
очень неполиткорректно обзывать журнал документов "цветным"

10. Сергей (Che) Коцюра (CheBurator) 23.11.09 19:17
(8) задача __регулярного__ визуального поиска в БОЛЬШОЙ таблице наводит на мысль: что-то не то в датском королевстве...
ZOMI; Yashazz; +2 Ответить 1
11. Алексей Прилепский (IamAlexy) 23.11.09 19:32
(10) угу.. нормальные пользователи пользуются отборами :)
если уж отчетов нет
12. Андрей Михайлов (Svetozor) 23.11.09 20:46
(3) Алгоритм раскрашивания можно сказать ещё в разработке. В текущей версии просто весь диапазон цветов делится на количество различных значений реквизита в журнале. Это даёт не всегда корректную окраску в плане контрастности цветов, поэтому разработка алгоритма продолжается.
13. Игорь <...> (I_G_O_R) 23.11.09 21:10
А если документов 100000 быстро откроется? даже при 10 документах неприятное моргание
14. Игорь <...> (I_G_O_R) 24.11.09 00:33
Честно говоря, автору не мешало бы книжки почитать, вместо того чтоб так беспонтово красотульки наводить. Смотрите как делается журнал, там осталось только добавить колонки и раскрасить :)
Прикрепленные файлы:
ЖурналДокументов.epf
15. Андрей Куканов (KukA.5) 24.11.09 00:42
Немного напрягло ПриВыводеСтроки() - это плохие подходы, лучше использовать ПриПолученииДанных(). Но когда посмотрел что там внутри... по другому наверное и не сделаешь :) Присутствует аккуратность в программировании. Но скорее всего это все-таки просто красота - такой атом разработчика нужно в использовать "в мирных целях".

Плюс земляку влепил с удовольствием.
16. Игорь <...> (I_G_O_R) 24.11.09 00:56
(15)а документы заполняются из Запроса в ТаблицуЗначений, посмотри как я сделал и сравни
17. Аркадий Кучер (Abadonna) 24.11.09 06:55
(0)
..сохранить зрение

Ну это кому как... У меня от такой ряби наоборот глаза напрягаются ;)
18. Андрей Михайлов (Svetozor) 24.11.09 09:08
(14) Использование объекта СписокДокументов вместо Запрос беспорно более выгодно как с точки зрения производительности, так и сточки зрения затрат на программирование и я тоже сначала хотел использовать именно этот способ, но к сожалению пришлось от этого сразу отказаться по той причине, что в следующей версии планируется добавить выводить документы общим списком.

С другой стороны как показало тестирование при нескольких дестяках тысяч позиций их вывод происходит не так быстро как хотелось бы. Поэтому думаю над комбинированым вариантом (СписокДокументов для однотипных списоков и Запрос для смешанного), а также над оптимизацией использования запроса.
19. Ярослав Радкевич (WKBAPKA) 24.11.09 10:15
+(1): ерунда в плане, что мы сами с усами
20. Андрей C (an77) 24.11.09 10:18
Симпатично смотрится. Еще неплохо вверху крупную кнопку добавить "Настройка списка" - пользователю очень пригодится.
Открыл у себя, сделал выделение по контрагентам (их более 1000) - сильно смотрится! Думаю японцам понравится, там даже школьники знают около 100 цветов ;)
Еще бы отсортировать по цвету - будет скрин неслабый!
Плюс.

21. pj12 (pj12) 25.11.09 06:47
А че нормально... бум использовать, только цвета по темнее сделал.
22. Наталия ... (tili) 25.11.09 12:26
(21) Спасибо. Очень удобно для пользователя. Большой плюс!
23. Александр (shape) 26.11.09 12:14
24. Сергей (sermish) 27.11.09 20:29
Как правильно заметили ранее - для 8.2 не актуально, там сам пользователь может свои стили задать.
25. Valera Moscwin (voler) 30.11.09 14:03
Плюс поставлю, но сточки зрения правильности не хватает следующего:
Дата оплаты, вы берете из поля "Оплата", правильнее писать прогнозируемая дата оплаты.

Не мешало бы вывести: реализацию, платежное поручение.

26. Valera Moscwin (voler) 30.11.09 14:25
Не работает сохранение и восстановление. Я выбираю себе "Заказ покупателя" нажимаю сохранить, а после захода заново не восстанавливается.
27. kiruha Дронов (kiruha) 30.11.09 16:30
В 8.2 же и так все журналы цветные - настроить список/ условное оформление
28. kiruha Дронов (kiruha) 30.11.09 16:33
Вообщем смысла публикации не понял
29. Наталья Буткевич (nata_li1979) 04.12.09 08:19
А что нужно сделать, чтобы эти цвета работали, по мимо того, что скачать? :)
30. Тотал Литвиненко (Тамагочи) 05.12.09 01:08
Интересно а в приходной накладной можно реализовать этот же принцип раскрашивания каждой строки товара по группам товара (3-5груп - цветов)
31. Артур Аюханов (artbear) 07.12.09 10:55
(30) У 1С же есть автоматический режим чередования цветов строк в табличной части ? :)
32. Артур Аюханов (artbear) 07.12.09 10:56
33. Павел Ли (jibi6a) 18.12.09 13:30
"Обработка работает на любой конфигурации 1С:Предприятие 8.1."

на 1.2.7.1 не работает :cry:
34. AlexsisIT (Alexsisit) 02.02.10 07:09
Все отлично, только подтормаживает при прокрутке )).

Сделал так:

Процедура СписокДокументовПриПолученииДанных(Элемент, ОформленияСтрок)
для Каждого стр из ОформленияСтрок Цикл
Если ЦветовыеРеквизитыДокументов <> "- Не выделять цветом -" Тогда
ПозицияПалитры = ПалитраЦветов.Найти(стр.ДанныеСтроки[ЦветовыеРеквизитыДокументов], ЦветовыеРеквизитыДокументов);
Если ПозицияПалитры <> Неопределено Тогда
стр.ЦветТекста = Новый Цвет(ПозицияПалитры.ЦветR, ПозицияПалитры.ЦветG, ПозицияПалитры.ЦветB);
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Тормозит намного меньше, только при первом прокручивании, а дальше как обычный список.

Так что убери процедуру СписокДокументовПриВыводеСтроки и посторайся её использовать как можно меньше )))

А так идейка хороша ;)
35. Дима Кузнецов (dakinder) 02.03.10 22:12
эээх можно было бы еще в оборотно сальдовой ведомости такое сделать...цены бы не было:))
36. igor_gk (igor_gk) 06.11.10 10:10
Идея не нова (напр в Excel - усовное форматирование), давно пользую... Ток я больше с упором на цвет фона... Буквы чОрные должны быть и чОткие
:D
37. Igor Emelyanenkov (IEmelya) 02.10.11 22:20
А можно ли в Журнале Операций ставить цветные метки на определенных документах?
Присваивать конкретному документу определенный цвет.
Например красный - внимание, зеленый - док.исправлен, синий - жду со склада. и т.п.
38. Igor Emelyanenkov (IEmelya) 02.10.11 23:29
Она будет работать на 1с8.2 ?
39. Андрей Михайлов (Svetozor) 05.10.11 00:04
(37) Без доработки нет
(38) У меня после конвертации работала
40. Михаил Иванов (wwizard) 14.03.12 14:02
У меня на 8,2 работает после конвертации. Как поменять порядок цветов?
41. Михаил Иванов (wwizard) 14.03.12 14:02
Мне нужно для подразделения
42. Михаил Иванов (wwizard) 14.03.12 14:05
(14) I_G_O_R, этот Ваш отчет, вообще не работает даже не конвертируется!!! Одни ошибки!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа