Заведение Пользователя Во Всех Имеющихся БД

Администрирование - Защита, права, пароли

Заведение Пользователя Во Всех Имеющихся БД

Дело в том, что в нашей организации около 50ти Баз Данных. И логинить во всех них одного пользователя довольно утомительно. Вот собственно и созрела данная обработочка.

 1. Есть списки (txt). В них пути к БД. Списки разбиты на разные конфигурации (к примеру: ЗИК БУХ ТИС).

 2. В стандартной вариации конфигурации существуют как правило одинаковые права и интерфейсы (для этого собственно и необходимо разбиение п.1 ).

В Бухгалтерии есть стандартный интерфейс "Бухгалтер" и стандартные права: "Администратор", а так как жесткие правила доступа в Бухгалтерии у нас не ведутся, я ставлю им стандартные интерфейсы, стандартные права, создаю ему каталог, ставлю пароль.......... Вообщем проделав это действие в 30ти Базах Данных начинаешь понимать чта проще что-то дописать.....

Вот что и родилось в океане любви и нежности к себе..............

Скачать файлы

Наименование Файл Версия Размер
-
.rar 417,13Kb
23.11.09
145
.rar 417,13Kb 145 Скачать

См. также

Комментарии
1. Алексей (ACE$) 102 23.11.09 15:45 Сейчас в теме
2. Алексей (ACE$) 102 23.11.09 15:45 Сейчас в теме
извиняюсь, после обновления страницы все появилось
3. Сергей Солнышкин (Myti) 91 23.11.09 15:45 Сейчас в теме
4. Сергей Солнышкин (Myti) 91 23.11.09 15:46 Сейчас в теме
Сразу оговорюсь...........Компонента написана немной...........Респект разработчику
5. Сергей Солнышкин (Myti) 91 23.11.09 15:48 Сейчас в теме
Хотел сделать еще предварительный пинг адресов.........но это позднее............если кому то понадобиться конечна........
6. Андрей (ghostishe) 287 23.11.09 15:51 Сейчас в теме
(0)
1. Есть списки (txt). В них пути к БД.

Они у всех что ли есть? Или надо создавать списки?
7. Сергей Солнышкин (Myti) 91 23.11.09 16:06 Сейчас в теме
:D ню у нас точно есть...Помнить пути 50ти баз .НЕРЕАЛЬНО
8. Владимир (vovan519) 274 24.11.09 17:09 Сейчас в теме
Не хотел писать комментарий, но фраза "Вот что и родилось в океане любви и нежности к себе" просто повергла в ступор.
Как можно одновременно любить себя и заставлять свои ЛЮБИМЫЕ ПАЛЬЧИКИ стучать по клавиатуры, набирая права пользователя и интерфейс пользователя ВРУЧНУЮ, когда все знают и автор в том числе, как их получить при помощи UsersDef. И как их не жаль при заполнении списка баз в текстовом файле, хотя получить список путей к базам не состовляет труда. Не понимаю о какой любви тут идет речь?
9. Сергей Солнышкин (Myti) 91 24.11.09 17:17 Сейчас в теме
Списки БД обновляються и составляються автоматом (ServisDesk).
А UsersDef использовать нехотелось. Дело в том что основная цель обработки, это заведение одного пользователя в несколько БД.
и есле спрашивать интерфейс и права при заведении в каждую БД - то ето уже не автомат.
А дополнить можно чем угодно.........................................
Кстита, принимаю идею на доработку, одна есть....
10. blackoperator (fastwriter) 25.11.09 08:51 Сейчас в теме
А оно новые права ставит в конец списка или в алфавитном порядке?
Если нет - хорошо бы добавить такую возможность.
11. Сергей Солнышкин (Myti) 91 25.11.09 10:50 Сейчас в теме
(10) - В конец списка,,,,,.добавим
12. GSoft. (GSoft) 2766 25.11.09 10:58 Сейчас в теме
(5) пинг адресов очень просто командой системы

Код
 

      Если ВыбЗнач = "Выполнить команду PING" Тогда 
         Попытка
            //ЗапуститьПриложение("cmd /k /t:0a ping " + Адрес);
            ЗапуститьПриложение("ping -t " + Адрес);
         Исключение
            //КомандаСистемы("start ping " + Адрес);
         КонецПопытки;
      ИначеЕсли ВыбЗнач = "Открыть в проводнике (сетевое окружение)" Тогда
         ЗапуститьПриложение("\" + Адрес);
      ИначеЕсли ВыбЗнач = "Список ПО (при наличии FPinger)" Тогда
          ВывестиСписокПО(ИмяПК);
      ИначеЕсли ВыбЗнач = "Log Off" Тогда
         Если Вопрос("Будет произведена попытка послать команду ""Log Off"" компьютеру """ +
         Адрес + """. Продолжить?", "Да+Нет") = "Нет" Тогда
            Возврат;
         КонецЕсли;
         глВыключениеУдаленногоКомпьютера(Адрес, 4);
      ИначеЕсли ВыбЗнач = "Reboot" Тогда
         Если Вопрос("Будет произведена попытка послать команду ""Reboot"" компьютеру """+
         Адрес + """. Продолжить?", "Да+Нет") = "Нет" Тогда
            Возврат;
         КонецЕсли;
         глВыключениеУдаленногоКомпьютера(Адрес, 6);
      ИначеЕсли ВыбЗнач = "Shutdown" Тогда
         Если Вопрос("Будет произведена попытка послать команду ""Shutdown"" компьютеру """+
         Адрес +""". Продолжить?", "Да+Нет") = "Нет" Тогда
            Возврат;
         КонецЕсли;
         глВыключениеУдаленногоКомпьютера(Адрес, 5);
      КонецЕсли;
Показать полностью
13. Сергей Солнышкин (Myti) 91 25.11.09 11:04 Сейчас в теме
(12) - Спасибо...спасибо.....Но мне как то Скрипты ближе, чтоли........
Хотя способ прикольный, а главное......более восприимчивый :)
14. GSoft. (GSoft) 2766 25.11.09 11:20 Сейчас в теме
если делать пингование скриптами то только для того чтобы не дать пользователю доступ к командной строке, перенаправить результат работы в текстовый файл и открыть его

но тогда вопрос - если пользователю нельзя пользоваться командной строкой - то зачем ему пингование))
15. Сергей Солнышкин (Myti) 91 25.11.09 11:26 Сейчас в теме
16. Дмитрий Дрейцер (MadDAD) 117 25.11.09 11:37 Сейчас в теме
При некоторой доработке заработао в нужном виде.
17. Сергей Солнышкин (Myti) 91 25.11.09 11:49 Сейчас в теме
(16) - вот и отличненько..........
18. Владимир (vovan519) 274 25.11.09 15:57 Сейчас в теме
(14) "если делать пингование скриптами то только для того чтобы не дать пользователю доступ к командной строке, перенаправить результат работы в текстовый файл и открыть его ..."

Позвольте категорически не согласиться с Вами. Даже аргументировать не хочеться
19. Альтаир (Altair777) 635 25.11.09 16:04 Сейчас в теме
(0) Долго думал, как это оценить.
И решил, что отрицательно. Вы же программист 1С, а мыслите не 1С-овскими категориями.
Почему текстовые файлы со списком баз? Почему Вы не создали отдельную конфу, где это можно было сделать красиво и удобно?
Со справочниками... с докуменатами. С отчетами, в конце концов :)
Минус не за разработку... Это тактика. Минус за стратегию.
Не рекомендую я это другим пользователям со схожей задачей.
20. Сергей Солнышкин (Myti) 91 25.11.09 17:12 Сейчас в теме
(19) -
1. Список есть в Экселе, системщики с ним работают, им удобно.
Пересаживать их на писанную конфу не целесообразно. Да и проблематично.
Списки в тексте потому, что надо разделять Базы по конфигурациям.
Из экселя брать тоже нерезонно.
2. Подобная конфа уже есть, там правда работа с сетью в основном.
Плагиатом я незанимаюсь.
3. Вот как наберу кучу полезностей, сразу напишу конфу со всему.....
А пока, цените так как есть......... :)))
21. Bosma Иванов (Bosma) 68 11.12.09 10:48 Сейчас в теме
(20) конфигурация уже есть http://infostart.ru/public/20072/ Пользуйтесь.
22. Сергей Солнышкин (Myti) 91 11.12.09 11:17 Сейчас в теме
(21) - Респект разработке.
Но функция заведения одного пользователя во все БД отсутствует.
23. Bosma Иванов (Bosma) 68 11.12.09 11:22 Сейчас в теме
(22) Одним нажатием - да, отсутствует, (надо выбрать к каким базам и с какими правами добавлять) но часто ли надо добавлять пользователя во ВСЕ базы? у нас даже глав. бух. далеко не во все базы доступ имеет. :)
24. Сергей Солнышкин (Myti) 91 11.12.09 11:27 Сейчас в теме
(23) - :D :D :D В нашей шарашке, да, много таких пользов.....
Вапче штукенция прикольная,,,,
Оставьте свое сообщение