IE 2016

Поздравление с Новым Годом 2010

Опубликовал kenshin в раздел Сообщество - Поздравления

Идея позаимствованная. Автор оригинальной версии - djkxfhf(точка)nm(точка)ru

Я лишь доработал поправил картинки + добавил слои и т.д и немного текст.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
сам файл ert
.ert 2,67Mb
15.02.10
656
.ert 2,67Mb 656 Скачать

См. также

Лучшие комментарии

14. kenshin (файл скачал) 01.12.2009 19:43
если успею напишу для 8 ки
# Ответить
53. artbear (файл скачал) 01.11.2011 16:42
(52) Спасибо лучше всего выразить плюсом за публикацию из (47)
+ 1 [ 23778; ]
# Ответить
1. Abadonna (файл скачал) 26.11.2009 14:47
Идея не моя. Я лишь доработал поправил картинку и немного текст.

Ну и положи тогда в раздел Life.
Ответили: (4)
+ 1 [ 7pts; ]
# Ответить

Комментарии

1. Abadonna (файл скачал) 26.11.2009 14:47
Идея не моя. Я лишь доработал поправил картинку и немного текст.

Ну и положи тогда в раздел Life.
Ответили: (4)
+ 1 [ 7pts; ]
# Ответить
2. vovan519 26.11.2009 14:51
Заголовок не хочешь откорректировать?
# Ответить
3. kenshin (файл скачал) 26.11.2009 14:53
сори о печатался
# Ответить
4. Abadonna (файл скачал) 26.11.2009 15:30
плюс за правильную реакцию на (1) :D
# Ответить
5. Доня (файл скачал) 26.11.2009 18:33
Красиво и глаз от цифр отдыхает, а можно побольше прикольных картинок
# Ответить
6. kenshin (файл скачал) 26.11.2009 20:28
можно, но только весить оно будет больше, каждая картинка это дополнительных 180 кб -200кб
# Ответить
7. bav (файл скачал) 27.11.2009 17:35
Че-то с переменными напутано немного:
НадоПоздравитьс8марта=Нет; Переменная не определена (Нет)
НадоПоздравитьс8марта=Да; Переменная не определена (Да)

И анекдоты старенькие))
А так, конечно, плюс: остальное всё новенькое, да и вообще раньше всех в этом году спохватился)
+ 1 [ kenshin; ]
# Ответить
8. Tatitutu (файл скачал) 27.11.2009 18:34
+7
это должна быть или переменная или перечисление ДА или НЕТ

а вот размер можно было и поменьше сделать в 5 РАЗ посмотри
всего 499 кб и не в архиве

Прикрепленные файлы:

ПоздравляемНовыйГод.ert
+ 1 [ wolfsoft; ]
# Ответить
9. kenshin (файл скачал) 28.11.2009 02:31
bav 27.11.2009 17:35:55

Че-то с переменными напутано немного:
НадоПоздравитьс8марта=Нет; Переменная не определена (Нет)
НадоПоздравитьс8марта=Да; Переменная не определена (Да)

Может быть
если у кого в друг будет вопрос, почему 8марта, ответ потому что влом переменную в глобальнике было переписывать, она у мя там просто за 15 дней до нового года на машинах данный отчет запускает, или когда 8 марта ))
# Ответить
10. kenshin (файл скачал) 28.11.2009 02:34
Спасибо за + кто поставил :D
# Ответить
11. Solo (файл скачал) 29.11.2009 23:17
А у меня не работает :( С переменными чего-то
# Ответить
12. kenshin (файл скачал) 30.11.2009 12:16
Solo что за ошибку пишет напиши
# Ответить
13. lukas 01.12.2009 12:47
Эх, такую бы разработку да под 8.1... Тоже хочется поздравить ;)
# Ответить
14. kenshin (файл скачал) 01.12.2009 19:43
если успею напишу для 8 ки
# Ответить
15. AlexBugs (файл скачал) 02.12.2009 07:37
А как вы такие картинки вставили в отчет?
хочу вырезать из картинки "AfalinaSoft", но не получается сохранить картинку в отчете :(
# Ответить
16. galyna (файл скачал) 02.12.2009 08:28
Понравилось.
# Ответить
17. mayka (файл скачал) 02.12.2009 09:36
Спасибо! :D
# Ответить
18. marina4183 (файл скачал) 02.12.2009 09:52
Спасибо, очень понравилось :)
# Ответить
19. громозека (файл скачал) 02.12.2009 10:08
Спасибо. Пригодится.
# Ответить
20. kenshin (файл скачал) 02.12.2009 10:29
AlexBugs 02.12.2009 07:37:21
Просто вставь туда текст или кнопку какую со своим логотипом и все ))
# Ответить
21. NatMar (файл скачал) 02.12.2009 10:49
Ошибочку выдает :( НадоПоздравитьс8марта=Нет<<?>>;
# Ответить
22. kenshin (файл скачал) 02.12.2009 10:56
Убрал Логотип
# Ответить
23. Nicholas (файл скачал) 02.12.2009 10:56
Раз уж указываете платформу 1С: Расчет 7.7 как поддерживаемую, то будьте добры проверить работоспособность в типовой конфигурации 1С: Зарплата и Кадры.

НадоПоздравитьс8марта=Нет<<?>>;
{D:\1C CALC\EXTFORMS\ОБРАБОТКИ АЙТИШНЫЕ\ПОЗДРАВЛЯЕМНОВЫЙГОД\ПОЗДРАВЛЯЕМНОВЫЙГОД.ERT(49)}: Переменная не определена (Нет)
НадоПоздравитьс8марта=Да<<?>>;
{D:\1C CALC\EXTFORMS\ОБРАБОТКИ АЙТИШНЫЕ\ПОЗДРАВЛЯЕМНОВЫЙГОД\ПОЗДРАВЛЯЕМНОВЫЙГОД.ERT(53)}: Переменная не определена (Да)
Если НадоПоздравитьс8марта=Нет <<?>>Тогда
{D:\1C CALC\EXTFORMS\ОБРАБОТКИ АЙТИШНЫЕ\ПОЗДРАВЛЯЕМНОВЫЙГОД\ПОЗДРАВЛЯЕМНОВЫЙГОД.ERT(55)}: Переменная не определена (Нет)

Нет таких переменных в типовой конфигурации. Чтобы заработало, надо все это дело исправить или хотя бы закомментировать.

В целом идея хорошая, хоть и не Ваша.
# Ответить
24. kenshin (файл скачал) 02.12.2009 11:00
NatMar 02.12.2009 10:49:38
//НадоПоздравитьс8марта=Нет;
//ПредупредитьЗаДней=10;
//ДатаСКоторойПоздравлять="24.11."+Строка(ДатаГод(ТекущаяДата()));
//Если (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))<ПредупредитьЗаДней) и (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))>=0) тогда
// НадоПоздравитьс8марта=Да;
//КонецЕсли;
//Если НадоПоздравитьс8марта=Нет Тогда
// Форма.Закрыть(0);
// СтатусВозврата(0);
//КонецЕсли;

за Комментируй это в конфигураторе и будет счастье
# Ответить
25. kenshin (файл скачал) 02.12.2009 11:01
Nicholas 02.12.2009 10:56:55 я это написал в шапке что идея по заимствованная
# Ответить
26. kenshin (файл скачал) 02.12.2009 11:12
подправил
# Ответить
27. AlexBugs (файл скачал) 02.12.2009 11:49
kenshin 02.12.2009 10:29:36
Хочу картинку почищенную от логотипа ставить. И так много всяких кнопочек... Подскажите как, pls...
# Ответить
28. kenshin (файл скачал) 02.12.2009 12:03
я уже выложил почищенную от логотипа
# Ответить
29. AlexBugs (файл скачал) 02.12.2009 13:57
kenshin 02.12.2009 12:03:18
Спасибо! за чустую картинку :)
а все-таки... расскажи как их вставлял...
# Ответить
30. kenshin (файл скачал) 02.12.2009 14:13
Вставить можно по разному, ну я что б не использовать другие папка в которых бы лежали картинки, решил использовать слои, то есть правой кнопкой мыши нажимаешь на слое, далее свойства закладка картинка - изменить картинку - добавить (сверку синяя кнопочка с пальцем) - далее добавляю и вуаля
Ответили: (34)
# Ответить
31. irina_ph (файл скачал) 02.12.2009 18:38
Спасибо. Порадуем бухов
+ 1 [ golm; ]
# Ответить
32. Veduin (файл скачал) 04.12.2009 08:12
Довольно таки интересная затея... Колективу понравилось!
Спасибо!
# Ответить
33. pavlo (файл скачал) 04.12.2009 09:18
то, что картинка не разворачивается на весь экран вместе с отчетом и загружается очень долго - не айс.
а так прикольно!
# Ответить
34. Craig (файл скачал) 04.12.2009 21:26
(30)Что то быстро пропадают сообщения фокусника (( что делать???
# Ответить
35. support 04.12.2009 23:54
Напомните, где шутка про сканер отпечатка пальца на мониторе.
Ответили: (37)
# Ответить
36. nixoli (файл скачал) 06.12.2009 13:55
Прикольно! Спасибо! :D
# Ответить
37. Shaman100M 07.12.2009 08:51
(35) у чебура?
# Ответить
38. kenshin (файл скачал) 08.12.2009 02:26
народ отпишите, как вам и что под редактировать в дальнейшем, какая реакция бухгалтеров 717 скачало уже ))
Спасибо за Спасибо :!:
# Ответить
39. len2304 14.12.2009 07:38
а написать, что для обработки надо установить spchapi и движок Дигало, не надо было? :) или это все знают? :oops:
# Ответить
40. kenshin (файл скачал) 14.12.2009 14:33
ну кому надо поймут, да и у большинства бухгалтеров нет колонок на рабочем месте все завалено макулатурой ;)
# Ответить
41. vlas (файл скачал) 18.12.2009 07:42
В Новогодней зимней стуже
Пусть согреет Вашу кровь :
Елка, горка, добрый ужин
И взаимная любовь!
# Ответить
42. dobraleks (файл скачал) 21.12.2009 21:45
УЛЫБНУЛО! :D
+1 от меня!
# Ответить
43. dobraleks (файл скачал) 22.12.2009 22:24
сижу вот под себя перестраиваю, впечатлений от данного поздравления море.
Автор порекомендовал бы Вам на кнопку повесить не просто стрелочки ">>" а добавить к примеру так " ЕЩЕ>>".

Не каждый сразу догадается что можно еще раз нажать на кнопку и будет продолжение, а так к примеру :
"Поздравляем" -- "Поздравляем! ЕЩЕ>>" --- "Поздравляем! ЕЩЕ>>" ----"Поздравляем!".
Я думаю Вы меня поняли что я имел ввиду!
:)
# Ответить
44. Littleboy72 (файл скачал) 24.12.2009 13:52
Подскажите новичку, как заставить обработку автоматически загружаться при входе пользователя, плизззззз :)
# Ответить
45. kenshin (файл скачал) 28.12.2009 11:24
Процедура ПриНачалеРаботыСистемы()
ПредупредитьЗаДней=12;
ДатаСКоторойПоздравлять="31.12."+Строка(ДатаГод(ТекущаяДата()));
Если (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))<ПредупредитьЗаДней) и (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))>=0) тогда
НадоПоздравитьс8марта=Да;
КонецЕсли;
Если НадоПоздравитьс8марта=Да Тогда
ОбработкаПоздравление=КаталогИБ()+"extforms\Поздравляем.ert";
Если ФС.СуществуетФайл(ОбработкаПоздравление)=1 тогда
ОткрытьФорму("Отчет",,ОбработкаПоздравление);
КонецЕсли;
КонецЕсли;
КонецПроцедуры;
# Ответить
47. artbear (файл скачал) 28.12.2009 17:12
Выложил свой вариант поздравлялки для 8.1
http://infostart.ru/public/63428/
моя версия основана на данной обработке + серьезная переделка кода и т.п.
Подробнее на странице моей разработки.

ЗЫ долго ждал, пока кто-нибудь сделает для 8.1, но народ не спешил, пришлось самому заняться :)
Ответили: (52) (53)
# Ответить
48. bav (файл скачал) 29.12.2009 10:34
В общем в старой комплексной (2.6) после запуска обработки - проявляется следующий глюк:
В гм следующие переменные:
Да=Перечисление.Булево.Да;
Нет=Перечисление.Булево.Нет;
До поздравлялки, соответственно: в отладчике Да=Да Нет=Нет
После запуска: Да="" Нет=""

Оказалось в обработке тоже эти переменные есть.((
А я уж на агента стал грешить.
# Ответить
49. kenshin (файл скачал) 29.12.2009 16:19
Выложил свой вариант поздравлялки для 8.1
http://infostart.ru/public/63428/
моя версия основана на данной обработке + серьезная переделка кода и т.п.
Подробнее на странице моей разработки.

Я НАЧИНАЛ ДЕЛАТЬ НА 8-ке но как написано очень много переделки а времени свободного нет так что молодец что сделал народ надо баловать
Ответили: (23)
# Ответить
50. kenshin (файл скачал) 29.12.2009 16:48
НУ что какой следующий праздник делать ;) :idea:
# Ответить
51. a237 (файл скачал) 01.11.2011 13:03
Ставим юзерам- все довольны (и мы тоже) спасибо.
# Ответить
52. a237 (файл скачал) 01.11.2011 14:46
(47) artbear,
полезно
Ответили: (53)
# Ответить
53. artbear (файл скачал) 01.11.2011 16:42
(52) Спасибо лучше всего выразить плюсом за публикацию из (47)
+ 1 [ 23778; ]
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл