gifts2017

УНФ. Партионный учет для списания материалов в документе "Сборка заказов". Версия 0.01

Опубликовал Федор Программист (fedor40) в раздел Программирование - Практика программирования

Документ заполняется материалами по спецификации, но графа партии не заполняется. Теперь под словом Партия 1с понимает чисто управленческий учет. Партия как качество или особенность номенклатуры. Поэтому даже не планируется списание этих управленческих партий каким либо автоматическим методом. Партию надо выбирать вручную ! Данная доработка заполняет табличную часть документа Сборка заказов по спецификации методом ФИФО.

Жду ваших комментариев и предложений по совершенствованию

Алгоритм пока не рабочий. Остатки по документу поступления (регистратору) не видны.

 

Документ заполняется материалами по спецификации, но графа партии не заполняется. Теперь под словом Партия 1с понимает чисто управленческий учет. Партия как качество или особенность номенклатуры. Поэтому даже не планируется списание этих управленческих партий каким либо автоматическим методом. Партию надо выбирать вручную ! Данная доработка заполняет табличную часть документа Сборка заказов по спецификации методом ФИФО.

 

Жду ваших комментариев и предложений по совершенствованию.

Алгоритм пока не рабочий. Остатки по документу поступления (регистратору) не видны.

 

  1. Изменил процедуру формы документа.

 

&НаСервере

// Процедура заполняет Запасы по спецификации.

//

Процедура ЗаполнитьПоСпецификацииНаСервере()

           

            Документ = РеквизитФормыВЗначение("Объект");

            Документ.ЗаполнитьТабличнуюЧастьПоСпецификации();

           

            //изменено нач

            ТЗМатериаловДляСписания = Документ.Запасы.Выгрузить(,"Номенклатура,Количество,ЕдиницаИзмерения");

           

            Запрос = Новый Запрос;

    МенеджерВТ = Новый МенеджерВременныхТаблиц;

    Запрос.МенеджерВременныхТаблиц = МенеджерВТ;

           

            Запрос.УстановитьПараметр("Организация", Документ.Организация);

            Запрос.УстановитьПараметр("СтруктурнаяЕдиница", Документ.СтруктурнаяЕдиница);

            Запрос.УстановитьПараметр("СчетУчета", ПланыСчетов.Управленческий.СырьеИМатериалы);

            Запрос.УстановитьПараметр("МоментВремени", Документ.МоментВремени());

            Запрос.УстановитьПараметр("ТЗМатериаловДляСписания", ТЗМатериаловДляСписания);

           

            Запрос.Текст =

                        "ВЫБРАТЬ

                        |           ТЗ.Номенклатура КАК Номенклатура,

                        |           ТЗ.Количество КАК Количество,

                        |           ТЗ.ЕдиницаИзмерения

                        |ПОМЕСТИТЬ Номенклатурка

                        |ИЗ

                        |           &ТЗМатериаловДляСписания КАК ТЗ

                        |

                        |ИНДЕКСИРОВАТЬ ПО

                        |           Номенклатура";

            Запрос.Выполнить();

                       

            Документ.ЗапасыОчистить();

                       

            Запрос.Текст =

                        "ВЫБРАТЬ

                        |           МАКСИМУМ(ВложенныйЗапрос.КолДляСписания) КАК КолДляСписания,

                        |           ВложенныйЗапрос.Регистратор КАК Регистратор,

                        |           ВложенныйЗапрос.Номенклатура КАК Номенклатура,

                        |           ВложенныйЗапрос.Партия КАК Партия,

                        |           МАКСИМУМ(ВложенныйЗапрос.КоличествоКонечныйОстаток) КАК КоличествоКонечныйОстаток,

                        |           ВложенныйЗапрос.ЕдиницаИзмерения КАК ЕдиницаИзмерения

                        |ИЗ

                        |           (ВЫБРАТЬ

                        |                       МАКСИМУМ(ВложенныйЗапрос.Количество) КАК КолДляСписания,

                        |                       ЗапасыОстаткиИОбороты.Регистратор КАК Регистратор,

                        |                       ЗапасыОстаткиИОбороты.Номенклатура КАК Номенклатура,

                        |                       ЗапасыОстаткиИОбороты.Партия КАК Партия,

                        |                       МАКСИМУМ(ЗапасыОстаткиИОбороты.КоличествоКонечныйОстаток) КАК КоличествоКонечныйОстаток,

                        |                       ВложенныйЗапрос.ЕдиницаИзмерения КАК ЕдиницаИзмерения

                        |           ИЗ

                        |                       (ВЫБРАТЬ

                        |                                   Номенклатурка.Номенклатура КАК Номенклатура,

                        |                                   Номенклатурка.Количество КАК Количество,

                        |                                   Номенклатурка.ЕдиницаИзмерения КАК ЕдиницаИзмерения

                        |                       ИЗ

                        |                                   Номенклатурка КАК Номенклатурка) КАК ВложенныйЗапрос

                        |                                   ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.Запасы.ОстаткиИОбороты(, &МоментВремени, Регистратор, ДвиженияИГраницыПериода, Номенклатура В (&ТЗМатериаловДляСписания)) КАК ЗапасыОстаткиИОбороты

                        |                                   ПО ВложенныйЗапрос.Номенклатура = ЗапасыОстаткиИОбороты.Номенклатура

                        |          

                        |           СГРУППИРОВАТЬ ПО

                        |                       ЗапасыОстаткиИОбороты.Регистратор,

                        |                       ЗапасыОстаткиИОбороты.Номенклатура,

                        |                       ЗапасыОстаткиИОбороты.Партия,

                        |                       ВложенныйЗапрос.ЕдиницаИзмерения) КАК ВложенныйЗапрос

                        |

                        |СГРУППИРОВАТЬ ПО

                        |           ВложенныйЗапрос.Номенклатура,

                        |           ВложенныйЗапрос.Регистратор,

                        |           ВложенныйЗапрос.Партия,

                        |           ВложенныйЗапрос.ЕдиницаИзмерения

                        |ИТОГИ ПО

                        |           Номенклатура,

                        |           Регистратор,

                        |           Партия,

                        |           ЕдиницаИзмерения";

 

            //Запрос.УстановитьПараметр("Номенклатура", ТЗМатериаловДляСписания);

           

            Результат = Запрос.Выполнить();

 

           

            ВыбНом = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

            Пока ВыбНом.Следующий() Цикл

                       

                        Нужно = ВыбНом.КолДляСписания;

                       

                        ВыбРег = ВыбНом.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

                        Пока ВыбРег.Следующий() Цикл

                                  

                                   Если Нужно <=  0 Тогда

                                               Продолжить;   

                                   КонецЕсли;

                                  

                                   ВыбПартия = ВыбРег.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

                                   Пока ВыбПартия.Следующий() Цикл

 

                                               ВыбПартияЕдИзм = ВыбПартия.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

                                       ВыбПартияЕдИзм.Следующий();

                                              

                                               ДоступноДляСписания = ВыбПартияЕдИзм.КоличествоКонечныйОстаток;

                                               Если Нужно >  ДоступноДляСписания Тогда

                                                           Документ.ДобавляемСтрокуЗатратПартия(ВыбПартияЕдИзм,ДоступноДляСписания);

                                                           Нужно = Нужно - ДоступноДляСписания;        

                                               Иначе

                                                           //списываем остаток

                                                           ДоступноДляСписания = Нужно;

                                                           Документ.ДобавляемСтрокуЗатратПартия(ВыбПартияЕдИзм,ДоступноДляСписания);

                                                           Нужно = 0;

                                               КонецЕсли;

                                              

                                   КонецЦикла;

                                  

                        КонецЦикла;

                       

            КонецЦикла;

            //изменено Кон

           

            ЗначениеВРеквизитФормы(Документ, "Объект");

            Модифицированность = Истина;

           

 

КонецПроцедуры // ЗаполнитьМатериальныеЗатратыПоСпецификацииНаСервере()    

 

  1. Добавил свои процедуры в модуль документа

 

//изменено

Процедура ДобавляемСтрокуЗатратПартия(СтрокаВыборки, КолДляСписания) Экспорт

           

            НоваяСтрока = Запасы.Добавить();

                                  

            ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаВыборки);

            НоваяСтрока.Количество = КолДляСписания;

           

КонецПроцедуры

 

Процедура ЗапасыОчистить() Экспорт

            Запасы.Очистить();

КонецПроцедуры

 

 

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа