gifts2017

Исправление ошибки в декларации НДС за 4 кв 2009 для Предприниматель 7.7

Опубликовал Алексей Новиков (novav) в раздел Печать - Регламентированная отчетность

В 1С.Предприниматель 7.7 - регламентированная отчетность за 4 кв 2009 в декларации НДС ошибка, не позволяющая сформировать разделы (формирует корректно только титульный лист). Исправить можно заменив процедуру "Заполнить реквизиты" в файлах отчета: NDS902.ert - NDS910.ert на исправленную:

Заменяете Процедуру "Заполнить реквизиты" во всех файлах отчета декларации НДС (не путаем со старыми формами, их 1С оставило в комплекте отчетности), на м нужно исправить файлы отчетности : NDS902.ert - NDS910.ert. В указанных 8 файлах заменяем 1С ную процедуру на такой код: //*******************************************************************************
Процедура ЗаполнитьРеквизиты( ИзмФирма=0 )
                 
    СписокДанных = СоздатьОбъект( "СписокЗначений" );
        
    Если ИдентКонфигурации <> "NLGPL" Тогда
       
        СписокДанных.Установить( "Контекст",         Контекст );
        СписокДанных.Установить( "Дата",             Дата2 );
        СписокДанных.Установить( "ИНН",             "" ); 
           
        СписокДанных.Установить( "КаталогХранения", "" );
       
        Попытка
            глПолучитьДанные( СписокДанных );  
        Исключение
        КонецПопытки;   
       
        ОргИНН = СписокДанных.Получить( "ИНН" );     
        ИНН       = СРЕД(ОргИНН, 1, 10);
        КПП       = СРЕД(ОргИНН, 12,20);
       
    Иначе
        // для конфигурации 1С:Налогоплательщик     
        СписокДанных.Установить( "Контекст",        Контекст );
        СписокДанных.Установить( "Дата",            Дата2 );
        СписокДанных.Установить( "ИНН",             "" );
        СписокДанных.Установить( "КППЮЛ",           "" );
   
        СписокДанных.Установить( "КаталогХранения", "" );
       
        Попытка
            глПолучитьДанные( СписокДанных );  
        Исключение
        КонецПопытки;
       
        ОргИНН = СписокДанных.Получить( "ИНН" );
        ОргКПП = СписокДанных.Получить( "КППЮЛ" );
        ИНН       = СРЕД(ОргИНН, 1, 10);
        КПП    = ОргКПП;
       
    КонецЕсли;   
    Если СтрДлина(ОргИНН) <> 12 Тогда
        // Налогоплательщик - юр. лицо       
        ИНН = "00" + ИНН;       
    Иначе                                    
        // Налогоплательщик - физ. лицо
        ИНН = ОргИНН;
        КПП = "";       
    КонецЕсли;     
  
    Если  ПустоеЗначение(КаталогХранения)=1 Тогда
        // Определяем каталог хранения из ИБ
        КаталогХранения = СокрЛП(СписокДанных.Получить("КаталогХранения"));
    КонецЕсли;         
   
    ЗаполнитьИНН_КПП();
             
КонецПроцедуры // ЗаполнитьРеквизиты()

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Igоr Sаulеviсh (gutentag) 18.01.10 13:03
Имхо Ввиду выходов новой отчетности и релизов конфигураций, эта статья может не иметь практической ценности. В том числе из-за выхода новой декларации по НДС.
http://buh.ru/newsDescr-5680
http://buh.ru/newsDescr-5677
2. Алексей Новиков (novav) 18.01.10 13:25
Ошибка именно в новой декларации НДС релиза от 15 января 2010 года!!! В старых фрмах как раз все работало как часы.
3. Igоr Sаulеviсh (gutentag) 18.01.10 14:20
(2) Но у вас об этом в анотации ни слова нет :-/
4. Александр Зубцов (iov) 19.01.10 01:01
http://www.rnk.ru/news/tax/document128164.phtml
Без паники Налоговые службы и старые примут (Звонили - узнавали - те подтвердили).
5. Александр Зубцов (iov) 19.01.10 01:02
За код спасибо плюсану (но ОЧЕНь надеюсь что там нет ошибок)
6. Poppy (poppy) 20.01.10 00:27
(4) На местах об этом знают?
В пятницу до обеда принимали, потом отправили переделывать.

(5) К сожалению, ошибки есть.
7. Александр Зубцов (iov) 20.01.10 00:55
(6) А основание могли предоставить? Официальная публикация запланированная на 20 ? то есть последний день сдачи (и то не в тот же день имеют право требовать ибо в 6 утра никто ничего и не опубликует так что к обеду все с новыми формами быть не могут). так что это просто незнание сотрудников налоговой на местах.
8. Алексей Новиков (novav) 20.01.10 02:02
(6) 1c-цы сегодня выложили уже правленную отчетность, так что тема уже неактуальна... И где ошибки вы накопали, у меня на Предпринимателе все работает и отчетность уже 3 дня как используя эти исправления сформировал и сдал декларацию...
9. Poppy (poppy) 20.01.10 22:48
(7)
А кто говорит, что это сложное незнание сотрудников на местах? Иногда складывается впечатление, что такие места повсеместно. :'(
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа