gifts2017

Доработка отчета "Отчет по кадровым данным и данным расчетов для ЗиК.7.7 ред.2".

Опубликовал Борис Балясников (bb1962) в раздел Программирование - Практика программирования

Для подписчиков ИТС доступен отчет "Отчет по кадровым данным и данным расчетов для ЗиК.7.7". Начиная с 2010 года в программе "1С: Зарплата и Кадры" появился еще один журнал расчетов "Страховые взносы". С этим журналом расчетов отчет работать не умеет, т.е. раздел, посвященный ЕСН (с 2010 года страховым взносам), заполняться в 2010 году не будет.

Для подписчиков информационно-технологического сопровождения фирмы 1С (далее ИТС) доступен отчет "Отчет по кадровым данным и данным расчетов для ЗиК.7.7". Как следует из описания (см. Рис.1) он предназначен для вывода данных из двух журналов расчетов "Заплата" и "Налоги с ФОТ". Начиная с 2010 года в программе "1С: Зарплата и Кадры" появился еще один журнал расчетов "Страховые взносы". С этим журналом расчетов отчет работать не умеет, т.е. раздел, посвященный ЕСН (с 2010 года страховым взносам), заполняться в 2010 году не будет. По крайней мере на конец января 2010 года это так. Необходимые доработки описаны в приложенном файле.

Рис.1 Описание отчета.

Учтите, что в отчетах переходящих с 2009 года на 2010 год ЕСН формироваться будет неправильно, будут отражены суммы только 2010 года. Вряд ли кому понадобиться складывать суммы из разных налоговых периодов. Впрочем, желающие могут ввести для взносов 2010 года отдельные колонки. Нужно раскомментировать строки вида:

//Тзн.НоваяКолонка("ПФРНакопительнаяЧастьс2010","Число",16,2);

И новые виды расчета нужно добавлять в этом случае не в список спЕСН2010, а в список спЕСН.

Скачать файлы

Наименование Файл Версия Размер
Перечень необходимых доработок 261
.txt 2,42Kb
02.02.10
261
.txt 2,42Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Борис Балясников (bb1962) 08.02.10 10:31
Еще нужно заменить в 2010 году глСобратьДанныеДляЕСН() на глСобратьДанныеДляСтраховыхВзносов(). Можно вот так:
Добавлены строки (709, 715)
<-- //bb
<-- СобраныДанныеДляСтраховыхВзносовИлиЕСН = 0;
<-- Если ДатаГод(КонДата) >= 2010 Тогда
<-- Если глСобратьДанныеДляСтраховыхВзносов(ДоходыВычетыНалогиСотрудников,СпСотров,КонДата,Контекст) = 1 Тогда
<-- СобраныДанныеДляСтраховыхВзносовИлиЕСН = 1;
<-- КонецЕсли;
<-- Иначе
Добавлены строки (717, 722)
<-- СобраныДанныеДляСтраховыхВзносовИлиЕСН = 1;
<-- КонецЕсли;
<-- КонецЕсли;
<-- Если СобраныДанныеДляСтраховыхВзносовИлиЕСН = 1 Тогда
<-- //если базы ПФР и ОМС разные, то в качесте ЕСН = ОМС см. ниже Если (БазаПФР <> БазаОМС) ... значит нужно раскрыть по видам
<-- //bb\
Номера строк не совпадают с типовым отчетом!!!
2. Борис Балясников (bb1962) 08.02.10 10:46
Есть вариант для комплексной конфигурации.
3. Михаил Величко (Efklid) 17.04.10 16:22
Не могу понять до конца - этот .txt похож на какой-то патч-фаил. Его нужно как-то применять? Или все делать вручную?
Пытаюсть вручную искать и доьбавлять указанные строки, но вижу что они не совпадают.
Что с этим делать подскажите пожалуйста! :?:
4. Борис Балясников (bb1962) 18.04.10 12:28
(3) Нужно вручную исправить модуль отчета, используя эту информацию.
5. Михаил Величко (Efklid) 20.04.10 11:32
(4) Тогда что делать с несовпадением строк? Или строки только у меня не совпадают?
Подскажите хотя бы после чего вставлять те или иные строки.
6. svetic (svetic) 05.10.11 09:26
Обработка актуальная, но не работает в 314 релизе
7. Борис Балясников (bb1962) 05.10.11 09:38
svetic пишет:
Обработка актуальная, но не работает в 314 релизе

Работает, доработанная как описано, работает.
8. Светлана Фоменко (safia-med) 13.03.14 10:32
Будет ли работать в 336 релизе
9. Борис Балясников (bb1962) 13.03.14 11:01
(8) safia-med, до 2014 - будет, с 2014 в части ПФР не будет.