gifts2017

1С - Внутренние идентификаторы объектов

Опубликовал Владимир (V0fka) в раздел Программирование - Практика программирования

1С 7.7 - Внутренние идентификаторы объектов

Функция ПолучитьИД_Вариант1(Объект)
Перем Стр;
Стр=ЗначениеВСтрокуВнутр(Объект);
СЗ=СоздатьОбъект("СписокЗначений");
СЗ.ИзСтрокиСРазделителями(Сред(Стр,2,СтрДлина(Стр)-2));
Возврат СЗ.ПолучитьЗначение(СЗ.РазмерСписка());
КонецФункции
//_____________________________________________________________________________

Функция ПолучитьИД_Вариант2(Объект)
Перем Стр;
СЗ=СоздатьОбъект("СписокЗначений");
СЗ.ДобавитьЗначение("",Объект);
СЗ.ПолучитьЗначение(1,Стр);
Возврат Стр;
КонецФункции
//_____________________________________________________________________________

Процедура Сформировать()
// Пусть "Объект" - это реквизит формы типа "Справочник"
Сообщить("Объект: "+Объект.ТекущийЭлемент());
Сообщить("Вариант 1: "+ПолучитьИД_Вариант1(Объект.ТекущийЭлемент()));
Сообщить("Вариант 2: "+ПолучитьИД_Вариант2(Объект.ТекущийЭлемент()));
КонецПроцедуры




Если нужно получить id в том виде, в котором он хранится в таблицах 1С, воспользуйтесь недокументированной функцией _IdToStr(),
н-р: Сообщить("Вариант 1: "+_IdToStr(ПолучитьИД_Вариант1(Объект.ТекущийЭлемент())));
Подробнее о недокументированных возможностях 1С можно посмотреть здесь.

Необходимо добавить, что если база с использованием УРБД, то система не контролирует уникальность этого идентификационного номера.
Необходимо еще к номеру добавлять место создания, т.е. префикс той базы, где был создан объект.

Формат строки, полученной с помощью ф-ии ЗначениеВСтрокуВнутр():

Список = СоздатьОбъект("СписокЗначений");
Список.ДобавитьЗначение("O"); // тип
Список.ДобавитьЗначение("0"); // длина
Список.ДобавитьЗначение("0"); // точность
Список.ДобавитьЗначение("255"); // ИД вида объекта
Список.ДобавитьЗначение("0"); // флаг неотр. (?)
Список.ДобавитьЗначение("0"); // флаг разделения триад (?)
Список.ДобавитьЗначение("9548"); // ИД объекта
Зн = ЗначениеИзСтрокиВнутр("{"+Список.ВСтрокуСРазделителями()+"}")

Седьмой параметр списка - строка 13 символов:
01-10 ИД вида объекта
11-20 ИД объекта
21-23 ИД информационной базы (УРИБ).
В таком виде он будет, если передавать не Объект.ТекущийЭлемент(), а просто Объект.

Типы объектов:
Неопределенный "U"
Число "N"
Строка "S"
Дата "D"
<> "B"
<> "O"
<> "T"
<> "P"
<> "K"
<> "C"
<> "A"



(с) интернет

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Александр Рытов (Арчибальд) 02.02.10 16:33
Сейчас 5 минут пройдет, и отплюсуюсь :D
2. Юрий Тимофеев (Tatitutu) 02.02.10 16:36
(с) интернет
- вот как то так, но не как не программа (тем более Ваша)
был раньше сайт хороший с FAQ по 1С как то http://www.sinor.ru/~my1c (точно не помню названия,сайт закрыт, но точно вижу что это оттуда)
3. RomDron (RomDron) 02.02.10 16:52
4. Владимир (V0fka) 02.02.10 16:52
(2) у меня это в текстовом файле было. Откуда взял - не помню. Вот и написал (с) интернет :oops:
5. Владимир (V0fka) 02.02.10 16:53
6. Владимир (V0fka) 02.02.10 16:55
7. vip (vip) 02.02.10 16:57
(2) угу
У Ёпрста ссылка есть.
Ёпрст; +1 Ответить
8. vip (vip) 02.02.10 16:58
(4) У Рупора Абсурда ты взял не спросясь.
9. Сергей Кучеров (СергейКа) 02.02.10 18:13
(2) ссылка точная.
Прикладываю файл оттуда в виде doc. Когда-то был скопирован... Не изменял, с примечаниями оригинала.
Прикрепленные файлы:
1с.doc
Арчибальд; +1 Ответить
10. RomDron (RomDron) 03.02.10 08:17
(5) Ответ можно считать так "Это невозможно в принципе"? :D
11. Епрст (Ёпрст) 03.02.10 10:37
Баян с синьёры ?
Низачот
12. Епрст (Ёпрст) 03.02.10 10:38
(2) Весь FAQ с синьёры есть в вебархиве, если что.