(V 7.7) Справка по работе с метаданными (с примерами)

Опубликовал Tatitutu в раздел Программирование - Практика программирования

Когда то, мне очень потребовалось ПРОГРАММНО узнать ЕСЛИ ли на конфигурации пароль....и на этом этапе я познакомился с МЕТАДАННЫМИ 1С.


Метаданные в 1С - это специальные данные, описывающие структуру базы данных. Почти все, что мы видим в графическом представлении в конфигураторе может быть получено программным путем при работе в 1С в режиме «Предприятие». Исключение составляют только наборы прав и интерфейсы. В программе получение метаданных происходит через объект «Метаданные».

Метаданные в 1С - это специальные данные, описывающие структуру базы данных. Почти все, что мы видим в графическом представлении в конфигураторе может быть получено программным путем при работе в 1С в режиме «Предприятие». Исключение составляют только наборы прав и интерфейсы. В программе получение метаданных происходит через объект «Метаданные».

Теперь рассмотрим подробно все разделы метаданных. Для краткости будут описаны только основные свойства. Всю доступную информацию о метаданных можно получить в конфигураторе: Главное меню -> Конфигурация -> Описание структуры метаданных.

(Константы)

С помощью объекта метаданных «Константа» можно получить доступ к списку констант конфигурации и к свойствам каждой из констант.

Метаданные.Константа() - возвращает количество констант в конфигурации. Доступ к свойствам константы возможен либо по ее порядковому номеру в конфигурации, либо по ее идентификатору. Метаданные.Константа(["Идентификатор"/Номер]).

У константы есть следующие свойства:
- Идентификатор - идентификатор константы (Cтрока).
- Синоним - синоним константы (Cтрока).
- Комментарий - комментарий константы (Cтрока).
- Тип - тип константы (Cтрока).
- Вид - вид (Cтрока), (если тип - Справочник).
- Длина - длина (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - запрет отрицательных значений (Число [0/1]).
- РазделятьТриады - разделять триады (Число [0/1]).
- Периодический - является ли данная константа периодической (Число [0/1]).

Вот пример доступа к константам по их порядковому номеру, сообщающий все константы конфигурации и их свойства:
Для к=1 по Метаданные.Константа() Цикл
  Сообщить("===============Константа==================");
  Сообщить("Идентификатор: "+Метаданные.Константа(к).Идентификатор);
  Сообщить("Синоним:" +Метаданные.Константа(к).Синоним);
  Сообщить("Комментарий: "+Метаданные.Константа(к).Комментарий);
  Сообщить("Тип: "+Метаданные.Константа(к).Тип);
  Сообщить("Вид: "+Метаданные.Константа(к).Вид);
  Сообщить("Длина: "+Метаданные.Константа(к).Длина);
  Сообщить("Точность: "+Метаданные.Константа(к).Точность);
  Сообщить("НеОтрицательный: "+Метаданные.Константа(к).НеОтрицательный);
  Сообщить("РазделятьТриады: "+Метаданные.Константа(к).РазделятьТриады);
  Сообщить("Периодический: "+Метаданные.Константа(к).Периодический);
КонецЦикла;

Доступ по идентификатору:
Сообщить("Тип:"+Метаданные.Константа("ОсновнаяВалюта").Тип);

(Справочники) 

Количество справочников в конфигурации можно узнать следующим образом: Метаданные.Справочник().

Для работы с метаданными справочников используется такая конструкция: Метаданные.Справочник(["Идентификатор"/Номер]).

У каждого справочника доступны следующие свойства:
- Идентификатор - идентификатор справочника (Cтрока).
- Синоним - синоним справочника (Cтрока).
- Комментарий - комментарий справочника (Cтрока).
- Владелец - ссылка на справочник-владелец (МетаданныеСсылка).
- КоличествоУровней - количество уровней в справочнике (Число).
- ДлинаКода - длина кода элемента/группы справочника (Число).
- ДлинаНаименования - длина наименования элемента/группы справочника (Число).
- СерииКодов - вариант назначения кодов справочника (Cтрока ["ВПределахПодчинения" / "ВесьСправочник"]).
- ТипКода - тип кода (Cтрока ["Числовой" / "Текстовый"]).
- ОсновноеПредставление - режим представления элемента/группы справочника (Cтрока ["ВВидеКода" / "ВВидеНаименования"]).
- КонтрольУникальности - контроль уникальность элементов справочника (Число [0 / 1]).
- АвтоНумерация - автоматическая нумерация элементов/групп справочника (Число [1 / 2]). 1 - нет автонумерации, 2 - есть.
- ГруппыВпереди - показывать группы в начале списка (Число [0 / 1]).
- СпособРедактирования - способ редактирования элемента/группы (Cтрока ["ВСписке" / "ВДиалоге" / "ОбоимиСпособами"]).
- ЕдинаяФормаЭлемента - одна форма для элемента и группы(Число [0 / 1]).
- ОсновнаяФорма - ссылка на основную форму списка справочника (МетаданныеСсылка).
- ОсновнаяФормаДляВыбора - ссылка на форму списка для выбора справочника (МетаданныеСсылка).
Количество реквизитов у справочника в конфигурации можно узнать следующим образом: Метаданные.Справочник(["Идентификатор"/Номер]).Реквизит()



Для доступа к свойствам реквизита справочника используется следующая конструкция:
Метаданные.Справочник(["Идентификатор"/Номер]).Реквизит(["Идентификатор"/Номер]), то есть после определения анализируемого справочника по его идентификатору или порядковому номеру в конфигурации идет определение реквизитов справочника по их идентификатору или порядковому номеру.

У каждого из реквизитов справочника доступны следующие свойства:
- Идентификатор - идентификатор реквизита справочника (Cтрока).
- Синоним - синоним реквизита справочника (Cтрока).
- Комментарий - комментарий реквизита справочника (Cтрока).
- Тип - тип реквизита справочника (Cтрока).
- Вид - вид реквизита справочника (Cтрока), (если тип - Справочник).
- Длина - длина (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - запрет отрицательных значений (Число [0 / 1]).
- РазделятьТриады - разделять триады (Число [0 / 1]).
- Периодический - является ли данный реквизит справочника периодическим (Число [0 / 1]).
- Сортировка - показывает, возможен ли отбор или поиск по данному реквизиту методами НайтиПоРеквизиту() или ВыбратьЭлементыПоРеквизиту()(Число [0 / 1]).
- Отбор - показывает, возможен ли интерактивный отбор элементов (Число [0 / 1]).
- РучноеИзменение - показывает, разрешено ли ручное изменение для данного реквизита, если он периодический (Число [0 / 1]).
- ИзменяетсяДокументами - показывает возможность установления периодического реквизита документами(Число [0 / 1]).
- Использование - режим использования реквизита справочника (Cтрока ["ДляЭлемента","ДляГруппы","ДляОбоих"]).

Далее следует описание всех доступных форм списка справочника.

Количество имеющихся форм можно узнать следующим образом: Метаданные.Справочник(["Идентификатор"/Номер]).ФормаСписка();

У формы списка есть три доступных свойства:
- Идентификатор - идентификатор формы списка(Cтрока).
- Синоним - синоним формы списка(Cтрока).
- Комментарий - комментарий формы списка(Cтрока).
 

 (Общие реквизиты документов) 

Для получения сведения о количестве общих реквизитов документов из метаданных используется конструкция: Метаданные.ОбщийРеквизитДокумента();

Для доступа к свойствам каждого реквизита в свойствах общего реквизита документа используется следующая конструкция:
Метаданные.ОбщийРеквизитДокумента(["Идентификатор"/Номер]).Реквизит(["Идентификатор"/Номер]), то есть после определения анализируемого общего реквизита документа по его идентификатору или порядковому номеру в конфигурации идет определение реквзитов общего реквизита документа по их идентификатору или порядковому номеру.

У каждого из общих реквизитов документа доступны следующие свойства:
- Идентификатор - идентификатор общего реквизита документа (Cтрока).
- Синоним - синоним реквизита общего реквизита документа (Cтрока).
- Комментарий - комментарий реквизита общего реквизита документа (Cтрока).
- Тип - тип реквизита общего реквизита документа (Cтрока).
- Вид - вид реквизита общего реквизита документа (Cтрока), (если тип - Справочник).
- Длина - длина (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - запрет отрицательных значений (Число [0/1]).
- РазделятьТриады - разделять триады (Число [0/1]).
- Сортировка - показывает, режим размещения поля, содержащего данный общий реквизит документа в базе данных (Число [0/1]). Если 0 - то такое поле содержится в шапке каждого из документов, если 1 - такое поле не содержится в документах, а содержится в журнале документов 1sjourn.

Вот пример доступа к общим реквизитам документа по их порядковому номеру, сообщающий все общие реквизиты документа в конфигурации и их свойства:
Колво=Метаданные.ОбщийРеквизитДокумента();
Для к=1 по Колво Цикл
  Сообщить("===============Общий реквизит документа==================");
  Сообщить("Идентификатор:"+Метаданные.ОбщийРеквизитДокумента(к).Идентификатор);
  Сообщить("Синоним:"+Метаданные.ОбщийРеквизитДокумента(к).Синоним);
  Сообщить("Комментарий:"+Метаданные.ОбщийРеквизитДокумента(к).Комментарий);
  Сообщить("Тип:"+Метаданные.ОбщийРеквизитДокумента(к).Тип);
  Сообщить("Вид:"+Метаданные.ОбщийРеквизитДокумента(к).Вид);
  Сообщить("Длина:"+Метаданные.ОбщийРеквизитДокумента(к).Длина);
  Сообщить("Точность:"+Метаданные.ОбщийРеквизитДокумента(к).Точность);
  Сообщить("НеОтрицательный:"+Метаданные.ОбщийРеквизитДокумента(к).НеОтрицательный);
  Сообщить("РазделятьТриады:"+Метаданные.ОбщийРеквизитДокумента(к).РазделятьТриады);
  Сообщить("Сортировка:"+Метаданные.ОбщийРеквизитДокумента(к).Сортировка);
КонецЦикла;

(Нумераторы) 

Нумераторы в 1С - очень полезная вещь. Они позволяют вести сквозную нумерацию по нескольким различным видам документов.

Количество нумераторов в конфигурации можно узнать следующим образом: Метаданные.Нумератор().

Для работы с метаданными нумераторов используется такая констукция: Метаданные.Нумератор(["Идентификатор"/Номер]).

У каждого нумератора доступны следующие свойства:
- Идентификатор - идентификатор нумератора (Cтрока).
- Синоним - синоним нумератора (Cтрока).
- Комментарий - комментарий нумератора (Cтрока).
- ПериодичностьНомера - вариант установленной периодичности номера для данного нумератора (Строка ["Все"/"Год"/"Квартал"/"Месяц"/"День"]).
- ДлинаНомера - длина номера документа для этого нумератора (Число).
- ТипНомера - тип номера документа в нумераторе (Строка ["Числовой"/"Текстовый"]).
- АвтоНумерация - признак автонумерации документа Число ["1"/"2"]). Единица обозначает отсутствие автонумерации документов, двойка - наличие автонумерации.
- КонтрольУникальности - признак контроля уникальности номеров документов для данного нумератора Число ["0"/"1"]). Ноль - нет контроля, единица - контроль включен.

 (Документы)  

Для получения количества документов, присутствующих в конфигурации, используется следующая конструкция: Метаданные.Документ();

Для работы с метаданными документов используется такая констукция: Метаданные.Документ(["Идентификатор"/Номер]).
Присутствующая в метаданных информация описывает как свойства самого документа, так и свойства всех его реквизитов, как находящихся в шапке, так и в табличной части документа (об общих реквизитах документа можно прочитать здесь).



Для начала рассмотрим непосредственно свойства документа:
- Идентификатор - идентификатор документа (Cтрока).
- Синоним - синоним документа (Cтрока).
- Комментарий - комментарий документа (Cтрока).
- Журнал - ссылка на журнал, к которому относится данный документ (МетаданныеСсылка).
- ПериодичностьНомера - вариант установленной периодичности номера (Строка ["Все" / "Год" / "Квартал" / "Месяц" / "День"]).
- ДлинаНомера - длина номера документа (Число).
- ТипНомера - тип номера в документе (Строка ["Числовой" / "Текстовый"]).
- АвтоНумерация - признак автонумерации документа Число ["1" / "2"]). Единица обозначает отсутствие автонумерации документов, двойка - наличие автонумерации.
- КонтрольУникальности - признак контроля уникальности номеров документов Число ["0" / "1"]). Ноль - нет контроля, единица - контроль включен.
- Нумератор - ссылка на используемый в документе нумератор (МетаданныеСсылка).
- ОперативныйУчет - признак принадлежности документа к оперативному учету (Число ["0" / "1"]).
- Расчет - признак принадлежности документа к расчету (Число ["0" / "1"]).
- БухгалтерскийУчет - признак принадлежности документа к бухгалтерскому учету (Число ["0" / "1"]).
- СоздаватьОперацию - вариант создания операции в бухгалтерских документах (Строка ["Всегда" / "Выборочно" / "ТолькоПриПроведении"]).
- АвтоНумерацияСтрок - признак автоматической нумерации строк документа (Число ["0" / "1"]).
- АвтоудалениеДвижений - признак автоматического удаления движений (Число ["0" / "1"]).
- РедактированиеОпераций - признак разрешения редактировать операцию документа (Число ["0" / "1"]).
- РазрешитьПроведение - признак разрешения проведения документа (Число ["0" / "1"]).
- ВводимыеНаОснованииДокументы - список документов, вводимых на основании документов данного вида (МетаданныеСсылки).
- ОснованиеДляЛюбогоДокумента - признак принадлежности документа к бухгалтерскому учету (Число ["0" / "1"]).
- ОбластьРаспространения - область распространения данных документов этого вида (Строка ["ВсеИнформационныеБазы" / "МестоСоздания" / "МестоСозданияИЦентр"]).
- АвтоРегистрация - автоматическая регистрация изменений (Число ["0" / "1"]).
- ДополнительныеКодыИБ - дополнительные коды баз для компоненты УРБД (Строка).

Для доступа к метаданным, описывающим реквизиты документа используется следующий механизм доступа.

Для получения количества реквизитов шапки документа используется обращение:
Метаданные.Документ(["Идентификатор"/Номер]).РеквизитШапки().

Для обращения к свойствам реквизита используется такая конструкция:
Метаданные.Документ(["Идентификатор"/Номер]).РеквизитШапки(["Идентификатор"/Номер]).

У каждого из реквизитов шапки документа доступны следующие свойства:
- Идентификатор - идентификатор реквизита документа (Cтрока).
- Синоним - синоним реквизита документа (Cтрока).
- Комментарий - комментарий реквизита документа (Cтрока).
- Тип - тип реквизита документа (Cтрока).
- Вид - вид реквизита (Cтрока), (если тип - Справочник).
- Длина - длина (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - запрет отрицательных значений (Число [0 / 1]).
- РазделятьТриады - разделять триады (Число [0 / 1]).

Для получения количества реквизитов табличной части документа используется обращение:
Метаданные.Документ(["Идентификатор"/Номер]).РеквизитТабличнойЧасти().

Для обращения к свойствам реквизита табличной части документа используется такая конструкция:
Метаданные.Документ(["Идентификатор"/Номер]).РеквизитТабличнойЧасти(["Идентификатор"/Номер]).

У каждого из реквизитов табличной части документа доступны следующие свойства:
- Идентификатор - идентификатор реквизита табличной части документа (Cтрока).
- Синоним - синоним реквизита табличной части документа (Cтрока).
- Комментарий - комментарий реквизита табличной части документа (Cтрока).
- Тип - тип реквизита документа (Cтрока).
- Вид - вид реквизита (Cтрока), (если тип - Справочник).
- Длина - длина (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - запрет отрицательных значений (Число [0 / 1]).
- РазделятьТриады - разделять триады (Число [0 / 1]).
- ИтогПоКолонке - признак наличия итога по колонке для данного реквизита табличной части документа (Число ["0" / "1"]).

(Журналы)  

Количество журналов в конфигурации можно узнать следующим образом: Метаданные.Журнал().

Для работы с метаданными журналов используется такая констукция: Метаданные.Журнал(["Идентификатор" / Номер]).

У каждого журнала доступны следующие свойства:
- Идентификатор - идентификатор журнала (Cтрока).
- Синоним - синоним журнала (Cтрока).
- Комментарий - комментарий журнала (Cтрока).
- ТипЖурнала - тип журнала (Cтрока ["Обычный" / "Общий" / "Дополнительный"]).
- Состав - Список документов, входящих в данный журнал (МетаданныеСсылки).
- ОсновнаяФорма - Основная форма журнала (МетаданныеСсылка).
- ОсновнаяФормаДляВыбора - Форма журнала, предназначенная для выбора документа (МетаданныеСсылка).
- ДляЖурналаПодчиненныхДокументов - признак использования данного журнала в качестве журнала подчиненных документов (Число ["0" / "1"]).
- ДляПолногоЖурнала - признак использования данного журнала в качестве полного журнала документов (Число ["0" / "1"]).

Кроме всего прочего, метаданные позволяют получить доступ к свойствам граф журнала. Количество существующих граф журнала определяется следующим образом: Метаданные.Журнал(["Идентификатор" / Номер]).Графа();.

Соответственно, чтобы получить доступ к свойствам конкретной графы используется следующая конструкция: Метаданные.Журнал(["Идентификатор" / Номер]).Графа(["Идентификатор" / Номер]).

У каждой графы журнала существует следующий набор свойств:
- Идентификатор - идентификатор графы журнала (Cтрока).
- Синоним - синоним графы журнала (Cтрока).
- Комментарий - комментарий графы журнала (Cтрока).
- Ссылки - список ссылок на реквизиты документов, составляющие содержимое данной графы (МетаданныеСсылки).

Далее следует описание всех доступных форм списка журнала.

Количество имеющихся форм можно узнать следующим образом: Метаданные.Журнал(["Идентификатор"/Номер]).ФормаСписка();

У формы списка есть три доступных свойства:
- Идентификатор - идентификатор формы списка(Cтрока).
- Синоним - синоним формы списка(Cтрока).
- Комментарий - комментарий формы списка(Cтрока).

(Перечисления) 

Количество перечислений в конфигурации можно узнать следующим образом: Метаданные.Перечисление();.

Для работы с метаданными перечислений используется такая констукция: Метаданные.Перечисление(["Идентификатор" / Номер]).

У каждого перечисления доступны следующие свойства:
- Идентификатор - идентификатор перечисления (Cтрока).
- Синоним - синоним перечисления (Cтрока).
- Комментарий - комментарий перечисления (Cтрока).

Далее следует описание всех доступных значений перечисления.

Количество имеющихся значений перечисления можно узнать следующим образом: Метаданные.Перечисление(["Идентификатор"/Номер]).Значение();

У каждого значения перечисления есть три доступных свойства:
- Идентификатор - идентификатор значения перечисления (Cтрока).
- Комментарий - комментарий значения перечисления (Cтрока).
- Представление - представление значения перечисления (Cтрока).

Вот пример доступа к перечислениям по их порядковому номеру, сообщающий все виды и значения перечислений в конфигурации и их свойства:
Для к=1 по Метаданные.Перечисление() Цикл
   ТекВид=Метаданные.Перечисление(к);
  Сообщить("====================Перечисление====================","!!!");
  Сообщить("Идентификатор: "+ТекВид.Идентификатор,"i");
  Сообщить("Синоним: "+ТекВид.Синоним,"i");
  Сообщить("Комментарий: "+ТекВид.Комментарий);


   Для й=1 по ТекВид.Значение() Цикл
      Сообщить("----------Значение----------","!");
      ТекЗнач=ТекВид.Значение(й);
      Сообщить("Идентификатор: "+ТекЗнач.Идентификатор);
      Сообщить("Комментарий: "+ТекЗнач.Комментарий);
      Сообщить("Представление: "+ТекЗнач.Представление);
  КонецЦикла;


КонецЦикла;

 

(Отчеты и обработки)

Количество отчетов и обработок в конфигурации можно узнать следующим образом: Метаданные.Отчет(); и Метаданные.Обработка();.

Для работы с метаданными отчетов и обработок используется такие констукции: Метаданные.Отчет(["Идентификатор" / Номер]) и Метаданные.Обработка(["Идентификатор" / Номер]).

У каждого отчета и обработки доступны следующие свойства:
- Идентификатор - идентификатор отчета или обработки (Cтрока).
- Синоним - синоним отчета или обработки (Cтрока).
- Комментарий - комментарий отчета или обработки (Cтрока).

(Последовательности)

Количество последовательностей в конфигурации можно узнать следующим образом: Метаданные.Последовательность();.

Для работы с метаданными последовательностей используется такие констукции: Метаданные.Последовательность(["Идентификатор" / Номер]).

У каждой последовательности доступны следующие свойства:
- Идентификатор - идентификатор последовательности (Cтрока).
- Синоним - синоним последовательности (Cтрока).
- Комментарий - комментарий последовательности (Cтрока).
- ВлияющиеДвижения - список регистров, влияющих на данную последовательность (МетаданныеСсылки).
- Документы - список документов, входящих в данную последовательность (МетаданныеСсылки).

 (Регистры) 

Для получения количества регистров, присутствующих в конфигурации, используется следующая конструкция: Метаданные.Регистр();

Для работы с метаданными регистров используется такая констукция: Метаданные.Регистр(["Идентификатор"/Номер]).

У регистра доступны следующие свойства:
- Идентификатор - идентификатор регистра (Cтрока).
- Синоним - синоним регистра (Cтрока).
- Комментарий - комментарий регистра (Cтрока).
- ТипРегистра - тип регистра (Строка ["Остатки" / "Обороты"]).
- ПериодичностьРегистра - периодичность хранения оборотов для оборотного регистра (Cтрока ["День" / "Неделя" / "Декада" / "Месяц" / "Квартал" / "Год"]).
- БыстраяОбработкаДвижений - признак установленности быстрой обработки движений для регистра (Число ["0" / "1"]).
- МиграцияЗапрещена - Признак запрета миграции данного регистра в другие базы при использовании компоненты управления разпределенными базами данных (Число ["0" / "1"]).

У каждого регистра может быть набор измерений, ресурсов и реквизитов. Рассмотрим всех их по порядку.

Для получения количества измерений у регистра используется следующая конструкция: Метаданные.Регистр(["Идентификатор" / Номер]).Измерение();

Для доступа к свойствам измерения используется следующая конструкция: Метаданные.Регистр(["Идентификатор" / Номер]).Измерение(["Идентификатор" / Номер]);

У каждого из измерений регистра доступны следующие свойства:
- Идентификатор - идентификатор измерения регистра (Cтрока).
- Синоним - синоним измерения регистра (Cтрока).
- Комментарий - комментарий измерения регистра (Cтрока).
- Тип - тип измерения регистра (Cтрока).
- Вид - вид измерения регистра (Cтрока), (если тип - Справочник, Документ или Перечисление).
- Длина - длина (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - не используется.
- РазделятьТриады - разделять триады (Число [0 / 1]).
- ОтборДвижений - признак установленности отбора движений для регистра по данному реквизиту (фактически означает создание дополнительного индекса к таблице движений регистра).(Число ["0" / "1"]).
- ОтборИтогов - признак установленности отбора итогов для регистра по данному реквизиту (фактически означает создание дополнительного индекса к таблице итогов регистра).(Число ["0" / "1"]).

Для получения количества ресурсов у регистра используется следующая конструкция: Метаданные.Регистр(["Идентификатор" / Номер]).Ресурс();

Для доступа к свойствам ресурсов используется следующая конструкция: Метаданные.Регистр(["Идентификатор" / Номер]).Ресурс(["Идентификатор" / Номер]);

У каждого из ресурсов регистра доступны следующие свойства:
- Идентификатор - идентификатор ресурса регистра (Cтрока).
- Синоним - синоним ресурса регистра (Cтрока).
- Комментарий - комментарий ресурса регистра (Cтрока).
- Тип - не используется, всегда "Число".
- Вид - не используется.
- Длина - длина (Число).
- Точность - точность (Число).
- НеОтрицательный - не используется.
- РазделятьТриады - разделять триады (Число [0 / 1]).

Для получения количества реквизитов у регистра используется следующая конструкция: Метаданные.Регистр(["Идентификатор" / Номер]).Реквизит();

Для доступа к свойствам реквизитов используется следующая конструкция: Метаданные.Регистр(["Идентификатор" / Номер]).Реквизит(["Идентификатор" / Номер]);

У каждого из ресурсов реквизитов доступны следующие свойства:
- Идентификатор - идентификатор реквизитов регистра (Cтрока).
- Синоним - синоним ресурса реквизитов (Cтрока).
- Комментарий - комментарий ресурса регистра (Cтрока).
- Тип - тип ресурса регистра (Cтрока).
- Вид - вид ресурса регистра (Cтрока), (если тип - Справочник, Документ или Перечисление).
- Длина - длина ресурса (Число), (если тип - Строка или Число).
- Точность - точность (если тип - Число).
- НеОтрицательный - запрет отрицательных значений (Число [0/1]).
- РазделятьТриады - разделять триады (Число [0 / 1]).
- Сортировка - признак установленного отбора движений по значению реквизита (фактически означачет дополнительный индекс по таблице движений регистра) (Число [0/1]).

(Графы отбора журналов) 

Для получения количества граф отбора журналов, присутствующих в конфигурации, используется следующая конструкция: Метаданные.ГрафаОтбора();

Для работы с метаданными граф отбора журналов используется такая констукция: Метаданные.ГрафаОтбора(["Идентификатор"/Номер]).

У графы отбора журнала доступны следующие свойства:
- Идентификатор - идентификатор графы отбора журнала (Cтрока).
- Синоним - синоним графы отбора журнала (Cтрока).
- Комментарий - комментарий графы отбора журнала (Cтрока).
- Ссылки - ссылки на элементы метаданных, формирующих данную графу отбора журнала (МетаданныеСсылки).
- ОтборПустыхЗначений - отбор пустых значений для графы отбора журнала (Число [0/1]).
- Тип - тип графы отбора журнала (Cтрока).
- Вид - вид графы отбора журнала (Cтрока), (если тип - Справочник, Документ или Перечисление).

(Свойства метаданных 1с) 

Здесь находится вся общая информация, описывающая конфигурацию 1с в целом:
- Метаданные.Идентификатор - идентификатор конфигурации (Cтрока). Пример: "Торговля+Склад, редакция 9.0"
- Метаданные.Синоним - синоним конфигурации (Cтрока).
- Метаданные.Комментарий - комментарий конфигурации (Cтрока).
- Метаданные.Пароль - наличие пароля на конфигурации (Число [0/1]).
- Метаданные.Язык - язык конфигурации (Cтрока). Пример: "Русский".
- Метаданные.Округление - выбранный в конфигурации вариант округления (Cтрока ["Окр1_5До2"/"Окр1_5До1"]).
- Метаданные.НепосредственноеУдалениеОбъектов - разрешено ли непосредственное удаление (Число [0/1]).
- Метаданные.АвторРазвернутаяИнформация - информация об авторе полная (Cтрока).
- Метаданные.АвторКороткаяИнформация - информация об авторе краткая (Cтрока).
- Метаданные.ЖурналПодчиненныхДокументов - журнал подчиненных документов (МетаданныеСсылка). Пример: "Журнал.Общий".
- Метаданные.ПолныйЖурнал - полный журнал документов (МетаданныеСсылка). Пример: "Журнал.Общий".

Тип реквизита метаданных 1с МетаданныеСсылка - это ссылка на другие объекты метаданных 1с.

 

Статью нашел на просторах сети

http://www.softpoint.ru/article_id77.htm 

88

См. также

Лучшие комментарии

7. afanasko 03.02.2010 18:00
(5). Нееее. Я не в том смысле, что статья плохая, а в том, что написана была очень давно и много раз всплывала на различных ресурсах. Я ее прочел еще в 2007-м.
Статья очень полезная -- это несомненно. Без умения работы с метаданными практически невозможно создать что-то универсальное и гибкое ))).
+ 1 [ Tatitutu; ]
# Ответить
8. Арчибальд 03.02.2010 18:08
(4)
Ответили: (10)
+ 1 [ ZOMI; ]
# Ответить
6. Tatitutu 03.02.2010 11:53
(5) Спасибо за ссылку на первоисточник - шапку поправил.
Ну что это баян - я с тобой не соглашусь. Хорошая и доступно понятная статья
по работе с метаданными.Как то так.
Ответили: (10)
+ 1 [ Kurt; ]
# Ответить
Отчет-сверка “Сравнение документов и справочников в двух базах” V4.01
Конфигурация “Планирование очереди заданий” V2.01
Настраиваемый управленческий баланс V3.14
Штрихкодовая линейка для автоматизации измерения габаритов
Мастер печатных форм (Управляемое приложение) v 1.8
Обработка распознает (читает) pdf - файл
Обработка "Консоль администратора 1С"
Проверка корректности заполнения счетов-фактур (web-сервис ФНС)
Выгрузка данных из Управления торговлей 10.3 в Бухгалтерию предприятия, ред. 3.0 (Версия 1.6.2)
АРМ "Жилой фонд" для управляющих компаний ЖКХ, ТСЖ
Рентабельность предприятия (конфигурация): Доходы и расходы; Денежные средства; Бюджет доходов и расходов, движения дене...
Алкогольная декларация для 1С 8 (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 формы) с подписью и шифрованием, редакция 2.3

Комментарии

Показать все сообщения
7. afanasko 03.02.2010 18:00
(5). Нееее. Я не в том смысле, что статья плохая, а в том, что написана была очень давно и много раз всплывала на различных ресурсах. Я ее прочел еще в 2007-м.
Статья очень полезная -- это несомненно. Без умения работы с метаданными практически невозможно создать что-то универсальное и гибкое ))).
+ 1 [ Tatitutu; ]
# Ответить
8. Арчибальд 03.02.2010 18:08
(4)
Ответили: (10)

Прикрепленные файлы:

meta.als
+ 1 [ ZOMI; ]
# Ответить
9. afanasko 03.02.2010 18:09
Кстати на сайте СофтПойнта еще очень много полезного. ;)
# Ответить
10. Valet 03.02.2010 23:31
(8)(6)Для тех кто для себя только открывает метаданные, als файл быстрее увидят, если он к статье прикреплен, а не к комментариям.
# Ответить
11. NoMax 04.02.2010 11:37
Еще можно и в HTML выводить http://infostart.ru/public/21844/
+ 1 [ Tatitutu; ]
# Ответить
12. nss 10.02.2010 11:20
отличная статья. Давно искал комплексную инфу по метаданным
# Ответить
13. IrinaKostroma 04.04.2012 19:12
Хорошая статья, помогла, а то по регистрам обычно пропускают описание.
# Ответить
14. notepad 27.08.2012 12:38
Хорошая статья, интересно, много нового узнал про метаданные.
# Ответить
15. sergiobargio1 18.10.2012 17:48
а как обратиться к метаданным табличной части документа?
может немного проконсультируете (в синакс-помощнике не могу отыскать) ?
пожалуйста, напишите как правильно с точки зрения синтаксиса обращаться к метаданным:
- находясь внутри модуля документа, определить табличные части документа;
- зная имя табличной части, обратиться к структуре табличной части;
- проверить заполнена ли табличная часть;
Ответили: (16)
# Ответить
16. valval 18.10.2012 19:56
(15) "а как обратиться к метаданным табличной части документа?"

Для Инд=1 По Метаданные.Документ() Цикл
мдДок = Метаданные.Документ(Инд);
ИДДок = мдДок.Идентификатор;
// обходим реквизиты
Для Инд2=1 По мдДок.РеквизитШапки() Цикл
Ркв=мдДок.РеквизитШапки(Инд2);
КонецЦикла;
Для Инд2=1 По мдДок.РеквизитТабличнойЧасти() Цикл
Ркв=мдДок.РеквизитТабличнойЧасти(Инд2);
КонецЦикла;
КонецЦикла;
+ 1 [ sergiobargio1; ]
# Ответить
Логин:
Пароль:
Текст сообщения*
Прикрепить файл
88
Другие публикации автора:

Создание 02.02.10 17:19

Обновление 20.06.11 11:04

№ Публикации 65108

Статистика:

Просмотры 17947

Загрузки 0

Комментарии 16