gifts2017

Проверка всех реквизитов работников для годовых отчетов (СЗВ-6, 2-НДФЛ) в ЗУП 2.5

Опубликовал Иван Чагаев (BoneD) в раздел Отчеты - Бухгалтерские

Отчет объединяет в себе проверки всех реквизитов (ИНН, номер ПФР, соответствие адреса загруженному в 1С КЛАДР), которые производятся при проведении документов СЗВ-6 и 2-НДФЛ. ВСЕ проверки "выдернуты" из кода 1С и собраны в одном месте.

 Отчет объединяет в себе проверки всех реквизитов (ИНН, номер ПФР, соответствие адреса загруженному в 1С КЛАДР), которые производятся при проведении документов СЗВ-6 и 2-НДФЛ. ВСЕ проверки "выдернуты" из кода 1С и собраны в одном месте.
 Может быть использован работниками отдела кадров для предварительной проверки правильности внесенных реквизитов, чтобы потом при формировании отчетов расчетным отделом выводилось меньше сообщений об ошибках по сотрудникам. Актуально для больших фирм, где корректировкой реквизитов работника занимается отдел кадров, а подготовкой инд.сведений в ПФР и налоговой - расчетный.
 Данные проверяются по сотрудникам, имеющим доход в указанном периоде (с возможностью отбора по организации).
 Есть возможность проверить сразу всех физ.лиц в базе данных, для этого надо указать "Проверять всех, независимо от дохода". Такой вариант больше подходит для внедрения ЗУП: для проверки данных после переноса из другой программы.
 По результатам отчета формируется таблица с подробным описанием найденных ошибок.

 История изменений: 

 Версия от 07.07.2010: добавлена возможность выбора реквизитов для проверки.

 Версия от 12.07.2010: добавлена возможность проверки всех физ.лиц в базе данных.

 Версия от 01.03.2011: отчет адаптирован для использования в версии ЗУП начиная с 2.5.31.4.

Скачать файлы

Наименование Файл Версия Размер
ПроверкаРеквизитовРаботниковДляОтчетов.epf 479
.erf 19,72Kb
02.03.16
479
.erf 02.03.2016 19,72Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Роман Осадченко (cleaner_it) 02.07.10 04:35
2. mikle vedekhin (MikleVV) 25.02.11 21:42
в ЗУП 2.5.31.4 8.2 ругаетсая:

----------------------------------------------------------------------------------
{Форма.Форма.Форма(377)}: Ошибка при вызове метода контекста (Выполнить)
ВыборкаФизЛиц = Запрос.Выполнить().Выбрать();
по причине:

по причине:
{(17, 30)}: Поле не найдено "Гражданство.НеЯвляетсяНалоговымРезидентомРФ"
КОГДА ЕСТЬNULL(Гражданство.<<?>>НеЯвляетсяНалоговымРезидентомРФ, ЛОЖЬ)
------------------------------------------------------------------------

Не планируете выход обработки под новые релизы?
3. Андрей Григорьев (Borisych) 26.02.11 00:59
Форма кривовата, кнопка справки без справки, но в общем полезная вещь
to (2) не адаптировал, просто исправил имя реквизита, помеченного на удаление фирмой 1С :
Прикрепленные файлы:
ПроверкаРеквизитовРаботниковПередПодготовкойРегламентированныхОтчетов.epf
4. mikle vedekhin (MikleVV) 26.02.11 12:03
5. Иван Чагаев (BoneD) 01.03.11 15:13
Borisych пишет:
Форма кривовата, кнопка справки без справки

Не надоело еще Borisych ругать и минусовать за мои обработки? И сахар не сладкий и уксус не кислый... Я ведь не пишу, что Ваша 2-НДФЛ с рестром образца 2009 г. это изобретение велосипеда, т.к. 1С форму тоже сделала и выложила на сайте техподдержки.
6. Сергей Иванов (chirs) 06.04.11 08:54
Borisych пишет:

Форма кривовата, кнопка справки без справки, но в общем полезная вещь

to (2) не адаптировал, просто исправил имя реквизита, помеченного на удаление фирмой 1С :

Какая нафиг справка ? какая нафиг красота ?
Отчет работает ! выводит результат - это самое главное !
Спасибо надо сказать, что человек потратил время на отчет, а потом еще и поделился им со всеми другими.
7. Юрий Сафонов (Ted1982) 16.09.11 15:09
Интересная обработка. В поддерживаемых организациях приходится использовать дополнительные проверки, но данная обработка помогла (сэкономила время - просто добавил свои проверки)
8. Ирина (lika11) 26.12.11 12:30
Нужная вещь-показывает все недочеты при оформлении сотрудников.Мне очень помогла.
9. rasswet (rasswet) 05.04.12 12:15
Спасибо, на 2.5.48.1 работает. Правда с трудом нашел поиском.
10. Алексей Тараканов (taramaz) 11.04.12 18:39
2.5.48.1 да. Большое спасибо.
11. Андрей А. (Amras) 12.07.12 08:31
Спасибо за обработку. Еще можно проверять код подразделения в паспорте РФ, примерно такую функцию добавить надо (почему ее в типовой конфе не придумали?):

Функция ПроверитьКодПодразделенияУдостоверенияЛичности(ДокументКодИМНС, Знач КодПодразделения , СтрОшибка) Экспорт
	
	// проверка
	Если ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС01
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС03 Тогда
		ТипДока = 1;
	ИначеЕсли ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС04
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС06
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС07
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС26
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС27 Тогда
		ТипДока = 2;
	ИначеЕсли ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС02
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС09
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС22 Тогда
		ТипДока = 3;
	ИначеЕсли ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС21 Тогда
		ТипДока = 4;
	Иначе
		ТипДока = 5;
	КонецЕсли;
	
	СтрОшибка = "";
	
	КодПодразделения = СокрЛП(КодПодразделения);
	
	Если ТипДока = 4 Тогда // КодПодразделения - две группы цифр разделенные <->: новый паспорт
		
		Поз = Найти(КодПодразделения,"-");
		Если Поз=0 Тогда
			СтрОшибка = "В коде подразделения документа должно быть две группы цифр, разделенных <->!";
			Возврат Ложь;
		КонецЕсли;
		
		ПервЧасть = Лев(КодПодразделения,Поз-1);
		ВторЧасть = СокрЛП(Сред(КодПодразделения,Поз+1));
		
		Поз = Найти(ВторЧасть," ");
		Если Поз <> 0 Тогда
			СтрОшибка = "В коде подразделения документа должно быть только две группы цифр!";
			Возврат Ложь;
		КонецЕсли;
		
		Если (СтрДлина(ПервЧасть) <> 3) ИЛИ
			(ПустаяСтрока(РегламентированнаяОтчетность.ЗаменитьОдниСимволыДругими("0123456789",ПервЧасть,"          "))=0) Тогда
			СтрОшибка = "Первая группа символов кода подразделения документа должна содержать три цифры!";
			Возврат Ложь;
		КонецЕсли;
		
		Если (СтрДлина(ВторЧасть) <> 3) ИЛИ
			(ПустаяСтрока(РегламентированнаяОтчетность.ЗаменитьОдниСимволыДругими("0123456789",ВторЧасть,"          "))=0) Тогда
			СтрОшибка = "Вторая группа символов кода подразделения документа должна содержать три цифры!";
			Возврат Ложь;
		КонецЕсли;
	Иначе
		// Пока нет проверки других типов документов
	КонецЕсли;
	
	Возврат Истина;
КонецФункции
...Показать Скрыть


Покопаюсь еще в обработке, может какие идеи позаимствую для проверки данных.
12. Андрей А. (Amras) 12.07.12 09:45
Хочу спросить разрешения автора, немного дополнил обработку, можно ли выложить почти все тоже самое, но малость с расширенной проверкой (?):
- Просроченный паспорт;
- Отбор по подразделениям;
- Проверка на код подразделения удостоверения личности.
13. Иван Чагаев (BoneD) 12.07.12 18:06
(12) Ради бога, но она не особо "урожайная" на плюсы. Я её давно не расширяю, только скрытие настроек добавил недавно.
14. Андрей А. (Amras) 13.07.12 07:41
(13) Не ради плюсов оно. Просто столкнулся с задачей формирования реестра для открытия счетов в банке, а там как раз нужно много проверок разных, и дабы сократить время, изменил этот отчет и отдал его в кадры, пусть проверяют. Им понравилось.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа