Обновления 2012 . Для пользователя, бухгалтера (пакет отчетов и обработок)

Опубликовал kompas-dm в раздел Обработки - Менеджеры внешних отчетов

Пакет  обработок и отчетов для бухгалтера построен по технологии регламентированных отчетов.
Технология ранее публиковалась в составе конфигурации. По просьбе пользователей ИС сделал самостоятельное приложение. В составе пакета представлены ряд обработок и отчетов для ежедневной работы ( стандартные, собственные и очень интересный, профессиональный  отчет от http://infostart.ru/public/14467/).
Обработка "ВнешниеОтчеты.ert" будет работать в любой бухгалтерской конфигурации 7.7.
Обновлено 3 января 2012 г.

Обновление 03 января 2012 г.

Работаем в законодательном поле налогового кодекса.

Состав пакета отчетов и обработок:

Основные средства

ОсновныеСредства2012.ert;             Основные средства : Бухгалтерский и налоговый учет
ИзносНУдекларация.ert;                   Износ для декларации - налоговый учет

Зарплата

ЛицевойСчет2011.ert;                      Лицевой счет сотрудника (произвольный период)
ПерерасчетНДФЛ2011тип.ert;          Перерасчет НДФЛ годовой и на дату

Запасы, Деньги,Налоги

ДвижениеТМЦ.ert;                             Движение запасов
Деньги.ert;                                         Наши денежные счета
Расчет_Налогов.ert;                          Ведомость расчетов по налогам

Технологические обработки

ПечатьДоковDOCPRINT.ERT;                      Печать Документов
ПечатьСпрREFPRINT.ERT;                           Печать Справочников
ЗаменаСсылокСПР_Доков_REPLVAL.ERT;   Замена Ссылок в справочниках и документах
MOVEDOC.ERT;                                            Перенос документов (OLE)
УстановкаЗначенийSETATTRS.ERT;            Установка Значений
Очистка справочников.ert;                        Очистка справочников
УбратьТМЦиТовары.ert;                             Очистка номенклатуры товаров,услуг

09 августа 2011

Налоговый кодекс Украина. Основные средства по-новому.

Основа - новый План счетов с 1.04.2011, релиз 287-288. Отчет формирует данные о наличии ОС и начисленной амортизации раздельно по  бухгалтерскому и налоговому учету.

Также , можно получить данные для заполнения налоговой декларации (Приложение АМ)  -  по группам 1-17 в разрезе видов затрат

 

12 апреля 2011

-------------------------------------------------------------

В публикации  выложен отчет- Выгрузка данных по зарплате для Пенсионного фонда. Это альтернатива регламентированному "Отчет  пенсионнй фонд (ЕСВ) типовой 285

А это просто нужно знать Крылатые афоризмы

 

 

24 февраля 2011 г. ----------------------------------

 

Обновился отчет "Лицевая карточка". Теперь он работает и  с ЕСН.

__________________________________________________________________________________

Внешние отчеты не входят в саму конфигурацию, а представлены файлами, имеющих расширение ERT.   В данной работе внешние отчеты сгруппированы в свои смысловые каталоги :

1C_1NALOGI.REP

1C_2Бух.REP

1C_3TMC.REP

1C_4ZARP.REP

1C_5ОСВ.REP

1C_9Адм.REP


Каталог группы отчетов должен иметь название :
1C_?????????.REP, 
где:    1C_ , REP  -   латиница
 ??????????- кирилица,  краткое название
группы (Бух, Админ, и т.д )  . Пробелы не используем . Цифры в наименовании каталогов - для сортировки.

       Кроме того, в каталоге, содержащем группу отчетов, располагается
текстовый файл RpList.txt, содержащий перечень отчетов данной группы
и соответствующие им имена файлов.

Пример текстового файла  RpList.txt для группы (каталога) 1C_3TMC.REP :

ТМЦ и НМА // информация
ДинамикаТС.ert;Динамика реализации товаров
ДвижениеТМЦ.ert;Движение ТМЦ
НематериальныеАктивы.ert;Состояние Нематериальных Активов

Как пользоваться этим пакетом.

1. Распаковать вложение в любой каталог. Лучше создать новый.

2. Запустить обработку из  1С  из этого каталога (Меню: файл - открыть   - ВнешниеОтчеты.ert).

3. Все.

Для включения в интерфейс 1С :

конфигурация - интерфейсы - Основной (или какой надо) - панели инструментов - отчеты- создать новый - параметры - найти и выбрать файл "ВнешниеОтчеты.ert".

Для добавления своего (нового)  отчета:

Зайти в каталог, который Вы себе определили и где находится файл "ВнешниеОтчеты.ert":

1. Определиться с "папочкой", куда поместить новый отчет. Можно создать новую.

2.Записать туда новый файт (???????.ERT)

3.Отредактировать любым текстовым редактором файл  RPLIST.TXT, добавив строку

???????.ERT; Новый отчет

4.Все

              На ИС обработок по управлению внешними отчетами несколько. Хорошие, профессиональные. Этот вариант позволяет редактировать отчеты, обработки , добавлять новые и т.д. не притрагиваясь к 1С на компьютере пользователя. Мне нужно только знать расположение каталога с отчетами и иметь к нему доступ. Дальше - удаленка.... или по сети ...

Состав пакета:

Бухгалтерские (Движение денег на счетах предприятия)

ТМЦ и НМА (Движение ТМЦ, Состояние Нематериальных Активов, динамика реализации)

Зарплата (Лицевой счет работника) - НОВЫЙ 2011

Налоги (Ведомость расчетов по налогам)

Технологические обработки и администрирование

(Печать Документов,Печать Справочников,Замена Ссылок в справочниках и документах,Установка Значений,Перенос документов (OLE),Очистка справочников, перенос справочников (OLE))

 

Интерактивная ОСВ v2.50

 

 

 

 

 

 

 

Файлы

Наименование Файл Версия Размер Кол. Скачив.
Обновление_2012
.rar 130,36Kb
15.01.14
105
.rar 130,36Kb 105 Скачать
Лицевой Счет 2011
.rar 13,81Kb
15.01.14
183
.rar 13,81Kb 183 Скачать
ПакетБухУКР Обновление 13.12.2010
.zip 360,25Kb
15.01.14
314
.zip 360,25Kb 314 Скачать
Пакет_ обновление_22.12.2010
.zip 360,22Kb
15.01.14
120
.zip 360,22Kb 120 Скачать

См. также

Комментарии

1. Доня (файл скачал) 26.02.2010 12:42
Собрать готовые отчеты в один флакон - тоже нужная работа!
# Ответить
2. Agema (файл скачал) 26.02.2010 19:51
Извините, а для бюджетки 6.1 подойдет?
Ответили: (3) (12)
# Ответить
3. kompas-dm 27.02.2010 11:06
(2) Управление отчетами - да, а сами отчеты нужно пробовать. Все-таки Бюджет, там совсем другие субконто...
Ответили: (12)
# Ответить
4. Berrimor 28.02.2010 20:32
Посмотрите http://infostart.ru/public/14474/ и не изобретайте велосипед с квадратными колесами
Ответили: (5)
# Ответить
5. kompas-dm 01.03.2010 10:16
(4)
На ИС обработок по управлению внешними отчетами несколько. Хорошие, профессиональные. Этот вариант позволяет редактировать отчеты, обработки , добавлять новые и т.д. не притрагиваясь к 1С на компьютере пользователя.
.
У azernot другая заточка.
# Ответить
6. CheBurator 01.03.2010 14:52
беглый осмотр показал - что у Зернятко инструмент более предпочтительный.
Ответили: (7)
# Ответить
7. kompas-dm 01.03.2010 17:01
(6) "Нас уже 103060". Простых пользователей - 98 %. Для запуска серьезных работ нужен специалист, время и контакт с клиентом.
Работу регламентированных отчетов знают все. Просто и надежно.
С уважением отношусь к механизму azernot'а . Его обработка без доработок, с сохранением авторства использована мною в трех проектах.
Ориентировался на бухгалтеров, пользователей, находящихся без поддержки 1С-ника . Фишка не в управлении отчетами, а в составе пакета...
Ответили: (8)
# Ответить
8. artbear 01.03.2010 18:45
(7) Пока минусую из-за цитаты "Фишка не в управлении отчетами, а в составе пакета..."
Где состав пакета? где хотя бы краткое описание каждого отчета?

Поправишь, минус уберу.
Ответили: (9)
# Ответить
9. kompas-dm 02.03.2010 10:12
(8)
В составе пакета представлены ряд обработок и отчетов для ежедневной работы ( стандартные, собственные и очень интересный, профессиональный отчет от http://infostart.ru/public/14467/).

См СкринШоты, рис 3,4,5.
Да и размер скачивания 321 кб
Ответили: (10)
# Ответить
10. artbear 02.03.2010 15:17
(9) Спасибо. Минус убрал.
# Ответить
11. sema-5263 (файл скачал) 25.12.2010 19:45
Отчеты понравились.Очень.Только вот, самый нужный для меня..Налоги. Есть пару вопросов. Ну тот же Пенсионный. Вначислении идет разбивка сумми по фондам (32,2%,4%,2%), а вот с "Оплочено" у меня идет одной суммой,попадая ПФ с з/п с банковской выписки.Хотя...платежек было 3(32,2%,4%,2%),и в банковской выписке проходит тоже три суммы, а не одна общая, как показано в отчете. В итоге, остатки к начислению в отчете,не совпадают сфактическими по бух учету. Может кто-то объяснит в чем проблема???
# Ответить
12. dobraleks (файл скачал) 12.01.2011 16:34
отчеты понравились, вроде иду, но пока проверяю еще..
Отчет Необоротные активы не захотел на моей конфе работать, не давал выбирать план счетов, пришлось маленько подправить под себя. Может кому то пригодится:
Если ((сч.Забалансовый = 0) И ((сч.видсубконто(2) = ВидыСубконто.НеоборотныеАктивы) или (сч.видсубконто(3) = ВидыСубконто.НеоборотныеАктивы)))
//Если (сч.Забалансовый = 0)и ((строка(сч.видсубконто(2)) = ВидыСубконто.НеоборотныеАктивы) или (строка(сч.видсубконто(3)) = "Необоротные активы") )
# Ответить
14. kompas-dm 11.12.2011 14:06
(13) a237, Пожалуйста
# Ответить
15. Фред (файл скачал) 04.01.2012 09:40
В публикации упомянута Украина...
Вопрос- данный продукт будет работать в российских конфигурациях?
Ответили: (16)
# Ответить
16. kompas-dm 04.01.2012 10:39
(15) Управление внешними отчетами - да, сами же отчеты затачивайте под себя. В России другой план счетов и субконто.
Ответили: (17)
# Ответить
17. Фред (файл скачал) 04.01.2012 11:39
(16) kompas-dm, Спасибо!
То есть это навигатор по отчетам? Комплектовать самостоятельно или есть набор по умолчанию?
Ответили: (18)
# Ответить
18. kompas-dm 04.01.2012 12:11
(17) По умолчанию - в пакете много отчетов и обработок. Прочитайте описание настройки и ВПЕРЕД самостоятельно. Навигатор - для любой конфигурации 7.7.
Ответили: (19)
# Ответить
19. Фред (файл скачал) 04.01.2012 12:47
(18) kompas-dm,
Загрузил...Попробовал.
Сам инструмент нормально загрузился, работает.
Первые три папки с отчетами (Налоги,денежные счета и ТМЦ), судя по
всему, не от моей семерки.
При загрузке ругаются. Остальное (ОСВ и Технологические обработки)
работает.
По моему мнению, сложноват процесс добавления новых отчетов.
Хотелось бы указанием пути прямо из меню.
+ за проведенную работу.
Спасибо.
# Ответить
20. rus128 04.01.2012 13:17
"В публикации упомянута Украина... "
А я наоборот нигде (в шапке и кратком описании) не увидел этих упоминаний - только в разделе обновлений от 9 августа 2011 года (по новому налоговому кодексу).
# Ответить
21. AlexTorin (файл скачал) 06.01.2012 15:46
Благодарю за проделанную работу! Очень нужно и своевременно!
# Ответить
22. Mika-Marinka (файл скачал) 25.01.2012 20:38
Реально пригодилась) Очень круто) Большое спасибо
# Ответить
23. z5515 (файл скачал) 21.02.2013 09:43
на типовой бух. 537 не пашет...

ВыбраннаяФирма = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","Фирма");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(24)}: Функция не обнаружена (глВосстановитьЗначение)
датаС = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаС");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(25)}: Функция не обнаружена (глВосстановитьЗначение)
датаПо = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаПо_");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(26)}: Функция не обнаружена (глВосстановитьЗначение)
фСчет = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСчет");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(27)}: Функция не обнаружена (глВосстановитьЗначение)
фСклад = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСклад");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(28)}: Функция не обнаружена (глВосстановитьЗначение)
фПартия = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фПартия");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(29)}: Функция не обнаружена (глВосстановитьЗначение)
фДокументы = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фДокументы");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(30)}: Функция не обнаружена (глВосстановитьЗначение)
СписокСохр = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","СписокСохр");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(31)}: Функция не обнаружена (глВосстановитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","СписокСохр",СписокСохр);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(64)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСчет",фСчет);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(65)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фДокументы",фДокументы);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(66)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фПартия",фПартия);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(67)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСклад",фСклад);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(68)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","Фирма",ВыбраннаяФирма);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(69)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаС",ДатаС);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(70)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаПо",ДатаПо);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(71)}: Процедура не обнаружена (глСохранитьЗначение)
# Ответить
24. kompas-dm 21.02.2013 09:55
В типовой для Украины (тек.релиз 296) есть две процедуры в гл.модуле:
// Локально сохраняет значение по ключу
// ===============================
// Конт - или контекст документа, или строка (для совместимости)
// сИдентификатор - идентификатор значения
// Значение - значение для сохранения
Процедура глСохранитьЗначение(Конт="", сИдентификатор="", Значение="") Экспорт
Если ТипЗначенияСтр(Конт) = "ГрупповойКонтекст" Тогда
сГруппа = Конт.Вид();
Иначе
// строка или что-то другое, преобразуем все к строке
сГруппа = СокрЛП(Строка(Конт));
КонецЕсли;
сКлюч = ?(ПустаяСтрока(сГруппа) = 0, сГруппа+"_", "")+СокрЛП(сИдентификатор);
СохранитьЗначение(сКлюч, Значение);
КонецПроцедуры

// В зависимости от значения глОбщиеУстановки или восстанавливает локально
// сохраненное значение или берет значение константы (реквизита справочника)
// Используется для присвоения значений по умолчанию
// ===============================
// Конт - или контекст документа, или строка (для совместимости)
// сИдентификатор - идентификатор значения
// ЗначПоУмолчанию - значение по умолчанию, если ничего не "восстановили"
Функция глВосстановитьЗначение(Конт="", сИдентификатор="", ЗначПоУмолчанию=0) Экспорт
Перем сГруппа, Фирма, ДатаЗнач;
Если ТипЗначенияСтр(Конт) = "ГрупповойКонтекст" Тогда
сГруппа = Конт.Вид();
Фирма = Конт.Фирма;
ДатаЗнач = Конт.ДатаДок;
Иначе
// строка или что-то другое, преобразуем все к строке
сГруппа = СокрЛП(Строка(Конт));
Фирма = 0;
ДатаЗнач = РабочаяДата();
КонецЕсли;
// сразу попытаемся восстановить значение по ключу
сКлюч = ?(ПустаяСтрока(сГруппа) = 0, сГруппа+"_", "")+СокрЛП(сИдентификатор);
Значение = ВосстановитьЗначение(сКлюч);
Если (глОбщиеУстановки = 2) и (ТипЗначенияСтр(Значение) <> "") Тогда
// оставляем то, что уже получили
ИначеЕсли Метаданные.Константа(сИдентификатор).Выбран() = 1 Тогда
// берем из константы...
Если Метаданные.Константа(сИдентификатор).Периодический = 1 Тогда
// ...периодической
Значение = Константа.ПолучитьАтрибут(сИдентификатор).Получить(ДатаЗнач);
Иначе
// ...обычной
Значение = Константа.ПолучитьАтрибут(сИдентификатор);
КонецЕсли;
ИначеЕсли ПустоеЗначение(Фирма) = 0 Тогда
// из реквизита объекта (справочника)
Попытка
// прочитаем реквизит
Реквизит = Метаданные.Справочник("Фирмы").Реквизит(сИдентификатор);
Если Реквизит.Выбран() = 1 Тогда
// есть такой реквизит...
Если Реквизит.Периодический = 1 Тогда
//... периодический
Значение = Фирма.ПолучитьАтрибут(сИдентификатор).Получить(ДатаЗнач);
Иначе
//... обычный
Значение = Фирма.ПолучитьАтрибут(сИдентификатор);
КонецЕсли;
КонецЕсли;
Исключение
КонецПопытки;
КонецЕсли;
// если все-таки ничего не получили, то используем значение по умолчанию
Если ТипЗначенияСтр(Значение) = "" Тогда
Значение = ЗначПоУмолчанию;
КонецЕсли;
Возврат Значение;
КонецФункции

-----------------------------------------------------------------
Поправьте или отчеты, или свой релиз ...
# Ответить
25. miramak 04.04.2013 15:00
Очень нравится пакет обработок, но, две работают у меня почему-то не правильно.
В обработке "Основные средства 2012г" пишет:
Ти.Загрузить(т_);
{D:\БО СБФДБТ\1SBUKR\EXTFORMS\ОСНОВНЫЕСРЕДСТВА2012.ERT(593)}: Значение не представляет агрегатный объект (Загрузить)
Что это такое не знаю?
И в обработке " Расчет_налогов":
не правильно считает налоги к уплате,в расчет попадает итоговая сумма (выделенная цветом) по сч.651 (в частности). Можно ли это исправить?
Ответили: (26)

Прикрепленные файлы:

Ведомость расчетов по налогам.xls
# Ответить
26. kompas-dm 04.04.2013 16:02
(25) Проверю "Расчет налогов" и отпишу. А "Загрузить" - у Вас нет компоненты 1СPP.
Положите ее в каталог ИБ.

Прикрепленные файлы:

1CPP.dll
# Ответить
27. miramak 04.04.2013 17:04
Спасибо за быстрый ответ и 1СРР, буду ждать Ваших результатов
# Ответить
28. miramak 04.04.2013 17:46
Посмотрела обработку "Основные средства 2012г"- на опции "бухгалтерский учет" в наличие ОС показывает не корректно период. Выбираю квартал, показывает данные на последний день квартала, а это искажение данных (т.к. остатков на начало периода не было). И в шапке не помещается название предприятия.

Прикрепленные файлы:

ведомость наличия ОС_.xls
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл