gifts2017

Поздравление с 8 марта

Опубликовал Александр (Sanek) в раздел Сообщество - Поздравления

Обработка запускающая в день праздника 8 марта открытку.

Данный отчетик запуститься 5 марта, т.к все уходят отдыхать 5го.

 

Впихните в глобальный модуль:

Процедура ПриНачалеРаботыСистемы()
 
 //8 марта
ДатаПраздника = 5;
МесяцПраздника = 3;
Если (ДатаМесяц(ТекущаяДата()) = МесяцПраздника) и (ДатаЧисло(ТекущаяДата()) = ДатаПраздника) Тогда
ОткрытьФорму("Отчет.марта8");
КонецЕсли;

 

P.S. С праздником весны Вас милые дамы!!!

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Отчетик с поздравлением
.ert 474,50Kb
04.03.13
512
.ert 474,50Kb 512 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Gen Tay (GenTay) 27.02.10 10:31
Идея очень и очень, но можно как-то без глобального модуля, у меня куча перифериек, и МД неслабый. Из-за них менять глобальный не хочу, но и обработка нравится - как быть?
2. Дмитрий Бухалов (Re:аниматор) 27.02.10 12:50
(1)

1. По электронке разослать всем сотрудницам данную обработку
2. 05.03.2010 ИЛИ 08.03.2010
3. Меню "Файл"-"Открыть" и выбрать обработку "8марта.ert"
4. Наслаждаться результатом

=)
3. Аркадий Кучер (Abadonna) 27.02.10 13:14
(0)
ДатаПраздника = 5;
МесяцПраздника = 3;
Если (ДатаМесяц(ТекущаяДата()) = МесяцПраздника) и (ДатаЧисло(ТекущаяДата()) = ДатаПраздника) Тогда
ОткрытьФорму("Отчет.марта8");
КонецЕсли;

А почему не
Если ТекущаяДата()=Дата("08.03.10") Тогда
ОткрытьФорму("Отчет.марта8");
КонецЕсли;
...Показать Скрыть

4. Александр (Sanek) 27.02.10 14:31
(3) Можно и так, но сработает только в 2010 году ;)
5. Аркадий Кучер (Abadonna) 27.02.10 14:32
Тогда так:
Если Лев(Строка(ТекущаяДата()),5)="03.08" Тогда...
6. Александр (Sanek) 27.02.10 14:33
7. Михаил (Albinos) 03.03.10 06:07
А как сделать в Торговле и склад, при закгрузке вылетает ошибка "{Глобальный модуль(14658)}: Неверно указан вид. 8marta" ?
8. Михаил (Albinos) 03.03.10 06:08
И ещё интересно бы было, чтоб можно было исключить некоторых пользователей, а то мужики не оценят ;)
9. Дима Федосеев (Mitay_D) 03.03.10 07:32
10. Михаил (Albinos) 03.03.10 07:55
(7) Спасибо, добрым людям :) , надо так :
Если ТекущаяДата()=Дата("03.03.10") Тогда
ОткрытьФорму("Отчет",,КаталогИБ()+"\ExtForms\8marta.ert");
КонецЕсли;
11. Михаил (Albinos) 03.03.10 08:37
(8) Додумался :) , чтоб исключить некоторых пользователей, надо так:

Если ТекущаяДата()=Дата("03.03.10") Тогда Если ИмяПользователя() <> (указываем код пользователя) Тогда
ОткрытьФорму("Отчет",,КаталогИБ()+"\ExtForms\8marta.ert");
КонецЕсли;
КонецЕсли;
12. Александр (Sanek) 03.03.10 09:10
Ну вот можете ведь сами подумать, когда захотите ;)
13. Koнст (Koнст) 04.03.10 11:21
(10) Чтобы работало каждый год в последний рабочий предпразничный день с учетом выходных:

ДатаПраздника = 7;
Если (ДатаЧисло(ТекущаяДата())>4)И(ДатаЧисло(ТекущаяДата())<7)И(НомерДняНедели(ТекущаяДата())=5) Тогда
ДатаПраздника=ДатаЧисло(ТекущаяДата());
КонецЕсли;
14. Igor2010 (IgorXml) 04.03.10 20:36
Вот для 8-ки сделал(стянул у хорошего человека из "Поздравление с Новым Годом 2010") и переделал чуток. http://infostart.ru/public/66677/
15. Артур Аюханов (artbear) 05.03.10 10:27
(13), (11) Изучаем http://www.infostart.ru/public/19232
код автора и мой пост №16
Хотя там код для 8-ки, но и 77 код почти полностью аналогичен :)
16. Koнст (Koнст) 05.03.10 11:43
(15) Увы, с восьмеркой не знаком, соответсвенно и отчеты восьмерочные не смотрю.
Много кода, ниасилил ;)
Пусть будет так:

Функция Поздравлялка(РаботаемВсубботу=0)
Если ДатаМесяц(ТекущаяДата())=3 Тогда
ДатаПраздника = 7;
Если (ДатаЧисло(ТекущаяДата())>4)И(ДатаЧисло(ТекущаяДата())<ДатаПраздника)И(НомерДняНедели(ТекущаяДата())=5+РаботаемВСубботу) Тогда
ДатаПраздника=ДатаЧисло(ТекущаяДата());
КонецЕсли;
Если (Прав(СоклЛП(ПолноеИмяПользователя()),2)="на")И(ДатаПраздника=ДатаЧисло(ТекущаяДата())) Тогда
ОткрытьФорму("Отчет",,КаталогИБ()+"\ExtForms\8marta.ert");
КонецЕсли;
КонецЕсли;
КонецФункции
17. kleo1986 14.02.11 14:00
не работает((( вставляю в ПриНачалеРаботыСистемы в конец (и не только) ну не открывается автоматически, подскажите в чем дело?
Дату в отчете ставлю не 5-3 как там, а 14-2, т.е. хочу что б сегодня открылась
18. sergey1280 (sergey1280) 11.10.11 08:17
Все работает замечательно, спасибо автору!))
19. vIKYS vkalinsk (MoonBee) 24.10.11 12:49
Оригинальное, красочное и радостное поздравление!)))) Огромнейшее спасибо автору от коллектива финансистов!! =))
20. Вячеслав Клюев (slavik27) 28.11.11 12:44
Отлично! То что нужно было в свое время, порадовал своих бух-ов перед праздником. Правда некоторые забыли отключить 1с и на следующий день ничего не увидели.(
21. Александр (Sanek_159) 24.02.12 14:30
(20) slavik27, Не забыть всех выгнать за день до этого, под предлогом обновления :)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа