gifts2017

НДФЛ удержанный

Опубликовал Nicholas Mikuslas (Nicholas) в раздел Программирование - Практика программирования

"НДФЛ исчисленный = НДФЛ удержанный" или как делать НЕЛЬЗЯ!

Никогда не поддавайтесь уговорам и ни под каким предлогом не идите на поводу бухгалтеров если они вас просят уровнять НДФЛ исчисленный и НДФЛ удержанный, ибо нарушаются сразу несколько статей НК РФ!

В большинстве случаев, НДФЛ удержанный не равен
исчисленному (к примеру, это переходящие больничные и отпуска, частичная
выплата зарплата и выплата не в месяце начисления).  Если НФДЛ
расходится по каким-то другим причинам, то это скорее всего ошибка
бухгалтера, например, очень часто, просто забывают рассчитать запись
удержанного в журнале расчетов.

Никогда не ищите в глобальном модуле функцию глСобратьДанныеДляНДФЛ2005().

Никогда не ищите в этой функции строку "// здесь собираются налоги (исчисленные и удержанные) - по периоду регистрации".

Никогда не меняйте ниже по тексту:

ИначеЕсли НомерКолонки > 0 Тогда
    Для Сч = МесяцДохода По 12 Цикл

        //Nicholas [<>] 17.03.2010 17:29:15
        //Comments: Никогда так не делайте!
        //Been:

            //ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерСтрокиСотрудника+Сч,НомерКолонки,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника+Сч,НомерКолонки)+СуммаРез);
        //Turn:
        Если НомерКолонки = 7 Тогда
            ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерСтрокиСотрудника+Сч,7,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника+Сч,7)+СуммаРез);
            ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерСтрокиСотрудника+Сч,10,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника+Сч,10)+СуммаРез);
        ИначеЕсли НомерКолонки = 10 Тогда
            //Ковыряемся в носу
        Иначе
            ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерСтрокиСотрудника+Сч,НомерКолонки,ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(НомерСтрокиСотрудника+Сч,НомерКолонки)+СуммаРез);
        КонецЕсли;
        //EndNicholas [<>]

    КонецЦикла;

    Если глРежимТрассировки=1 Тогда
        СтрокаТрассировки="_П01: _П02";
        СтрокаТрассировки=СтрокаТрассировки+";0;0;"+глПредставлениеВидаРасчета(ВР)+"; ;"+СуммаРез+";"+"Ч15.2;";
        ТрассировкаНалогиПоРегистрации.ДобавитьЗначение(ПериодДействия,СтрокаТрассировки);
    КонецЕсли;
   
КонецЕсли;

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Сергей Кучеров (СергейКа) 17.03.10 16:21
Типа не делайте так и указание что конкретно и где изменить.
Я понимаю что лайф, но блин как-то уж ... Иные на это и не посмотрят.
ИМХО вредный совет. Да и переход по ссылке "в никуда".
За что и отминусовал.
seven77782; albert; +2 1 Ответить
2. Татьяна Шавлак (Stety) 17.03.10 18:09
"на воводу у бухгалтеров" - что за грязные намеки на премьер-министра?

Упала. Лежу под столом и не знаю, что поставить - ведь сам 1С над этими своими методическими упертостями, реализованными в 7-ке уже полностью произдевался сам, дав возможность выбора "упрощенного учета НДФЛ" в учетной политике в 8-ке. Написать что ль такую же "нельзялку" про удержание за неотработанный отпуск в 7-ке? :D :D :D
3. Андрей Лихоманов (lihomanov) 18.03.10 05:54
Прикольно, но как вы знаете 1С Предприятие 8.1 ЗУП, в настройках есть такая функция НДФЛ исчисленный = НДФЛ удержанный, почему в 1С ЗиК 7.7 нельзя?
4. Страпот (Bobak) 18.03.10 17:47
НДФЛ удержанный - это "остатки старого режима", сказано "должны удержать весь начисленный налог", так и удерживайте.
Зачем в ЗиК его так старательно считает, для меня загадка.
Плюс не ставлю, так как не считаю совет вредным :D .
5. Светлана Фоменко (safia-med) 03.09.14 12:14