gifts2017

А ты умеешь СТУЧАТЬ? (или Азбука Морзе на 1С)

Опубликовал Юрий Тимофеев (Tatitutu) в раздел Программирование - Практика программирования

Азбука Морзе теперь и на языке 1С .
А ты знаешь, как звучит сигнал "SOS" ?
А ты сможешь в трудную минуту его просигналить ?

А ты знаешь, как звучит сигнал "SOS" ? - можно прослушать

Можно научится его выбивать.

Таблица символов.

Вам интересно ? Тогда просто кликайте мышкой по кнопке "Стучать" -

"настучите" ,какой-то код и программа попытается перевести.

Учится никогда не поздно, в жизни все может пригодится.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Morze.zip
.zip 541,00Kb
20.02.12
197
.zip 541,00Kb 197 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. larissa builova (larisab) 22.03.10 20:12
"Тatitutu - самый лучший выдумщик на свете !"
Стучать, перевести!
Да, и на этот раз!!!
Классно, посмеялась над азбукой В - видала, Л - лунатики )))))
Tatitutu; +1 Ответить
2. Сергей Солнышкин (Myti) 22.03.10 22:43
3. MaxDavid (MaxDavid) 23.03.10 00:16
Гм...
Если открыть таблицу символов, закрыть и снова открыть - она будет пустой.
4. Юрий Тимофеев (Tatitutu) 23.03.10 06:52
(3) Таки это - конспирация, батенька (с)
Фильмов что ли про войну не смотрел, в дверь стучать - шифровку нужно съесть )))
5. Юрий Тимофеев (Tatitutu) 23.03.10 07:04
(3) Ты мне лучше скажи, ты хозяин своего голоса ?

Новый голос за А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)
От кого noreply@infostart.ru добавить▼
Кому Tatitutu@narod.ru
Отправлено 23 марта 2010 в 00:06


Tatitutu,

Новый голос за "А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)" от пользователя MaxDavid.
Оценка: +1

Перейти на страницу объекта http://infostart.ru/public/67755/

MID #1556064.271 (23.03.2010 00:06:46)


Письма о том что ты снял голос нет. Так ладно, но еще

Новый голос за А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)
От кого noreply@infostart.ru добавить▼
Кому Tatitutu@narod.ru
Отправлено 22 марта 2010 в 23:36


Tatitutu,

Новый голос за "А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)" от пользователя bashta.aleksey.
Оценка: +1

Перейти на страницу объекта http://infostart.ru/public/67755/

MID #1556036.271 (22.03.2010 23:36:37)


и еще

Новый голос за А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)
От кого noreply@infostart.ru добавить▼
Кому Tatitutu@narod.ru
Отправлено 22 марта 2010 в 23:01


Tatitutu,

Новый голос за "А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)" от пользователя Eugeneer.
Оценка: +1

Перейти на страницу объекта http://infostart.ru/public/67755/

MID #1555992.271 (22.03.2010 23:01:54)


и еще

Новый голос за А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)
От кого noreply@infostart.ru добавить▼
Кому Tatitutu@narod.ru
Отправлено 22 марта 2010 в 21:16


Tatitutu,

Новый голос за "А ты умеешь СТУЧАТЬ ? (или Азбука Морзе на 1С)" от пользователя Boris.Andry.
Оценка: +1

Перейти на страницу объекта http://infostart.ru/public/67755/

MID #1555947.271 (22.03.2010 21:16:32)


и.т.д. и еще....вчера в 22:00 скачавших файл было 15 человек.

Сегодня утром 1 человек скачал и 1 человек проголосовал.
Что на это ты скажешь ? Сайт тупит или тормозит ? Нет !!!
- это конспирация, батенька (с)
Что на это ты скажешь ? Сайт тупит или тормозит ? Не
6. Юрий Португалов (Sprite) 23.03.10 07:54
Баки текут.
Даже не открывая "+".
Лет 30 назад в Армии был воздушным стрелком радистом. Теперь прикольно вспомнить.
Улыбнуло :D
Tatitutu; +1 Ответить
7. Александр Рытов (Арчибальд) 23.03.10 08:28
Глюк какой-то. Ставлю плюс, но не вижу его :o
8. Юрий Тимофеев (Tatitutu) 23.03.10 08:34
(7) И я , а том же :D - это конспирация, батенька (с)
Фокус такой - ни кто не качает, ни кто не ставит плюсы (а их бы было уже далеко за 10)
Сайт же ФСБ мониторит... а потом придут к тебе и спросят
"Уважаемый, Арчибальд, а для чего Вам азбука Морзе - Вы, что шпион"

Это глобальный заговор. Вот попробуй поставить заново, тебе вежливо ответят, что Вы уже голосовали ))))
9. Александр Рытов (Арчибальд) 23.03.10 08:40
(8) Ну, в мое время азбуку Морзе в школе изучали, в ДОСААФовских кружках :D
А насчет глобального заговора Абадонна должен быть в курсе - он искусный в ентом деле полиглот :idea:
10. Юрий Тимофеев (Tatitutu) 23.03.10 08:52
(9)
Шухер ! Облава !!! Нас спалили...На главной странице у публикации 9 звезд , а здесь только 1 - это подства и засада...

думал Штирлиц первый раз зайдя на ИС
12. Трактор Трактор (Трактор) 23.03.10 10:17
Звуком морзянку даёт? ИМХО рисовать точки и тире глупейшее занятие.
13. MaxDavid (MaxDavid) 23.03.10 10:18
(10)Вроде поправили. Хотя теперь на главной странице все мои настройки слетели...
Tatitutu, то ты Эксели роняешь, то порталы. Нехорошо... :)
14. Юрий Тимофеев (Tatitutu) 23.03.10 10:54
(12)
ИМХО рисовать точки и тире глупейшее занятие

я уважаю твое мнение - и мой совет - НЕ РИСУЙ.
16. Юрий Тимофеев (Tatitutu) 23.03.10 10:58
(13) тише...эфир прослушивается...
переходи на
-- --- .-. --.. .
17. Трактор Трактор (Трактор) 23.03.10 11:02
(14) Умеешь говорить :-) Это тебе не я.

Моё первое образование включает в себя знание азбуки Морзе. Я даже писал датчик кода Морзе в 1991 году. Звуком. На бейсике, потом переписал на ассемблере. Для компьютера БК0011. А приёмник написать так и не осилил.
18. Юрий Тимофеев (Tatitutu) 23.03.10 11:26
(17) Так кто на что учился :D
Моё первое образование включает в себя знание азбуки Морзе

нет в школе меня этому не учили, научился сам - ради интереса, с друзьями в подвале перестукивались,
а вот в моем первом высшем образовании - Командно - тактической вещевого и продовольственного обеспечения войск (гражданская специальноть инженер - экономист) учили и неплохо учили. И даже пригодилось в жизни, но это совершенно другая история.
19. bulpi bulpi (bulpi) 23.03.10 11:36
Всем радистам - привет! Ностальгия, ептыть!!!
Tatitutu; +1 Ответить
20. Евгений Ильяшенков (ЗАК) 23.03.10 19:59
21. larissa builova (larisab) 23.03.10 20:36
(20) "Бить будете, папаша?" (с)
23. Юрий Португалов (Sprite) 23.03.10 21:32
:idea: Беглая мысль:
А может быть сделать иммитатор ключа, повесить на "Del".
Как определить длительность нажатия? Может быть в кладовочке у Альфа что-то имеется?
Ваще было бы классноо!
24. Юрий Португалов (Sprite) 23.03.10 21:39
Беглая мысль:
А может быть сделать иммитатор ключа, повесить на "Del".
Как определить длительность нажатия? Может быть в кладовочке у Альфа что-то имеется?
Ваще было бы классноо!
25. Алексей (ACE$) 23.03.10 22:00
В радиокружке изучали... На слух тренировались принимать. Только мнемоники у нас другие были: типа "На-ти-на-ти дай-дай-ви-на" - CQ
Ностальгия...
Tatitutu; +1 Ответить
26. Юрий Тимофеев (Tatitutu) 23.03.10 22:10
(24) в обработке определяется время нажатия клавиши,
только оно разное - при нажатии клавишой или кликом мышки
27. Александр Цегельников (markers) 24.03.10 07:31
28. Александр Медведев (sashankz) 24.03.10 12:58
настольгия....
в армии учили такое дело гдето до сих пор есть это дело в блакноте солдатском))
у нас минимум был 60зн в мин
инекоторые до 120 доходили ... а так прием обычно в районе 90-120 идет

ну а так спасибо конечно
только у нас напевки (словестное сочетание) дургие были
и учатся именно они так напевками очень просто .. ток в начале сложно
Tatitutu; +1 Ответить
29. Дмитрий Литовченко (kompas-dm) 24.03.10 16:47
В разведшколе напевки были другие :
а - ти-та
б - бей ба-ра-бан
в - вол- ча-та
и т.д.
Пели на скорость страницами...
mgb; Tatitutu; +2 Ответить
30. Константин Воробьёв (kostik_love) 24.03.10 18:29
давайте и для 8-ки такую
:(((
31. Юрий Тимофеев (Tatitutu) 24.03.10 19:51
только на 8.2 могу выложить
32. Юрий Португалов (Sprite) 24.03.10 20:51
(26) Посмотрю в Конфигураторе. Но мышью по кнопе у меня как-то не корректно отрабатывает.
А может быть через Formex?:
ПриНажатииЛевойКнопки() и далее через ОбработкуОжидания() ловим время, заканчивая ПриОтжатииЛевойКнопки() Благо у Альфа "Обработка Ожидания" ловит миллисекунды.
ПриНажатииКнопкиКлавиатуры() - не получится. Потому, что нет "ПриОтжатии...."
33. Анатолий Ситников (acsent) 26.03.10 15:54
Разве где-то еще вручную стучат на таких доисторических приборах?
34. Юрий Тимофеев (Tatitutu) 26.03.10 15:58
(33) ой, как СТУЧААААААААААТ
разве не слышишь...та...ти...ту.ту :D
35. Анатолий Ситников (acsent) 26.03.10 16:03
(34) То что некоторые фапают ностальгируют - это понятно
36. Юрий Тимофеев (Tatitutu) 26.03.10 16:27
(35) так это и есть главный результат ! Если хоть кому то приятно сделал уже самый большой плюс для меня.
Sprite; larisab; +2 Ответить
37. Трактор Трактор (Трактор) 27.03.10 12:57
38. Максим Епанчинцев (McSeem) 30.03.10 05:12
Думаю, нужна доработка в виде обратной операции - перевод русского текста в морзянку и вывод звука (на спикер, или при помощи чередования файлов tochka.wav и tire.wav).
39. Трактор Трактор (Трактор) 30.03.10 10:18
(38) Я даже алфавит скачал с сайта http://www.morsetone.ru/. Затолкал файлы mp3 в макеты обработки. Осталось только ввод текста и создание файлов m3u прикрутить. Возьмёшься? У меня руки до этого дойдут совсем не скоро.
41. Максим Епанчинцев (McSeem) 30.03.10 12:14
(39) Раз есть готовые mp3 файлы по буквам, то так даже проще. Вот процедурка создания плейлиста, на большее у меня тоже нет времени. ;)

//******************************************************************************
// Вывод()
//
Процедура Вывод(ИсходныйТекст)

// Инициализация переменных
ПутьВыводимогоФайла = КаталогВременныхФайлов() + "Morze.m3u";
ПутьMP3Файлов = КаталогИБ() + "morze\"; // здесь должны лежать файлы а.mp3 - 9.mp3, а также желательны Пробел.mp3 и Ошибка.mp3
Плейлист = СоздатьОбъект("Текст");
Плейлист.ДобавитьСтроку("#EXTM3U");
ДлинаТекста = СтрДлина(ИсходныйТекст);
МаксРазрядность = СтрДлина(Строка(ДлинаТекста));
ТЗОдобренныеСимволы = СоздатьОбъект("ТаблицаЗначений");
ТЗОдобренныеСимволы.НоваяКолонка("Символ", "Строка", 1);
ТЗОдобренныеСимволы.НоваяКолонка("СуществуетФайл", "Число", 1, 0);
Для i = 1 По ДлинаТекста Цикл
ТекСимв = НРег(Сред(ИсходныйТекст, i, 1));
Если (СокрЛП(ТекСимв) = "") Тогда
ТекСимв = "Пробел";
Иначе // проверяем существование файлов, с сохранением результатов проверки в ТЗ
гн = 0;
Если ТЗОдобренныеСимволы.НайтиЗначение(ТекСимв, гн, "Символ") = 1 Тогда
Если ТЗОдобренныеСимволы.ПолучитьЗначение(гн, "СуществуетФайл") = 0 Тогда
ТекСимв = "Ошибка";
КонецЕсли;
Иначе
ТЗОдобренныеСимволы.НоваяСтрока();
ТЗОдобренныеСимволы.Символ = ТекСимв;
ТЗОдобренныеСимволы.СуществуетФайл = ФС.СуществуетФайл(ПутьMP3Файлов + ТекСимв + ".mp3");
КонецЕсли;
КонецЕсли;
Плейлист.ДобавитьСтроку("#EXTINF:1,Символ " + ТекСимв);
Плейлист.ДобавитьСтроку(Формат(i, "Ч(0)" + МаксРазрядность) + ". " + ПутьMP3Файлов + ТекСимв + ".mp3");
КонецЦикла;
Плейлист.Записать(ПутьВыводимогоФайла);
ЗапуститьПриложение(ПутьВыводимогоФайла);

КонецПроцедуры // Вывод
42. Максим Епанчинцев (McSeem) 30.03.10 12:18
Как бы тут от случайного даблпоста избавиться? :(
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа