gifts2017

Кредитный калькулятор

Опубликовал anry mc (AnryMc) в раздел Обработки - Универсальные обработки

Расчет платежей по кредиту 2-мя методами:
1) простой процент
2) аннуитетные платежи

Еще одна "житейская мелочь" - поможет принять решение как лучше платить равными платежами и большей переплатой, или с большей "нагрузкой" в начале...

Скачать файлы

Наименование Файл Версия Размер
КредитныйКалькулятор.epf 272
.epf 10,63Kb
14.08.13
272
.epf 10,63Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Kur ChataD (KurchataD) 03.04.10 09:45
Здорово, классная вещь. Вот бы такое для 7.7 Бух сделать.
2. HEKPOH (wguki@yandex.ru) 03.04.10 15:45
"Сумма по кредиту гаситЬся равными суммами" :o
3. anry mc (AnryMc) 04.04.10 02:35
(2) А можно подробней - где именно лишнее или не хватает (Ь)

"Всю жизнь не может смириться с тем, что ветер ГАСИТ огонь надежды."
Из греческих тетрадей. Записки детского поэта / Агния Барто

"электромагнитные волны могут, накладываясь, усиливать или ослаблять и даже полностью «ГАСИТЬ» друг друга (интерференция волн)..."
Квантовая теория поля - Большая Советская Энциклопедия

+ см. рис. прикрепл. файл
Прикрепленные файлы:
5. Аркадий Кучер (Abadonna) 04.04.10 04:52
(3)
А можно подробней - где именно лишнее или не хватает (Ь)

Да запросто! Проверка: кредит что делаеТ? - га'сиТСя.
Что будет делатьТЬ кредит? - гаси'ТЬся
На вскидку не скажу в каком именно классе начальной школы...
На форме отчета - АБСОЛЮТНО ВЕРНО написано.
Прикрепленные файлы:
6. anry mc (AnryMc) 04.04.10 09:04
(5) Так в каком месте ошибка? Не могу найти.
7. Аркадий Кучер (Abadonna) 04.04.10 09:30
(6) Непонятки возникают в связи с глюками сайта ;)
НЕТ ОШИБКИ.
8. anry mc (AnryMc) 04.04.10 09:47
(5) Мне уже 25 минут назад пришло на почту сообщение № 6, а я его пока не вижу на сайте :-(
Какое тут живое общение?
9. HEKPOH (wguki@yandex.ru) 04.04.10 12:21
Откройте прикрепленное изображение на этой страничке в описании обработки. Там в отчете написано следующее:
"Основной долг по кредиту гаситься равными суммами, на остаток начисляются проценты" - зеленым шрифтом.

Читаем дальше:
"Сумма по кредиту гаситься равными суммами" - это сразу над таблицей

Понимаю, что это не грамота.ру, но знание азов грамматики никто не отменял :)
10. HEKPOH (wguki@yandex.ru) 04.04.10 12:23
Повторю изображение :)
Прикрепленные файлы:
11. Аркадий Кучер (Abadonna) 04.04.10 17:46
(10) Прикольно, но та версия, которую я скачал (4 апреля, утром по Москве)
НЕ СОДЕРЖИТ ошибок
Прикрепленные файлы:
12. Евгений (Amedis) 07.04.10 06:18
Вопрос автору:
скажите для кого предназначается эта разработка?

Для обычного человека, желающего расчитать, например, потребительский кредит сроком 10 месяцев? Но даже в этом случае пользователю придется напрягать могз и думать, а что же за период №8???? Какой это месяц???? А попробуйте расчитать например ипотечный кредит на 25 лет или 300 месяцев!!!!! Вобщем я бы заменил номер периода на дату или представление месяца (апрель 2010)... Кроме того мне как человеку взявшему кредит наверняка понадобится сделать перерасчет и посмотреть что же будет если я заплачу больше чем рекомендует банк. Неплохо было бы так же учитывать возможность изменения процентной ставки.

Что касается предприятий, то подобные кредиты там вообще редкость. В основном открываются возобновляемые кредитные линии и процентов одних там видов пять....
Сейчас сам пишу подобную штуковину для расчета процентов по кредитным линиям.
Прикрепленные файлы:
13. anry mc (AnryMc) 07.04.10 07:47
(12) Еще можно добавить страховку кредита, проценты или фиксированную плату за ежемесячное обслуживание (комиссия ежемесячная), единоразовый платеж за открытие (комиссия одноразовая), штраф за досрочное погашение, проценты на проценты и пр. пр. - что только наши банки не придумают, для того что бы скрыть эффективную ставку.
Можно вычислять Процентные расходы по кредиту, Средневзвешенную сумму кредита, Эффективную ставку, Пеню за просрочку...

Но как писалось в сказках - это уже другая история

И если ваша разработка появиться в свободном доступе с удовольствием ею воспользуюсь
14. Сергей Палыч (AhtungG) 08.04.10 06:04
15. anry mc (AnryMc) 08.04.10 06:45
16. Николай Шилкин (RayCon) 30.04.10 23:01
(6)
>Так в каком месте ошибка? Не могу найти.

На верхнем скриншоте в двух местах:
Основной долг по кредиту гаситЬся равными суммами... (зелёный шрифт в шапке)
Сумма долга по кредиту гаситЬся равными сумммами (нижняя строка в заголовке)


(13) Я бы рекомендовал дополнить сию полезную разработку пакетным формированием документов по автоматическому начислению процентов с одной стороны и платёжных поручений по погашению кредита - с другой. Вся информация для этого есть: график платежей, суммы процентов и основного долга, наименования контрагентов, договоров и т.д.
17. Максим Симонович (mctsimco) 01.12.10 17:48
KurchataD пишет:

Здорово, классная вещь. Вот бы такое для 7.7 Бух сделать.


//*****************************
Процедура СформироватьАннуитет()
тз.видимостьколонки("Комиссия",?(КомиссияМес=0,0,1));
Форма.фКомиссия.Видимость(?(КомиссияМес=0,0,1));
Форма.сКомиссия.Видимость(?(КомиссияМес=0,0,1));
НачСумма = СуммаКредита;
ставкаМес = (ставкаГод / 12) / 100;
Игого = 0;
ИгогоПроц = 0;
суммаМесВсего = СуммаКредита *(ставкаМес)/(1-1/вСТЕПЕНЬ((1+ставкаМес), срокКредита));
Для й = 1 По СрокКредита Цикл
суммаПроцентов = НачСумма * ставкаМес;
СуммаМес = суммаМесВсего - суммаПроцентов;
НачСумма = НачСумма - суммаМес;
Игого = Игого + суммаМесВсего;
ИгогоПроц = ИгогоПроц + суммаПроцентов;
//Таб.ВывестиСекцию("Строка");
тз.НоваяСтрока();
тз.Мес= й;
тз.СуммаОсн = СуммаМес;
тз.СуммаПроц = суммаПроцентов;
тз.комиссия = суммакредита / 100 * комиссияМес;
тз.Сумма = суммаМесВсего + тз.комиссия;
КонецЦикла;
Переплата = Игого - СуммаКредита;
сПРЦ = тз.Итог("СуммаПроц");
сВсего = тз.Итог("Сумма");
скомиссия = тз.итог("Комиссия");
КонецПроцедуры

//*****************************
Процедура СформироватьСтандартный()
Перем МесячнаяСумма;
тз.видимостьколонки("Комиссия",?(КомиссияМес=0,0,1));
Форма.фКомиссия.Видимость(?(КомиссияМес=0,0,1));
Форма.сКомиссия.Видимость(?(КомиссияМес=0,0,1));

НачСумма = СуммаКредита;
ставкаМес = (ставкаГод / 12) / 100;
Игого = 0;
ИгогоПроц = 0;
ИгогоОсн = 0 ;
МесячнаяСумма = Окр(СуммаКредита / срокКредита,2);
Для й = 1 По СрокКредита Цикл
Если й = срокКредита Тогда
НачСумма = СуммаКредита - ИгогоОсн;
СуммаМес = НачСумма;
Иначе
СуммаМес = МесячнаяСумма;
КонецЕсли;
суммаПроцентов = НачСумма * ставкаМес;
СуммаМесВсего = СуммаМес + суммаПроцентов;
НачСумма = НачСумма - суммаМес;
Игого = Игого + суммаМесВсего;
ИгогоПроц = ИгогоПроц + суммаПроцентов;
ИгогоОсн = ИгогоОсн + СуммаМес;
тз.НоваяСтрока();
тз.Мес= й;
тз.СуммаОсн = СуммаМес;
тз.СуммаПроц = суммаПроцентов;
тз.комиссия = суммакредита / 100 * комиссияМес;
тз.Сумма = суммаМесВсего + тз.комиссия;

КонецЦикла;
Переплата = Игого - СуммаКредита;
сПРЦ = тз.Итог("СуммаПроц");
сВсего = тз.Итог("Сумма");
скомиссия = тз.итог("Комиссия");
КонецПроцедуры
//*****************************
18. Дмитрий Фамилия (freek) 28.12.11 14:08
19. Гость 28.12.11 14:09
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа