Налоговая ведомость 2010 по страховым взносам (учитывает 4000 МатПомощь и превышение 415000)

Опубликовал Александр Приходько (bubliko_o) в раздел Отчеты - Бухгалтерские

За основу взята уже опубликованная здесь налоговая ведомость, не помню какая именно.
06.08.2010 добавил:
1. учет сторно матпомощей

 

Ни одна налоговая ведомость у меня не подошла в части учета матпомощи 4000. Выбрал уже готовую и допилил под себя, чтобы считало мат помощь, в моих базах все теперь как надо. На оптимальность кода не претендую. Может, кому пригодится хотя бы под подпилку, хотя, поидее, все кому надо уже все сделали))

 

Скачать файлы

Наименование Файл Версия Размер
НалоговаяВедомость2010.ert
.ert 121,50Kb
20.03.13
271
.ert 121,50Kb 271 Скачать

См. также

Комментарии
1. Igоr Sаulеviсh (gutentag) 250 05.04.10 16:44 Сейчас в теме
2. Александр Приходько (bubliko_o) 31 06.04.10 08:45 Сейчас в теме
на 2-ом слое для удобства отладки расположены 2 таблицы значений, можно разрешить их видимость, а в модуле обработки раскоментировать 2 строки:
//ТаблицаБазПоВР.Выгрузить(ТабПросмотр);
//ТаблицаБазПоВРПФРСтНк.выгрузить(ИСШО);
и удобно смотреть что будет выводиться в отчет
3. Елена Мocкаленко (melenaspb) 208 06.04.10 16:35 Сейчас в теме
Не учитывает предел расчета для страховых взносов 415000. :cry:
4. Александр Приходько (bubliko_o) 31 06.04.10 23:56 Сейчас в теме
постараюсь сделать в ближайшие дни
5. Дмитрий (dka) 30.04.10 12:24 Сейчас в теме
При ВР зарегестрированном в одном месяце, но имеющим протяженность 2 периода (переходящий отпуск например) в базу по НДФЛ попадает только одна часть.
В принципе и в предыдущей версии от Домино софт такая же история.
6. besks (besks) 26 03.06.10 16:33 Сейчас в теме
7. besks (besks) 26 03.06.10 16:59 Сейчас в теме
Еще не учитывает необлагаемую мат.помощь в 4 000
8. besks (besks) 26 03.06.10 17:05 Сейчас в теме
И еще чуть-чуть...
Во взносах на соц.страхование в сумму расходов за счет ФСС не включается сумма пособия до 1.5 лет
u_n_k_n_o_w_n; +1 Ответить
9. Сергей Иванов (u_n_k_n_o_w_n) 31 06.06.10 14:00 Сейчас в теме
+ автору за работу. обработка для тех кому особо не хочется сидеть и изобретать велосипед, либор тем кто это делсть не умеет. Ошибки я думаю можно исправить в процессе работы, и выслать автору исправленные куски модуля для улучшения данного отчета.
После строки
"ИначеЕсли КодДохода = "Содержание прокуроров" Тогда // !!!
НомерКолонки = 19;
ВходитВЕСН = 0;
КонецЕсли;"
добавляем следующее "
Если ВР.ВходитВГруппу(ГруппаРасчетов.РасходыЗаСчетФСС)=1 Тогда
НомерКолонки = 9; // расходы за счет ФСС
НомерКолонкиПФР = 31;
ВходитВЕСН = 0;
КонецЕсли;"
и решается проблема указанная в в пункте 8.

10. Александр Приходько (bubliko_o) 31 06.06.10 16:14 Сейчас в теме
когда выкладывал было сделано только ограничение 4000, а потом выкладывали еще (более качественные варианты) и поэтому обновлять не стал, думал что уже никому не надо. но раз надо, выкладываю уже сбитую со всех авторов версию. вроде работает нормально
u_n_k_n_o_w_n; +1 Ответить
11. Сергей Иванов (u_n_k_n_o_w_n) 31 06.06.10 18:25 Сейчас в теме
В процессе тестирования выявлены следующие неточности: Не работает в случае отрицательной налоговой базы, просьба учесть при использовании.
12. Александр Приходько (bubliko_o) 31 25.06.10 11:46 Сейчас в теме
отрицательная база более не выводится и, соответственно, правильно считаются сторно записи
13. Александр (Tyndra) 34 09.07.10 05:34 Сейчас в теме
(11) Да ты прав
Если СпрДопПроводок.ПроцентОтРасчетнойБазы > 0 Тогда
Операции сравнения на больше-меньше допустимы только над значениями совпадающих базовых типов (число, строка, дата)
14. Света Зеленкова (cler_31) 2 03.08.10 12:46 Сейчас в теме
"отрицательная база более не выводится и, соответственно, правильно считаются сторно записи"

у меня в базе сделан массовый перерасчет больничных и отпусков.. сумма с + попадает в базу, а сумма сторно нет. Следовательно происходит завышение базы. Вообще-то база должна совпадать с суммой начислений по отчету "Свод по заработной плате".

Из-за вот этого кода этого не происходит:
Если ((ВР.Код = "ОплатаБЛс2010") ИЛИ (ВР.Код = "ОплатаБЛЗаСчетРаботодателяс2010")
ИЛИ (ВР.Код = "ОтпускОчередной") ИЛИ (ВР.Код = "ОтпускДополнительный")
ИЛИ (ВР.Код = "КомпенсацияОтпускаСверх28дней") ИЛИ (ВР.Код = "КомпенсацияОтпуска")
ИЛИ (ВР.Код = "ОтпускОчередной") ИЛИ (ВР.Код = "ОтпускУчебный")
ИЛИ (ВР.Код = "ОтпускЗаСвойСчетДолгосрочный") ИЛИ (ВР.Код - "ОтпускЗаСвойСчетКраткосрочный")) И (СуммаРез<0) Тогда
Продолжить;
КонецЕсли;
bubliko_o; +1 Ответить
15. Света Зеленкова (cler_31) 2 03.08.10 14:18 Сейчас в теме
Зачем в отчете присутствуют проверки этого перечисления "Перечисление.ТипыДоходовДляЕСН.ЗаСчетПрибыли" ? влияющие на итоговый результат ? и ни одной проверки перечисления ТипыДоходовДляСтраховыхВзносов ? Это же налоговая ведомость для страховых взносов.
17. Александр Приходько (bubliko_o) 31 06.08.10 17:15 Сейчас в теме
cler_31 ты абсолютно прав эта проверка действительно лишняя, было сделано на скорую руку да еще и не правильно)) заменил файл на правельный. там добавил учет сторно матпомощей. есть один небольшой баг, не правильно показывает сторно матпомощь если человек временно не работает, т.е. сделали сторно и потом до конца года нет начислений, но это бывает ппц как редко, поэтому не заморачивался. а так вроде все работает норм
18. Игорь Гладкий (smooth) 172 13.09.10 17:48 Сейчас в теме
явно что-то не то с разбивкой налогов по ИФ...
а жаль... :(
19. Светлана Петрова (Nad_ya) 25 26.10.11 22:00 Сейчас в теме