gifts2017

Обвертка к драверу энкодера магнитных карт BitaTek BME 630

Опубликовал ontru3shka (ontru3shka) в раздел Программирование - Внешние компоненты

Создавалась для себя, как часть системы по централизованному управлению скидками. Возможно кому-нибудь пригодится.

Позволяет записывать\читать содержимое дорожек магнитных карт из 1с.

Для работы нужен .Net Framework v>1.1

Для регистрации компоненты:

RegAsm.exe "C:\Program Files\1cv81\bin\NETConnector.dll" /tlb:NETConnector.tlb

файлы: NETConnector.dll (обвертка) и zt607.dll (драйвер), должны находится в одной директории.

Код 1с:

Процедура Подключить()
  Попытка
      Plugin = новый COMОбъект("AddIn.NETConnector");
  Исключение
      Plugin = 0;
      Предупреждение(ОписаниеОшибки()); 
  КонецПопытки;
КонецПроцедуры

Процедура Отключить()
  Если Plugin <> 0 Тогда
      Plugin.Done();
      Plugin = 0;  
  КонецЕсли;
КонецПроцедуры

Функции:

Plugin.ReadData2(nCom);               //прочитать 2 дорожку
Plugin.ReadData3(nCom);              //прочитать 3 дорожку
Plugin.ReadData23(nCom);              //прочитать 2,3 дорожку
Plugin.ReadData123(nCom);                //прочитать 1,2,3 дорожку
                                                          
Plugin.WriteData2(nCom, data2);          //записать 2ую дорожку
Plugin.WriteData3(nCom, data3);          //записать 3ю дорожку
Plugin.WriteData12(nCom, data1, data2);      //записать 1,2 дорожки
Plugin.WriteData23(nCom, data2, data3);      //записать 2,3 дорожки
Plugin.WriteData123(nCom, data1, data2, data3);//записать 1,2,3 дорожки
 
Plugin.GetVersion(nCom);             //Получить версию прошивки
Plugin.Reset(nCom);                 //Сброс настроек устройства

Параметры:

nCom - номер com-порта, к которому подключено устройсто (число)

dataN - Содержимое дорожки (Строка)

 

Обработка результата:

В модуле формы:

Процедура ВнешнееСобытие(Источник, Событие, Данные)

Если Событие = "WriteData123" Тогда
...
ИначеЕсли Событие = "ReadData123" Тогда
...

//и т.д
КонецЕсли;

КонецПроцедуры

 

В модуле приложения:

Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)

Если Событие = "WriteData123" Тогда
...
ИначеЕсли Событие = "ReadData123" Тогда
...

//и т.д

КонецЕсли;

КонецПроцедуры

Спасибо автору статьи http://www.rsdn.ru/article/dotnet/cs1c.xml "COM+-компонент для 1С на C#"

 

 

 

 

Скачать файлы

Наименование Файл Версия Размер
pack 55
.rar 21,05Kb
03.05.10
55
.rar 21,05Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа