gifts2017

Расчетная ведомость с детализацией по месяцам

Опубликовал Дмитрий Анкудинов (Diamante) в раздел Печать - Универсальные печатные формы

Стандартная расчетная ведомость с возможностью формирования за произвольный период. С детализацией по месяцам.

Сначала сделал детализацию стандартной печатной формы "Расчетная ведомость", но данный отчет слишком долго формировался.

Далее сделал собственный способ формирования и сделал похоже на стандартную печатную форму Расчетной ведомости.

Скачать файлы

Наименование Файл Версия Размер
Расчетная ведомость_По месяцам.ert 612
.ert 278,50Kb
07.12.14
612
.ert 278,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Kapitan911 Юрий (Kapitan911) 05.05.10 06:31
ВсегоУдержано_1 = ВсегоУдержано_1 + Таб2.ПолучитьЗначение(Таб2.НомерСтроки,Значение_ВР);
{D:\РАСЧЕТНАЯ ЗА ПЕРИОД\РАСЧЕТНАЯ ВЕДОМОСТЬ_ПО МЕСЯЦАМ.ERT(3114)}: Номер за пределами значения!
2. Дмитрий Анкудинов (Diamante) 05.05.10 07:59
Да косяк нашел, косяк происходил при наличии удержаний. Прошу прошения.
Косяк исправлен, можно пользоваться.
gutentag; +1 Ответить
3. Igоr Sаulеviсh (gutentag) 06.05.10 00:10
Почему данные в обработке "Вдомость0 от 1С" и "Ведомость по месяцам" показывают разные результаты ?
4. Дмитрий Анкудинов (Diamante) 06.05.10 06:06
Исправлен косяк в строке "Итого по ведомости" и в последней строке "Итого по сотруднику" по колонкам "Итого натуральных доходов" и "Итого удержано".

>gutentag
Где именно разнятся данные?
Для решения твоей проблемы необходимо знать строки и колонки по которым разные результаты или можешь прислать скриншоты!.
5. Igоr Sаulеviсh (gutentag) 06.05.10 13:48
(4) см.картинку
Прикрепленные файлы:
6. Igоr Sаulеviсh (gutentag) 13.05.10 16:23
Замечание: Если в программу вводить документ "накопленная задолженность", то суммируются данные в колонках Сальдо начальное и Сальдо конечное.
Имхо это ошибка, т.к. если задолженность возникла и погашена в середине года, то Сальдо начальное и Сальдо конечное должны по Сотруднику быть равны нулю.
7. Максим Я (maxchaos) 23.08.10 19:19
А что за оригинальная проверка в процедуре "Детализация" (в строке 40):
Процедура Детализация()
	Если ВыводПоМес = 1 Тогда
		Если ПериодСтр(д1, ДатаАктуальности) = 1 Тогда
			ВыводПоМес = 0;
			Предупреждение("Не корректно выбран Период!",30);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть

Это как же ПериодСтр(д1, ДатаАктуальности), т.е. строка, может быть равна числу 1? :o :D
8. Арутюн (harutyunb) 27.10.10 14:53
есть недоработка!
Кода выберешь период с детализацией по месяцам а потом форму отчета
"не" - "Расч. вед. в разрезе по месяцам", то обработка зацикливается !!!
Исправьте!
9. Rus (Pitot) 28.10.11 06:15
10. hanio (hanio) 03.11.11 10:46
а зачем ты убрал отработано дней? первый же в лоб вопрос бухгалтера - "В расчетной старой это было а сейчас почему нет??" верни пожалуйста.
11. Татьяна Фролова (Мать Тереза) 24.01.12 15:41
Что то с итоговым сальдо-выходит минус, хотя в штатной ведомости-норм, но меня устраивает-распечатать одну-и сверять и НДФЛ и базу по страховым взносам.
12. Владимир Шатохин (vovkakursk) 15.02.12 13:21
13. Anatoliy (NOVOPRO) 13.04.12 07:39
ВсегоУдержано_1 = ВсегоУдержано_1 + Таб2.ПолучитьЗначение(Таб2.НомерСтроки,Значение_ВР);
{с:\РАСЧЕТНАЯ ЗА ПЕРИОД\РАСЧЕТНАЯ ВЕДОМОСТЬ_ПО МЕСЯЦАМ.ERT(3114)}: Номер за пределами значения! У меня такаяже проблема.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа