gifts2017

Расширение границ доступа для отдельных типов документов

Опубликовал Андрей Андреев (Glaver) в раздел Программирование - Практика программирования

Не сложная доработка практически любой типовой конфигурации 1С 8.1, 8.2, расширяющая границы доступа для отдельных типов документов. Проверено на УПП и БП. Доработка облегчает жизнь администраторам БД, вынужденных открывать/закрывать доступ к документам в закрытом периоде

Часто на предприятии бывает так, что для какого-то вида документов необходимо иметь возможность менять в нем какие-либо данные задним числом. Например, Заказ покупателя оформлен, но в работу не запущен по причине отсутствия оплаты. И вот через полгода оплата пришла, но банковский счет уже поменялся или еще что-нибудь поменялось. Новый заказ оформлять менеджерам лень.

Или, например, период закрыли для изменения бух учете, а в упр. учете еще что-то необходимо менять.

Короче масса случаев, когда это необходимо, но в типовых конфигурациях этого не предусмотрено. Данная доработка позволяет установить свою дату запрета для какого-либо вида документов. Эту дату запрета можно также периодически пододвигать.

Доработка не подходит для тех случаев, когда необходимо "срочно-срочно" открыть период для изменения одного документа и "срочно-срочно" опять закрыть период.

Итак , изменения. Добавляем один новый объект и изменяем идин типовой:

I. Создаем Новы регистр сведений.

Я его назвал РасширениеГраницДоступаОтдельныхОбъектов. Одно измерение ОбъектДоступа (Строка, 50). Один ресурс ГраницаЗапретаИзменений (Дата).

В это регистре будем хранить записи для типов документов с датами запрета изменения данных отличных от общей даты запрета редактирования

II.Вносим изменения в общий модуль "НастройкаПравДоступа"

1. Добавляем новую функцию ЕстьРасширениеГраницДоступа, которая вернет истину, если в нашем новом регистре сведений есть запись для данного типа документов и ложь в обратном случае. Также в параметрах эта функция вернет нам дату запрета редактирования этого типа документов

//Функция ЕстьРасширениеГраницДоступа возвращает булево,

//параметр ИмяОбъекта - строка с именем документа, как оно задано в конфигураторе,

//параметр ДатаДляПроверки - в эту переменную фукнция запишет дату запрета для данного типа документов

Функция ЕстьРасширениеГраницДоступа(ИмяОбъекта, ДатаДляПроверки) Экспорт

    Запрос = Новый Запрос("ВЫБРАТЬ
                            |    ГраницаЗапретаИзменений
                            |ИЗ
                            |    РегистрСведений.РасширениеГраницДоступаОтдельныхОбъектов КАК    
                                     РасширениеГраницДоступаОтдельныхОбъектов
                            |ГДЕ
                            |    РасширениеГраницДоступаОтдельныхОбъектов.ОбъектДоступа = &ОбъектДоступа"
);
                           
    Запрос.УстановитьПараметр("ОбъектДоступа",ИмяОбъекта);
   
    ТЗ = Запрос.Выполнить().Выгрузить();
    Если ТЗ.Количество() > 0 Тогда
        ДатаДляПроверки = КонецДня(ТЗ[0].ГраницаЗапретаИзменений);
    КонецЕсли;
   
    Возврат НЕ ТЗ.Количество() = 0;    
   
КонецФункции

2. Изменяем Функцию ПолучитьДатуПроверкиПоТипуДокумента. Эта функция в типовой конф. вызывается перед записью любого документа, подписанного на событие ПередЗаписьюДокументаДатаЗапретаРедактирования.

В эту функцию в самое начало добавляем код:

ДатаДляПроверки = Неопределено;
    Если ЕстьРасширениеГраницДоступа(ПараметрыПроверкиДокумента.МетаданныеДокумента.Имя, ДатаДляПроверки) Тогда
        Если ДокументОбъект.Дата > ДатаДляПроверки  Тогда
            Возврат ТекущаяДата();
        КонецЕсли;
    КонецЕсли;

В некоторых конфигурациях фукнции ПолучитьДатуПроверкиПоТипуДокумента нет, тогда ищем процедуру ПроверитьВерсиюДокумента и тоже можно в самое начало или после первого блока вставить:

ДатаДляПроверки = Неопределено;
    Если ЕстьРасширениеГраницДоступа(ПараметрыПроверкиДокумента.МетаданныеДокумента.Имя, ДатаДляПроверки) Тогда
        Если ДокументОбъект.Дата > ДатаДляПроверки  Тогда
            Возврат ; //
убираем ТекущаяДата()
        КонецЕсли;
    КонецЕсли;


3. Изменяем Процедуру ПроверкаПериодаЗаписейРегистров. Эта процедура в типовой конф. вызывается перед записью любого набора данных в регистры. Также в начало добавляем код:

Если ВидРегистра = "РегистрСведений" Тогда
        ПроверятьСуществующиеЗаписиПоРегистратору = (НаборЗаписей.Метаданные().РежимЗаписи = Метаданные.СвойстваОбъектов.РежимЗаписиРегистра.ПодчинениеРегистратору);
    Иначе
        // Регистр накопления, регистр расчета, регистр сведений, подчиненный регистратору
        ПроверятьСуществующиеЗаписиПоРегистратору = Истина;
    КонецЕсли;
//Этот блок в УПП можно не добавлять, он там уже есть

Если ПроверятьСуществующиеЗаписиПоРегистратору Тогда
        ДатаДляПроверки = Неопределено;
        Регистратор = НаборЗаписей.Отбор.Регистратор.Значение;
        Если ЕстьРасширениеГраницДоступа(Регистратор.Метаданные().Имя, ДатаДляПроверки) Тогда
            Если Регистратор.Дата > ДатаДляПроверки  Тогда
                Возврат;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

 

Вот собственно и все. Изменения рабочие. Использую в своих конфигурациях. Буду рад, если кому-нибудь пригодится

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Никита Уколов (zzerro) 12.05.10 15:54
А как насчет обработки даты запрета редактирования отдельно по организациям и отдельно по пользователям?
2. Андрей Андреев (Glaver) 12.05.10 16:09
Если есть необходимость обрабатывать отдельно организациям и/или пользователям, добавляем в регистр сведений соответствующие измерения. И модифицируем нашу функцию ЕстьРасширениеГраницДоступа, добавляя в запросе условия по организации и пользователю. Ну а в параметрах запроса указываем текущего пользователя (ПараметрыСеанса.ТекущийПользователь) . Организацию, видимо, надо брать из документа, поэтому добавляем в функцию ЕстьРасширениеГраницДоступа параметр Организация и везде при вызовах этой функции вставляем ДокументОбъект.Организация. Конечно не во всех документах есть реквизит Организация. Поэтому лучше проверять сначала есть ли такой реквизит в документе:
Если НЕ ДокументОбъект.Метаданные().Реквизиты.Найти("Организация") = Неопределено Тогда
Организация = ДокументОбъект.Организация
Иначе
Организация = Справочники.Организации.ПустаяСсылка()
КонецЕсли;
3. Сергей Ожерельев (Поручик) 01.06.10 19:20
Пригодилась сама идея и готовый код.
А вот курочить штатные процедуры и модули я не стал, сделал отдельные подписки на события и отдельный модуль для доработанных процедур.
4. Сергей Ожерельев (Поручик) 01.06.10 19:28
Пока делал, пришла в голову мысль расширить фичу для пользователя и групп, как в штатной УТ.
5. Аркадий Кучер (Abadonna) 01.06.10 19:35
6. Игорь Исхаков (Ish_2) 01.06.10 19:53
В (3) подход посимпатичнее , чем у автора.
7. Сергей Ожерельев (Поручик) 02.06.10 03:13
Всё-таки пришлось немного вторгнуться в штатный модуль НастройкаПравДоступа и заменить вызовы ПроверитьВерсиюДокумента на свою доработанную ДополнительныеПраваДоступа.ПроверитьВерсиюДокумента
Забыл про проверку в форме при открытии. :(
Завтра протестирую на своих соб.., юзкрах
8. Сергей Ожерельев (Поручик) 02.06.10 03:15
Всё-таки пришлось немного вторгнуться в штатный модуль НастройкаПравДоступа и заменить вызовы ПроверитьВерсиюДокумента на свою доработанную ДополнительныеПраваДоступа.ПроверитьВерсиюДокумента
Забыл про проверку в форме при открытии. Тут уж ничего не сделаешь :(
Завтра протестирую на своих подопытных соб.., юзерах.
9. Ильшат (shatt) 29.01.11 13:35
(2)+1 Спасибо за идеи. Тоже вот одни попросили. Вопросы все таки у всех одинаковые.
Мне тоже непонятно зачем в стандартных поставках нет данного функционала..
10. Мини М (minie) 22.09.11 10:40
Спасибо, очень пригодилось)
11. Мастер Йода (master_yoda) 06.03.12 09:56
Замечательная идея.....однозначно плюс
12. sumixam (sumixam) 19.07.12 14:01
Спасибо. Как раз у меня возникла такая проблема, однозначно в выходыне протеститрую.
13. Денис Кузнецов (kuza_87) 07.02.13 22:04
Я не понимаю как это должно работать...в этот регистр мы добавляем те документы для которых можно делать изменения?????? а почему ресурс "строка"???
14. MADINAABAZA (MADINAABAZA) 09.08.13 11:35
Вот именно, странно! Я попробовала, и ничего не работает!!!
15. MADINAABAZA (MADINAABAZA) 09.08.13 11:36
Ресурс-строка,и что, просто писать название дока???
16. Андрей Андреев (Glaver) 09.08.13 14:59
(15) MADINAABAZA, да, просто строка. Необходимо указать тип документов строкой, так как они заданы в конфигураторе, например "ЗаказПокупателя" (в регистр вписывать без ковычек). Откроется доступ для всех документов "Заказ покупателя"
17. MADINAABAZA (MADINAABAZA) 09.08.13 15:01
Вот я сейчас сижу в БП, все сделала как вы прописали, и ничего не срабатывает!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа