gifts2017

Универсальная выгрузка/загрузка таблицы значений в dbf файл

Опубликовал Евгений 111 (xronos) в раздел Обмен - Обмен через DBF

Обработка выгрузки и загрузки ТЗ в dbf

В обработке представлен код, для выгрузки и загрузки в dbf файл таблиц значений.

Код на 7.7, но легко модифицируеться и для 8.

 Использовал для обмена чтобы постоянно не прописывать структуру таблиц при выгрузки и загрузке

Скачать файлы

Наименование Файл Версия Размер
Универсальная выгрузка/загрузка ТЗ 639
.ert 42,50Kb
20.05.10
639
.ert 42,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Евгений 111 (xronos) 20.05.10 13:21
Обработка простая, но надеюсь кому-нибудь сэкономит время :)
demask87; victory; +2 Ответить
2. Andrey Golubev (razzmuzz) 29.09.11 12:05
Когда работаешь не монопольно, то иногда выдает ошибку, что невозможно завершить транзакцию
3. divalis (divalis) 13.10.11 16:55
4. Владимир Саблин (emptyteam) 20.01.12 23:38
Спасибо, просто, но помогло
6. gunner_Hans Gunner (gunner_Hans) 25.03.12 07:48
7. Владимир Попов (Vladraven) 25.02.16 09:03
Правильнее так:

Функция ДБФвТЗ(ИмяФайла) 
	
	ДБФ = СоздатьОбъект("xBase");
	ДБФ.ОткрытьФайл(ИмяФайла);  
	ТЗ = СоздатьОбъект("ТаблицаЗначений");
	
	КолвоКолонок=ДБФ.КоличествоПолей();
	Для Кол=1 По КолвоКолонок Цикл 
		Поле = ""; ТипПоля = ""; ДлинаПоля = 0; ТочностьПоля = 0;
		ДБФ.ОписаниеПоля(Кол, Поле, ТипПоля, ДлинаПоля, ТочностьПоля);
		ТЗ.НоваяКолонка(Поле,ТипПоля,ДлинаПоля,ТочностьПоля);
	КонецЦикла;
	
	ДБФ.Первая();	
	Пока ДБФ.ВКонце() =0 Цикл
		
		ТЗ.НоваяСтрока();	
		Для ном=1 По ДБФ.КоличествоЗаписей() Цикл 
			     
			Для Кол=1 По КолвоКолонок Цикл 
				тз.УстановитьЗначение(ном,Кол,ДБФ.ПолучитьЗначениеПоля(Кол));  
			КонецЦикла;
		КонецЦикла;
		ДБФ.Следующая(); 
		
	КонецЦикла;  
	ДБФ.ЗакрытьФайл();
	Возврат ТЗ ; 
	
конецФункции
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа