gifts2017

Почтовый сбор при пересылке алиментов

Опубликовал Светлана Иванова (Cvetic) в раздел Программирование - Практика программирования

В стандартной конфигурации ЗиК неправильно рассчитывается "Почтовый сбор при пересылке алиментов". Правильный модуль вида расчета ПочтовыйСбор :

Процедура ПровестиРасчет()

 // если запись исправлена или фиксирована, то ее не рассчитываем
 Если (Исправлена=1) или (Фиксирована=1) Тогда
  глСообщениеТрассировки(глСообщенияТрассировки, "" + ?(Исправлена=1,"Результат записи исправлен вручную","Запись фиксирована") + ". Расчет не проводился.", , 1);
  Возврат
 КонецЕсли;

 ЖурналРасчетовЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
 ЖурналРасчетовЗарплата.ВыбратьЗаписиПоОбъекту(Объект,ДатаНачала,ДатаОкончания);

 Пока ЖурналРасчетовЗарплата.ПолучитьЗапись()=Цикл
  Если (ЖурналРасчетовЗарплата.ВидРасч=ВидРасчета.УдержаниеПоИсполнительномуЛисту)
  и (ЖурналРасчетовЗарплата.Документ=Документ) Тогда

   // Почтовый сбор при пересылке алиментов исчисляется за каждый
   // полный или не полный рубль по исполнительному листу
   СуммаПоИспЛисту = ЖурналРасчетовЗарплата.Результат;
   Если (СуммаПоИспЛисту <= 1000) и (СуммаПоИспЛисту > 0) тогда
    Результат = 25 + СуммаПоИспЛисту*0.05;
   ИначеЕсли (СуммаПоИспЛисту > 1000) и (СуммаПоИспЛисту <= 5000) тогда
    Результат = 75 + (СуммаПоИспЛисту - 1000)*0.04;
   ИначеЕсли (СуммаПоИспЛисту > 5000) и (СуммаПоИспЛисту <= 20000) тогда
    Результат = 235 + (СуммаПоИспЛисту - 5000)*0.02;
   ИначеЕсли (СуммаПоИспЛисту > 20000) и (СуммаПоИспЛисту <= 500000) тогда
    Результат = 535 + (СуммаПоИспЛисту - 20000)*0.01;
   КонецЕсли;
   Прервать;
  КонецЕсли;
 КонецЦикла;
 РасшифСуммаПоИспЛисту = Окр(СуммаПоИспЛисту);
 глСообщениеТрассировки(глСообщенияТрассировки, "Почтовый сбор при пересылке алиментов исчисляется от суммы удержания: _П01", 0, 1, РасшифСуммаПоИспЛисту, "Ч15");
 глСообщениеТрассировки(глСообщенияТрассировки, "Процент исчисления почтового сбора для перечисления алиментов: _П01", 0, 0, Документ.ПроцентПочтовогоСбора, "Ч5.2");
 глСообщениеТрассировки(глСообщенияТрассировки, "Сумма почтового сбора по исполнительному документу составила: _П01", 0, 0, Результат, "Ч15.2");

КонецПроцедуры // ПровестиРасчет

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Алексей Константинов (alexk-is) 25.05.10 15:55
Текст модуля в публикации можно раскрасить. Например, так http://www.infostart.ru/public/18924/
2. Евгений Ганшин (lhfrjy) 25.05.10 16:33
Эта ошибка у них с самого начала.
3. lll lll (log22) 26.05.10 05:29
этот модуль не учитывае вариант когда у одного сотрудника НЕСКОЛЬКО исполнительных листов, что далеко не редкость
4. Ник Коленц (nkolentcev) 26.05.10 10:47
По-моему модуль так же не учитывает дату перехода на новый почтовый тариф, т.е. при перерасчете как он себя поведет?
5. Светлана Иванова (Cvetic) 26.05.10 13:28
(1) подскажи, пожалуйста, как раскрашивать. Я не нашла :oops:
(3) Почтовый сбор рассчитывается с каждого удержания по исполнительному листу, а не с их суммы. Каждый почтовый перевод денег это отдельный перевод
(4) Какие перерасчеты могут быть? Сколько денег перечислили столько перечислили. А если сумма изменилась, то перечисления пойдут по новым тарифам.
7. econom1 26.05.10 16:02
ставлю + за новость об изменении тарифа
8. Светлана Иванова (Cvetic) 27.05.10 09:35
(6) это для 8-ки :( А для 7 есть?
9. Алексей Константинов (alexk-is) 27.05.10 09:39
(8) Конечно. Вторая ссылка и ссылки в комментариях к публикации в первой ссылке.
10. Светлана Иванова (Cvetic) 27.05.10 16:14
11. Михаил Рубик (rm1965) 17.06.10 21:54
Я вставил еще проверку - ввели ли процент почтового сбора в документ типа :
Если Документ.ПроцентПочтовогоСбора <> 0 Тогда - считаем почтовый сбор.

Если этого не сделать- с любых сумм алиментов будет удерживаться почтовый сбор, а некоторые перечисляют по банку - не по почте.
12. Lika Ivanova (Lik2707) 09.02.12 10:04
В 516 релизе Комплексной и в 320 ЗиК это так и не исправлено, придется подправлять. Вот только не совсем удобно: лазить в модуль при смене тарифа. Но пока так.