gifts2017

Вывод горизонтальных разделителей в отчете на СКД

Опубликовал Олег Кравчук (kravchuk) в раздел Программирование - Практика программирования

Многие сталкивались с проблемой  возможности вывода в отчете на СКД горизонтальных разделителей страниц.  В этой статье будет изложено одно из возможных решений для платформы 8.2 для управляемой формы отчета.

Итак, имеем отчет на СКД.


В СКД создаем вычисляемое поле «Горизонтальный разделитель страниц».



На форме отчета создаем команду для вывода отчета с разделителями:


Код команды:

&НаКлиенте
Процедура КомандаСформироватьСРазделителями(Команда)
КомандаСформироватьСРазделителямиСервер();
КонецПроцедуры

&НаСервере
Процедура КомандаСформироватьСРазделителямиСервер()
ДанныеРасшифровкиВ =Новый ДанныеРасшифровкиКомпоновкиДанных;
КомпоновщикМакета =Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки =КомпоновщикМакета.Выполнить(Отчеты.Отчет.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных"),Отчет.КомпоновщикНастроек.ПолучитьНастройки(),ДанныеРасшифровкиВ);
ПроцессорКомпоновки =Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,,ДанныеРасшифровкиВ);
ПроцессорВывода =Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
Результат.Очистить();
ПроцессорВывода.УстановитьДокумент(Результат);
ПроцессорВывода.НачатьВывод();
ПервыйПропущен =Ложь;
Пока Истина Цикл
ЭлементРезультата =ПроцессорКомпоновки.Следующий();
Если
ЭлементРезультата =Неопределено Тогда
Прервать;
Иначе
Для Каждого
Параметр Из ЭлементРезультата.ЗначенияПараметров Цикл
Если
Параметр.Значение="Горизонтальный разделитель страниц" Тогда
Если
ПервыйПропущен Тогда
Результат.ВывестиГоризонтальныйРазделительСтраниц();
Иначе
ПервыйПропущен=Истина;
КонецЕсли;
Прервать;
КонецЕсли;
КонецЦикла;
ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
КонецЕсли;
КонецЦикла;
//Зачистим поля с горизонтальным разделителем страниц
НайденнаяОбласть =Результат.НайтиТекст("Горизонтальный разделитель страниц");
Пока
НайденнаяОбласть<>Неопределено Цикл
НайденнаяОбласть.Текст="";
НайденнаяОбласть =Результат.НайтиТекст("Горизонтальный разделитель страниц");
КонецЦикла;
ПроцессорВывода.ЗакончитьВывод();
ДанныеРасшифровки =ПоместитьВоВременноеХранилище(ДанныеРасшифровкиВ,Новый УникальныйИдентификатор);
КонецПроцедуры



В результате этой команды будет сформирован табличный документ ,  где перед каждым выводом группировки, в которой будет участвовать поле «Горизонтальный разделитель страниц» ,будет выведен горизонтальный разделитель страницы, само поле, как и его заголовок будут выведены пустыми.
Недостатком предложенного способа является образование лишней незаполненной колонки таблицы отчета.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Дмитрий Глух (IronDemon) 29.05.10 10:51
Опять танцы с бубном :cry:
Когда уже 1С нормальную реализацию сделает.
2. Олег Кравчук (kravchuk) 29.05.10 11:58
Да, могли бы в дополнительные свойства группировки ввести свойство "выводить на новой странице" было бы проще.
3. Андрей Д. (detec) 10.06.10 14:56
А можно сделать картинку выполненного отчёта, чтобы можно было визуально оценить работу процедуры?
4. Олег Кравчук (kravchuk) 10.06.10 19:03
Тут не так много операций, в любом отчете можешь попробовать сделать.
5. it-kostya (it-kostya) 14.06.11 11:16
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа