gifts2017

Обработка "Меню пользователя" для 1С:Предприятие

Опубликовал Александр Синцов (Sintson) в раздел Администрирование - Защита, права, пароли

Обработка предназначена для интерактивного формирования меню быстрого доступа пользователя к объектам конфигурации (с организацией ограничения по ролям, редактировать меню может только ПолныеПрава).
Предназначена для конфигураций "1С: Бухгалтерия" и "1С: Управление производственным предприятием",  "Торговля" и т.п.
Обработка предназначена для интерактивного формирования меню быстрого доступа пользователя к объектам конфигурации (с организацией ограничения по ролям, редактировать меню может только пользователь с ролью ПолныеПрава).
Предназначена для конфигураций "1С: Бухгалтерия" и "1С: Управление производственным предприятием",  "Торговля" и т.п.
Аналоги:
а также вырезка из розницы
Для работы автозапуска обработки вставить в модуль приложения в конец процедуры ПриНачалеРаботыСистемы()
следующий текст:
				// {{Синцов А.С.
			
		
				МенюПользователя = Обработки._МенюПользователя.Создать();
			
		
				Запрос = Новый Запрос(
			
		
				"ВЫБРАТЬ
			
		
				|СохраненныеНастройки.СохраненнаяНастройка
			
		
				|ИЗ
			
		
				|РегистрСведений.СохраненныеНастройки КАК СохраненныеНастройки
			
		
				|ГДЕ
			
		
				|СохраненныеНастройки.Пользователь = &Пользователь
			
		
				|И СохраненныеНастройки.ИмяОбъекта = &ИмяОбъекта
			
		
				|И СохраненныеНастройки.НаименованиеНастройки = &НаименованиеНастройки");
			
		
				Запрос.УстановитьПараметр("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
			
		
				Запрос.УстановитьПараметр("ИмяОбъекта", МенюПользователя.Метаданные().Имя);
			
		
				Запрос.УстановитьПараметр("НаименованиеНастройки", "Основная");
			
		
				Выборка = Запрос.Выполнить().Выбрать();
			
		
				Если Выборка.Следующий() Тогда
			
		
				СохраненнаяНастройка = Выборка.СохраненнаяНастройка.Получить();
			
		
				Если СохраненнаяНастройка.ОткрыватьПриЗапуске Тогда
			
		
				МенюПользователя.ПолучитьФорму().Открыть();
			
		
				КонецЕсли;
			
		
				КонецЕсли;
			
		
				// Синцов А.С.}}
			
		
	


Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
UserMenu.rar
.rar 37,24Kb
29.08.12
35
.rar 37,24Kb 35 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Евгений Люлюк (Evg-Lylyk) 20.07.10 13:22
3. Эстер Коган (e.kogan) 20.07.10 16:49
Да их уже такое множество... всё равно рабочий стол мне удобнее :)
4. Александр Синцов (Sintson) 21.07.10 02:50
5. A.Y 21.07.10 17:22
да, аналог уже был. нового мало, но хотелось бы...

сложно сделать аналог, но только с группировкой не по виду объекта по функциям?
к примеру группа "Управление продажами" (называем сами) и подключаем в эту группу документы, обработки, отчеты связанные с продажами. и т д.
6. Ivon (Ivon) 22.07.10 10:19
(5). В моем интерфейсе как раз именно это.
7. A.Y 22.07.10 10:38
видимо я перекурил )) и мне мерещется то что на скриншотах?
на скрине видно что объекты подключаются с группой по виду объекта.
документы, отчеты, обработки.

или это секретный функционал обработки, потому на скрине он не отображен?

можно тогда выложить скрин с демонстрацией группировки объектов не по виду объекта а по произвольным функциям?
8. Александр Синцов (Sintson) 22.07.10 13:14
(7) Обратите внимание на АВТОРА сообщения на которое Вы отвечаете, он очень хотел бы чтобы Вы обратили внимание на его разработку, в моей обработке НЕТ произвольных группировок, т.к. при создании обработки такая задача не ставилась, но раз есть пожелание от пользователей, постараюсь удовлетворить в ближайшее время (день-два). Все мои разработки в "свежем" виде можно найти здесь ;)
9. Надежда Иванова (Nadezhda09) 07.10.10 11:59
Здравствуйте!
Скачала обработку. Почему-то пусто в списке Документов и Отчетов. Справочники и Обработки есть.
10. Надежда Иванова (Nadezhda09) 07.10.10 12:16
1С:Предприятие 8.1 (8.1.14.72)
Управление производственным предприятием, редакция 1.2 (1.2.25.1)

И еще: не открывается при запуске, даже если "галочка" установлена.
11. Александр Синцов (Sintson) 07.10.10 17:55
(10) Настройку для автозапуска добавил в описании разработки, также описание встроено в макет, ознакомиться с ним можно в конфигураторе.
12. Надежда Иванова (Nadezhda09) 08.10.10 06:23
13. Андрей Литвинов (andreylitvinov) 17.10.11 20:06
Неплохой вариант меню.
Вполне жизнеспособный.
Спасибо.
14. Александр Синцов (Sintson) 17.10.11 22:24
(13) Благодарю за высокую оценку, пользуйтесь на здоровье!
15. Александр Клюев (alw-1) 26.12.11 13:18
Попытался применить обработку для Бух.Корп 8.2 предворительно сконвертировал. Обработка вызывается но запускать ее при вызове не получается. Код приведенный выше поместил в модуль приложения в указанную процедуру.
Выдала ошибку что не находит объект. Прописал обработку как объект конфигурации и в коде изменил имя создаваемой обработки. Выдает ошибку , что у меню пользователя нет процедуры Открыть(). Может подскажите как переделать код для запуска при открытии.
16. Александр Синцов (Sintson) 27.12.11 03:20
Должно быть так:

// {{Синцов А.С.
МенюПользователя = Обработки.ВашеНазваниеОбработкиВКонфигурации.Создать();
Запрос = Новый Запрос(
"ВЫБРАТЬ
| СохраненныеНастройки.СохраненнаяНастройка
|ИЗ
| РегистрСведений.СохраненныеНастройки КАК СохраненныеНастройки
|ГДЕ
| СохраненныеНастройки.Пользователь = &Пользователь
| И СохраненныеНастройки.ИмяОбъекта = &ИмяОбъекта
| И СохраненныеНастройки.НаименованиеНастройки = &НаименованиеНастройки");
Запрос.УстановитьПараметр("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
Запрос.УстановитьПараметр("ИмяОбъекта", МенюПользователя.Метаданные().Имя);
Запрос.УстановитьПараметр("НаименованиеНастройки", "Основная");
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
СохраненнаяНастройка = Выборка.СохраненнаяНастройка.Получить();
Если СохраненнаяНастройка.ОткрыватьПриЗапуске Тогда
МенюПользователя.ПолучитьФорму().Открыть();
КонецЕсли;
КонецЕсли;
// Синцов А.С.}}
Все должно работать, не будет, обращайтесь, помогу.
Можете написать в личку, созвонимся.
17. Алексей Роза (DoctorRoza) 30.08.12 10:03
Вы можете выложить эту разработку на управляемых формах?
18. Александр Синцов (Sintson) 30.08.12 10:45
(17) Спасибо за интерес к моей разработке!
Но, если честно, я не понимаю для чего она нужна в управляемых формах!?!
Там же другая философия построения командного интерфейса!
Вот например: http://infostart.ru/public/148369/
Или я чего - то не понимаю?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа