gifts2017

Альтернативное заполнение сведений о стаже

Опубликовал zuza (zuza) в раздел Обработки - Универсальные обработки

Альтернативное заполнение сведений о стаже для бухгалтерии и Усн.

Альтернативное заполнение сведений о стаже для бухгалтерии и Усн. Тестировалось на 517 релизе бух. и 172 Усн.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ВводСтажа
.zip 18,05Kb
20.07.10
214
.zip 18,05Kb 214 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Юрий (YuryKr) 21.07.10 09:45
Обработка очень полезная. Особенно в плане возможностью заполнения по списку сотрудников
2. Наталия ... (tili) 21.07.10 11:31
Спасибо автору! Большой плюс
3. Rash Kaz (kazrash) 21.07.10 13:56
Пригодится для тех, кто еще не обновил конфигурацию.
4. Валерий Генин (valgen) 21.07.10 15:28
Может быть у меня не всё заполнено, но на 517 релизе при выборе любого сотрудника выдаётся ошибка:
ДоходыВычетыНалогиСотрудников.НайтиЗначение(глПолучитьУникальныйКодСотрудника(Сотрудник)+"01",СтрокаИтоговойТаблицы,1);
{Глобальный модуль(18761)}: Номер за пределами значения!
5. zuza (zuza) 21.07.10 16:09
(4) странно... у меня все ок, а конфа типовая?
6. Арина Итальянцева (best2085) 21.07.10 16:33
Спасибо за обработку. Когда много сотрудников сокращается время на заполнение стажа.
7. Elena (elen_l) 22.07.10 06:14
Удобная обработка. Спасибо за заботу о бухах. 8-)
8. Elena Ignatieva (LeIgn) 22.07.10 07:31
Обработка понравилась, Спасибо.
9. Валерий Хоменко (ValeraH) 22.07.10 11:50
Взял обработку на вооружение. Подкорректировал процедуру ВнестиСведения(), для уменьшения ручного ввода. Вместо стандартного
//СпрСтажа.Начало = НачПериода;
//СпрСтажа.Окончание = КонПериода;
обрабатываю периодический реквизит ХарактерРаботы определяя ДатаНачалаСтажа, ДатаОкончанияСтажа и далее задаю Начало и Окончание в зависимости от условий:
// Если нет даты увольнения И при этом был зачислен на работу (до фига не работавших, используемых для доверенностей)
// Принят в выбранном периоде

Есть дата увольнения и при этом:
// Уволен после начала выбранного периода
// Принят в выбранном периоде
// Уволен до окончания выбранного периода

Кроме того добавил процедуру печати списком, чтобы всех увидеть одним взглядом.
10. Павел Николаев (pnick79) 22.07.10 12:25
Скачал. Все хорошо работает. Спасибо.
11. Ольга Кравченко (attra) 22.07.10 13:17
скачал, открыл, а как к 1с подцепить то. Подскажите
12. zuza (zuza) 22.07.10 13:47
(11) это внешний отчет. Можно через "Файл"-->"Открыть" или через "Сервис" -->"Дополнительные возможности".
13. finansy2004 (finansy2004) 23.07.10 09:31
Мне понравилось :) Пробовала на Бух. 517. Правда, почему-то стаж у уволенных сокращается на 1 день, то есть, если человек уволен, допустим, 02.03.10 (приказом), то окончание периода ставится 01.03.10. Это только у меня?
14. finansy2004 (finansy2004) 23.07.10 12:46
:!: Зачем нужна кнопка "Внести сведения о стаже по умолчанию"??? нажала ее, а она мне у всех поставила стаж с 23.07 по 23.07! И теперь только ручками у каждого это все удалять! Предупреждать надо...
15. Елена (fd1) 23.07.10 20:20
Спасибо! Очень нужная вещь!!! :D
16. this11 25.07.10 13:06
бухи ненарадуются, довольно большое снижение времени на забивание стажа.... автору огромное спасибо
17. Игорь Одиноков (Odinokov) 26.07.10 12:33
Большое спасибо, очень помогло.
18. анка (анфиска) 29.07.10 10:42
Прекрасно работает. Мы уже все сдали, но в следующий раз надеюсь поможет 8-)
19. Kavar (Kavar) 29.07.10 12:18
Удобная обработка. Спасибо.

З.Ы. переделал под ЗиК
20. Alex (ondi) 30.07.10 23:10
У себя использовал кнопку встроенного первичного заполнения на форме отчета ПодготовкаСведенийПФР2010, а для изменений стажа использовал "не альтернативную обработку".
Да, обработка показалась интересной..., не было времени рассмотреть её полезность внимательней, только сейчас взглянул... Некий итог:
Для ускорения просмотра таблицы стажа, было бы интересно бросить на форму (за пределы рабочего окна) элемент текста с функцией типа:
Функция ПриИзменении()
Если ТЗ_Сотр.КоличествоСтрок()>0 Тогда
Если ТекСтрока=ТЗ_Сотр.ТекущаяСтрока() Тогда
Возврат "";
Иначе
ТекСтрока=ТЗ_Сотр.ТекущаяСтрока();
КликПоСтрокеТЗ();
Возврат "";
КонецЕсли;
КонецЕсли;
КонецФункции

Такая конструкция позволит при изменении активной строки таблицы сразу делать КликПоСтрокеТЗ().

Несколько смущает, для чего вставляется избыточная строка в таблицу стажа, в случае прерывистого стажа и при вводе новой строки?

21. Олег Грехнев (oleggrek) 09.08.10 09:55
Удобная обработка. В принципе все понравилось.
Но проблема в том, что она не правильно заполняет периоды стажа за первое полугодие, если делать это в августе.
22. Mari Guseva (uectxtr) 17.08.10 10:01
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа