gifts2017

Получить данные ГНАУ (Государственной налоговой администрации Украины)

Опубликовал Денис Краснов (Neco) в раздел Обмен - Интеграция с WEB

Обработка «Получить данные ГНАУ» предназначена для получения детальной информации о юридических и физических лицах зарегистрированных в информационных базах налоговой инспекции Украины . Актуально для украинских конфигураций.

 

Внимание! Обработку "ПолучитьданныеГНАУv2.epf" можно использовать только в конфигурациях с доступными управляемыми формами!

 

Обработки можно использовать в толстом и тонком клиенте, для любых конфигураций на платформе 1С: Предприятие 8.х. Для корректной работы нужно подключение к сети Интернет и прямой доступ по протоколу HTTP (порт 80) на сайты ГНАУ: http://www.sts.gov.ua/ и Информационного-ресурсного центра (ИРЦ):  http://www.irc.gov.ua.

Функциональные особенности: 

  1. Можно получать данные о юридических и физических лицах не покидая удобной среды 1С не переключаясь в браузер.
  2. В типовых конфигурациях, где предусмотрен справочник «Контрагенты», можно выбирать определенного контрагента, для проверки его данных и сравнения с полученными на сайтах ГНАУ и ИРЦ.
  3. В конфигурациях, где предусмотрен справочник «Контрагенты» можно создавать новые элементы на основании данных полученных с сайтов ГНАУ и ИРЦ.
  4. Обработки можно встраивать в конфигурации, расширяя функционал типового решения.

Важно: На сайтах ГНАУ и Информацинонно-ресурсного центра (ИРЦ) перед получением данных нужно ввести капчу.

Update 11.02.2013

- добавлена обработка ПолучитьДанныеГНАУv2.epf предназначенная для использования в конфигурациях с управляемыми формами. Возможно подключение как доп.обработки.

- исправлено получение данных ИРЦ

 

Update 06.12.2012

- Исправлена ошибка получения данных ИРЦ

- Исправлена ошибка получения данных физ.лиц.

Update 03.07.2012

 Благодаря wmp внесены следующие изменения:

- добавлен код получения данных сайта http://sts.gov.ua

 

Update 21.02.2012

 Благодаря Asdam внесены следующие изменения:

 - добавлена возможность поиска по физическим лицам

 - добавлена экспортная функция для встраивания обработки как внешней печатной формы справочников и документов

 - исправлена функция получения данных с сайта ГНАУ

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Получить данные ГНАУ
.rar 42,93Kb
11.02.13
134
.rar 42,93Kb 134 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Lutiy Balash (Lutiy) 10.08.10 22:24
2. Денис Краснов (Neco) 11.08.10 10:31
для использования в 8.2 обработку нужно сконвертировать.
3. Эдуард Стрельцов (benzotopor) 12.12.10 19:54
при получении данных с irc.gov.ua пишет ошибку:
Файл не обнаружен "ua/search"

Вероятно на сайте поменялась папка. Не подскажете название новой?
4. Asdam (Asdam) 07.01.12 18:34
Доступен поиск контрагента на странице http://irc.gov.ua/ua/Poshuk-v-YeDR.html
Неплохо бы объединить поиск по двум базам.
5. Денис Краснов (Neco) 05.02.12 23:24
Обновил обработку. Теперь доступны данные с сайта http://www.irc.gov.ua
6. Asdam (Asdam) 21.02.12 11:36
(5) Спасибо!
Все отлично, но только в ЕГР ищет только юрлиц. Для того чтобы искало и физлиц, нужно в строке
HTTP.Send("type=2&query=" + СокрЛП(КодПоЕДРПОУ));
Менять параметр "type=2" - юрлицо; "type=1" - физлицо.
7. Asdam (Asdam) 21.02.12 15:19
(5) Подправил обработку для работы с физлицами и был косячек с номером свидетельства.
Скачать исправленную можно отсюда: http://rghost.ru/36632468
Автору респект!
8. Vond Pufilov (Vond) 22.02.12 03:03
Какая замечательная штука. Помнится ранее была обработка которая просто вытаскивала данные а тут еще и изменение существующей карточки ? Супер :)
9. Александр Коновалов (askoder) 24.02.12 10:43
10. Ольга Lenn (LCLNN) 06.03.12 16:47
Спасибо, полезная веСЧь =)
11. Max (mkobzancev) 06.03.12 18:20
не все данные есть на сайте ГНАУ
12. Asdam (Asdam) 06.03.12 18:52
(11) Внимательно читайте описание.
Обработка получает данные из сайта ГНАУ: http://www.sta.gov.ua/ и Информационного-ресурсного центра (ИРЦ): http://www.irc.gov.ua.
Вам известны еще сайты с данными?
13. Andrey Dyak (electronik) 05.04.12 09:04
Задумка неплохая, но хотелось бы во первых сама налоговая вногсила дание по все кто занимается комерческой деятельностью, во вторых елибы была возможность получать и обрабативать даные не по одному а по нескольких клиентах сразу ето бы в разы ускорило работу. Автору респект и уважение за проделаную работу
14. Дмитрий Глеков (glek) 22.05.12 17:14
Автору однозначно респект и большой плюс ))
15. Kostya genovskiy (genkostya002) 07.06.12 20:06
Теперь нужно писать для нового сайта http://sts.gov.ua/ там тоже есть капча
16. Владимир (wmp) 15.06.12 12:19
Процедура для поиска данных на сайте sts.gov.ua
Большая просьба встроить ее в эту обработку. Спасибо.
И выложить, желательно на внешний ресурс.


Процедура Запрос2Нажатие(Элемент)
ПоискКодОКПО = "";
ПоискНомерСвидетельства = "";

WinHttp=Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
WinHttp.Option(2,"Windows-1251");
WinHttp.Open("POST","http://sts.gov.ua/reestr",0);

WinHttp.SetRequestHeader("Accept-Language", "ru");
WinHttp.SetRequestHeader("Accept-Charset","Windows-1251");
WinHttp.setRequestHeader("Content-Language", "ru");
WinHttp.setRequestHeader("Content-Charset", "Windows-1251");
WinHttp.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=Windows-1251");
WinHttp.Send();


WinHttp.Open("GET","http://sts.gov.ua/passremind.php?captcha=giveme",0);
WinHttp.Send();

ИмяВыходногофайла = ПолучитьИмяВременногоФайла();
BinaryStream = Новый COMОбъект("ADODB.Stream");
BinaryStream.Type = 1;
BinaryStream.Open();
BinaryStream.Write(WinHttp.ResponseBody);
BinaryStream.SaveToFile(ИмяВыходногофайла);

// ЭлементыФормы.ПолеКартинки.Картинка = Новый Картинка (ИмяВыходногофайла);

ФормаКапчи = ПолучитьФорму("ФормаКапчи");
ФормаКапчи.ЭлементыФормы.КартинкаКапчи.Картинка = Новый Картинка(ИмяВыходногоФайла);
КодКаптча = ФормаКапчи.ОткрытьМодально();

WinHttp.Open("POST","http://sts.gov.ua/reestr",0);
WinHttp.SetRequestHeader("Accept-Language", "ru");
WinHttp.SetRequestHeader("Accept-Charset","Windows-1251");
WinHttp.setRequestHeader("Content-Language", "ru");
WinHttp.setRequestHeader("Content-Charset", "Windows-1251");
WinHttp.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=Windows-1251");
ПараметриПОСТ = "logic="+"1"+"&kod="+ПоискКодОКПО+"&kod_pdv="+""+"&nom_svd="­+ПоискНомерСвидетельства+"&name="+""+"&captcha="+ВРег(СокрЛП(КодКаптча))+"&action=req&ozn="+"0";
//Сообщить(ПараметриПОСТ);
//WinHttp.Send("captcha="+СокрЛП(Капча) + "&reqid=" + СокрЛП(КодСессии));
WinHttp.Send(ПараметриПОСТ);

ТекстОтвета = WinHttp.ResponseText();

ТекстОтвета = Сред (ТекстОтвета, Найти(ТекстОтвета, "<div class=""result"));
ТекстОтвета = Сред(ТекстОтвета,1,Найти(ТекстОтвета,"</div>"));
ТекстОтвета = СтрЗаменить(ТекстОтвета,"<p>", "");
ТекстОтвета = СтрЗаменить(ТекстОтвета,"</p>", "");
ТекстОтвета = СтрЗаменить(ТекстОтвета,"<div class=""result_search_pdv green"">", "");
ТекстОтвета = СтрЗаменить(ТекстОтвета,"</br>", Символ(10)); // символ перевода строки
ТекстОтвета = СтрЗаменить(ТекстОтвета,"<", "");
ТекстОтвета = СтрЗаменить(ТекстОтвета,"--", "-");
ТекстОтвета = СтрЗаменить(ТекстОтвета,"-", "-");

Текст = ЭлементыФормы.ПолеТекстовогоДокумента1;
Текст.Очистить();

Если Найти(ТекстОтвета,"red") > 0 Тогда
Предупреждение("Неправильно введен защитный код");
Иначе
Текст.ДобавитьСтроку(ТекстОтвета);

//ИмяВремФайла = ПолучитьИмяВременногоФайла("txt");
тДок = Новый ТекстовыйДокумент;
тДок.ДобавитьСтроку(ТекстОтвета);

//
тДок2 = Новый ТекстовыйДокумент;

Для НомСтр = 1 По тДок.КоличествоСтрок() Цикл
ТекСтрока = СокрЛП(тДок.ПолучитьСтроку(НомСтр));
Если ЗначениеЗаполнено(ТекСтрока) Тогда
тДок2.ДобавитьСтроку(ТекСтрока);
КонецЕсли;
КонецЦикла;

ИндНалогНомер = Сред(тДок2.ПолучитьСтроку(1), 36);
КодЕДРПОУ = Сред(тДок2.ПолучитьСтроку(2), 14);
Наименование = Сред(тДок2.ПолучитьСтроку(3), 50);
НомерСвидетельстваНДС = Сред(тДок2.ПолучитьСтроку(4), 34);
ДатаНачалаСвидетельстваНДС = Сред(тДок2.ПолучитьСтроку(5), 36);
КонецЕсли;

КонецПроцедуры
17. Ольга Lenn (LCLNN) 19.06.12 10:37
wmp, а где строки с получением кода сессии?...
18. Ольга Lenn (LCLNN) 19.06.12 11:37
Ой, не заметила, что строка закомментина, сорри)
19. Iam Name (ru5) 21.09.12 10:38
с 20.09.2012 эта обработка не получает информацию с сайта ЕГР.
Не верный запрос информации.
20. Денис Краснов (Neco) 24.09.12 12:03
Какие-то глюки, я не могу получить данные даже через сайт http://irc.gov.ua/ua/Poshuk-v-YeDR.html
21. Iam Name (ru5) 25.09.12 16:34
Если известен только ИНН предприятия, обработка не ищет предприятие в реестре ГНАУ и получает пустой ответ.
и с поиском Физлиц в реестре ГНАУ тоже не что-то получается.
22. Александр Квачук (Shturman88) 26.09.12 09:49
При попытке получит данные, на форме где нужно вводить код, не отображается картинка.
Подскажите с чем это связано и как это можно решить?
23. Sergey Klymenko (sbklymenko) 06.10.12 11:29
При запуске обработки конфигурации Бухгалтерия для Украины выводится пустая форма без надписей и подписей кнопок.
24. Sergey Klymenko (sbklymenko) 06.10.12 11:29
25. Sergey Klymenko (sbklymenko) 06.10.12 11:45
В конфигураторе все открывается и все отлично, обработка очень полезная, еще-бы сканер капчи прикрутить в вообще будет СУПЕР :)
26. Ольга Lenn (LCLNN) 30.10.12 15:17
не могу получить данные с сайта ИРЦ, что случилось, как исправить? (:
27. RolexStrider 17.01.13 12:40
Сканер капчи для sts.gov.ua и irc.gov.ua существует и довольно успешно работает. Реализован в виде веб-сервиса. Детали реализации пока разглашать не буду. Скажу только что sts.gov.ua его эффективность порядка 70%, для irc.gov.ua - 95-97%. Больше подробностей - здесь: http://towcoder.blogspot.com В отличии, скажем, от этого решения в духе "а давайте помиллиона китайцев будут вбивать картинки, помогая наполнять нашу базу", у меня все по-честному, т.е. автоматическое распознавание символов. Пока веб-сервис находится в стадии закрытого бета-тестирования. Если есть идеи или предложения о сотрудничестве - пишите, буду рад пообщаться.

28. RolexStrider 17.01.13 12:54
И еще пара картинок для привлечения внимания:


29. Игорь Иваненко (ios4444) 07.02.13 14:52
Не работает с ИРЦ
Пишет "не знайдена інформація"
Хотя при наборе вручную на сайте все отлично видит
О горе-мне-горе :)
Такая отличная прога
30. Игорь Иваненко (ios4444) 07.02.13 15:30
а теперь еще и восьмерка зависает и откзывается работать при запуске "получить информацию" :(((((
31. Игорь Иваненко (ios4444) 12.02.13 12:33
Спасибки за обновление!!! Просто спасли
32. Iam Name (ru5) 12.02.13 13:29
Скачал обновленный файл от 11.02.13г. с сайта ЕГР информацию не может найти (может из-за изменений формата самого сайта ЕГР).
При запросе списком с www.vpp-odessa.gov.ua выдает слишком не актуальную инфомацию - нашел по двум предприятиям старые номера свидетельств.
Главное все-таки чтобы была информация с официальных источников. меня интересует с сайта ЕГР - можно исправить файл обработки, чтобы получать информацию
33. Iam Name (ru5) 12.02.13 15:30
Я еще раз перепроверил , Информацию с ЕГР эта обработка получает. Проблемы были с самим проверяемым предприятием.
А информация по плательщикам НДС - вообще непонятная у меня на руках свидетельство двух недельной давности - но на официальном сайте ГНАУ информация о том что действует старое свидетельство НДС.
Поэтому Спасибо за обработку.
34. Dmitriy (daho) 17.04.13 14:14
Ну вообще полезная штука... только задалбывает постоянно вводить графические символы.. нельзя ли это как-то обойти?
36. Александр Квачук (Shturman88) 18.09.13 11:10
В чем может быть проблема, не отображается картинка капчи?
37. Ольга Гуральник (gol12351) 30.01.14 15:58
Добрый день! Вопрос можно? Где обработка берет собственный прокси и порт ?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа