gifts2017

"Консолидация ПРОФ" - уровень точности

Опубликовал в раздел Программирование - Практика программирования

В конфиграции  "Консолидация" ПРОФ - уровень точности для каждой ячейки.

В конфиграции Конфигурация "Консолидация" ПРОФ устанавливается уровень точности для всей таблицы.
Видимо предполагалось использовать ее для тех областей, где точность явно не задана.
Фактически же, этот уровень точности применяется ко всей таблице.
Мне удалось избавиться от этого, несколько подправив модуль документа НастраиваемыйОтчет.
(Конфигурация "Консолидация" ПРОФ, ред. 1.3    1.3.4.1)

строки 8105 -8116 (Процедура ЗаполнитьПоказателиВМакете)
заменить на

 

СписокФорматов = ПолучитьСписокПараметровФормата(Обл.Формат);

Если СписокФорматов.Получить("ЧДЦ") = Неопределено Тогда Обл.ТипЗначения = ОписаниеТипов;

СписокФорматов = ПолучитьСписокПараметровФормата(Обл.Формат);

СписокФорматов.Вставить("ЧДЦ", Строка(УровеньТочности));

Если НЕ Стр.НеМасштабируется Тогда СписокФорматов.Вставить("ЧС", 0);

Обл.Значение = Стр.Значение / Делитель; Иначе Обл.Значение = Стр.Значение;

КонецЕсли; Обл.Формат = ПреобразоватьВСтрокуФормата(СписокФорматов);

КонецЕсли;

 

строку 8261 (Процедура ПрименитьПараметрыОтображения) заменить на

Если СписокПараметров.Получить("ЧДЦ") = Неопределено Тогда

СписокПараметров.Вставить("ЧДЦ", УровеньТочности);

КонецЕсли; 

 

 

Если необходимо изменить точность в расшифровках, надо проанализировать другие места, где встречается "ЧДЦ".

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Алексей Константинов (alexk-is) 23.09.10 06:24
Текст модуля в публикации можно раскрасить получше
2. Павел Кострома (minikos) 23.09.10 13:43