gifts2017

Сабклассинг главного окна 1С

Опубликовал Аркадий Кучер (Abadonna) в раздел Программирование - Внешние компоненты

Для разработчиков ВК. Дельфи.
Конкретные пацаны не будут , конечно же, использовать хуки-муки, а воспользуются всеми прелестями
сабклассинга :)

Материал из Википедии — свободной энциклопедии:

Сабклассинг — процесс переопределения оконной процедуры, которую Windows назначает по умолчанию.
Назначение технологии
Данная технология применяется в том случае, если требуется наделить окно какой-либо специфической реакцией на сообщение Windows. При помощи сабклассинга можно организовывать контроль ввода, блокировку закрытия окна. В целом самым важным здесь является то, что при необходимости программист получает полный контроль над поведением окна.
Преимущества сабклассинга
В Windows есть довольно богатый выбор элементов управления, однако вы можете столкнутся c ситуацией, когда нужно дополнить поведение элемента управления. И здесь есть затруднение: процедуру, которую Windows назначает элементу управления изменить саму по себе невозможно. Есть два пути:
Написать элемент управления заново
Воспользоваться возможностью переопределения оконной процедуры у данного элемента управления, что и является сабклассингом.
Недостатки первого подхода в том, что фактически программист вынужден заново «изобретать велосипед». Преимущество же сабклассинга в том, что он позволяет программисту сосредоточится только на действительно нужных ему Windows сообщениях, а остальные передать стандартной оконной процедуре.


Вот примерчик (из кода MiracleV8.dll ):

var Old1CWindowProc: Pointer;

function New1CWindowProc(WindowHandle: hWnd;
 
TheMessage: WParam;
 
ParamW: WParam;
 
ParamL: LParam): LongInt
{$IFDEF WIN32} stdcall;
{$ELSE}; export;
{$ENDIF}
var b: array[0..255] of AnsiChar;
begin
 
// анализируем сообщения
 // тут, к примеру, реакция на нажатие пункта меню
 
if TheMessage = WM_COMMAND then begin
   
// в ParamW - идентификатор пункта, в переменную b помещаем строковое значение пункта
   
GetMenuString(GetMenu(WindowHandle), ParamW, @b, 256, MF_BYCOMMAND);
   
// генерим внешнее событие для 1С
   
pEvent._AddRef;
   
pEvent.ExternalEvent('MiracleV8_1C', 'MENUSELECT', IntToStr(ParamW) + ',' + StrPas(b));
 
end;
 
if TheMessage = WM_WINDOWPOSCHANGING then begin
   
// тут отслеживаем (если надо) перестройку меню, в 7.7 оно постоянно меняется
   
pEvent._AddRef;
   
pEvent.ExternalEvent('MiracleV8_1C', 'MENURECREATE', IntToStr(ParamW));
 
end;
 
// в общем, что хотим - то и творим ;)
 // передаем управление родной оконной процедуре
 
New1CWindowProc := CallWindowProc(Old1CWindowProc, WindowHandle, TheMessage,
   
ParamW, ParamL);
end;

procedure TMiracleClass.SetNew1CWindowProc;
begin
 
// запоминаем указатель на родную оконную процедуру и переопределям на новую
 
Old1CWindowProc := Pointer(SetWindowLong(h1C, GWL_WNDPROC, LongInt(@New1CWindowProc)));
end;



Примечания:
h1C - хэндл главного окна 1С, полученный любым образом, например, через
интерфейс IExtWndsSupport.
pEvent - интерфейс IAsyncEvent
(оба описаны в ТСВК)

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Игорь Исхаков (Ish_2) 02.10.10 18:29
Черт возьми ! Знакомые буквы : "if ", "begin","end".
Смахнул слезу... Спасибо , Аркадий.
2. Аркадий Кучер (Abadonna) 02.10.10 18:30
(1) :D Однако, это не первая моя с такими словами ;)
Уже были
3. Игорь Исхаков (Ish_2) 02.10.10 18:40
(2) Ты бы лучше написал пример использования.
Вот мы открыли окно командой Форма.Открыть().
Каких 1с -овских возможностей нам не хватает , чтобы им управлять ?
Зачем мне это нужно
"При помощи сабклассинга можно организовывать контроль ввода, блокировку закрытия окна " ?
Ведь в "1с" есть соответсвующие события и обработчики к ним .
4. Аркадий Кучер (Abadonna) 02.10.10 18:49
(3) Вообще-то примерчики использования есть в описании к Miracle.
Например:
SetNewMDIWindowProc() переопределить основную оконную процедуру WindowProc для окна MDI
Примечание: ничего страшного! ;) после обработки в новой процедуре события WM_PARENTNOTIFY
вызывается старая (родная ) оконная процедура
Обработка события WM_PARENTNOTIFY позволяет отследить создание/разрушение форм.
Генерирует внешние события
Источник="MiracleV8_MDI"
Событие = "FormCreate" (рождение) или "FormDestroy" (смерть)
Данные: для FormCreate - хэндл новой формы,
для FormDestroy - заголовок формы и через запятую хэндл
Последовательность процедур при рождении формы:
ПередОткрытием() // 8.1
ПриОткрытии()
FormCreate // что-то вроде ПослеОткрытия()
Пример глобального контроля на любые формы (отчеты, обработки, журналы, документы...)
// ГМ
Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
Если Источник="MiracleV8_MDI" Тогда
ЗаписьЖурналаРегистрации(Событие+" "+Данные);
КонецЕсли;
КонецПроцедуры

Аналог ПослеОткрытия() на форме (8.1)
Процедура ВнешнееСобытие(Источник, Событие, Данные)
Если Событие="FormCreate" Тогда
L.SetTrackBar(Ширина-10,255);
L.TrackPosition(255);
КонецЕсли;
КонецПроцедуры

А именно примерчик из статьи используется для динамического создания в последней редакции библиотеки (не опубликовано) любого меню для 7.7 и получения реакции на него в программе.
P.S. А
При помощи сабклассинга можно организовывать контроль ввода, блокировку закрытия окна

не моё, а из Википедии ;)
Прикрепленные файлы:
5. Аркадий Кучер (Abadonna) 02.10.10 19:01
+(4) Добрый АЛьФ приделал к 7.7 своим формексом ПослеОткрытия(), а в 8x такой нема (бе-бе-бе)
6. Игорь Исхаков (Ish_2) 02.10.10 19:08
(3) Понятно. Но.
Ты пишешь :
Аналог ПослеОткрытия() на форме (8.1) 
Процедура ВнешнееСобытие(Источник, Событие, Данные) 
Если Событие="FormCreate" Тогда 
L.SetTrackBar(Ширина-10,255); 
L.TrackPosition(255); 
КонецЕсли; 
КонецПроцедуры 
...Показать Скрыть

Если я правильно понял в Данных сидит Handle и тогда :
Процедура ВнешнееСобытие(Источник, Событие, Данные)
Если Событие="FormCreate" Тогда
Данные.SetTrackBar(Ширина-10,255);
Данные.TrackPosition(255);
КонецЕсли;
КонецПроцедуры [/1C-CODE]
Так ? Иначе непонятно откуда взялся "L".

Слушай , как -то в обработке мне позарез нужно было узнать открыто в данный момент окно определенного документа или нет ? Это можно ?
7. Аркадий Кучер (Abadonna) 02.10.10 19:12
(6) L - это переменная класса библиотеки. Из тестовой базы.
Загрузка:
ЗагрузитьВнешнююКомпоненту(Путь+"MiracleV8.dll");
Примечание: первый раз 1С обязательно должна быть запущена с правами локального администратора (1С производит регистрацию в реестре)
Создание объекта:
8.1 L=ПолучитьCOMОбъект("","AddIn.MiracleClass");
7.7 L=СоздатьОбъект("AddIn.MiracleClass");
Примечание: L (или любая другая) - переменная для обращения к методам библиотеки.

Давай я тут не буду по новой про Miracle рассказывать? ;)
http://infostart.ru/public/59436/

8. Игорь Исхаков (Ish_2) 02.10.10 19:13
9. Аркадий Кучер (Abadonna) 03.10.10 12:24
Просто как приложение ни к селу, ни к городу ;)
Для Дельфи решил нарыть иконок/картинок из Общих в конфе 8.1
Прикрепленные файлы:
ВыгрузитьКартинки.zip
10. Ярослав Радкевич (WKBAPKA) 03.10.10 15:15
А что, разве для 8.1 можно перехватить handle главного окна? вернее, перехватить то можно, но внешними средствами, а в технологии ВК для 1С они убрали интерфейс работы с главным окном!
11. Аркадий Кучер (Abadonna) 03.10.10 15:21
(10) Уффф... у одного строковое dbf -поле больше 254 символа не читается восьмерочным XBase, другой говорит "убрали" :D
Метод GetAppMainFrame не убрали, остальные убрали.
Для 8.2 вообще по другому искать надо, но никакой проблемы в этом не вижу.
12. Ярослав Радкевич (WKBAPKA) 03.10.10 15:45
2(11): под 8-ку я ВК не писал, в описании к ВК 2.0 вычитал... получить главное окно можно и средствами WinAPI, а вот как затулить свою форму в рамки этого окна, в рамках технологии ВК от 1С, это уже вопрос!
13. Аркадий Кучер (Abadonna) 03.10.10 15:52
(12) Даже близко не вопрос ;)
Miracle же работает с формами и 7.7, и 8.1, и 8.2
в рамках технологии ВК от 1С

а на рамки их технологии я положил еще году в 2001-ом :D
14. Ярослав Радкевич (WKBAPKA) 03.10.10 16:00
15. Ярослав Радкевич (WKBAPKA) 03.10.10 23:15
2(13): ложить конешно можно на все что угодно, некоторые даже ложуть на жисть, тока плохо это кончается... как быть увереным, что при использовании данной ВК вдруг не выпрыгнет некий интересный глюк, в самый, что нинаесть не подходящый момент... и спросить то с не кого ;)
16. Аркадий Кучер (Abadonna) 04.10.10 03:08
(15)
. как быть увереным

Тогда срочно выброси formex, сpp, все душеловские. Они-то точно не в рамках, поэтому и компоненты, а не детские забавы.
17. dushelov (Душелов) 04.10.10 17:54
Ты мне скажи, мил человек, ты разрулил все таки 8-очный класс окна? Кнопки выковырял?
18. zavedeev (zavedeev) 06.10.10 17:17
Уважаемый, как показала практика лучше использовать хуки!!!
19. Аркадий Кучер (Abadonna) 06.10.10 17:20
(18) ЧЬЯ практика показала? Твоя, Гейтса, Ерохина Андрюхи?
20. zavedeev (zavedeev) 07.10.10 22:37
Abadonna, сначала научись уважать и слушать собеседника.
21. Аркадий Кучер (Abadonna) 08.10.10 03:20
(20)
1. А что было слушать? Безапелляционное заявление, что хуки лучше и амба?
2. Кого мне уважать, я сам решаю. А тут, извини, информации маловато:

zavedeev
Рейтинг: 0
Рейтинг за программы: 0
Рейтинг за статьи: 0

3. Я конкретно спросил, чей опыт показал, что хуки лучше? И что тут обидного? И Ерохина там не зря в пример привел: он активно использует и хуки, и сабклассинг. Равно, как и я.
22. Михаил Усков (MMF) 16.10.10 13:47
вообще говоря безграмотно писать
if TheMessage = XXX then begin
end;
if TheMessage = XXX then begin
end;
поскольку это ненужные проверки, это конструкция описывается Case-ом.
Далее, нормальной практикой вызова функций API, подобных GetMenuString, является два вызова - первый с длиной =0, далее - резервирование буфера под требуемую длину, и второй вызов - уже получение данных. А за такое как в статье более опытные товарищи отпускают шалбаны.
К тому же, если уж пишем типа "статья для новичков", то нужно написать про восстановление родной оконной процедуры
23. Аркадий Кучер (Abadonna) 17.10.10 10:14
(22)
вообще говоря безграмотно писать
if TheMessage = XXX then begin

Просто стоял сначала один if, потом понадобился второй, на case было лень переделывать.
то нужно написать про восстановление родной оконной процедуры

А
// запоминаем указатель на родную оконную процедуру и переопределям на новую

и
// передаем управление родной оконной процедуре

недостаточно?
является два вызова - первый с длиной =0, далее - резервирование буфера под требуемую длину, и второй вызов - уже получение данных.

Использование нединамического массива с запасом мне всегда нравилось, использовал и буду использовать! ;)
24. Михаил Усков (MMF) 17.10.10 22:45
недостаточно?

При уничтожении объекта компоненты адрес оконной процедуры указывает в небо. Это может привести к чему угодно, если оконная процедура успеет вызваться.
А насчет любви к статическим буферам, тут еще одна серьезная ошибка.
Читаем букварь (http://msdn.microsoft.com/en-us/library/ms647983(VS.85).aspx)
nMaxCount [in] The maximum length, in characters, of the string to be copied.
If the string is as long or longer than lpString, the string is truncated and the terminating null character is added.
Вопрос: где в памяти будет размещаться терминирующий ноль, если строка меню длинее или равна 256 символов (а буфер у нас только на 256)? Такую глюкотину сложно искать и легко предотвратить, если сразу писать некривой код.
25. Михаил Усков (MMF) 17.10.10 22:48
Под восстановлением оконной процедуры я имел ввиду возврат на место
SetWindowLong(h1C, GWL_WNDPROC, Old1CWindowProc) при разрушении компоненты
27. zag2art (zag2art) 20.11.10 14:27
Спасибо, использовал в своей ВК.
28. Владимир (hogik) 01.01.12 19:13
(0)
Аркадий.
Решил я вспомнить детство. ;-) Попробовать перехват клавиши Esc (прерывание "выполнения") таким способом в ВК для "1С 7.7". В сути методики, вопрос восстановления "родного" адреса оконной процедуры - дребезжит. Думаю, есть шанс восстановить НЕЧТО, если в сеансе 1С-а "кто-то" еще пользуется аналогичным методом. Но, это можно отследить и/или заменять/восстанавливать адрес не на всё время "жизни" ВК. А, вот, нажатие Esc у меня не получается отследить. Не могу понять... :-( Последовательность сообщений в окно поступает, мне мало понятная. Может в окно, полученное через "интерфейс IExtWndsSupport"(с), это сообщение не доходит (грубо говоря)?
Извини меня, пожалуйста, за глупый мой вопрос. Не специалист я по взламыванию "форточек". ;-) Ткни, пожалуйста, пальцем - где копать. Если на это у тебя уйдет твоего времени не более одной минуты...
29. Аркадий Кучер (Abadonna) 02.01.12 07:02
(28)
Ткни, пожалуйста, пальцем - где копать.

__________________________________
"Воровать ничего не надо, всё уже украдено до вас" ©"Операция Ы" ;)
//...............
L.KbdHook();
Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
Если Источник="MiracleV8_KbdHook" Тогда

Если Событие="KEYDOWN" Тогда
Сообщить("Нажата клавиша с кодом "+Данные);
КонецЕсли;
Если Событие="KEYUP" Тогда
Сообщить("Отпущена клавиша с кодом "+Данные);
КонецЕсли;
КонецЕсли;
КонецПроцедуры
---------------------------------------
function KeyboardProc(code: integer; wParam: word; lParam: longint): longint; stdcall;
begin
if lParam < 0 then begin
pEvent._AddRef;
pEvent.CleanBuffer;
pEvent.ExternalEvent('MiracleV8_KbdHook', 'KEYUP', IntToStr(wParam));
end
else begin
pEvent._AddRef;
pEvent.CleanBuffer;
pEvent.ExternalEvent('MiracleV8_KbdHook', 'KEYDOWN', IntToStr(wParam));
end;
Result := 0;
end;

function TMiracleClass.KbdHook: Integer;
var ThrID, PrID: DWORD;
begin
if KbrdHook > 0 then begin
ShowMessage('Hook уже установлен');
RESULT := KbrdHook;
exit;
end;
ThrID := GetWindowThreadProcessId(h1C, PrID);
KbrdHook := SetWindowsHookEx(WH_KEYBOARD, @KeyboardProc, 0, ThrID);
RESULT := KbrdHook;
end;
Прикрепленные файлы:
30. Владимир (hogik) 02.01.12 17:03
(29)

"всё уже украдено до вас"(с)
Это - точно! :-)

L.KbdHook();
{Обработка.новый1.ФФорма.Модуль(2)}: Поле агрегатного объекта не обнаружено (KbdHook)

Тренировался вот на этих кошечках: http://infostart.ru/public/59436/

Аркадий.
Что касается текста на пасЦале, это понятно и полному ... , т.е. - мне. :-)
Но, я пробовал подобный прием в коне прошлого века. ;-) Тогда у меня не получилось...
Надо было перехватить (блокировать) в момент выполнения, например, такого цикла:
Для Н=1 По 1000000 Цикл
Состояние(Н);
КонецЦикла;
Тогда ОНО у меня не получилось "твоим" способом. Я решил, что проблема во мне. ;-) И завязал с этим способом. Нашёл другое решение... Очень хлопотное. :-( Вот решил вернуться к этой "проблеме" через "Сабклассинг главного окна 1С".
Потрать, пожалуйста, еще одну минутку на меня. ;-)
Проверь в твоей ВК отлов прерывания в моём примере цикла. Надеюсь, что на твоём ПК в твоей ВК еще не украли метод KbdHook(). Если ловит, тогда я буду упираться в "твою" методу перехвата уже в своей ВК. Может я за десять лет поумнел, и у меня теперь получится... ;-)
31. Аркадий Кучер (Abadonna) 04.01.12 07:03
(30)
Тренировался вот на этих кошечках: http://infostart.ru/public/59436/

Качать надо с сайта автора, а не где попало :)))
В цикла, да еще для MDI-ного приложения никакие хуки не прокатят. В цикле главному окну WM_KEYDOWN не приходит вообще. Перед появлением окошка 1С "Прервать...?" приходит сообщение WM_WINDOWPOSCHANGING (как раз потому что позиция главного окна в Z-ордере будет меняться). Вот тут (и достаточно через ж...) надо гасить модальное окно 1С. Другого способа пока не вижу.
Прикрепленные файлы:
32. Владимир (hogik) 04.01.12 16:17
(31)
Аркадий.
Огромное тебе спасибо за участие в моих бедах. ;-)
Буду пробовать погрузиться в проблему указанным тобой направлением - через ж...
Странно, что за всё время существование "семерки" не появилось решение этой "проблемы". Точнее, есть одна ВК. Пробовал. Были проблемы. Отказался от её использования...
33. Аркадий Кучер (Abadonna) 04.01.12 20:27
(32) Лови. Через ж, но работает безотказно
Прикрепленные файлы:
MiracleV8_NoBreak.rar
34. Владимир (hogik) 04.01.12 22:30
(33)
Аркадий.
Как с тобой скучно... ;-) Всё ты знаешь, всё - можешь. :-(
По сути - что надо. А по жизни - у меня возникают вот такие смешные последовательности:
Процедура Сформировать()
L.SetNew1CWindowProc();
L.SetNew1CWindowProc();
До=100000;
Для А=1 По До Цикл
Состояние(""+А+ " из "+До);
КонецЦикла;
L.RestoreMainProg();
L.RestoreMainProg();
L.RestoreMainProg();
КонецПроцедуры
Т.е. требуется четко отслеживать "парность" вызовов. Если включена блокировка - не включать её еще раз. Аналогично, при отключении блокировки. Отслеживать это глобальной переменной не есть хорошо. Юзера успевают нажать Esc между операторами включения признака и самой сутью алгоритма. ;-) Именно на это я и напоролся в своем (теперешнем) алгоритме "логического отслеживания" нажатия клавиши Esc. Еще важный момент - блокировка может выполниться в одной диалоговой форме (грубо говоря), а отмениться в другой. Такие ситуации отработают нормально?
P.S. Кусочком текста этой методики на пасЦале, поделишься?
35. Аркадий Кучер (Abadonna) 04.01.12 22:31
(34) уже сделал красиво... доточу - сообщу
36. Аркадий Кучер (Abadonna) 04.01.12 23:59
(34) Качай Miracle2.1.3.13
Все оказалось проще, без сабклассингов
37. Владимир (hogik) 05.01.12 02:38
(36)
Аркадий.
Огромное тебе спасибо!
P.S. Очень хоЦа узнать метОду... ;-)
38. Аркадий Кучер (Abadonna) 05.01.12 02:40
(37)
P.S. Очень хоЦа узнать метОду... ;-)

Тогда и общайся, где положено ;)
На Инфостарте я не склонен больше ничего публиковать
39. Владимир (hogik) 05.01.12 02:57
(38)
Мой вопрос и туда положено... ;-)
40. Аркадий Кучер (Abadonna) 05.01.12 02:58
(39) Там я тебе в личку и написал. Ежели еще вопросы - туда же
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа