IE2017

Договор возмездного оказания услуг + акт сдачи-приемки услуг для ЗУП 2.5

Печать - Печатные формы документов

Договор возмездного оказания услуг + акт сдачи-приемки услуг для ЗУП 2.5
Есть авторегистрация. Печатается из документа "ДоговорНаВыполнениеРаботСФизЛицом".

Договор возмездного оказания услуг + акт сдачи-приемки услуг для ЗУП 2.5
Есть авторегистрация. Печатается из документа "ДоговорНаВыполнениеРаботСФизЛицом".

Наименование услуги берется из поля "Комментарий".

P.S.: Сделано на базе Внешние печ. формы для ЗУП 2.5.20.3

Скачать файлы

Наименование Файл Версия Размер
DogovorVUS.rar
.rar 13,87Kb
07.10.10
169
.rar 13,87Kb 169 Скачать

См. также

Комментарии
1. МagIvan (RailMen) 12.10.10 01:07 Сейчас в теме
Обычная работа. Твердый середняк.

Понравилось:
1) Параметры авторегистрации
2) модуль формы, сама формы - идеально
3) инструкции препроцессору в модуле объекта :
#Если Клиент Тогда
Функция Печать() Экспорт
...
#КонецЕсли


Есть несколько замечаний:
1) почему макеты не MSWord (OpenOffice)? Неужели ваши бухи не хранят электронные копии?
2) ЗАЧЕМ в Функция СформироватьЗапросДляПечатиТрудовогоДоговора()
два раза строка
Запрос.Выполнить(); //36 и 84
????
Почему первый запрос вместо МенеджерВременныхТаблиц просто не сделать пакетом??? Это копипаст типовой, не так ли?
3) Функция ПолучитьНомерТрудовогоДоговора() Экспорт
- так и вообще шедевр ))))
Позволю себе процитировать:

Запрос.Текст = ТекстЗапроса;
Если Запрос.Выполнить().Пустой() Тогда
Возврат СсылкаНаОбъект.Организация.Префикс + "0000001";
Иначе
СтрокаРезультата = Запрос.Выполнить().Выгрузить()[0];
Если НЕ ЗначениеЗаполнено(СтрокаРезультата.НомерДок) Тогда
Возврат СсылкаНаОбъект.Организация.Префикс + "0000001";
Иначе
Возврат ПроцедурыУправленияПерсоналом.ПолучитьСледующийНомер(СокрП(СтрокаРезультата.НомерДок));
КонецЕсли;
КонецЕсли;

Ты 2 раза выполняешь запрос:
первый раз в условии: Если Запрос.Выполнить().Пустой() Тогда
и второй раз: СтрокаРезультата = Запрос.Выполнить().Выгрузить()[0]; - это конечно перл!!!

А что есть у организации нет префикса? Что тогда вернется???

- а теперь самое главное:
Процедура ПроверитьНомерТрудовогоДоговора(НачальнаяДатаДокумента) Экспорт
и
Функция ПолучитьНомерТрудовогоДоговора() Экспорт
не вызываются НИГДЕ!!! Тогда зачем ОНИ??? Их забыли удалить после копипаста или забыли вызвать?

- почему параметры макета заполняются конструкциями "через точку" ???
Макет.Параметры.ИНН_ФЛ = СсылкаНаОбъект.Физлицо.ИНН;
Макет.Параметры.ПФР_ФЛ = СсылкаНаОбъект.Физлицо.СтраховойНомерПФР;
Каждая такая строка трассируется как отдельный запрос в базе. Это не правильно.

- почему бы тебе вместо неоптимального вызова типовой неоптимальной функции
СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Выборка.НазваниеОрганизации, СсылкаНаОбъект.Дата);
не написать свой запрос к РС КонтактнаяИнформация???

P.S. Это бесплатная и неплохая резензия. Надеюсь автор ее оценит.
alex1976alex; +1 Ответить
2. Алексей Авраменко (alex1976alex) 24 16.10.10 22:47 Сейчас в теме
На комментарий к "Договор возмездного оказания услуг + акт сдачи-приемки услуг для ЗУП 2.5"

Спасибо за оценку.

>Есть несколько замечаний:
>1) почему макеты не MSWord (OpenOffice)? Неужели ваши бухи не хранят электронные копии?

К сожалению, я не программист 1С, а бухгалтер с некоторыми навыками программирования. Как сделать макет в Ворде очень плохо себе представляю :(

>2) ЗАЧЕМ в Функция >СформироватьЗапросДляПечатиТрудовогоДоговора()
>два раза строка
>Запрос.Выполнить(); //36 и 84
>????
>Почему первый запрос вместо МенеджерВременныхТаблиц просто не >сделать пакетом??? Это копипаст типовой, не так ли?

Работа с запросами для меня вообще тёмный лес.

>3) Функция ПолучитьНомерТрудовогоДоговора() Экспорт
>- так и вообще шедевр ))))
>Позволю себе процитировать:
>
>Запрос.Текст = ТекстЗапроса;
>Если Запрос.Выполнить().Пустой() Тогда
>Возврат СсылкаНаОбъект.Организация.Префикс + "0000001";
>Иначе
>СтрокаРезультата = Запрос.Выполнить().Выгрузить()[0];
>Если НЕ ЗначениеЗаполнено(СтрокаРезультата.НомерДок) Тогда
>Возврат СсылкаНаОбъект.Организация.Префикс + "0000001";
>Иначе
>Возврат >ПроцедурыУправленияПерсоналом.ПолучитьСледующийНомер(СокрП(>СтрокаРезультата.НомерДок));
>КонецЕсли;
>КонецЕсли;

>Ты 2 раза выполняешь запрос:
>первый раз в условии: Если Запрос.Выполнить().Пустой() Тогда
>и второй раз: СтрокаРезультата = >Запрос.Выполнить().Выгрузить()[0]; - это конечно перл!!!

Я как та собака, смотрю умными глазами, но сказать нечего не могу :oops:

>А что есть у организации нет префикса? Что тогда вернется???
Понятие префикса у организации для меня весьма туманно :-(

>- а теперь самое главное:
>Процедура >ПроверитьНомерТрудовогоДоговора(НачальнаяДатаДокумента) >Экспорт

>Функция ПолучитьНомерТрудовогоДоговора() Экспорт
>не вызываются НИГДЕ!!! Тогда зачем ОНИ??? Их забыли удалить >после копипаста или забыли вызвать?

Не стал удалять на всякий случай, вдруг это чем-нить чревато.

>- почему параметры макета заполняются конструкциями "через точку" ???
>Макет.Параметры.ИНН_ФЛ = СсылкаНаОбъект.Физлицо.ИНН;
>Макет.Параметры.ПФР_ФЛ = >СсылкаНаОбъект.Физлицо.СтраховойНомерПФР;
>Каждая такая строка трассируется как отдельный запрос в базе. Это >не правильно.

>- почему бы тебе вместо неоптимального вызова типовой >неоптимальной функции
>СведенияОбОрганизации = >УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Выборка.>НазваниеОрганизации, СсылкаНаОбъект.Дата);
>не написать свой запрос к РС КонтактнаяИнформация???

Еще бы где-нибудь толково было написано про эти запросы, как с ними работать, а то единственный способ для меня скопировать чужое и поправить :-(


>P.S. Это бесплатная и неплохая резензия. Надеюсь автор ее оценит.
Спасибо за рецензию, будем стараться.
3. ULAS SV (ulas) 05.10.11 22:43 Сейчас в теме
Для 8.1 пришлось переделывать. Но форма хорошая
4. Маргарита Гаманюкова (ritavg) 25.01.12 04:10 Сейчас в теме
Спасибо за обработку. Приходилась в ворде набирать акт вручную.
6. Женя Волкова (Jen) 23.01.14 15:02 Сейчас в теме
Пригодилось, но пришлось подправить по совету http://forum.infostart.ru/forum26/topic84068/message888240/#message888240
ФИО = ОбщегоНазначенияЗК.РазложитьСтрокуВМассивПодстрок(...

Поскольку не находил метод))
7. Наталья (valya977) 4 30.12.14 00:47 Сейчас в теме
Значение не является значением объектного типа (Пол)
Оставьте свое сообщение