gifts2017

Экспорт встроенных XML-схем описаний типов 1С:Предприятия

Опубликовал Дмитрий Иванчура (Dmitryiv) в раздел Программирование - Практика программирования

Экспорт встроенных XML-схем описаний типов 1С:Предприятия

Предыстория:

Как-то писал обмен между разношерстными конфигурациями на платформе 8.1 на базе XML. Разбор-построение XML-файла обмена делалось по схемам (использовался механизм XDTO). И возникла необходимость при разработке схем иметь под рукой полное описание встроенных типов 1С, которые сериализуются через XDTO, дабы импортировать их в свои схемы. Вот и написал небольшой код для выгрузки встроенных схем в отдельные XSD-файлы. Может кому-то понадобится. XSD-файлы прилагаются.

Собственно код:

    Для Каждого Пакет из ФабрикаXDTO.Пакеты Цикл
        Если Пакет.URIПространстваИмен = "http://www.w3.org/2001/XMLSchema" Тогда
            Продолжить;
        КонецЕсли;   
        НаборСхем = ФабрикаXDTO.ЭкспортСхемыXML(Пакет.URIПространстваИмен);
        Для Счетчик = 0 по НаборСхем.Количество() - 1 Цикл
            Схема = НаборСхем.Получить(Счетчик);
            Схема.ОбновитьЭлементDOM();
            ЗаписьDOM = Новый ЗаписьDOM;
            ЗаписьXMLСтрока = Новый ЗаписьXML;
            ЗаписьXMLСтрока.УстановитьСтроку();
            ЗаписьXMLФайл = Новый ЗаписьXML;
            ЗаписьDOM.Записать(Схема.ДокументDOM, ЗаписьXMLСтрока);
            ЗаписьXMLФайл.ОткрытьФайл(ИмяФайла + "[" + Формат(Счетчик,"ЧЦ=10;ЧГ=0;ЧН=") + "].xsd");
            ЗаписьXMLФайл.ЗаписатьБезОбработки(ЗаписьXMLСтрока.Закрыть());
            ЗаписьXMLФайл.Закрыть()
        КонецЦикла;   
    КонецЦикла;

Скачать файлы

Наименование Файл Версия Размер
Схемы 8.1 59
.zip 16,72Kb
28.05.15
59
.zip 16,72Kb Бесплатно
Схемы 8.2 57
.zip 38,70Kb
28.05.15
57
.zip 38,70Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Vlada (Davlad_A) 08.11.10 10:17
Дмитрий, ваш материал может быть очень полезен!!
Однако без пошаговой инструкции "для чайников" разобраться сложно, хотя очень бы нужно. Если вам удастся добавить описание к данному виду интеграции "разношерстных" ИС, думаю, от многих будет немалый респект.
Вобщем, плюсуем с надеждой на продолжение :) ...
2. Владимир Самойлов (samamoiloff) 04.06.12 12:25
3. Александр Катков (katkov_a) 17.05.16 13:54
Спасибо!
Чёрт, как же меня мучил вопрос: как из СхемыXML XSD вытащить.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа