gifts2017

Использование "характеристик" в УТ редакции 10.х

Опубликовал Евгений Стоянов (quick) в раздел Программирование - Практика программирования

Бывают ситуации когда необходимо учитывать по одним и тем же характеристикам практически всю номенклатуру, но заполнять для каждой позиции характеристику ... занятие не для слабонервных.
В этой статье примеры того как можно это сделать очень быстро.

Сразу к делу

Цель:

1. Заполнить характеристики номенклатуру по какому нибудь типовому списку.
2. Строить отчеты в разрезе этих характеристик.

Решение:

1. Простановка характеристик
Используя типовую обработку из ИТС UNIREPS81\UniversalSelection\УниверсальныеПодборИОбработкаОбъектов.epf 
Делаю выборку номенклатуры, потом на закладке "Обработки" клацаю по "Произвольный алгоритм"

и добавляю след. код

 

Сорта = Новый Массив;
Сорта.Добавить("Сорт-1");
Сорта.Добавить("Сорт-2");
Сорта.Добавить("Сорт-3");
Сорта.Добавить("Сорт-СО");
СписокСортов=Новый Соответствие;
Для Каждого сорт из Сорта Цикл
	СписокСортов.Вставить(сорт,1);
КонецЦикла;
Хар = Справочники.ХарактеристикиНоменклатуры.Выбрать(,Объект.Ссылка);
Сообщить("Хар-"+ТипЗнч(Хар));
Пока Хар.Следующий() Цикл
	О = Хар.ПолучитьОбъект();
	Сообщить(СокрЛП(О)+" Тип:"+ТипЗнч(О));
	СписокСортов[СокрЛП(О)]=0;
КонецЦикла;

Хар = Справочники.ХарактеристикиНоменклатуры;
Для Каждого сорт из Сорта Цикл
	Если СписокСортов[сорт]=1 Тогда
		Сообщить("Создать:"+сорт);
		НовХар=Хар.СоздатьЭлемент();
		НовХар.Наименование = сорт;
		НовХар.Владелец = Объект.Ссылка;
		НовХар.Записать();
	КонецЕсли;
КонецЦикла;
Если Объект.ВестиУчетПоХарактеристикам=Ложь Тогда
	Объект.ВестиУчетПоХарактеристикам = Истина;
	Объект.Записать();
КонецЕсли;

Здесь Сорт-1, Сорт-2... это список характеристик общий для всех позиций. Его вы формируете на свое усмотрение.

2. Отчеты

В отличии от редакции УТ11, где можно характеристика может быть привязана к виду номенклатуры, в УТ10 каждая характеристика привязывается к позиции номенклатуры. Поэтому выбрав в отчете детализацию по характеристике вы получите что то типа этого:

Сорт1
  Товар 1
Сорт1
  Товар 2

Что бы отчет выглядел нормально, надо установить в детализации ХарактеристикиНоменклатуры.Наименование и вы получите необходимую картину

Сорт1
  Товар 1
  Товар 2

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Зубцов (iov) 03.11.10 22:28
(0) Скачать "УниверсальныеПодборИОбработкаОбъектов.epf (8.1)" для 1С
Файл не найден или был удален
2. Евгений Стоянов (quick) 04.11.10 10:03
3. Сергей Ожерельев (Поручик) 05.11.10 17:19
(2) А нахрена заливать штатную обработку с ИТС, нарушать авторские права 1С?
Если у кого её нет, это их проблемы.
4. Аркадий Кучер (Abadonna) 06.11.10 19:53
Автор, прочти (3) и прибей файлы с ИТС! А то жаль снимать с публикации, алгоритм-то не виноват ;)
5. Евгений Стоянов (quick) 06.11.10 23:04
Готово! Ищите товарищи обработки на ИТС. :)
6. Сергей Иванов (Lokon) 08.02.12 06:24
Да, это правда! использование характеристик упрощает справочник, но осложняет приходование... Хотя количество ошибок при любом методе остается одинаковым,тут уж как посмотреть... Но в любом случаебольшое спасибо за подсказку и наработку обработки :-)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа