gifts2017

ПрогрессБар отдельной формой

Опубликовал Игорь Высоковских (via) в раздел Программирование - Работа с интерфейсом

ПрогрессБар отдельной формой. Со "статистикой" (без ВК)

 

В Глобальный модуль вставить процедуру:

 

 

//*****************************************************************************

Процедура глПрогрессБар(Сейчас=0,Всего=0) Экспорт

Попытка

Если Всего>0 Тогда

Если ПустоеЗначение(глКонтПрогрессБар)=0 Тогда

глКонтПрогрессБар.Сейчас=Сейчас;

глКонтПрогрессБар.Всего=Всего;

глКонтПрогрессБар.Форма.Обновить();

КонецЕсли;

Иначе

Если ТипЗначенияСтр(Сейчас)="Строка" Тогда

ОткрытьФорму("Обработка.ПрогрессБар",глКонтПрогрессБар);

глКонтПрогрессБар.Форма.Заголовок(Сейчас);

Иначе

Если ПустоеЗначение(глКонтПрогрессБар)=0 Тогда

глКонтПрогрессБар.Форма.Закрыть();

КонецЕсли;

КонецЕсли;

КонецЕсли;

Исключение

КонецПопытки;

КонецПроцедуры

 

... Ну и Обработку "ПрогрессБар"

 

И пользовать.. Вот пример:

 

глПрогрессБар("Тест ПрогрессБара...");

Для ин=1 По 10000 Цикл

глПрогрессБар(ин,10000);

КонецЦикла;

глПрогрессБар();

 

Скачать файлы

Наименование Файл Версия Размер
ПрогрессБар.ert 19
.ert 49,00Kb
13.02.12
19
.ert 49,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Игорь Высоковских (via) 19.11.10 13:24
! Обратите внимание на бегающие часики
2. alex_merfi (alex_merfi) 24.11.10 08:26
3. Никитин Д.В. (DeniNikitin) 30.11.10 12:07
А файл конечно выкладывать не надо!!!
4. romanuil romanuil (romanuil) 11.02.12 15:44
5. Игорь Высоковских (via) 13.02.12 10:44
6. romanuil romanuil (romanuil) 13.02.12 13:02
О, появилось. Оперативно!
Осталось поднять свой рейтинг больше 50

:(
7. Ruslan (flash82) 16.02.12 08:12
классно давно искал что то подобное спасибо и конечно +
8. Игорь Высоковских (via) 16.02.12 09:29
Такую форму прогрессбара (в отличие от прогрессбара в строке состояния) можно использовать, например, при перепроведении документов (т.к. строка состояния там всякой лабудой забивается)
9. Алексей (Rockman) 14.03.12 16:01
10. Павел Никифоров (Lyns_owner) 14.12.12 17:35
(1) via, Очередной изобретатель велосипеда)

В общих формах в типовых решениях "ХодВыполненияОбработкиДанных", не?

11. Игорь Высоковских (via) 17.12.12 12:00
(10) Lyns_owner, Когда я это делал - делал в 7-ке (в 8-ку не смотрел)... Когда потом (в свое время) мне такое же понадобилось в 8-ке - увидел, что там уже такое есть (причем как оказалось очень похоже реализовано). В данном случае это как раз для 7-ки было выложено.
12. Павел Никифоров (Lyns_owner) 17.12.12 13:09
(11) via, Не заметил, что для 7.7, убрал минус.
13. Dmitry Vidmanov (etmarket) 15.12.14 00:10
А где изображение прогресс бара? Неясно, стоит ли тратить СМ...
14. Игорь Высоковских (via) 15.12.14 10:30
(13) etmarket, Да вроде как видно же.. Мелковато, конечно, но общее представление даёт.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа