gifts2017

Параметры сеанса произвольного типа

Опубликовал direktorSan (direktorSan) в раздел Программирование - Практика программирования

При создании параметра сеанса конфигураци выбор типа ограничен весьма небольшим списком: примитивные типы, ссылочные типы, фиксированные коллекции, системные перечисления, NULL, хранилище значения, уникальный идентификатор, характеристики и описание типов.
Но в версии 8.2 платформы появилась возможность создать параметр сеанса произвольного типа!

Итак.

Как это делается.

Дано: необходимо в некой конфигурации реализовать вычисление времени с точностью до миллисекунды.

Один из способов решения: для вычисления времени с заданной точностью применим ява скрипт.

Инициализацию скрипта опишем в функции:

Функция ПолучитьЯваСкрипт() ЭКСПОРТ

    ЯваСкрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
    ЯваСкрипт.Language = "JavaScript";

    Возврат
ЯваСкрипт;

КонецФункции

Функцию опишем в общем модуле ДополнительныеПараметрыСенаса.

И вот теперь самое главное: у этого модуля установим свойство "Повторное использование возвращаемых значений" в значение "На время сеанса"!

 

Что нам это дает?

Давайте посмотрим на два замера производительности.

Первый замер сделан с использованием непосредственного создания COM-объекта в цикле из 10 тыс. итераций.

Производилось это в функции ВернутьТочноеВремя_Простая():

Функция ВернутьТочноеВремя_Простая() ЭКСПОРТ

   
ЯваСкрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
   
ЯваСкрипт.Language = "JavaScript";

    Возврат
ЯваСкрипт.Eval("new Date().valueOf()");

КонецФункции
// ВернутьТочноеВремя_Простая()

Как видим основное время - 72% - заняло создание нового экземпляра COM-объекта. И это создание происходило 10 тыс. раз!

 

Теперь давайте посмотрим на замеры функции из созданного нами модуля:

Функция ВернутьТочноеВремя() ЭКСПОРТ

   
ЯваСкрипт = ДополнительныеПараметрыСеанса.ПолучитьЯваСкрипт();

    Возврат
ЯваСкрипт.Eval("new Date().valueOf()");

КонецФункции
// ВернутьТочноеВремя()

Как видим здесь расклад уже иной - наиболее затратной операцией явилась операция вычисления точного времени!

Создание же COM-объекта происходило всего лишь один раз при самом первом вызове функции!

Давайте теперь посчитаем выигрыш в скорости - код с кэшированием возвращаемых значений отработал в 45 раз быстрее!

(При тестировании на циклах в 100 тыс. итераций этот показатель был скромнее - 38 раз. Но по времени выполнения эти 38 раз были ощутимы - 17 секунд против 643 секунд!)

Уверен, что вы уже поняли, какие возможности сулит данная технология - создание и использование параметров сеанса практически произвольных типов практически во всех видах клиентов.

На этом все!

Удачи!

 

P.S. Утверждение про все виды клиентов основано только на результатах проверки конфигурации со всеми выставленными флагами синтаксического контроля. Реально действие технологии проверялось, увы, только в толстом клиенте. Cry 

P.P.S. Буду признателен всем пользователям портала, которые протестируют данную технологию в других клиентах и сообщат о результатах

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Старых (tormozit) 30.11.10 00:14
Считаю, акцент на параметрах сеанса сделан неверно. ПараметрыСеанса имеют ключевую особенность - они автоматически синхронизируются между клиентским контекстном сеанса и серверным. А в данной статье продемонстрировано свойство неглобального общего модуля "Повторное использование возвращаемых значений".
2. Андрей Д. (detec) 30.11.10 09:57
Ещё можно сохранять COM-объекты во временном хранилище. Тут уже были публикации на эту тему. Пример реализации:

&НаСервере
Функция СоздатьИСохранитьComОбъект(ИмяCOMОбъекта, УИДФормы, ПоИмениФайла = Ложь)

Если ПоИмениФайла Тогда
Обработчик = ПолучитьCOMОбъект(ИмяCOMОбъекта);
Иначе
Обработчик = Новый COMОбъект(ИмяCOMОбъекта);
КонецЕсли;



АдресCOMОбъекта = ПоместитьВоВременноеХранилище(Обработчик, УИДФормы);
Возврат АдресCOMОбъекта;
КонецФункции


На управляемую форму кидаем реквизиты с типом строка, куда записываются адреса сохранённых COM-объектов. И потом мы их функциями дёргаем, например:



&НаСервере
Функция ВернутьРеестр()

Возврат ПолучитьИзВременногоХранилища(АдресРеестра);

КонецФункции // ВернутьРеестр()
3. direktorSan (direktorSan) 30.11.10 09:59
(1)
Говоря об автоматической синхронизации - что Вы имеете в виду?
Поясню вопрос.
Выдержка из ИТС от сентября 2010г.: "В клиент-серверном варианте 1С:Предприятия значения параметров сеанса хранятся на сервере и доступны как с сервера, так и с клиента".
Т.е., как я понимаю, в данном режиме работы обращение к параметрам сеанса = обращению к серверу за значением соответствующего именованного параметра.

Но кроме клиент-серверного режима работы есть еще и другие режимы.
Но вообще, опять же выдержка из ИТС: "Кроме того, они могут использоваться в конфигурациях и для других целей, когда необходимо хранить информацию, характеризующую сеанс 1С:Предприятия".

Т.е. параметр сеанса - это характеристика текущего сеанса работы - будь то на сервере, на толстом клиенте или при внешнем соединении.

А COM-объект, созданный в текущем сеансе работы - разве не может являться такой характеристикой?
И то, что этот COM-объект не виден серверу в клиент-серверном режиме работы, на мой взгляд, нисколько неуменьшает его значимости как некоего локального дополнительного параметра сеанса.

В одном с Вами соглашусь - параметры сеанса это объект метаданных и за их использованием 1С:Предприятие осуществляет повышенный контроль.
Такого контроля в случае использования неглобального модуля, возвращаемые значения функций которого кэшируются на время сеанса, скорее всего просто нет.
4. mailrum2004 05.04.12 16:55
Исключать повторные создания COM-объектов - это хороший подход к увеличению производительности.
При измерении времени с помощью ЯваСкрипт.Eval("(new Date()).valueOf()") нужно понимать, что полученные значения идут с шагом 15-16, т.е. точность измерения времени 0.015 - 0.016 секунды.
5. Fomix (fomix) 15.06.12 17:15
(3) direktorSan, Действительно спорное название публикации, т.к. приведенный пример свойства "повторного использования на время сеанса" больше похож на рекурсию... А как в общем влияет это свойство на поведение всего модуля, если кроме подобной функции туда вставить другие процедуры и функции?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа