gifts2017

Удаление вспомогательных данных 1С 8

Опубликовал Ilya Baykov (Ilyabaykov) в раздел Администрирование - Сервисные утилиты

Простой способ удалить старые временные файлы 1С из каталогов \Application Data\1C и \Local Settings\Application Data\1C

Во время свой работы 1С 8 создает достаточное количество временных файлов, в них хранятся пользовательские настройки настройки фильтров форм, параметры подключения к хранилищу и прочее. Все-бы ничего, но когда удаляешь базу все эти файлы остаются. Это не проблема для пользователей, но при активной разработке, когда постоянно создаешь новые и удаляешь уже не нужные базы объем этого баласта может стать достаточно большим. Удалять все временные данные без разбору - не хочется, потому как там хранятся в том числе кэш хранилища и параметры подключения. Для себя написал обработку, и решил поделиться ею с вами :) Она ищет все временные файлы 1С потом пытается связать эти данные с зарегистрированными у пользователя базами.

Есть возможность удалить данные по конкретной базе, или все бесхозные данные. Работает со всеми версиями 1С 8, запускается под 8.2, обычная форма.

Протестировано под WinXP и Win 7.

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Обработка
.epf 14,58Kb
13.02.11
254
.epf 14,58Kb 254 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Ilya Baykov (Ilyabaykov) 11.02.11 21:03
Сорь, сначала выложил кривую версию, удаление не работало. Обновил.
У таб. части надо установить признак "ИзменятьСоставСтрок"
2. Erne100 (Erne100) 13.02.11 01:07
Вывалилась по ошибке при заполнении:
{ВнешняяОбработка.ОчисткаДискаОтСохраненныхДанных1С.МодульОбъекта(147)}: Итератор для значения не определен
Для каждого СтрТаб из Таб цикл

с сообщением:
Файла C:\Documents and Settings\я\Application Data\1C\1Cv8\v8ib.lst не существует!
3. Erne100 (Erne100) 13.02.11 01:16
Ну нет у меня на этой машине ни одной базы на 8.0
4. Erne100 (Erne100) 13.02.11 02:01
Добавил себе отбор:

Процедура ВыполнитьПоиск() Экспорт
	НайденныеДанные.Очистить();
	
	Если НеLocalSetings Тогда
		Если ВосемьНоль Тогда 
			БазовыйКаталог = APPDATA+"\1C\1Cv8";
			ДобавитьДанныеИзКаталогов(БазовыйКаталог, "8.0", "Предприятие/Конфигуратор");
		КонецЕсли;
		Если ВосемьОдин Тогда
			БазовыйКаталог = APPDATA+"\1C\1Cv81";
			ДобавитьДанныеИзКаталогов(БазовыйКаталог, "8.1", "Предприятие");
		КонецЕсли;
		Если ВосемьДва Тогда 
			БазовыйКаталог = APPDATA+"\1C\1Cv82";
			ДобавитьДанныеИзКаталогов(БазовыйКаталог, "8.2", "Предприятие");
		КонецЕсли;
	КонецЕсли;
	
	Если LocalSetings Тогда
		Если ВосемьОдин Тогда
			БазовыйКаталог = LOCALAPPDATA+"\1C\1Cv81";
			ДобавитьДанныеИзКаталогов(БазовыйКаталог, "8.1", "Конфигуратор");
		КонецЕсли;
		Если ВосемьДва Тогда  	
			БазовыйКаталог = LOCALAPPDATA+"\1C\1Cv82";
			ДобавитьДанныеИзКаталогов(БазовыйКаталог, "8.2", "Конфигуратор");
		КонецЕсли;
	КонецЕсли;
	
	Если ВосемьНоль Тогда 		
		ИмяФайла = APPDATA+"\1C\1Cv8\v8ib.lst";
		Таб = СформироватьСписокБаз(ИмяФайла, "8.0");
		ДобавитьСсылкиНаБазы(Таб);
	КонецЕсли;
	Если ВосемьОдин Тогда
		ИмяФайла = APPDATA+"\1C\1Cv81\ibases.v8i";
		Таб = СформироватьСписокБаз(ИмяФайла, "8.1");
		ДобавитьСсылкиНаБазы(Таб);
	КонецЕсли;
	Если ВосемьДва Тогда  	
		ИмяФайла = APPDATA+"\1C\1CEStart\ibases.v8i";
		Таб = СформироватьСписокБаз(ИмяФайла, "8.2");
		ДобавитьСсылкиНаБазы(Таб);
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть
5. Ilya Baykov (Ilyabaykov) 13.02.11 22:48
(2) Спасибо, поправил, обновил.
СформироватьСписокБаз теперь всегда возвращает таблицу
6. aspirator 23 (aspirator23) 17.02.11 07:01
А для сервера такую сделать?
Когда создаю кластеры и затем удаляю из консоли, все равно остаются записи об этих кластерах.
Их конечно гораздо меньше чем баз у разработчика, но все же, это вроде бы одного поля ягода.
7. Ilya Baykov (Ilyabaykov) 18.02.11 00:13
(6) Угу, было-бы неплохо, но все руки никак не дойдут...
8. Наталья Зотова (natik86) 27.09.11 13:20
У меня все прекрасно работает. Очистила комп от старого хлама. За обработку спасибо!
9. Сергей Шепелев (redgoll) 26.10.11 09:36
Мне очень понравилась идея. У меня куча баз и постоянно добавляются новые. Недавно чистил кэш руками, он у меня достиг 30 гб. Теперь правда приходится долго ждать загрузки старых баз. Думаю, мне эта обработка будет очень полезна. Кстати, никто не знает можно ли как-то настраивать папку сохранения кэша, то есть чтобы кэш сохранялся в какую-то другую папку?
11. Елена (elena_77) 02.12.11 15:28
Спасибо, полезная обработка. Пригодится
12. Марина Николаева (mnikol) 13.12.11 14:55
Очень актуально, особенно при большом количестве баз.Спасибо!
13. Ирина Филиппова (ia57) 15.01.12 00:21
Скачала бы, да баллов нет.
14. Сергей Тропин (sergant500) 01.08.12 20:44
Круто, спасибо. С ходу выборочно очистил 1,5 Gb.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа