gifts2017

Добавим немного позитива в 1с ?!

Опубликовал dmsoft (dmsoft) в раздел Программирование - Работа с интерфейсом

Пользователям понравилось, делюсь с сообществом ))

Иногда однообразный интерфейс 1с несколько утомляет. Хочется позитива, хотя бы немного ;). Идея витала давно. На реализацию много ресурсов не потребовалось.

Идея простая - при загрузке БД из некого сетевого каталога в произвольном порядке выводить , в данном случае на рабочий стол пользователя (хотя в принципе можно и просто на открываемую форму), некую имиджевую (креативную, поздравительную и пр.) картинку.

В конфигурации введены 3 константы

1.  ИспользоватьМотиваторы (булево)

2. МотиваторыПостоянный (строка) - постоянный мотиватор для всех.

3.  МотиваторыПуть (строка) - рандомайзный мотиватор

Код запуска мотиватора (при открытии рабочего стола) приведен ниже , соот-но требует доработки под конкретную конфигурацию.

Процедура ИспользоватьМотиваторы()
ПутьККартинке = "";
Если Константы.ИспользоватьМотиваторы.Получить() = Истина Тогда
ЭлементыФормы.ОсновнаяПанель.Страницы.Мотиваторы.Видимость = Истина;



ПутьККартинке = Константы.МотиваторыПостоянный.Получить();

Если ПутьККартинке = "" Тогда
//выберем рандомайзную из папки
ПутьКПапке = Константы.МотиваторыПуть.Получить();

МассивНайденных = НайтиФайлы(ПутьКПапке, "*.jpg");

МассивНайденных.Количество();

ГСЧ = Новый ГенераторСлучайныхЧисел();

Если МассивНайденных.Количество() <> 0 Тогда
СлучЧисло = ГСЧ.СлучайноеЧисло(0 , МассивНайденных.Количество()-1);
ПутьККартинке = МассивНайденных.Получить(СлучЧисло).ПолноеИмя;
КонецЕсли;

КонецЕсли;

КонецЕсли;

Если ПутьККартинке <> "" Тогда

ЭлементыФормы.Мотиватор1.Картинка= Новый Картинка();
ЭлементыФормы.Мотиватор1.Картинка= Новый Картинка(ПутьККартинке);

ЭлементыФормы.ОсновнаяПанель.Страницы.Мотиваторы.Видимость = Истина;
ЭлементыФормы.Мотиватор1.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.ТекущаяСтраница = ЭлементыФормы.ОсновнаяПанель.Страницы.Мотиваторы;
Иначе
ЭлементыФормы.Мотиватор1.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Мотиваторы.Видимость = Ложь;

КонецЕсли;

КонецПроцедуры

 Начинал с показа мотиваторов. Потом были Айвазовский, Шишкин, Третьяковская галлерея, Дали.

Руководство оценило положительно, пользователям нравиться )).

См. также

Подписаться Добавить вознаграждение
Комментарии
1. artmicro (artmicro) 16.02.11 16:56
Идея не плохая, но мне кажется, что есть большая вероятность, на самом деле "демотивирующего" эффекта.

Еще из мелких замечаний:
1. Рандомайс у Вас скорее всего не рабочий :)
2. Код запуска при открытии рабочего стола - только увеличит время его открытия, он и так не реактивно открывается, логичнее было бы делать это при смене страницы.

Вот такое вот ИМХО :)
2. dmsoft (dmsoft) 16.02.11 17:31
конечно .. не без готов среди нас ;)

1. а в чем нерабочесть ? случ. число генерится из указанного диапазона... картинки у всех разные ... что то пропустил ?
2. смотрел через Замер производительности - время увел-ся на копейки
3. Алексей Константинов (alexk-is) 16.02.11 19:10
(0) Я знаю как раскрасить текст модуля в публикации.
4. Михаил Ражиков (tango) 16.02.11 19:38
прикольно. обычно хочется, чтоб эта хрень по-быстрее открылась
а за изменение типового кода - ваще минус
(0) пользователи - ламеры, и десять плюсанувших
5. dmsoft (dmsoft) 16.02.11 20:08
alexk-is,
спасибо в след. публикациях учту

tango,
увы .. весь рабочий стол не типовой... да и конфа тоже ...
6. Михаил Ражиков (tango) 16.02.11 20:18
7. Сергей Марфин (MCitrus) 17.02.11 08:11
Я почти тоже самое делал. Только вместо картинок у меня пословицы и поговорки выводятся))
8. dmsoft (dmsoft) 17.02.11 08:44
MCitrus,
кстати да, хотел над мотиваторами тоже какие нить слоганы пустить
типа законов Мерфи
а у вас коллега откуда сам текст грузится ?
в случае картинок все просто - качнул пак волпаперов да скинул в отдельную папку, вот и новая тема
9. Ирина Волкова (ir-ish-ka) 03.12.11 19:19
Кайф!
Долой серые будни ))
10. Павел (dardroze) 11.01.12 16:29
наконец-то можно будет отвлечься от строчек и цифр))