gifts2017

Напиши свое имя по-японски :)

Опубликовал Андрей Акулов (DrAku1a) в раздел Программирование - Практика программирования

Нашел в сети шутку и решил написать простенький преобразователь имен, чтобы не мучится "вручную". Пользы практической ноль, но отдохнуть и повеселиться - можно :)

Следует ввести в первое поле Ваше имя и нажать Enter, во втором поле появится преобразованное имя.

Написано на 8.2 (толстый клиент), но можете переписать на другие платформы.

Вот код:

Перем Алфавит;

Процедура ПриОткрытии()
  Алфавит = новый Соответствие);
  Алфавит.Вставить("А", "ка");
  Алфавит.Вставить("Б", "зу");
  Алфавит.Вставить("В", "ру");
  Алфавит.Вставить("Г", "жи");
  Алфавит.Вставить("Д", "тэ");
  Алфавит.Вставить("Е", "ку");
  Алфавит.Вставить("Ё", "ку");
  Алфавит.Вставить("Ж", "су");
  Алфавит.Вставить("З", "з");
  Алфавит.Вставить("И", "ки");
  Алфавит.Вставить("Й", "ки");
  Алфавит.Вставить("К", "мэ");
  Алфавит.Вставить("Л", "та");
  Алфавит.Вставить("М", "рин");
  Алфавит.Вставить("Н", "то");
  Алфавит.Вставить("О", "мо");
  Алфавит.Вставить("П", "но");
  Алфавит.Вставить("Р", "ши");
  Алфавит.Вставить("С", "ари");
  Алфавит.Вставить("Т", "чи");
  Алфавит.Вставить("У", "до");
  Алфавит.Вставить("Ф", "лу");
  Алфавит.Вставить("Х", "ри");
  Алфавит.Вставить("Ц", "ми");
  Алфавит.Вставить("Ч", "кэ");
  Алфавит.Вставить("Ш", "хи");
  Алфавит.Вставить("Щ", "хи");
  Алфавит.Вставить("Ъ", "зук");
  Алфавит.Вставить("Ы", "зук");
  Алфавит.Вставить("Ь", "зук");
  Алфавит.Вставить("Э", "мэй");
  Алфавит.Вставить("Ю", "фу");
  Алфавит.Вставить("Я", "на");
  Алфавит.Вставить(" ", " ");
КонецПроцедуры

Процедура ПолеВвода1ПриИзменении(Элемент)
  Перем Имя, Ответ, Сч, Буква;
  Имя = ВРЕГ(СокрЛП(ВводимоеИмя));
  Ответ = "";
  Для Сч=1 По СтрДлина(Имя)Цикл
   Буква = Сред(Имя, Сч, 1);
   Ответ = Ответ+Алфавит.Получить(Буква); 
  КонецЦикла;
  НовоеИмя = ТРег(Ответ);
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Японец.epf 78
.epf 62,76Kb
24.02.11
78
.epf 62,76Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Ийон Тихий (cool.vlad4) 24.02.11 10:52
:D "воскресный поединок якодзун"
maximus88; +1 Ответить
2. Виктор (Виктор1905) 03.03.11 03:45
Какой бред! Нашли глупость в инете и повторили в 1С. Ни одно сочетание близко не подходит к реальности. Например, слово "Арчибальд" в японском будет написано (и произноситься) как "Аручибаруду". Аната ва бакка бакаший дес ка.
3. sumixam (sumixam) 26.10.11 07:23
ну ващее))) круто народж развлекается
4. Zigfridish (Bassgood) 25.05.12 11:35
как говорится "сунь куй в чай" =))