gifts2017

Поздравление с 8 марта [2011]

Опубликовал execombat в раздел Сообщество - Поздравления

Обработка-поздравлялка пользователей базы с 8 марта.
Используется персонаж Merlin (читает текст вслух).
Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

Скоро праздник.  Решил выложить свою версию поздравлялки с 8 марта.

Навеяно вот этой разработкой (http://infostart.ru/public/80721/).

В обработке есть 2 формы с разными обоями. Выбирайте на ваш вкус =)).

 

Если хочется использовать "цветы", то путь к внешнему приложению нужно указать в переменной ПутьКПриложению_Цветы в процедуре ПриОткрытии().

Чтобы обработка сама запустилась при открытии базы в последний рабочий день перед праздником (05.03.2011) в модуль приложения нужна воткнуть это:

Процедура ПриНачалеРаботыСистемы()

#Если Клиент Тогда
Если НачалоДня(ТекущаяДата()) = НачалоДня(Дата(2011,03,05)) Тогда
           Попытка
                         ФормаПоздравлениеСПраздником = Обработки.ПоздравлялкаС8Марта.ПолучитьФорму("Форма");
                         Если ФормаПоздравлениеСПраздником.Открыта() Тогда
                                 ФормаПоздравлениеСПраздником.Активизировать();
                         Иначе
                                 Если Не ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") Тогда
                                         ФормаПоздравлениеСПраздником.Открыть();  
                                 КонецЕсли;
                         КонецЕсли;
           Исключение
           КонецПопытки;

КонецЕсли
#КонецЕсли

КонецПроцедуры

 

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Архив с обработками для платформ 1С8.1,1С8.2 и внешнее приложение "Цветы"
.zip 547,57Kb
10.12.14
341
.zip 547,57Kb 341 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. execombat 02.03.11 16:17
Обработка-поздравлялка пользователей базы с 8 марта.
Используется персонаж Merlin (читает текст вслух).
Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

Перейти к публикации

1. Аркадий Кучер (Abadonna) 02.03.11 16:17
Когда ж, блин, они закончатся, эти поздравлялки? :cry:
Неистребимы прям, как перенумераторы.
И Мерлин, читающий вслух, - у вас там юзверей всех колонками побаловали?
2. Владимир (vladismi) 02.03.11 16:21
Картинка качается, а где же поздравлялка?
3. SpiderRu (WolfKgn) 02.03.11 16:45
таки да - а где сама поздравлялка? :)
ЗЫ.. нашел.. но как-то странно она выложена
4. execombat 02.03.11 16:47
vladismi
SpiderRu
Исправлено. Можно качать.
5. execombat 02.03.11 16:53
Abadonna пишет:

Когда ж, блин, они закончатся, эти поздравлялки?

Не пойму. Чего плохого в поздравлялках? Кому не нужно, те и не качают.
Abadonna пишет:
... у вас там юзверей всех колонками побаловали?

Колонки легко заменяются гарнитурой.
6. Альтаир (Altair777) 02.03.11 18:52
Abadonna пишет:
Когда ж, блин, они закончатся, эти поздравлялки? :cry:
Неистребимы прям, как перенумераторы.

от перенумераторов хоть какой-то практический прок был ;)
7. UncleVader (UncleVader) 03.03.11 09:27
Abadonna пишет:
Когда ж, блин, они закончатся, эти поздравлялки? smile:cry:
Неистребимы прям, как перенумераторы.
Altair777 пишет:
от перенумераторов хоть какой-то практический прок был smile;)

Необоснованное ворчание!
А что плохого или вредного?!
8. Альтаир (Altair777) 03.03.11 10:21
(7) полезного ничего, а вредного?... засорение каталога разработок :)
9. UncleVader (UncleVader) 03.03.11 10:38
(8) Не соглашусь! Как источник эндорфинов с медицинской точки зрения очень даже полезно, особенно после затяжной унылой зимы!
10. Роман Семенов (rsu55) 03.03.11 10:57
антивирусник файл flower.exe определяет как вирус Joke.Rosenu
11. execombat 03.03.11 11:22
А что за антивирусник? NOD32 и Avast молчат.
12. Андрей Мухин (Muhin555) 03.03.11 13:46
неплохо было бы не из конфигурации, а из доп.обработок эти поздравлялки запускать....
13. Роман Семенов (rsu55) 03.03.11 17:10
execombat пишет:

А что за антивирусник? NOD32 и Avast молчат.


Symantec...
14. UncleVader (UncleVader) 04.03.11 12:16
Разделил логон-скрипты на мужской и женский, в женский закинул flower.exe, все просто счастливы :D
15. execombat 04.03.11 12:38
Я так понимаю теперь девушки получают цветы сразу после включения компьютера и ввода пароля? :D
16. Сергей (floodprog) 07.03.11 05:12
работать некому. заводы стоят ! :D
17. Сергей Сергеевич (onyx) 21.09.11 08:30
Когда ж, блин, они закончатся, эти поздравлялки?
Неистребимы прям, как перенумераторы.
18. Алексей Прокопенко (axelload) 26.09.11 11:58
Отличная обработка. только вот говорящие фигурки на windows7 не работают. пришлось выпрашивать патч у мелкомягких
19. Алексей Прокопенко (axelload) 26.09.11 11:59
патч прислали. фигурки заработали но анимация win7 работает весьма странно
20. execombat 27.09.11 09:24
А что за патч? Есть ссылка? У меня на win 7 персонажи работают. Только фон у фигурок не прозрачный (
21. Юлия Петрова (petrovaUL) 21.02.12 12:43
Отличная обработка. только вот говорящие фигурки на windows7 не работают. Какай патч нужен?
22. execombat 22.02.12 12:13
Для Win 7 нужно установить MS Agent. Скачал патч здесь
23. ivan ivanov (ivan07) 06.03.12 11:48
Интересная обработка, испытаю на своих коллегах. Спасибо!
24. Александр Щемелёв (zavyzka) 07.03.12 14:47
25. Дмитрий Алиулов (freezetron) 11.03.12 08:31
Спасибо! Всем очень понравилось!
26. grey_X (GREY_x) 22.02.13 10:29
Кто-нибудь решил проблему с не прозрачным фоном у фигурок в винде 7-ке?
27. С. Дмитрий (spa07) 04.03.13 10:25
КУсок вставки в процедуру ПриНачалеРАботыСИстемы отрабатывает некорректно, а именно
ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") первый раз возвращает неопределено и форма не открывается.
Пришлось допиливать.
28. execombat 06.03.13 16:23
(26) GREY_x,
Для того чтобы на WIN 7 фон у фигурок был прозрачным нужно установить патч. Ссылка есть выше. А вот с фоном цветов не знаю что делать.
29. Татьяна bDFYJDF (stata) 06.12.15 19:29
внешнее приложение "цветы", при вызове которого экран заполняется цветами можно такое скачать или нет. Очень хочется
30. Татьяна bDFYJDF (stata) 06.12.15 19:46
хОЧУ СКАЧАТЬ ПРОСТО внешнее приложение "цветы", при вызове которого экран заполняется цветами, МОЖНО ЭТО КАК ТО ИЛИ НЕТ.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа