Поздравление с 8 марта [2011]

Опубликовал execombat в раздел Сообщество - Поздравления

Обработка-поздравлялка пользователей базы с 8 марта.
Используется персонаж Merlin (читает текст вслух).
Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

Скоро праздник.  Решил выложить свою версию поздравлялки с 8 марта.

Навеяно вот этой разработкой (http://infostart.ru/public/80721/).

В обработке есть 2 формы с разными обоями. Выбирайте на ваш вкус =)).

 

Если хочется использовать "цветы", то путь к внешнему приложению нужно указать в переменной ПутьКПриложению_Цветы в процедуре ПриОткрытии().

Чтобы обработка сама запустилась при открытии базы в последний рабочий день перед праздником (05.03.2011) в модуль приложения нужна воткнуть это:

Процедура ПриНачалеРаботыСистемы()

#Если Клиент Тогда
Если НачалоДня(ТекущаяДата()) = НачалоДня(Дата(2011,03,05)) Тогда
           Попытка
                         ФормаПоздравлениеСПраздником = Обработки.ПоздравлялкаС8Марта.ПолучитьФорму("Форма");
                         Если ФормаПоздравлениеСПраздником.Открыта() Тогда
                                 ФормаПоздравлениеСПраздником.Активизировать();
                         Иначе
                                 Если Не ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") Тогда
                                         ФормаПоздравлениеСПраздником.Открыть();  
                                 КонецЕсли;
                         КонецЕсли;
           Исключение
           КонецПопытки;

КонецЕсли
#КонецЕсли

КонецПроцедуры

 

 

Файлы

Наименование Файл Версия Размер Кол. Скачив.
Архив с обработками для платформ 1С8.1,1С8.2 и внешнее приложение "Цветы"
.zip 547,57Kb
10.12.14
341
.zip 547,57Kb 341 Скачать

См. также

Лучшие комментарии

11. execombat 03.03.2011 11:22
А что за антивирусник? NOD32 и Avast молчат.
+ 1 [ rsu55; ]
# Ответить
12. Muhin555 (файл скачал) 03.03.2011 13:46
неплохо было бы не из конфигурации, а из доп.обработок эти поздравлялки запускать....
+ 1 [ echo77; ]
# Ответить

Комментарии

1. Abadonna 02.03.2011 16:17
Когда ж, блин, они закончатся, эти поздравлялки? :cry:
Неистребимы прям, как перенумераторы.
И Мерлин, читающий вслух, - у вас там юзверей всех колонками побаловали?
# Ответить
2. vladismi (файл скачал) 02.03.2011 16:21
Картинка качается, а где же поздравлялка?
# Ответить
3. SpiderRu (файл скачал) 02.03.2011 16:45
таки да - а где сама поздравлялка? :)
ЗЫ.. нашел.. но как-то странно она выложена
# Ответить
4. execombat 02.03.2011 16:47
vladismi
SpiderRu
Исправлено. Можно качать.
# Ответить
5. execombat 02.03.2011 16:53
Abadonna пишет:

Когда ж, блин, они закончатся, эти поздравлялки?

Не пойму. Чего плохого в поздравлялках? Кому не нужно, те и не качают.
Abadonna пишет:
... у вас там юзверей всех колонками побаловали?

Колонки легко заменяются гарнитурой.
# Ответить
6. Altair777 02.03.2011 18:52
Abadonna пишет:
Когда ж, блин, они закончатся, эти поздравлялки? :cry:
Неистребимы прям, как перенумераторы.

от перенумераторов хоть какой-то практический прок был ;)
# Ответить
7. UncleVader (файл скачал) 03.03.2011 09:27
Abadonna пишет:
Когда ж, блин, они закончатся, эти поздравлялки? smile:cry:
Неистребимы прям, как перенумераторы.
Altair777 пишет:
от перенумераторов хоть какой-то практический прок был smile;)

Необоснованное ворчание!
А что плохого или вредного?!
Ответили: (8)
# Ответить
8. Altair777 03.03.2011 10:21
(7) полезного ничего, а вредного?... засорение каталога разработок :)
Ответили: (9)
# Ответить
9. UncleVader (файл скачал) 03.03.2011 10:38
(8) Не соглашусь! Как источник эндорфинов с медицинской точки зрения очень даже полезно, особенно после затяжной унылой зимы!
# Ответить
10. rsu55 03.03.2011 10:57
антивирусник файл flower.exe определяет как вирус Joke.Rosenu
# Ответить
11. execombat 03.03.2011 11:22
А что за антивирусник? NOD32 и Avast молчат.
+ 1 [ rsu55; ]
# Ответить
12. Muhin555 (файл скачал) 03.03.2011 13:46
неплохо было бы не из конфигурации, а из доп.обработок эти поздравлялки запускать....
+ 1 [ echo77; ]
# Ответить
13. rsu55 03.03.2011 17:10
execombat пишет:

А что за антивирусник? NOD32 и Avast молчат.


Symantec...
# Ответить
14. UncleVader (файл скачал) 04.03.2011 12:16
Разделил логон-скрипты на мужской и женский, в женский закинул flower.exe, все просто счастливы :D
# Ответить
15. execombat 04.03.2011 12:38
Я так понимаю теперь девушки получают цветы сразу после включения компьютера и ввода пароля? :D
# Ответить
16. floodprog 07.03.2011 05:12
работать некому. заводы стоят ! :D
# Ответить
17. onyx (файл скачал) 21.09.2011 08:30
Когда ж, блин, они закончатся, эти поздравлялки?
Неистребимы прям, как перенумераторы.
# Ответить
18. axelload (файл скачал) 26.09.2011 11:58
Отличная обработка. только вот говорящие фигурки на windows7 не работают. пришлось выпрашивать патч у мелкомягких
# Ответить
19. axelload (файл скачал) 26.09.2011 11:59
патч прислали. фигурки заработали но анимация win7 работает весьма странно
# Ответить
20. execombat 27.09.2011 09:24
А что за патч? Есть ссылка? У меня на win 7 персонажи работают. Только фон у фигурок не прозрачный (
# Ответить
21. petrovaUL 21.02.2012 12:43
Отличная обработка. только вот говорящие фигурки на windows7 не работают. Какай патч нужен?
# Ответить
22. execombat 22.02.2012 12:13
Для Win 7 нужно установить MS Agent. Скачал патч здесь
# Ответить
23. ivan07 (файл скачал) 06.03.2012 11:48
Интересная обработка, испытаю на своих коллегах. Спасибо!
# Ответить
24. zavyzka (файл скачал) 07.03.2012 14:47
Звук не работает.
# Ответить
25. freezetron 11.03.2012 08:31
Спасибо! Всем очень понравилось!
# Ответить
26. GREY_x 22.02.2013 10:29
Кто-нибудь решил проблему с не прозрачным фоном у фигурок в винде 7-ке?
# Ответить
27. spa07 (файл скачал) 04.03.2013 10:25
КУсок вставки в процедуру ПриНачалеРАботыСИстемы отрабатывает некорректно, а именно
ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") первый раз возвращает неопределено и форма не открывается.
Пришлось допиливать.
# Ответить
28. execombat 06.03.2013 16:23
(26) GREY_x,
Для того чтобы на WIN 7 фон у фигурок был прозрачным нужно установить патч. Ссылка есть выше. А вот с фоном цветов не знаю что делать.
# Ответить
29. stata 06.12.2015 19:29
внешнее приложение "цветы", при вызове которого экран заполняется цветами можно такое скачать или нет. Очень хочется
# Ответить
30. stata 06.12.2015 19:46
хОЧУ СКАЧАТЬ ПРОСТО внешнее приложение "цветы", при вызове которого экран заполняется цветами, МОЖНО ЭТО КАК ТО ИЛИ НЕТ.
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл






IE 2016