gifts2017

Пример программного создания каталога для хранения данных на жестком диске или внешнем носителе.

Опубликовал Сергей Федоров (Bober777) в раздел Программирование - Практика программирования

Когда вопрос становится, где хранить файлы или каким образом программно создать каталоги для выгружаемых файлов из системы, то предлагаю следующий пример:    

Я решил сделать каталог год/месяц/число/

 

ПроцедураКоманднаяПанель6СохранитьТаблицуXML(Кнопка)
Запись = Новый ЗаписьXML;
СтандартныйПутьКФайлу = "C:\ExternalTable";
Дата_ТД = Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy");
Время_ТД = Формат(ТекущаяДата(),"ДЛФ=T");
ТекущийМесяц = ОпределитьМесяц(Прав(Лев(Дата_ТД,5),2)); //функция находится ниже
ВремяТекущееСкорректированное = СтрЗаменить(Время_ТД,":","_");
ПутьКФайлу = СтандартныйПутьКФайлу + "\" + Прав(Дата_ТД,4) + "\" + ТекущийМесяц 
+ "\" + Лев(Дата_ТД,2) + "\";
ПроверитьСуществованиеКаталога(ПутьКФайлу);
Запись.ОткрытьФайл(ПутьКФайлу + "ПервоначальнаяТаблица" +ВремяТекущееСкорректированное);
//Работа непосредственно с файлом
Запись.ЗаписатьОбъявлениеXML();
Запись.Закрыть();
КонецПроцедуры

 

 

 

ФункцияОпределитьМесяц(МесяцЦифровой)
Если МесяцЦифровой = "01" Тогда  
Возврат "Январь";
ИначеЕсли МесяцЦифровой = "02" Тогда  
Возврат "Февраль";
ИначеЕсли МесяцЦифровой = "03" Тогда  
Возврат "Март";
ИначеЕсли МесяцЦифровой = "04" Тогда  
Возврат "Апрель";
ИначеЕсли МесяцЦифровой = "05" Тогда  
Возврат "Май";
ИначеЕсли МесяцЦифровой = "06" Тогда  
Возврат "Июнь";
ИначеЕсли МесяцЦифровой = "07" Тогда  
Возврат "Июль";
ИначеЕсли МесяцЦифровой = "08" Тогда  
Возврат "Август";
ИначеЕсли МесяцЦифровой = "09" Тогда  
Возврат "Сентябрь";
ИначеЕсли МесяцЦифровой = "10" Тогда  
Возврат "Октябрь";
ИначеЕсли МесяцЦифровой = "11" Тогда  
Возврат "Ноябрь";
ИначеЕсли МесяцЦифровой = "12" Тогда  
Возврат "Декабрь";
КонецЕсли;
КонецФункции

 

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Сергей Федоров (Bober777) 06.03.11 06:19
Когда вопрос становится, где хранить файлы или каким образом программно создать каталоги для выгружаемых файлов из системы, то предлагаю следующий пример:

Перейти к публикации

1. Василий Демидов (Душелов) 06.03.11 06:19
А почему месяц сразу форматом и не получить?

ТекущийМесяц = Формат(Дата_ТД, "ДФ=MMMM");
Bober777; +1 Ответить
2. Александр (Staind111) 06.03.11 08:06
Тоже самое хотел написать :)

Или раз уж используем функцию для определения названия месяца, то почему его номер получаем таким странным образом, не легче было бы использовать - НомерМесяца = Месяц(ТекущаяДата())?
Bober777; +1 Ответить
3. Алексей Константинов (alexk-is) 06.03.11 08:32
А я всегда думал, что всё это делается так:
ПутьКФайлу = "C:\ExternalTable" + Формат(ТекущаяДата(), "ДФ=\yyyy\MMMM\dd\");
ИмяФайла = "ПервоначальнаяТаблица" + Формат(ТекущаяДата(), "ДФ=HH_mm");
СоздатьКаталог(ПутьКФайлу);
Запись = Новый ЗаписьXML
Запись.ОткрытьФайл(ПутьКФайлу + ИмяФайла);
...Показать Скрыть
sCHTASS; obmailok; Spartan; BigB; Yashazz; +5 Ответить
4. Сергей Федоров (Bober777) 06.03.11 09:34
Спасибо теперь буду знать).
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа