Акт сверки для УТ 11

Опубликовал Александр (sprinter) в раздел Отчеты - Управленческие

Внешняя обработка акт сверки для УТ 11, в редакции пользователя "Поручик"

Данная обработка тестировалась на версии Управление торговлей, редакция 11.0 (11.0.5.4), на других не пробовал. Эта редакция, любезно предоставлена пользователем "Поручик"

21.01.2012

Прежняя версия обработки работает до Управление торговлей, редакция 11.0 (11.0.7.13)

для тех у кого установлена версия 11.0.7.13 следует использовать обновлённую обработку

Акт_Сверки_11.0.7.13

05.03.2012

Исправлены ошибки, которые иногда возникали при расчете начального сальдо

Скачать файлы

Наименование Файл Версия Размер
Акт_Сверки_11.0.7.13
.epf 14,74Kb
05.03.12
291
.epf 14,74Kb 291 Скачать
Акт_Сверки (11.0.5.4 - 11.0.6.9)
.epf 14,63Kb
05.03.12
353
.epf 14,63Kb 353 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Сергей Ожерельев (Поручик) 3472 10.03.11 15:35 Сейчас в теме
(0) Форма в стиле "клюшек".
Сделай лучше по образцу http://infostart.ru/public/14228/ или других, цены не будет. Или за деньги будешь продавать.
lildee; sprinter; +2 Ответить
2. Антон (anton.fly7) 134 10.03.11 15:43 Сейчас в теме
или на СКД )) ваще нарядно былоб
3. Сергей Ожерельев (Поручик) 3472 10.03.11 17:54 Сейчас в теме
На СКД, кстати, хорошая тема.
4. Александр (sprinter) 87 10.03.11 21:32 Сейчас в теме
Спасибо за конструктивную критику, немножно доработал обработку.
Поручик; +1 Ответить 1
5. Сергей Ожерельев (Поручик) 3472 10.03.11 23:36 Сейчас в теме
(4)
1. При выборе партнёра контрагента можно подставлять автоматически, если он один.
2. При добавлении в дополнительные обработки предупреждение: обработка требует разрешить использование в небезопасном режиме.
ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);

Кстати, в будущей УТ 11.0.6 тоже работает.
6. Александр (sprinter) 87 11.03.11 09:51 Сейчас в теме
Спасибо, сделано, ну и если организация одна, тоже автоматом ставится
7. Сергей Ожерельев (Поручик) 3472 11.03.11 22:47 Сейчас в теме
(6) Держи облагороженную обработку, можешь опубликовать как свою.

[+] Форма в стиле 8.2.
[+] Сохранение настроек.
[+] Открытие документа в печатной форме.
[+] Небольшой рефакторинг кода.
8. Aerie (Aerie) 13.04.11 10:13 Сейчас в теме
Ошибка:При сверке с поставщиками у которых сальдо на начало периода дебетовое - выводит кредитовое!
9. Алена Белова (Alen76) 23.09.11 11:30 Сейчас в теме
Было бы возможно, поставила бы сотню плюсов! Спасибо!Отлично. Всё работает на Управление торговлей, редакция 11.0 (11.0.6.9)
10. Алена Белова (Alen76) 23.09.11 11:31 Сейчас в теме
Поручику отдельное спасибо за "наводку"...
11. wagospb (nikvel) 25.09.11 20:12 Сейчас в теме
В УТ 11.0.6.9 есть стандартная обработка "Сверки взаиморасчетов"
12. Алена Белова (Alen76) 06.10.11 12:40 Сейчас в теме
В УТ 11.0 печатная форма документа "сверка взаиморасчетов" очень не удобоваримая , непонятно зачем нужно было разработчикам выдумывать велосипед, если уже давно была нормальная форма акта сверки, которая в бухгалтерии предпр. 2.0 под 8.2 кстати осталась в нормальном виде.Всё возможные стандартные средства уже проверены и сделаны определенные выводы ... Взаиморасчеты в УТ 11 в любом виде (акты, ведомости и пр.)не удобно сделаны, т.к либо нужно "проходить" всех контрагентов на конец каждого периода и делать зачет задолжостей , либо привязку док.оплаты и док. отгрузки (заказа), а иначе долги дает в развернутом виде, а нужно (хотя бы в печатной форме) , чтобы взаиморасчеты были "свернуты", поэтому очень нужен был такой акт сверки, который представлен здесь. Теперь остается дождаться , чтобы ведомость взаиморасчетов со "свернутыми долгами" появилась, как это реализовано в УТ 10.3 (типа "по договору в целом")
Мое мнение, как обычного пользователя-потребителя продукта- бухгалтера, а не программиста, возможно оно поможет кому-нибудь понять наши приземленные потребности.
13. Мария Каширина (Иволга) 21.10.11 09:57 Сейчас в теме
Очень нужная вещь, особенно когда пользователи-бухгалтера хотят видеть В УТ 11 привычное. Спасибо, все работает. Это еще один аргумент, чтобы консерваторы-бухгалтера не кричали "Вот Ваша 8-ка..., а говорили все есть."
14. Владимир Сумин (sumv1) 7 17.11.11 10:16 Сейчас в теме
Спасибо. Работает. При этом мягко сказать "удивлен" отсутствием в типовой УТ стандартной формы акта сверки !!!
15. Max Home (Ty4a) 13.01.12 17:41 Сейчас в теме
(5) ,
"Кстати, в будущей УТ 11.0.6 тоже работает."
А эта обработка работает в УТ 11.0.7 ?
16. Сергей Ожерельев (Поручик) 3472 13.01.12 18:02 Сейчас в теме
(15) Проверь сам. Ещё не хватало, чтобы я чужие работы проверял.
17. Михаил Иванов (wwizard) 18.01.12 13:32 Сейчас в теме
в mxtv разница между стандартной 8,2 УТ?
18. Сергей Ожерельев (Поручик) 3472 20.01.12 09:01 Сейчас в теме
(0) На УТ 11.0.7.13 уже не работает. Функция ФамилияИнициалыФизЛица() из модуля ФормированиеПечатныхФорм перенесена в ФизическиеЛица.
Могу подарить рабочую версию.

С 1С мы без работы не останемся. Постоянные переносы процедур, переименования модулей, объектов не дадут скучать.
19. Max Home (Ty4a) 20.01.12 13:35 Сейчас в теме
(18) Поручик,
На УТ 11.0.7.13 уже не работает. Функция ФамилияИнициалыФизЛица() из модуля ФормированиеПечатныхФорм перенесена в ФизическиеЛица.
Могу подарить рабочую версию.

Я бы не отказался от рабочей версии в 11.0.7.13 ;-)
20. Сергей Ожерельев (Поручик) 3472 20.01.12 13:41 Сейчас в теме
(19) Обязательно повторять сообщение? Если автор согласится, выложу.
21. Александр (sprinter) 87 20.01.12 15:00 Сейчас в теме
"Обязательно повторять сообщение? Если автор согласится, выложу."
Добрый день. Если есть уже рабочая версия под 11.0.7.13 выложите пожалуйста, т.к. у меня на данный момент ещё нет такой версии УТ для доработки.
22. Александр (sprinter) 87 25.01.12 11:34 Сейчас в теме
Добавил файл обработки для версии УТ 11.0.7.13
Акт_Сверки_11.0.7.13
23. Сергей Ожерельев (Поручик) 3472 25.01.12 12:23 Сейчас в теме
(21) Надо было указать номер сообщения в круглых скобках, тогда я бы получил уведомление и вывалил в тот же день. Кстати, в своём варианте я сделал вывод входящей даты и номера в поступлении товаров и поступлении ДС.
24. Александр (sprinter) 87 25.01.12 14:57 Сейчас в теме
"Надо было указать номер сообщения в круглых скобках, тогда я бы получил уведомление и вывалил в тот же день"
Извините, мало общаюсь на форумах поэтому не знал таких нюансов
25. Михаил Кушев (ImPenguin) 9 01.03.12 06:49 Сейчас в теме
Ваш Акт сверки немного подглючивает, посмотрите на первом скриншоте в акте сверки сальдо на 31.12.11 в колонке Дебет, а на втором скриншоте, сальдо на начало периода 01.01.12 в колонке кредит...т.е. неправильно переносит сальдовку между годами.
Прикрепленные файлы:
26. Михаил Кушев (ImPenguin) 9 01.03.12 07:33 Сейчас в теме
Вот еще один пример неверного отображения данных, в этом случае на конец 2011 года сальдовки нет. А в 2012 году она появляется причем в удвоенном размере оборотов 2011 года...
Прикрепленные файлы:
27. Александр (sprinter) 87 01.03.12 09:25 Сейчас в теме
(26) Спасибо, посмотрю в чём причина, постараюсь исправить.
28. Александр (sprinter) 87 05.03.12 15:23 Сейчас в теме
(26) исправил найденные ошибки
30. Михаил Кушев (ImPenguin) 9 05.03.12 17:03 Сейчас в теме
(28)Спасибо, сейчас потестим!!!
31. Михаил Кушев (ImPenguin) 9 06.03.12 09:50 Сейчас в теме
(27) Посмотрел, для тех партнеров которых я приводил в пример, все нормально. Попробовал взять партнера с более частыми отгрузками, вот что получилось: опять проблема с сальдо...
Прикрепленные файлы:
32. Александр (sprinter) 87 07.03.12 17:07 Сейчас в теме
(31) Спасибо за сообщение, тестирую обработку, пока что не получается воспроизвести ситуацию, которая изображена на экране. Использую и возвраты и предоплату и не доплату: а также ситуацию когда один контрагент выступает и в качестве покупателя и в качестве продавца, ни как не выходит.
33. Михаил Кушев (ImPenguin) 9 08.03.12 16:39 Сейчас в теме
Может я смогу помочь еще информацией, этот партнер - это партнер родитель, т.е. у него есть еще несколько партнеров у которых контрагент просто ИП Никитенко. Я пораскрывал в акте сверки реализации и туда пападают все реализации по контрагенту ИН Никитенко, а партнеры (клиенты) в этих реализациях разные. А сальдо, возможно, переносится только по оному партнеру.
Прикреплю еще один скриншот, который охватывает весь период на предыдущих скриншотах.
И скриншот, где видно какая структура у партнера ИП Никитенко.
Прикрепленные файлы:
34. Михаил Кушев (ImPenguin) 9 22.03.12 06:12 Сейчас в теме
Интересно узнать, работаете ли Вы надо доработкой акта сверки? Я думаю причина его некорректной работы кроется именно в том, что имеются партнеры-родители и контрагенты-родители.
35. Александр (sprinter) 87 26.03.12 20:38 Сейчас в теме
(34) К сожалению пока ещё не разбирался с описанной Вами ситуацией, на текущий момент много работы. Как только обновлю версию отчёта сразу же отпишусь в комментариях.
36. Sergey Gromov (ov1) 31.05.12 16:32 Сейчас в теме
а как произвести печать из самого документа?
37. Александр (sprinter) 87 31.05.12 17:51 Сейчас в теме
(36) Обработка сделана не как внешняя печатная форма. Поэтому ни как.
38. Николай (realm) 14.12.12 04:17 Сейчас в теме
Не проверил ли кто работоспособность отчета на УТ 10? Заранее, спасибо.
39. михаил петров (m1kll) 7 14.12.12 05:44 Сейчас в теме
данная обработка будет работать на КА в управляемом интерфейсе?
40. romul_666 (romul_666) 3 08.05.13 18:47 Сейчас в теме
1С:Предприятие 8.2 (8.2.17.169)
Управление торговлей, редакция 11.1 (11.1.1.11)

В ней нет реквизитов ТекущийРуководитель уже... Соответственно нужно изменить код для подбора руководителя и бухгалтера из подчиненного справочника ОтветственныеЛицаОрганизаций.
41. romul_666 (romul_666) 3 08.05.13 21:28 Сейчас в теме
нашел код вот этот в модуле пользователя:
ТекущаяОбласть = Макет.ПолучитьОбласть("Подвал");
ТекущаяОбласть.Параметры.ДатаОкончания = Формат(ДатаОкончания, "ДФ=dd.MM.yyyy");
ТекущаяОбласть.Параметры.Организация = Организация;
ТекущаяОбласть.Параметры.Контрагент = Контрагент;
ТекущаяОбласть.Параметры.СальдоКонечное = Формат(ИтоговоеСальдо, "ЧДЦ=2");
ТекущаяОбласть.Параметры.СуммаПрописью = СуммаПрописью;
ТекущаяОбласть.Параметры.Результат = Результат;
ТекущаяОбласть.Параметры.ОрганизацияИНН = Организация.ИНН;
ТекущаяОбласть.Параметры.КонтрагентИНН = Контрагент.ИНН;
ТабличныйДокумент.Вывести(ТекущаяОбласть);

и после него вставил вот так:

// Получить выборку по ответственным лицам организации.
Выборка = Справочники.ОтветственныеЛицаОрганизаций.Выбрать( , Организация);

Пока Выборка.Следующий() Цикл
ФИО= ФизическиеЛица.ФамилияИнициалыФизЛица(Выборка.ФизическоеЛицо.Наименование);
Должность = сокрЛП(Выборка.ОтветственноеЛицо);

Если СокрЛП(Должность) = "Руководитель" тогда
РуководительФИО = ФИО;
РуководительДолжность = Должность;

КонецЕсли;
Если СокрЛП(Должность) = "Главный бухгалтер" тогда
ГлавныйБухгалтерФИО = ФИО;
ГлавныйБухгалтерДолжность = Должность;

КонецЕсли;
КонецЦикла;

Если ТипПодписи = "Руководитель" Тогда
ТекущаяОбласть = Макет.ПолучитьОбласть("Подпись");
ТекущаяОбласть.Параметры.ФИО = РуководительФИО;
ТекущаяОбласть.Параметры.ПредставлениеДолжности = РуководительДолжность;
ТабличныйДокумент.Вывести(ТекущаяОбласть);

ИначеЕсли ТипПодписи = "Оба" Тогда
ТекущаяОбласть = Макет.ПолучитьОбласть("Подпись");
ТекущаяОбласть.Параметры.ФИО = РуководительФИО;
ТекущаяОбласть.Параметры.ПредставлениеДолжности = РуководительДолжность;
ТабличныйДокумент.Вывести(ТекущаяОбласть);

ТекущаяОбласть = Макет.ПолучитьОбласть("Подпись");
ТекущаяОбласть.Параметры.ФИО = ГлавныйБухгалтерФИО;
ТекущаяОбласть.Параметры.ПредставлениеДолжности = ГлавныйБухгалтерДолжность;
ТабличныйДокумент.Вывести(ТекущаяОбласть);

Иначе
ТекущаяОбласть = Макет.ПолучитьОбласть("Подпись");
ТекущаяОбласть.Параметры.ФИО = ГлавныйБухгалтерФИО;
ТекущаяОбласть.Параметры.ПредставлениеДолжности = ГлавныйБухгалтерДолжность;
ТабличныйДокумент.Вывести(ТекущаяОбласть);

КонецЕсли;

ТекущаяОбласть = Макет.ПолучитьОбласть("МП");
ТабличныйДокумент.Вывести(ТекущаяОбласть);

Возврат ТабличныйДокумент;
42. romul_666 (romul_666) 3 08.05.13 21:30 Сейчас в теме
Хотел еще шапку доработать, чтобы вписывались сами ответственные лица, но руки пока не дошли...
43. Равиль Нургалиев (sk_acc) 5 09.06.14 21:47 Сейчас в теме