gifts2017

Ведомость времени работы пользователей в базе

Опубликовал Юрий (1с2с) в раздел Отчеты - Управленческие

Обработка осуществляет парсинг файла журнала регистрации текущей базы и определяет время начала, окончания и продолжительность работы пользователей за выбранный период.

Рассчитываются также суммарные и средние показания времени.

Детализация: пользователи и даты.

Точность: секунды или минуты.

Использован механизм чтения, предложенный в http://www.kb.mista.ru/article.php?id=311.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Ведомость времени работы пльзователей
.ert 53,00Kb
13.03.11
119
.ert 53,00Kb 119 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владислав Чинючин (vcv) 13.03.11 19:56
А что это даёт? Время прихода на работу и ухода с работы? Я могу прибежать в офис за полчаса до начала рабочего дня, запустить 1С и на два часа в курилку потрепаться.
Без анализа времени реальной активности пользователей - длина удава в попугаях.
Да и с анализом реальной активности пользователей что-то осмысленное отчет даст только для операторов, у которых задача долбить данные, а не думать.
2. Юрий (1с2с) 14.03.11 00:51
(1)
А что это даёт? Время прихода на работу и ухода с работы?...

некоторым нужно именно это...
3. Альтаир (Altair777) 14.03.11 10:14
а зачем через журнал регистрации?
у меня в одной конфе было через справочник - очень удобно было видеть в реал-тайме и в отчетах
4. Юрий (1с2с) 14.03.11 12:44
(3) хороший вариант..., есть свои плюсы...
5. Альтаир (Altair777) 14.03.11 13:14
+(3) вот кусочек кода из глобальника

Перем глПользователь Экспорт;
Перем winUSERNAME;

Процедура ПриНачалеРаботыСистемы()  Экспорт
	Попытка
		WSH=СоздатьОбъект("WScript.Shell");
		winUSERNAME=СокрЛП(WSH.ExpandEnvironmentStrings("%USERNAME%"));
	Исключение
		winUSERNAME="";
	КонецПопытки;

	// установка текущего пользователя
	Если ПустоеЗначение(ИмяПользователя())=0 Тогда
		Спр=СоздатьОбъект("Справочник.Пользователи");
		Если Спр.НайтиПоКоду(ИмяПользователя())=0  Тогда
			Спр.Новый();
			Спр.Код=ИмяПользователя();
			Спр.Наименование=ИмяПользователя();
			Спр.Записать();
		ИначеЕсли Спр.ПометкаУдаления()=1 Тогда
			Предупреждение("Пользователь удален из системы!",20);
			СтатусВозврата(0);
			Возврат;
		КонецЕсли;
		глПользователь=Спр.ТекущийЭлемент();
	Иначе
		Предупреждение("Пользователь системы не определен!",20);
		СтатусВозврата(0);
		Возврат;
	КонецЕсли;


	Спр=СоздатьОбъект("Справочник.Сеансы1СПодробно");
	Спр.Новый();
	Спр.Пользователь=глПользователь;
	Спр.ДатаВхода=ТекущаяДата();
	Спр.ВремяВхода=ТекущееВремя();
	Спр.Терминал=winUSERNAME;
	Спр.Записать();
КонецПроцедуры

// ===============================
Процедура ПриЗавершенииРаботыСистемы()
	Перем Спр;
	Спр=СоздатьОбъект("Справочник.Сеансы1СПодробно");
	Спр.ПорядокКодов();
	Спр.ОбратныйПорядок(1);
	Спр.ВыбратьЭлементыПоРеквизиту("Пользователь",глПользователь,1,0);
	Пока Спр.ПолучитьЭлемент() = 1 Цикл
		Спр.ВремяВыхода=ТекущееВремя();
		Спр.Записать();
		Прервать;
	КонецЦикла;
КонецПроцедуры
...Показать Скрыть
6. Юрий (1с2с) 14.03.11 14:38
(5) удобно, особенно для конфигураций оперативного учета...
"+++": удобство, простота и оперативность получения результата...
"---":
необходимость внесения изменений в конфигурацию;
универсальность (далеко не везде есть спр. Пользователи);
обновления (в части дописок глоб. модуля);
невозможность получения результата за период, предшествующий...
7. Альтаир (Altair777) 14.03.11 14:53
(6)
1с2с пишет:
"---": универсальность (далеко не везде есть спр. Пользователи);

Даже если его и нет, то имеет смысл создать - к нему много чего прикручено (подчиненные справочники) или он сам где-то привинчен :)

1с2с пишет:
невозможность получения результата за период, предшествующий...

Для каждой базы это разовая операция, которую можно сделать парсингом журнала регистраций.
8. Юрий (1с2с) 14.03.11 16:14
(7) т.е. его нет, а к нему уже "много чего прикручено..."? :)
9. Альтаир (Altair777) 14.03.11 16:23
да, так и сеть :D
- ну, Жора, жарь рыбу
- так нету ж рыбы
- ты, Жора, жарь, а рыба будет

Перефразирую из (7):
Даже если его и нет, то имеет смысл создать - в "моих" конфигурациях к нему много чего прикручено (подчиненные справочники) или он сам где-то привинчен
P.S. вообще как-то не верится что такого справочника вообще нет. М.б. он просто называется как-то по-другому?
Типа Сотрудники, Юзеры, Юзвери и т.д. и т.п.
10. Юрий (1с2с) 14.03.11 16:56
(9) за скороговорку...
V.Nikonov; +1 Ответить
11. Ольга (ivolga) 15.10.11 02:10
Лично мне пригодилась именно в таком виде, когда директору понадобилась информация о приходе-уходе сотрудников. Быстро и удобно. Спасибо!
12. volodya volodya (volodya1122) 06.07.12 13:21
обработка не учитывает промежуточные отключения в пределах дня. Тоисть я рано пришел, включил 1С на 5 минут и вышел. Вечером опять пришел включил 1С. И мне обработка сказала что я честно отработал 9 часов...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа