bdd2

Поиск картинок в интернете для Управления торговлей 11

Опубликовал Александр Шкураев (salexdv) в раздел Обработки - Обработка справочников

Обработка предназначена для поиска картинок и сохранения их в базе данных в качестве изображения конкретной позиции номенклатуры.
Поиск осуществляется с помощью двух поисковых систем: Google и Яндекс.

Предназначена для использования в конфигурации "Управление торговлей 11".

Позволяет быстро и легко находить и сохранять изображения для позиций справочника "Номенклатура".

Обработка может использоваться как в тонком клиенте, так и в веб-клиенте

 

Для поиска изображения необходимо проделать следующие шаги:

 

 

  • Выбираем поисковую систему (по умолчанию "Google")
  • Вводим строку поиска
  • Нажимаем кнопку "Начать поиск"

 

 

 В результаты поиска выводится 20 изображений (4x5)

 

Чтобы прикрепить изображение к конкретной позиции, нажимаем на понравившемся изображении и указываем пункт меню "Выбрать изображение", либо перетаскиваем изображение, зажав правую кнопку мыши. Жмем "Сохранить изменения" и наслаждаемся результатом. Все очень просто!

 

Если в качестве поисковой системы выбран Яндекс, то для изображения будет доступен выбор дополнительных размеров.

Версии:

  1. ImageSearcher.epf - для версий 11.0.5.х и более ранних
  2. ImageSearcher_new.epf - для более поздних версий

 

Похожие разработки:

Поиск картинок в интернете с помощью Google и Яндекс (без дополнительных компонент)

1C: Предприятие 8.2 "Поиск и установка изображений для номенклатуры (УТ 11, поиск в интернете)

 

http://shkuraev.ru

Скачать файлы

Наименование Файл Версия Размер
ImageSearcher.epf
.epf 49,93Kb
19.06.15
362
.epf 49,93Kb 362 Скачать
Описание.zip
.zip 46,31Kb
17.11.14
83
.zip 46,31Kb 83 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Юлия Хомич (Enigmochka) 22.03.11 14:17 Сейчас в теме
Подскажите открываю 1С выбираю эту обработку внешнюю в 1С но ничего не происходит
2. Alxd (salexdv) 29.03.11 16:06 Сейчас в теме
(1) В какой конфигурации открываете?
3. Юлия Хомич (Enigmochka) 22.07.11 13:02 Сейчас в теме
Подскажите открываю 1С выбираю эту обработку внешнюю в 1С но ничего не происходит (выбирала разработку new)

"Управление торговым предприятием для Украины", редакция 1.1.
Разработка конфигурации: "ABBYY Ukraine", 2007-2009
(1.1.15.1)
4. Alxd (salexdv) 22.07.11 13:28 Сейчас в теме
(3) Если честно, никогда не сталкивался с этой конфигурацией.
Не знаю насколько она схожа с УТ 11.
Платформа я так понимаю 8.2, а основное режим запуска какой стоит?
Если стоит "Обычное приложение", то ничего происходить не будет т.к. обработка предназначена для управляемого приложения
Enigmochka; +1 Ответить 1
5. Юлия Хомич (Enigmochka) 22.07.11 13:31 Сейчас в теме
А где посомтреть этот режим запуска подскажите пожалуйста. Заранее спс, очень нужна данная разработка так товаров много вручную не хочется искать каждый товар
6. Alxd (salexdv) 22.07.11 13:32 Сейчас в теме
(5) Надо запустить конфигуратор и в свойствах конфигурации посмотреть
7. Юлия Хомич (Enigmochka) 22.07.11 13:37 Сейчас в теме
Я сейчас в конфигураторе, где посомтреть, извините что так много вопросов но очень нужна данная разработка, буду Вам благодарна. С уважением Юлия
8. Alxd (salexdv) 22.07.11 13:45 Сейчас в теме
(7) Ищите в меню пункт "Конфигурация" -> "Открыть конфигурацию"
Если пункт недоступен, просто нажимаете CTRL+SHIFT+C
Откроется окно конфигурации, на самом верхнем элементе (скорее всего он называется что-то типа УправлениеТорговымПредприятиемДляУкраины и обозначен желтым кружком) щелкаете правой кнопкой и выбираете пункт "Свойства" и в открывшемся окне находите пункт "Основной режим запуска" (3 или четвертый сверху)
9. Юлия Хомич (Enigmochka) 22.07.11 14:06 Сейчас в теме
Я нашла только оно не закрашенное и не позволяет выбрать другой вариант. Может где то нужно поставить галочку? И на что это влияет?
10. Юлия Хомич (Enigmochka) 22.07.11 14:08 Сейчас в теме
Вот на картинке видно
Прикрепленные файлы:
11. Alxd (salexdv) 22.07.11 14:10 Сейчас в теме
(10) К сожалению, это обработка не подойдет под вашу конфигурацию.
Ее можно использовать только в конфигарации "Управление торговлей 11" и конфигурациях на ее основе
12. Юлия Хомич (Enigmochka) 22.07.11 14:15 Сейчас в теме
А почему не подойдет? Может ее можно как то сконвертировать ?
13. Юлия Хомич (Enigmochka) 22.07.11 14:17 Сейчас в теме
ОЧЕНЬ ОЧЕНЬ ОЧЕНЬ ОЧЕНЬ ЖАЛЬ (прямо капец) :-(
14. Юлия Хомич (Enigmochka) 22.07.11 14:17 Сейчас в теме
http://alxd.freedom-vrn.ru/?page_id=2 это ваш сайт? Так я там тоже нашла такую же обработку. Может она будет работать?
15. Alxd (salexdv) 22.07.11 14:19 Сейчас в теме
(14) Сайт мой, но работать она не будет т.к. она написана под конкретную конфигурацию. Она не универсальная
16. Юлия Хомич (Enigmochka) 22.07.11 14:23 Сейчас в теме
Ок я поняла, огромное спасибо за то что пытались помочь.
17. Юлия Хомич (Enigmochka) 22.07.11 14:29 Сейчас в теме
18. Юлия Хомич (Enigmochka) 22.07.11 14:59 Сейчас в теме
Alxd пишет:

(14) Сайт мой, но работать она не будет т.к. она написана под конкретную конфигурацию. Она не универсальная

А если ее доработать?
19. Alxd (salexdv) 22.07.11 15:23 Сейчас в теме
20. Игорь Войнов (igyo) 104 19.08.11 09:03 Сейчас в теме
УТ 11.0.6.9. После выбора картинки не активна кнопка сохранить :(
21. Александр Крутой (Alex@ander) 20.09.11 05:00 Сейчас в теме
22. Александр Киселев (sana78) 01.01.12 19:08 Сейчас в теме
очень полезная штуковина, побольше бы таких
23. Владимир sss (sinjevla) 161 09.04.12 17:47 Сейчас в теме
Может подскажите почему кнопка "Сохранить" не активна.
24. Андрей Балакин (Anri81) 01.06.13 21:07 Сейчас в теме
Подскажите пожалуйста скачал и установил обработку, при запуске выдает ошибку. Как исправить? платформа
1С:Предприятие 8.2 (8.2.18.96)
Управление торговлей, редакция 11.1 (11.1.2.8)
25. Александр Лобачёв (SANILLA) 01.06.13 23:17 Сейчас в теме
Опа, какая полезная обработочка, спасибо огромное, щас попробую.
26. yinfo (FireFox_Manager) 15.07.13 14:02 Сейчас в теме
Подтверждаю ошибку для УТ 11.1.2.9 - Переменная не определена (ФайловыеФункцииКлиентСервер)
27. Виктор Фабриков (fabri) 28 31.07.13 20:54 Сейчас в теме
По поводу ошибки Переменная не определена (ФайловыеФункцииКлиентСервер) - надо всего лиш в модуле формы "ФормаУправляемая"
в коде функции "СоздатьДокументНаОсновеФайла" поменять "ФайловыеФункцииКлиентСервер" на "ОбщегоНазначенияКлиентСервер".
28. Александр Шкураев (salexdv) 1335 05.08.13 09:00 Сейчас в теме
(27) На новых версиях УТ обработку не тестировал. Там в последнее время часто модули удаляются или переименовываются. Если будет время, постараюсь сделать под текущие конфигурации
29. Oleg Bobylev (JeckDigger) 01.10.13 20:11 Сейчас в теме
Подскажите, использую разработку Каталог радиолюбителя там автор использует ваш код для поиска картинок. У меня 1С работает на Linux и поиск не дает результатов. Возможно ли его поправить, чтоб поиск работал мультиплатформенно, или вы используете только Windows механизмы?
Прикрепленные файлы:
30. Евгений Палагин (Jon2011) 73 27.11.13 14:35 Сейчас в теме
Обработка перестала искать картинки! Это у меня что-то сломалось или у всех глючит?
31. Александр Шкураев (salexdv) 1335 27.11.13 14:58 Сейчас в теме
(30) Скорее всего поменялась выдача на поисковике. Надо будет глянуть
32. Евгений Палагин (Jon2011) 73 29.11.13 11:25 Сейчас в теме
(31) salexdv, да, файл от поисковика формируется, а вот скрипт не может идентифицировать картинки.
33. Виталий Довыденко (d_vit) 7 04.12.13 10:50 Сейчас в теме
(30)Удалось ли найти решение.
34. Александр Шкураев (salexdv) 1335 04.12.13 11:11 Сейчас в теме
(33) Пока нет времени. Как сделаю, сразу отпишусь
35. Иван (iones) 164 09.12.13 11:38 Сейчас в теме
оч удобная обработка. Да, изменилась выдача, надо регулярное выражение сменить...копался копался....чет не доходит до меня...
Ждем с нетерпением!
36. Александр Шкураев (salexdv) 1335 10.12.13 10:51 Сейчас в теме
(30)(33)(35) Для Яндекса поправил. А вот гугл совсем поменял выдачу, с ним мне не удалось получить нормального качества картинки, только миниатюры
37. piton66 (piton66) 3 10.12.13 17:25 Сейчас в теме
Скиньте пожалуйста сюда строку регулярного выражения хотя-бы для миниатюр.. Для теста))
38. Александр Шкураев (salexdv) 1335 10.12.13 17:46 Сейчас в теме
(37) Яндекс
"<div class=""b-images-item (?:.*?)""(?:.|\n)*?"html_href":"(.*?)","href":"(.*?)","height":"(.*?)","width":"(.*?)"(?:.|\n)*?"detail_url":"(.*?)"(?:.*?)"thmb_href":"(.*?)&"

Гугл
"<td st yle=.*?break-word"">.*?<a href=""/url\?q=(.*?)"".*?img height=""(.*?)"" src=""(.*?)"" width=""(.*?)"""
39. Александр Шкураев (salexdv) 1335 10.12.13 17:48 Сейчас в теме
(37) Не дает опубликовать тут такое рег.выражение
40. Виталий Довыденко (d_vit) 7 11.12.13 09:53 Сейчас в теме
41. Александр Шкураев (salexdv) 1335 11.12.13 10:23 Сейчас в теме
(40) Наверно, защита от инъекции. В (38) попытался вставить рег.выражение
42. piton66 (piton66) 3 11.12.13 11:08 Сейчас в теме
"<div class=""b-images-item (?:.*?)""(?:.|\n)*?"html_href":"(.*?)","href":"(.*?)","height":"(.*?)","width":"(.*?)"(?:.|\n)*?"detail_url":"(.*?)"(?:.*?)"thmb_href":"(.*?)&" 

Эта строка не вставляется в код яндекса. видно с ковычками что-то не то.
43. Александр Шкураев (salexdv) 1335 11.12.13 14:22 Сейчас в теме
(42) Замените \" на обычную кавычку. Это при публикации комментария сайт сам исковеркал
44. piton66 (piton66) 3 11.12.13 15:20 Сейчас в теме
Пока Порция < КоличествоЭлементов Цикл		
		
		Если Порция < НачальныйЭлемент Тогда
			Порция = Порция + 1;
			Продолжить;
		КонецЕсли;
		
		НомерВызова = ?(Порция = 0, "", "p=" + Порция + "&");
		
		// Запрос страницы HTML
		Если НЕ ПолучитьСтраницу("images.yandex.ru/yandsearch?" + НомерВызова+ "text=" + СтрЗаменить(СокрЛП(ПараметрыПоиска), " ", "+") + "&rpt=image&ed=1", ВремHTML) Тогда
			Возврат Неопределено;
		КонецЕсли;
		
		Текст = "";		
		Файл = Новый ТекстовыйДокумент;
		Попытка
			Файл.Прочитать(ВремHTML, КодировкаТекста.Системная);
			Текст = Файл.ПолучитьТекст();		
		Исключение
			Предупреждение(ОписаниеОшибки());
			Возврат Неопределено;		
		КонецПопытки;
							
		РегулярноеВыражение ="<div class=""b-images-item (?:.*?)""(?:.|\n)*?"html_href":"(.*?)","href":"(.*?)","height":"(.*?)","width":"(.*?)"(?:.|\n)*?"detail_url":"(.*?)"(?:.*?)"thmb_href":"(.*?)&";
		// Поиск регулярного выражения
		мRegExp.Pattern = РегулярноеВыражение;
		Matches = мRegExp.Execute(Текст);
		Вхождений = Matches.Count;
...Показать Скрыть


Не работает. Может сайт не только кавычки позаменял..
Может скриншот приложите вашего кода.
45. Александр Шкураев (salexdv) 1335 11.12.13 15:49 Сейчас в теме
46. piton66 (piton66) 3 11.12.13 18:12 Сейчас в теме
Спасибо. Но что-то не выходит ни с гуглом ни с яндексом.
В яндексе странуцу пустую получает. Что у вас тут написано в вашей обработке?
// Запрос страницы HTML
		Если НЕ ПолучитьСтраницу("images.yandex.ru/yandsearch?" + НомерВызова+ "text=" + СтрЗаменить(СокрЛП(ПараметрыПоиска), " ", "+") + "&rpt=image&ed=1", ВремHTML) Тогда
			Возврат Неопределено;
		КонецЕсли;
...Показать Скрыть
47. Александр Шкураев (salexdv) 1335 12.12.13 09:20 Сейчас в теме
(46) У меня все абсолютно тоже самое написано и работает
48. Виталий Довыденко (d_vit) 7 12.12.13 12:55 Сейчас в теме
(47) Интересное кино у всех все написано, но не у всех работает - чудеса.
Может подскажете почему у одних работает, а у других не работает?
49. Александр Шкураев (salexdv) 1335 12.12.13 13:15 Сейчас в теме
(46)(48) Вы прикрепленную обработку давно скачивали? Она работает?
Обновлял ее 10.12.2013. В ней такой же код получения HTML, как и (46)
50. Oleg Bobylev (JeckDigger) 12.12.13 13:36 Сейчас в теме
(49) salexdv, не скачивал, установил конфигурацию - она была в составе, под linux отказалась работать, в среде винды не пробовал. Предположительно использует IE для поиска через ocx библиотеку или надстройку какую. В общем не очень доволен, хоть бы параметры автор добавил для настройки поиска или описание предоставил.
51. Oleg Bobylev (JeckDigger) 12.12.13 13:39 Сейчас в теме
Параметры настройки поиска необходимо вывести наружу, чтоб в код не лазить. Не всегда есть возможность править код.
52. Александр Шкураев (salexdv) 1335 12.12.13 13:49 Сейчас в теме
(50) Как это дело работает по linux не знаю, обработка делалась когда о нормальной работе в этой среде и речи не шло. Если будет время, обязательно проверю.
хоть бы параметры автор добавил для настройки поиска или описание предоставил

Описание чего? Я сам не знаю как поисковики завтра изменят свою выдачу. Каждый раз, как они поменяют, приходится сидеть и заново изобретать выражение для вытаскивания изображений, и не всегда это получается быстро.
53. piton66 (piton66) 3 12.12.13 13:54 Сейчас в теме
Нормальная обработка. Работала отлично долгие годы)). За что автору большое спасибо.
Сейчас только гугль что-то там поменял и начала косячить.
В данный момент у меня гугл страницу получает, но вот с регулярным выражением там затык.
А яндекс страницу не получает. Сохраненный временный файл пустой. Хотя если строку руками в браузер забить, то всё вроде норм. В браузере поиск идет.
54. Евгений Палагин (Jon2011) 73 12.12.13 14:00 Сейчас в теме
Свежая обработка от 10.12.13 - рулит!
55. Oleg Bobylev (JeckDigger) 12.12.13 14:02 Сейчас в теме
Не могу оценить обработку по достоинству, т.к. не видел ее в работе. В том виде, как она есть в конфигурации она не работает.
56. Oleg Bobylev (JeckDigger) 12.12.13 14:03 Сейчас в теме
(54) Jon2011, Исправления будут в вашей разработке?
57. Александр Шкураев (salexdv) 1335 12.12.13 14:13 Сейчас в теме
(55) Можете выложить ёё куда-нибудь в вашем виде? Попробую разобраться
58. Евгений Палагин (Jon2011) 73 12.12.13 14:40 Сейчас в теме
(56) JeckDigger, данная обработка берет только миниатюры с Гугля, поэтому подождем.
Может автор найдет решение как из Гугля вытягивать большие картинки.
59. Евгений Палагин (Jon2011) 73 12.12.13 14:51 Сейчас в теме
(57) salexdv, Это та же самая обработка, что и ваша. Просто она не может найти скрипт VBScript.RegExp в linux.

Функция ПолучитьОбработчикВыражений(Отказ = Ложь) Экспорт
	
	// Создаем объект "VBScript.RegExp" для работы с регулярными выражениями
	Попытка
		мRegExp = Новый COMОбъект("VBScript.RegExp");  
	Исключение	
		Объект.Состояние = "Не удалось создать объект ""VBScript.RegExp""." + Символы.ПС + ОписаниеОшибки();		
		Отказ = Ложь;
		Возврат Неопределено;
	КонецПопытки;

	мRegExp.IgnoreCase = Истина; //Игнорировать регистр
	мRegExp.Global = Истина; //Поиск всех вхождений шаблона		
	
	Возврат мRegExp;
	
КонецФункции
...Показать Скрыть
60. piton66 (piton66) 3 12.12.13 15:15 Сейчас в теме
61. Александр Шкураев (salexdv) 1335 12.12.13 15:41 Сейчас в теме
(59) Ну в linux есть встроенные средства для работы с рег.выражениями. Даже интересно стало, попробую сделать работающую модификацию.
62. Александр Шкураев (salexdv) 1335 12.12.13 15:55 Сейчас в теме
(60) Замените процедуру на указанную ниже
Процедура ЗаполнитьРезультатЯндекс(Результат, Источник)
	
	Ссылка = СтрЗаменить(Источник.Item(1), "%2F", "/");
	ВремСтроки = СтрЗаменить(Ссылка, "/", Символы.ПС);
	ЧислоВременныхСтрок = СтрЧислоСтрок(ВремСтроки);
	Если ЧислоВременныхСтрок > 1 Тогда
		ПолноеИмя = СтрПолучитьСтроку(ВремСтроки, ЧислоВременныхСтрок);
		ДопСтроки = СтрЗаменить(ПолноеИмя, ".", Символы.ПС);
		ЧислоДопСтрок = СтрЧислоСтрок(ДопСтроки);
		Если ЧислоДопСтрок > 1 Тогда
			Расширение = СтрПолучитьСтроку(ДопСтроки, ЧислоДопСтрок);
			Имя = "";
			Для Сч = 1 По ЧислоДопСтрок-1 Цикл
				Имя = Имя + СтрПолучитьСтроку(ДопСтроки, Сч) + ".";
			КонецЦикла;
			ДлинаИмени = СтрДлина(Имя);
			Если ДлинаИмени > 0 Тогда
				Имя	= Лев(Имя, ДлинаИмени - 1);
			КонецЕсли;
			Результат.Имя = Имя;
			Результат.Расширение = Расширение;
		КонецЕсли;		
		Результат.ПолноеИмя = ПолноеИмя;
	КонецЕсли;
	
	Результат.Ссылка = Ссылка;
	Результат.Миниатюра = Источник.Item(5);
	Результат.Ширина = Источник.Item(3);
	Результат.Высота = Источник.Item(2);
	Результат.Система = 1;
	ДополнительнаяИнф = СтрЗаменить(Источник.Item(4), "&", "&");
	ДополнительнаяИнф = Лев(ДополнительнаяИнф, СтрДлина(ДополнительнаяИнф) - 1);
	Результат.Дополнительно = ДополнительнаяИнф;
	
КонецПроцедуры
...Показать Скрыть

И в процедуре НайтиКартинкиЯндекс замените Если SubMatches.Count = 5 Тогда на Если SubMatches.Count = 6 Тогда
63. piton66 (piton66) 3 12.12.13 18:16 Сейчас в теме
Можете файл или скриншот выложить, а то опять все символы перепутались.
64. Александр Шкураев (salexdv) 1335 12.12.13 18:48 Сейчас в теме
66. piton66 (piton66) 3 13.12.13 11:01 Сейчас в теме
Не работает..
Вот тут по яндексу даже страницу не получает. ВремHTML пустой.
// Запрос страницы HTML
		Если НЕ ПолучитьСтраницу("images.yandex.ru/yandsearch?" + НомерВызова+ "text=" + СтрЗаменить(СокрЛП(ПараметрыПоиска), " ", "+") + "&rpt=image&ed=1", ВремHTML) Тогда
			Возврат Неопределено;
		КонецЕсли;
...Показать Скрыть


По гуглу , в этом же месте страницу получает.
67. Виталий Довыденко (d_vit) 7 13.12.13 11:16 Сейчас в теме
(66)Аналогичная проблема.
Может ли это быть связано с моим местоположением (Казахстан)?
68. Александр Шкураев (salexdv) 1335 13.12.13 11:34 Сейчас в теме
(66)(67) Ну тогда даже не знаю чем еще могу помочь. Присланная вами обработка у меня все получает и показывает (могу прислать скрин). Яндекс бывает банит запросы, если они слишком часто идут, либо еще что-то не нравится. Можно попробовать поиграться с заголовками HTTP соединения
69. Александр Шкураев (salexdv) 1335 13.12.13 11:35 Сейчас в теме
(66) С другого компьютера (IP) пробовали запускать?
70. Виталий Довыденко (d_vit) 7 13.12.13 11:50 Сейчас в теме
Спасибо за оперативные ответы.
Попробую с другого компьютера открыть.
71. Виталий Довыденко (d_vit) 7 13.12.13 12:02 Сейчас в теме
(68)А что Вы имеете в виду
Можно попробовать поиграться с заголовками HTTP соединения
72. piton66 (piton66) 3 13.12.13 12:07 Сейчас в теме
Яндексом я не пользовался раньше, только гуглом.
Странность ещё в том, что если строку поиска забить в браузер напрямую - то всё показывает.
73. Александр Шкураев (salexdv) 1335 13.12.13 12:22 Сейчас в теме
(71)
А что Вы имеете в виду

HTTPСоединение.Получить(<Источник>, <ИмяВыходногоФайла>, <Заголовки>)
74. Александр Шкураев (salexdv) 1335 13.12.13 12:24 Сейчас в теме
(72) Это не странность. Яндекс точно знает когда "бот" запрашивает страницу, а когда человек через браузер. Во втором случае проблем не возникает.
Вы попробуйте на поисковик через HTTPСоединение покидать запросы без пауз, очень скоро обломаетесь, хотя через браузер все будет работать
75. Виталий Довыденко (d_vit) 7 13.12.13 12:40 Сейчас в теме
(74)А есть вариант "обломать" яндекс и получить от него интересующую информацию (картинки) и аналогично по гуглу
76. Александр Шкураев (salexdv) 1335 13.12.13 12:49 Сейчас в теме
77. Виталий Довыденко (d_vit) 7 13.12.13 13:10 Сейчас в теме
Я конечно очень сильно извиняюсь, но как
Заголовки подделать
я не знаю и поэтому прошу Вас помочь в этом вопросе.
78. Александр Шкураев (salexdv) 1335 13.12.13 13:36 Сейчас в теме
(77) Когда то пытался сделать, так и не получилось
79. Виталий Довыденко (d_vit) 7 13.12.13 14:04 Сейчас в теме
(78)Нет не пытался.
Покажите пожалуйста пример.
80. piton66 (piton66) 3 16.12.13 16:01 Сейчас в теме
Не хочет яндекс у меня работать. Буду гугл ждать.
Автор. сделайте строку регла выражения для гугла пожалуйста))
81. Александр Шкураев (salexdv) 1335 16.12.13 16:07 Сейчас в теме
(80) Да я бы с радостью, но пока в их выдаче ничего путного нет. А на другом компе пробовали запускать поиск?
Неужто вообще пустую страницу возвращает?
82. piton66 (piton66) 3 16.12.13 18:10 Сейчас в теме
83. Евгений Палагин (Jon2011) 73 16.12.13 23:40 Сейчас в теме
(82) piton66, Кроме самого регулярного выражения в обработке также и в процедуре "заполнение результатов..." надо кое-что изменить. Ни у отладчиком желательно посмотреть текст от поисковика получаем (должна быть большая портянка)?
84. Александр Шкураев (salexdv) 1335 17.12.13 09:24 Сейчас в теме
(82) Попробуйте заменить процедуру получения страницы на следующую
Функция ПолучитьСтраницу(Адрес, ИмяФайла) Экспорт
	
	Перем Соединение;
		
	Попытка 		
		// Объект для работы с HTTP-запросами
		Соединение = Новый COMОбъект("WinHttp.WinHttpRequest.5.1"); 
	Исключение     
		Объект.Состояние = "Не удалось инициализировать Microsoft WinHTTP:" + Символы.ПС + ОписаниеОшибки();
		Возврат Ложь;
	КонецПопытки; 
	   
	Попытка
		// Настройки прокси
		Соединение.SetProxy(2, Объект.АдресПрокси + ":" + Формат(Объект.ПортПрокси, "ЧГ=0"));
	Исключение
		Объект.Состояние = "Не удалось установить параметры прокси-сервера:" + Символы.ПС + ОписаниеОшибки();
		Возврат Ложь;
	КонецПопытки;
	
	// Таймаут
	Соединение.SetTimeouts(5000, 5000, 5000, 5000);
	
	Попытка 
		// Запрос файла
		Соединение.Open("GET", "http://" + Адрес, Ложь);
		Соединение.Send();		
		// Сохранение ответа на диск
		Stream = Новый COMОбъект("ADODB.Stream");
		Stream.Type = 1;
		Stream.Open();
		Stream.Write(Соединение.ResponseBody);
		Stream.SaveToFile(ИмяФайла, 2);
		Stream.Close();
		Stream = Неопределено;		
		Соединение = Неопределено;
		Возврат Истина;
	Исключение   		
		Объект.Состояние = "Не удалось получить ответ сервера:" + Символы.ПС + ОписаниеОшибки();				
		Возврат Ложь;
	КонецПопытки;
		
КонецФункции
...Показать Скрыть
85. piton66 (piton66) 3 17.12.13 10:09 Сейчас в теме
О , круто. Так работает.
А что делать если прокси нет?
86. Александр Шкураев (salexdv) 1335 17.12.13 10:12 Сейчас в теме
(85) Сорри, забыл про это тогда так:

Если Объект.ИспользоватьПрокси Тогда
    Попытка
        // Настройки прокси
        Соединение.SetProxy(2, Объект.АдресПрокси + ":" + Формат(Объект.ПортПрокси, "ЧГ=0"));
    Исключение
        Объект.Состояние = "Не удалось установить параметры прокси-сервера:" + Символы.ПС + ОписаниеОшибки();
        Возврат Ложь;
    КонецПопытки;
КонецЕсли;
...Показать Скрыть
87. piton66 (piton66) 3 17.12.13 11:45 Сейчас в теме
88. Виталий Довыденко (d_vit) 7 20.12.13 08:02 Сейчас в теме
Огромное спасибо. Работает.
Но хотелось бы задать вопрос по поводу Гугла, есть ли вариант того, что от Гугла можно будет получать картинки как раньше?

89. Александр Шкураев (salexdv) 1335 20.12.13 08:56 Сейчас в теме
(88) Пока, к сожалению, без вариантов. Из их выдачи можно получить только миниатюры
90. Сергей Алферов (SunShinne) 591 15.06.14 21:27 Сейчас в теме
Автору спасибо!!! НО: пришлось доработать конфигурацию, что бы отключить безопасный режим для внешних обработок, и яндекс не работает, и только миниатюру берет :(
91. Сергей Алферов (SunShinne) 591 15.06.14 21:29 Сейчас в теме
видимо надо парсер писать
92. Сергей Алферов (SunShinne) 591 15.06.14 21:31 Сейчас в теме
и еще перестало работать через несколько карточек :(
93. Александр Шкураев (salexdv) 1335 15.06.14 22:46 Сейчас в теме
(92) Поисковики постоянно меняют структуру выдачи, завтра посмотрю и постараюсь подправить
94. Максим Литвинов (maksa2005) 86 19.10.14 12:25 Сейчас в теме
(93) salexdv, Как можно увеличить размер картинке при поиске? очень актуально....а то в основном 100-150*80-150
95. Сергей Валутин (Bacemo) 19.10.14 15:20 Сейчас в теме
такое еще не видел нигде. Сейчас опробую.
96. Евгений Палагин (Jon2011) 73 20.10.14 08:40 Сейчас в теме
Яндекс тупо молчит. Гугль, - только миниатюры выдает. Автор, выручай. Если нет времени халяву делать, переводи обработку в платную. Думаю рубликов 500 ни кто не пожалеет.
97. Александр Шкураев (salexdv) 1335 20.10.14 09:26 Сейчас в теме
(94)(96) Размер зависит не от меня, а от того, что предоставляет поисковик. Времени с этим разбираться сейчас действительно нет. На инфостарте были платные аналоги. Например вот
98. Александр Шкураев (salexdv) 1335 31.10.14 08:53 Сейчас в теме
(94)(96) Сделал под новый формат. Теперь поиск работает, как и прежде. Не знаю только, надолго ли это.
P.S. Проверял на версии 11.1.2.15.
99. Евгений Васильченко (vas2005) 4 20.03.15 21:57 Сейчас в теме
Доброго времени суток!
Подскажите пожалуйста, я прикрутил эту обработку к существующей конфигурации, вроде все работает(допилил напильником) но есть один проблемммммм, кнопка "Сохранить изменения" не активна((((



что может быть???

Заранее спасибо!!
Прикрепленные файлы:
100. Александр Шкураев (salexdv) 1335 23.03.15 09:05 Сейчас в теме
(99) vas2005, здравствуйте!
Если кнопка не активна, значит элемент номенклатуры, для которого картинка должна сохранятся, не заполнен.