gifts2017

Обработка "Универсальная панель функций"

Опубликовал Эльвира Никитина (Elv_Ra) в раздел Администрирование - Системное

Универсальная панель функций для 1С "Комплексная автоматизация" 8.2.
Обработка содержит настройки вкладок панели по различным интерфейсам.

Универсальная панель функций для 1С "Комплексная автоматизация" 8.2.

 

Обработка содержит настройки вкладок панели по различным интерфейсам.

Если используется как внешняя обработка, нужно прописать код в процедуре ПриНачалеРаботыСистемы():

  //
ТекСсылка=Справочники.ВнешниеОбработки.НайтиПоНаименованию("Панель функций");
ИмяФайла = ПолучитьИмяВременногоФайла();
ДвоичныеДанные = ТекСсылка.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);
Если ТекСсылка.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет Тогда
    Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла);
Иначе
    Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
КонецЕсли;
Форма.Открыть();
УдалитьФайлы(ИмяФайла); 
  //

 

В основу обработки заложена типовая обработка "Панель функций" из конфигурации 1С "Бухгалтерия предприятия" 8.2.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Панель функций.epf
.epf 205,85Kb
25.06.12
362
.epf 205,85Kb 362 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

0. Эльвира Никитина (Elv_Ra) 23.03.11 19:57
Универсальная панель функций для 1С "Комплексная автоматизация" 8.2.
Обработка содержит настройки вкладок панели по различным интерфейсам.


Перейти к публикации

1. Олег Макаров (movled) 23.03.11 19:57
интересно конечно, не хватало этой панели в комплексной, но видимость вкладок в различных интерфейсах нужно настраивать. Совсем ни к чему кладовщику, например, видеть вкладку "Зарплата"
2. Elva_ (Elv_Ra) 24.03.11 06:25
Я прописала настройку для тех ролей, которые нужны мне были. Далее уже разберетесь ) Вот код:

ИнтерфейсКадры = ГлавныйИнтерфейс.КадровыйУчетОрганизаций.Видимость;
Если ИнтерфейсКадры Тогда
ЭлементыФормы.ОсновнаяПанель.Страницы.Кадры.Раскрыта = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Банк.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Касса.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.НМА.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.ОС.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Производство.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Покупка.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Продажа.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Склад.Видимость = Ложь;
КонецЕсли;

ИнтерфейсЗарплата = ГлавныйИнтерфейс.РасчетЗарплатыОрганизаций.Видимость;
Если ИнтерфейсЗарплата = Истина Тогда
ЭлементыФормы.ОсновнаяПанель.Страницы.Зарплата.Раскрыта = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.НМА.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.ОС.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Производство.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Покупка.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Продажа.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Склад.Видимость = Ложь;
КонецЕсли;

ИнтерфейсПолный = ГлавныйИнтерфейс.Полный.Видимость;
Если ИнтерфейсПолный Тогда
ЭлементыФормы.РегламентныеДокументы.Видимость = Ложь;
ЭлементыФормы.ОперацияБух.Видимость = Ложь;
ЭлементыФормы.РегистрБухгалтерииХозрасчетный.Видимость = Ложь;
ЭлементыФормы.ЗаписьКУДиР.Видимость = Ложь;
ЭлементыФормы.ОборотноСальдоваяВедомостьХозрасчетный.Видимость = Ложь;
ЭлементыФормы.ОборотноСальдоваяВедомостьПоСчетуХозрасчетный.Видимость = Ложь;
ЭлементыФормы.АнализСчетаХозрасчетный.Видимость = Ложь;
ЭлементыФормы.КарточкаСчетаХозрасчетный.Видимость = Ложь;
ЭлементыФормы.ОбщиеОбъектыРегламентированнойОтчетности.Видимость = Ложь;
ЭлементыФормы.НастройкаПараметровУчета.Доступность = Ложь;
ЭлементыФормы.НастройкиПрограммы.Доступность = Ложь;
ЭлементыФормы.УчетнаяПолитикаОрганизаций.Доступность = Ложь;
ЭлементыФормы.УчетнаяПолитикаПоПерсоналу.Доступность = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Банк.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Касса.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.НМА.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.ОС.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Производство.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Покупка.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Продажа.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Зарплата.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Кадры.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.ЗарплатаИКадры.Видимость = Ложь;
ЭлементыФормы.ОсновнаяПанель.Страницы.Склад.Видимость = Ложь;
КонецЕсли;

ИнтерфейсБух = ГлавныйИнтерфейс.БухгалтерскийиНалоговыйУчет.Видимость;
Если ИнтерфейсБух Тогда
ЭлементыФормы.ОсновнаяПанель.Страницы.Производство.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Банк.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Касса.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.НМА.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.ОС.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Предприятие.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Покупка.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Продажа.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Зарплата.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Кадры.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.ЗарплатаИКадры.Видимость = Истина;
ЭлементыФормы.ОсновнаяПанель.Страницы.Склад.Видимость = Истина;
КонецЕсли;
3. Elva_ (Elv_Ra) 24.03.11 06:26
Хотя.. чтобы сделать обработу универсальной, надо бы организовать настройку видимости.
4. Вячеслав Стеценкл (slava-fa) 24.03.11 12:19
Это просто бомба. Ей бы универсальности. В УПП 1.3 не работает( Автору однозначно +, и надежды на продолжение банкета :D
5. Elva_ (Elv_Ra) 24.03.11 12:23
Все будет, работаем над этим )
6. Дария Горная (gdo29) 27.03.11 15:36
подскажите, что не так????
сама панель не активна, в панели есть только вкладка Предприятие, при нажатии на "настройка" выдает:
{ОбщийМодуль.УправлениеПользователями.Модуль(67)}: Поле объекта не обнаружено (ОткрыватьПриЗапускеПанельФункций)
НастройкаСсылка = ПланыВидовХарактеристик.НастройкиПользователей[Настройка];
7. Elva_ (Elv_Ra) 28.03.11 07:04
Такой режим отображается для пользователя с полным интерфейсом. Код приведен выше. Это Процедура УстановитьВидимость().
8. Андрей Дегтярев (dagovich) 19.12.11 09:44
Скажите пожалуйста, а есть ли возможность запускать панель функций в КА автоматически при заходе пользователя не изменяя стандартный код (т.е. не снимая с поддержки конфу)? Может где-нибудь какой-нибудь типа автозапуск?
9. Станислав Бабицкий (websamson) 23.12.11 05:35
Держи плюс. Только имя кнопки "КлиентБанк" не верно :-)
10. Elva_ (Elv_Ra) 12.01.12 12:44
Скорее всего нет, прописывать запуск обработки придется..
11. Oralbek (kozan) 27.01.12 11:12
У кого есть еще такие обработки?
12. Oralbek (kozan) 27.01.12 11:19
Не подскажите как самому написать простенькую панель, чтобы там просто отображались документы и справочники??? и чтобы она отображалась при запуске!!!
13. юрий гулидов (gull22) 18.06.12 15:46
Спасибо автору, именно его панель явилась решающим аргументом для согласия бухгалтеров работать в КА. Очень их пугало наличие интерфейсов. Увы, человеческий фактор - "Дай картинку" и "Хочу как в Бухгалтерии".
sasafa; Elv_Ra; +2 Ответить
14. Elva_ (Elv_Ra) 25.06.12 13:08
15. Alex Misanets (Misanets) 25.06.12 13:50
(8) dagovich, как вариант положить ее на общедоступный сетевой ресурс добавить ключ запуска с ссылкой на эту обработку, ключ к примеру следующий:
"C:\Program Files\1cv82\8.2.15.301\bin\1cv8.exe" /enterprise /execute"\\server\Панель функций.epf"
16. Олег Владимирович (olezhe) 24.08.12 15:55
Скачал, посмотрел и плюсанул. Прикрутил во внешние обработки на рабочую базу. Зачёт.
17. Олег Владимирович (olezhe) 24.08.12 16:01
18. Олег Владимирович (olezhe) 24.08.12 16:10
(15) В свойствах информационной базы на последнем шаге в Дополнительных параметрах запуска достаточно указать вот это ваше /execute"\\server\Панель функций.epf" Это лучше, чем ярлык отдельный делать. Проверил, работает.
19. Игорь Осиф (Anaboliki) 31.01.13 13:15
/execute"\\server\Панель функций.epf"
olezhe, все супер, работает!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
20. Гость 06.02.16 16:53
Подскажите пожалуйста, как перемещаться между вкладками на форме обработки в конфигураторе?
Надо изменить ссылку на вкладке Кадровый учет, но как открыть эту вкладку не соображу, ни одна из комбинаций клавиш не работает. А по умолчанию открыта вкладка "Предприятие".
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа