gifts2017

Сравнение остатков и оборотов регистров бухгалтерии при переходе с БП 1.6 на БП 2.0

Опубликовал Maximilian Alekseevich (1cmax) в раздел Отчеты - Анализ учета

Подарок от фирмы 1с - новая редакция 2.0 обернулась геморроем.. И хоть правила обмена отлажены все равно расхождения между 1.6 и 2.0 значительные, а отчет о сравнении ведомостей - как иголка в стоге сена. Данная обработка позволяет сравнить остатки или обороты в двух базах и вывести подробный отчет по отличиям в разрезе субконто и распечатать в удобном виде для бухгалтера, который будет все это исправлять )

Обработку открываем в базе 2.0, через ком подключаемся к 1.6, выбираем необходимые ресурсы, субконто и организацию.

Возможности:

- выбор локально установленных файловых информационных баз из списка

- выбор уровня детализации по субконто

- выбор остатков/оборотов

- установка порядка округления позволяет выбрать погрешность с которой устанавливается сравнение

(-1) до десятков

0 - до единиц

1 - до десятых

- отбор по конткретной организации

- настройка цветов для различающихся, совпадающих и ненайденных строк

- вывод в удобном виде на печать

- разворачиваение веток дерева результата

 

Создано и оттестировано на 8.1 (конвертированная под 8.2 прилагается )

БП 2.0.19.13 и БП 1.6.30.7

 

На создание вдохновила публикация,

http://infostart.ru/public/21382/

автору отдельное спасибо!

Скачать файлы

Наименование Файл Версия Размер
СравнениеОстатковОборотов_16_20_81 807
.epf 29,45Kb
10.04.11
807
.epf 29,45Kb Скачать
СравнениеОстатковОборотов_16_20_82 239
.epf 31,33Kb
10.04.11
239
.epf 31,33Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Vitaly In-Touch (stail_en) 25.03.11 09:26
2. Александр Медведев (anig99) 25.03.11 10:52
3. Александр Медведев (anig99) 25.03.11 12:01
(1) потому что конвертировать из 8.1 в 8.2 можно, а обратно - фиг
4. Maxval (maxval) 25.03.11 18:19
stail_en пишет:

а почему для 8.1?

вообще-то для 8.2 уже конвертировано :) открываем закладку файлы
5. Алексей Заватский (AlexeyVZ) 27.03.11 20:33
У мну такая ситуевина:

1.6 на 8.1 було
2.0 на 8.2 щас

мне нужно конвертануть 1.6 на 8.2, потом использовать для 8.2?
6. Андрей К. (Abbra) 27.03.11 22:34
При попытке подключения к информационной базе произошла ошибка:
Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V81.COMConnector.1): Ошибка при выполнении операции с информационной базой
Несовместимая версия файла базы данных 'I:\_1C\CLIENTS\ПАС\25-03-2011\Предприниматель-25-03-2011-82/1Cv8.1CD'


обе базы 8.2 и обработка соответственно тоже
в чем может быть причина?
7. Александр Медведев (anig99) 27.03.11 22:57
(6) V81.COMConnector заменить на V82.COMConnector
8. Андрей К. (Abbra) 27.03.11 23:11
anig99,
спасибо


в обработке заменил
ВерсияПлатформыИнформационнойБазыДляПодключения = "V81";
на
ВерсияПлатформыИнформационнойБазыДляПодключения = "V82";


заработало
9. Андрей К. (Abbra) 27.03.11 23:17
Вообще при переносе первый раз вижу такое, что остатки по 41 счету перенеслись "как бы" не на 01.01.11, а на некоторую предстоящую дату, причем для каждого товара разную. При этом по 10 счету все нормально. Правила переноса последние от 23.03.2011 г. В чем может быть причина?
Предыдущие правила вообще ересь даже не похожую на правду переносят.
10. Maximilian Alekseevich (1cmax) 28.03.11 00:15
upd
добавил в форму переключатели для версии платформы
11. Алексей К (Shum23str) 29.03.11 13:22
Чтото у меня вся колонка "Значение" пустое?
Не подскажите почему?
У меня 1.6.30.6 и 2.0.20.9
12. креек фелер (GoodWinSpr) 29.03.11 18:19
налоговые сопоставляет?
13. sbv2005 (sbv2005) 30.03.11 12:17
Интересная обработка. Я написал тоже для сравнения БП 1.6 и БП 2.0, но в виде оборотной ведомости: http://infostart.ru/public/83429/
14. Maximilian Alekseevich (1cmax) 31.03.11 01:48
GoodWinSpr пишет:

налоговые сопоставляет?

нет, так как сравнение идет по одинаковым измерениям и ресурсам одинковых видов регистра бухгалтерии.
а налогового плана счетов как известно в 2.0 нет
15. Maximilian Alekseevich (1cmax) 31.03.11 01:51
Shum23str пишет:
подскажите

поле "Значение" - 2.0
Если все галочки поставлены, то возможно в базе 2.0 нет соответствующих данному разрезу по субконто остатков/оборотов,
что достаточно часто встречается
16. Maximilian Alekseevich (1cmax) 10.04.11 15:54
upd
добавлена возможность выбора в зависимости от платформы

локально установленных файловых информационных баз из списка

сделано с использованием (vbscript)
17. Дима (diman85) 25.09.11 19:52
Интересная обработка.Позволила сэкономить время
18. Галина Злобина (gala2009) 07.10.11 18:46
мы как раз переходим, созрели наконец, пригодится
19. Юрий (YuryKr) 12.10.11 22:31
Полезная обработка - баги все вылезли. время действительно сэкономили и все проверили.
20. Maximilian Alekseevich (1cmax) 12.10.11 22:34
Рад, что вам помогло. Не забываем плюсовать :)
21. Nata_07 (nata_07) 31.10.11 14:04
спасибо, пригодилось (для сравнения двух 2.0, кстати, тоже)
22. Дмитрий _________ (cv_admin) 22.06.12 09:58
Спасибо автору!
Помогает найти большинство косяков.
Плохо, что она не показывает результаты в виде таблицы значений (см. аттач) пришлось немного дописать
=============
Процедура СтрокиТЗПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
// Вставить содержимое обработчика.
сч=1;

если Не ДанныеСтроки.Дебет16=ДанныеСтроки.Дебет20 Тогда
ОформлениеСтроки.Ячейки.Дебет16.ЦветФона=ЦветРазличающихся;
ОформлениеСтроки.Ячейки.Дебет20.ЦветФона=ЦветРазличающихся;
КонецЕсли;

если Не ДанныеСтроки.Кредит16=ДанныеСтроки.Кредит20 Тогда
ОформлениеСтроки.Ячейки.Кредит16.ЦветФона=ЦветРазличающихся;
ОформлениеСтроки.Ячейки.Кредит20.ЦветФона=ЦветРазличающихся;
КонецЕсли;

КонецПроцедуры

=== Строка 99 - заменить на кусок кода
СтрокаЗаписи0=СтрокаОбъекта.Строки.Добавить();
СтрокаЗаписи0.НеНашли = НЕ Нашли;
СтрокаЗаписи0.Различаются = Истина;
СтрокаЗаписи0.Имя=Строка(Счетчик);
СтрокаЗаписи=СтрокаЗаписи0.Строки.Добавить();
СтрокаЗаписи.Имя="Измерения";

НоваяСтрокаТЗ=СтрокиТЗ.Добавить();

Для Каждого Измерение из Измерения Цикл
СтрокаИзмерения=СтрокаЗаписи.Строки.Добавить();
СтрокаИзмерения.Имя=?(Нашли,НайтиОбъект(стр[Измерение.Значение]),ВСтрокуCOM(стр[Измерение.Значение]));

//ДмитрийК
Если Нашли Тогда

Если Найти(Измерение.Значение,"Субконто")>0 Тогда
НоваяСтрокаТЗ[Измерение.Значение]=СтрокаИзмерения.Имя;
ИначеЕсли Измерение.Значение="Счет" ТОгда
НоваяСтрокаТЗ[Измерение.Значение]=СтрокаИзмерения.Имя;
КонецЕсли;


КонецЕсли;

КонецЦикла;

СтрокаЗаписи=СтрокаЗаписи0.Строки.Добавить();
СтрокаЗаписи.Имя="Ресурсы";
Для Каждого Ресурс из Ресурсы Цикл
Для Каждого Приставка2 из Приставка2М Цикл
СтрокаЗначения=СтрокаЗаписи.Строки.Добавить();
СтрокаЗначения.Имя=""+Ресурс.Значение+Приставка+Приставка2;
//СтрокаЗначения.Значение
СтрокаЗначения.Значение2=ОКР(стр[Ресурс.Значение+Приставка+Приставка2],Ресурс.РазрядностьДробнойЧасти);
Если Нашли Тогда
//СтрокаЗначения.Значение2
СтрокаЗначения.Значение=ОКР(стр1[Ресурс.Значение+Приставка+Приставка2],Ресурс.РазрядностьДробнойЧасти);
КонецЕсли;

Если Найти(СтрокаЗначения.Имя,"Дт")>0 Тогда
НоваяСтрокаТЗ.Дебет16=Число(СтрокаЗначения.Значение2);
НоваяСтрокаТЗ.Дебет20=Число(СтрокаЗначения.Значение);
ИначеЕсли Найти(СтрокаЗначения.Имя,"Кт")>0 Тогда
НоваяСтрокаТЗ.Кредит16=Число(СтрокаЗначения.Значение2);
НоваяСтрокаТЗ.Кредит20=Число(СтрокаЗначения.Значение);
КонецЕсли;

КонецЦикла;

КонецЦикла;

Если НоваяСтрокаТЗ.Дебет16=НоваяСтрокаТЗ.Дебет20 И НоваяСтрокаТЗ.Дебет20=НоваяСтрокаТЗ.Кредит20 Тогда
СтрокиТЗ.Удалить(НоваяСтрокаТЗ);
КонецЕсли;
Прикрепленные файлы: