gifts2017

Прикол над пользователями. 1 апреля

Опубликовал Serj (Serj1C) в раздел Программирование - Работа с интерфейсом

Завтра первое апреля. День смеха)) Разбавление обычных будней.
При открытии формы раскрашивает цветами радуги табличную часть.

 

 

При открытии формы раскрашивает цветами радуги табличную часть.
Выглядит очень  симпатично.

Реализовано в глобальном модуле:

Раскрашивать можно табличные части, таблицы значений и списки (справочников, документов и т.д.)

Перем глМассивЦветов; // 01.04.2011

Перем глГСЧ; // 01.04.2011


#Если Клиент Тогда
Функция РаскраситьСтрокиРадиШутки() Экспорт // 01.04.2011

    
Если Формат(ТекущаяДата(), "ДФ=ddMM")="0104" Тогда
        Возврат Ложь;
    КонецЕсли;

    Если 
глГСЧ.СлучайноеЧисло(0, 100)>13 Тогда
        Возврат Ложь;
    КонецЕсли;

    Возврат Истина;

КонецФункции

Процедура 
РаскраситьТЧ(Элемент, ОформленияСтрок) Экспорт  // 01.04.2011
    
Попытка

        
Сч = 0;
        
макс = глМассивЦветов.Количество();
        
ЭтоТЗ = ТипЗнч(Элемент.Значение)=Тип("ТаблицаЗначений") Или Найти(ТипЗнч(Элемент.Значение), "табличная часть")>0;

        Для Каждого 
Оформление Из ОформленияСтрок Цикл

            Если 
ЭтоТЗ Тогда
                
Оформление.ЦветФона = глМассивЦветов[ Элемент.Значение.Индекс(Оформление.ДанныеСтроки) % макс];
            Иначе
                
Оформление.ЦветФона = глМассивЦветов[ Сч % макс ];
                
Сч = Сч+1;
            КонецЕсли;

        КонецЦикла;

    Исключение
    КонецПопытки;
КонецПроцедуры
#КонецЕсли

глГСЧ = Новый ГенераторСлучайныхЧисел;
глМассивЦветов = Новый Массив;
глМассивЦветов.Добавить(Новый Цвет(255, 255, 255));
глМассивЦветов.Добавить(Новый Цвет(254, 251, 251));
глМассивЦветов.Добавить(Новый Цвет(254, 192, 192));
глМассивЦветов.Добавить(Новый Цвет(254, 106, 106));
глМассивЦветов.Добавить(Новый Цвет(254, 68, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 84, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 116, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 164, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 215, 62));
глМассивЦветов.Добавить(Новый Цвет(249, 249, 64));
глМассивЦветов.Добавить(Новый Цвет(165, 234, 74));
глМассивЦветов.Добавить(Новый Цвет(99, 207, 86));
глМассивЦветов.Добавить(Новый Цвет(62, 230, 200));
глМассивЦветов.Добавить(Новый Цвет(62, 237, 254));
глМассивЦветов.Добавить(Новый Цвет(62, 181, 232));
глМассивЦветов.Добавить(Новый Цвет(62, 109, 190));
глМассивЦветов.Добавить(Новый Цвет(160, 62, 185));
глМассивЦветов.Добавить(Новый Цвет(254, 95, 219));
глМассивЦветов.Добавить(Новый Цвет(254, 207, 243));

Для раскраски нужно приписать событие в обработчик ПриПолученииДанных:

Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

    
РаскраситьТЧ(Элемент, ОформленияСтрок); //01.04.2011

КонецПроцедуры

 

 

 

 

Скачать файлы

Наименование Файл Версия Размер
Раскраска.epf 78
.epf 8,10Kb
21.02.13
78
.epf 8,10Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. rsu5 (rsu5) 31.03.11 18:00
2. Serj (Serj1C) 31.03.11 20:43
(1) всего то в двух строках
3. Андрей Акулов (DrAku1a) 01.04.11 09:08
Ага... давайте внесем в стандартную конфу такие изменения, при этом надо включить режим изменения конфигурации, и потом будем огребать по попе при каждом обновлении баз )))
dj_serega; hansolo686; +2 2 Ответить 1
4. Serj (Serj1C) 01.04.11 10:36
(3) Всегда можно вернуться к конфигурации поставщика
5. Иван Дижа (IDija) 01.04.11 15:15
(0) Мне очень даже симпатично!!!Да и пользователи довольны! А изменение кода - ерунда! Можно и откатить...
6. Сонечка (esa35) 10.11.11 10:51
да, прикольненько!надо будет попробовать подшутить!
7. Евген Каравашкин (Lokiy) 10.11.11 11:05
Чето ломает меня конфу ради прикола такого обновлять, еще в переферийки ее тащить.
9. samir omarov (balabani) 23.11.11 02:21
Спасибо хорошая обработка
10. Павел (dardroze) 11.01.12 16:25
поставлю, посмотрим, что скажут бухгалтера
11. Иляна Кандаурова (lilly) 12.01.12 20:37
12. andreysan (andreysan) 03.04.12 09:58
Да ладно, до ума довести недолго , доработать под личные нужды, а идея неплохая
13. denis leonov (curys) 05.04.12 12:37
отличная шутка, спасибо автору, попробую сейчас заюзаем=)
14. Дмитрий Глеков (glek) 03.09.12 15:36
Пошутить - можно. Только не массово. Потому что замаешься по клиентам откатывать. Не хватает какого-то отключения.
15. Vlad (KillHunter) 03.09.12 17:25
16. Сергей Галюк (dj_serega) 24.10.12 11:42
Если бы было внешней обработкой было бы круче.
17. taste (taste) 24.10.12 12:04
кто оценил данную приколюху ??
18. alex Alex (shuhorov) 24.10.12 12:36
+ 1 за внешнюю, можно будет добавить в запуск при старте платформы
19. Елена Рябова (Xleo777) 29.03.13 18:25
Можно сделать свой общий модуль


#Если Клиент Тогда
Функция РаскраситьСтрокиРадиШутки() Экспорт // 01.04.2011
глГСЧ = Новый ГенераторСлучайныхЧисел;
Если Формат(ТекущаяДата(), "ДФ=ddMM")="0104" Тогда
Возврат Ложь;
КонецЕсли;

Если глГСЧ.СлучайноеЧисло(0, 100)>13 Тогда
Возврат Ложь;
КонецЕсли;

Возврат Истина;

КонецФункции

Процедура РаскраситьТЧ(Элемент, ОформленияСтрок) Экспорт // 01.04.2011
Попытка

Сч = 0;
глМассивЦветов = ПолучитьМассивЦветов();
макс = глМассивЦветов.Количество();
ЭтоТЗ = ТипЗнч(Элемент.Значение)=Тип("ТаблицаЗначений") Или Найти(ТипЗнч(Элемент.Значение), "табличная часть")>0;

Для Каждого Оформление Из ОформленияСтрок Цикл

Если ЭтоТЗ Тогда
Оформление.ЦветФона = глМассивЦветов[ Элемент.Значение.Индекс(Оформление.ДанныеСтроки) % макс];
Иначе
Оформление.ЦветФона = глМассивЦветов[ Сч % макс ];
Сч = Сч+1;
КонецЕсли;

КонецЦикла;

Исключение
КонецПопытки;
КонецПроцедуры
#КонецЕсли

Функция ПолучитьМассивЦветов()
глМассивЦветов = Новый Массив;
глМассивЦветов.Добавить(Новый Цвет(255, 255, 255));
глМассивЦветов.Добавить(Новый Цвет(254, 251, 251));
глМассивЦветов.Добавить(Новый Цвет(254, 192, 192));
глМассивЦветов.Добавить(Новый Цвет(254, 106, 106));
глМассивЦветов.Добавить(Новый Цвет(254, 68, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 84, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 116, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 164, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 215, 62));
глМассивЦветов.Добавить(Новый Цвет(249, 249, 64));
глМассивЦветов.Добавить(Новый Цвет(165, 234, 74));
глМассивЦветов.Добавить(Новый Цвет(99, 207, 86));
глМассивЦветов.Добавить(Новый Цвет(62, 230, 200));
глМассивЦветов.Добавить(Новый Цвет(62, 237, 254));
глМассивЦветов.Добавить(Новый Цвет(62, 181, 232));
глМассивЦветов.Добавить(Новый Цвет(62, 109, 190));
глМассивЦветов.Добавить(Новый Цвет(160, 62, 185));
глМассивЦветов.Добавить(Новый Цвет(254, 95, 219));
глМассивЦветов.Добавить(Новый Цвет(254, 207, 243));
Возврат глМассивЦветов
КонецФункции
20. Станислав Гирман (Niberu) 23.04.13 10:14
И может в подписку на какое-нибудь событие запихать.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа