gifts2017

Функция проверки номеров расчетных счетов (IBAN)

Опубликовал Евгений Тейфель (BadMadJohn) в раздел Обработки - Обработка справочников

Функция проверки номера расчетного счета на соответствие стандарту. (По контрольной сумме).

Скачать файлы

Наименование Файл Версия Размер
Проверка IBAN 96
.epf 7,02Kb
18.11.14
96
.epf 7,02Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. misha226 (misha226) 27.04.11 12:16
Хотелось бы по подробней... ;)
2. Rauan Sandybaev (sandybaev) 05.11.14 15:46
(1) misha226, вот держи специально для тебя.

В моем случае длина кода составляет 20 знаков
вдохновение брал вот отсюда:
http://www.morfoedro.it/doc.php?n=219&lang=ru


Функция ПроверитьКорректностьIBANКода(КодДляПроверки)

    ДлинаПравильная = ?(СтрДлина(КодДляПроверки) = 20, Истина, Ложь);
    
    Если ДлинаПравильная Тогда
        
        ПреобразованнаяСтрока = Перетащить4ЗнакаНазад(Строка(КодДляПроверки));
        
        ном = 0;
        ИтоговаяСтрока = "";
        Для Ном = 1 По СтрДлина(ПреобразованнаяСтрока) Цикл
        
            ИтоговаяСтрока = ИтоговаяСтрока + ВернутьЭквивалент(Сред(ПреобразованнаяСтрока, Ном, 1));	
        
        КонецЦикла; 
        
        
        Первые7Знаков = Лев(ИтоговаяСтрока, 7);
        
        ИтоговаяСтрока = СтрЗаменить(ИтоговаяСтрока, Первые7Знаков, "");
        
        Вторые7Знаков = Лев(ИтоговаяСтрока, 7);
        
        ИтоговаяСтрока = СтрЗаменить(ИтоговаяСтрока, Вторые7Знаков, "");
        
        Третьи7Знаков = Лев(ИтоговаяСтрока, 7);
        
        ИтоговаяСтрока = СтрЗаменить(ИтоговаяСтрока, Третьи7Знаков, "");
        
        Остаток       = Прав(ИтоговаяСтрока, 1);
        
        
        
        
        ПодготовленнаяСтрока = Первые7Знаков;
        
        ОстатокОтДеления = Число(ПодготовленнаяСтрока)%97;
        
        ПодготовленнаяСтрока = Строка(ОстатокОтДеления) + Вторые7Знаков;
        
        ОстатокОтДеления = Число(ПодготовленнаяСтрока)%97;
        
        ПодготовленнаяСтрока = Строка(ОстатокОтДеления) + Третьи7Знаков;
        
        ОстатокОтДеления = Число(ПодготовленнаяСтрока)%97;
        
        ПодготовленнаяСтрока = Строка(ОстатокОтДеления) + Остаток;
        
        ОстатокОтДеления = ПодготовленнаяСтрока%97;
        
        
        Если ОстатокОтДеления = 1 Тогда
            Возврат истина;
        Иначе	
            Возврат Ложь;
        КонецЕсли; 
        
    Иначе
        
        Возврат Ложь;
        
    КонецЕсли; 
    

КонецФункции // ()


и ещё две функции очень простых

Функция Перетащить4ЗнакаНазад(КодДляПроверки)

	ЧетыреЗнака = Лев(КодДляПроверки, 4);
    
    БезЧетырехЗнаков = СтрЗаменить(КодДляПроверки, ЧетыреЗнака, "");
    
    ИтоговаСтрока = БезЧетырехЗнаков + ЧетыреЗнака;
    
    Возврат ИтоговаСтрока;

КонецФункции // ()

Функция ВернутьЭквивалент(ОчереднойЗнак)

    а = 0;
    
    Если ОчереднойЗнак = "0" Тогда
    	Возврат "0";
    ИначеЕсли ОчереднойЗнак = "1" Тогда    
    	Возврат "1";
    ИначеЕсли ОчереднойЗнак = "2" Тогда    
    	Возврат "2";
    ИначеЕсли ОчереднойЗнак = "3" Тогда    
    	Возврат "3";
    ИначеЕсли ОчереднойЗнак = "4" Тогда    
    	Возврат "4";
    ИначеЕсли ОчереднойЗнак = "5" Тогда    
    	Возврат "5";
    ИначеЕсли ОчереднойЗнак = "6" Тогда    
    	Возврат "6";
    ИначеЕсли ОчереднойЗнак = "7" Тогда    
    	Возврат "7";
    ИначеЕсли ОчереднойЗнак = "8" Тогда    
    	Возврат "8";
    ИначеЕсли ОчереднойЗнак = "9" Тогда    
    	Возврат "9";
    ИначеЕсли ОчереднойЗнак = "A" Тогда    
    	Возврат "10";
    ИначеЕсли ОчереднойЗнак = "B" Тогда    
    	Возврат "11";
    ИначеЕсли ОчереднойЗнак = "C" Тогда    
    	Возврат "12";
    ИначеЕсли ОчереднойЗнак = "D" Тогда    
    	Возврат "13";
    ИначеЕсли ОчереднойЗнак = "E" Тогда    
    	Возврат "14";
    ИначеЕсли ОчереднойЗнак = "F" Тогда    
    	Возврат "15";
    ИначеЕсли ОчереднойЗнак = "G" Тогда    
    	Возврат "16";
    ИначеЕсли ОчереднойЗнак = "H" Тогда    
    	Возврат "17";
    ИначеЕсли ОчереднойЗнак = "I" Тогда    
    	Возврат "18";
    ИначеЕсли ОчереднойЗнак = "J" Тогда    
    	Возврат "19";
    ИначеЕсли ОчереднойЗнак = "K" Тогда    
    	Возврат "20";
    ИначеЕсли ОчереднойЗнак = "L" Тогда    
    	Возврат "21";
    ИначеЕсли ОчереднойЗнак = "M" Тогда    
    	Возврат "22";
    ИначеЕсли ОчереднойЗнак = "N" Тогда    
    	Возврат "23";
    ИначеЕсли ОчереднойЗнак = "O" Тогда    
    	Возврат "24";
    ИначеЕсли ОчереднойЗнак = "P" Тогда    
    	Возврат "25";
    ИначеЕсли ОчереднойЗнак = "Q" Тогда    
    	Возврат "26";
    ИначеЕсли ОчереднойЗнак = "R" Тогда    
    	Возврат "27";
    ИначеЕсли ОчереднойЗнак = "S" Тогда    
    	Возврат "28";
    ИначеЕсли ОчереднойЗнак = "T" Тогда    
    	Возврат "29";
    ИначеЕсли ОчереднойЗнак = "U" Тогда    
    	Возврат "30";
    ИначеЕсли ОчереднойЗнак = "V" Тогда    
    	Возврат "31";
    ИначеЕсли ОчереднойЗнак = "W" Тогда    
    	Возврат "32";
    ИначеЕсли ОчереднойЗнак = "X" Тогда    
    	Возврат "33";
    ИначеЕсли ОчереднойЗнак = "Y" Тогда    
    	Возврат "34";
    ИначеЕсли ОчереднойЗнак = "Z" Тогда    
    	Возврат "35";
    КонецЕсли; 
    
КонецФункции // ВернутьЭквивалент()
...Показать Скрыть


так что мани можно не тратить. сорри.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа