bdd2

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310)

Опубликовал Александр Нужный (Q-Q) в раздел Программирование - Практика программирования

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм).  Вернём полезную функцию!

В модуле формы справочника сотрудники, в процедуру ПриНажатииКнопки() добавляем в указанном месте:

Процедура ПриНажатииКнопки()
    
    Кнопка = Форма.АктивныйЭлемент();
    
    ЕстьСтраховыеВзносы = глЕстьСтраховыеВзносы(); 
    
    // Если нажали кнопку <Ввод данных>, то
    // формируется список форм для редактирования данных сотрудника (Т-2, Т-4,
    // Справка, Налоговая карточка, ...) и открывается выбранная пользователем форма.
    Если Кнопка="кнВводДанных" Тогда
        Если Выбран()=0 Тогда
            Предупреждение("Перед вводом данных необходимо записать этот элемент справочника (кнопка ""Записать"")");
            Возврат;
        КонецЕсли;
        СписокВыбора = СоздатьОбъект("СписокЗначений");
        Периодический = СоздатьОбъект("Периодический");
        Периодический.ИспользоватьОбъект("СостояниеФизлица",ТекущийЭлемент());
        СостояниеСотрудника = Периодический.ЗначениеНаДату(ИспользоватьДату());
        ДатаЗнач = ИспользоватьДату();
        Пока ПустоеЗначение(СостояниеСотрудника)=1 Цикл
            Если Периодический.НайтиЗначение(ДатаЗнач,-1)=0 Тогда
                Прервать
            КонецЕсли;
            СостояниеСотрудника = Периодический.Значение;
            ДатаЗнач = Периодический.ДатаЗнач-1;
        КонецЦикла;
        Если (ПустоеЗначение(СостояниеСотрудника)=0) и (глВоеннослужащий(ТекущийЭлемент(), ИспользоватьДату()) = 0) Тогда
            Если (СостояниеСотрудника=Перечисление.СостояниеФизлица.Госслужащий) Тогда
                СписокВыбора.ДобавитьЗначение("ФормаТ2ГС","Форма Т-2ГС");
            Иначе
                СписокВыбора.ДобавитьЗначение("ФормаТ2","Форма Т-2");
                Если Должность.Категория=Перечисление.КатегорииСотрудников.НаучныеИПедагогическиеРаботники Тогда
                    СписокВыбора.ДобавитьЗначение("ФормаТ4","Форма Т-4");
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        
        ДатаОтчета = ИспользоватьДату();
        
        СписокВыбора.ДобавитьЗначение("ВычетыСотрудниковПоНДФЛ","Вычеты по НДФЛ");        
        ГодОтчета = ДатаГод(ДатаОтчета); 
        Если ГодОтчета >= 2011 Тогда
            СписокВыбора.ДобавитьЗначение("КорректировкаДанныхПоНДФЛ","Корректировка данных по НДФЛ");  
            //Вставка
            СписокВыбора.ДобавитьЗначение("Форма1НДФЛ2009","Налоговая карточка 1-НДФЛ (форма с 2009 года)");
            //Конец вставки
        Иначе
            СписокВыбора.ДобавитьЗначение("Форма1НДФЛ2009","Налоговая карточка 1-НДФЛ (форма с 2009 года)");    
        КонецЕсли;

 


В форму обработки Форма1НДФЛ2009, в процедуру ПриОткрытии() добавляем в указанном месте:

 

Процедура ПриОткрытии()
    Если ТипЗначенияСтр(Форма.Параметр)="СписокЗначений" Тогда
        
        Параметры = Форма.Параметр;
        
        // основные параметры
        ДатаГода = Параметры.Получить("ДатаАктуальности");
        ФизЛицо = Параметры.Получить("Сотрудник");
        
        СпЛет.ДобавитьЗначение(2009, "2009 г.");
        СпЛет.ДобавитьЗначение(2010, "2010 г.");
        СтрокаТекущегоГода = СпЛет.НайтиЗначение(2010);
        Год = 2010;      
        
        //Вставка         
        СпЛет.ДобавитьЗначение(2011, "2011 г.");
        СтрокаТекущегоГода = СпЛет.НайтиЗначение(2011);
        Год = 2011; 
        //Конец вставки
        
        Если СтрокаТекущегоГода <> 0 Тогда

Готово! Можно пользоваться!

 

См. также

Добавить вознаграждение
Комментарии
1. rimma_n (rimma_n) 165 29.04.11 12:06 Сейчас в теме
а как же налоговый регистр по ндфл? появился в 2011 году. там прекрасно все суммы расшифрованы по видам дохода
считаю лишним. надо привыкать к новым формам, а не делать "как было раньше" :(
2. Илья (gucci76) 341 29.04.11 14:23 Сейчас в теме
(1) Использование 1НДФЛ не приведет же к ошибке, а привычка это дело личное. Думаю "минус" за это ставить не справедливо.
3. Vladimir (Boroda) 90 29.04.11 18:24 Сейчас в теме
Регистр, на мой взгляд, это вырожденец 1-НДФЛ, где данные по налогообложению были представлены наглядно и компактно.До сих пор удивляюсь, что 1С ушла от этой удобной формы, хотя можно было сделать пресловутый регистр и на основе 1НДФЛ, а не вводить Корректировку. Примеры этому на сайте здесь, кажется, есть. Однозначно - плюс.
4. Анатолий (agdedov) 07.05.11 13:43 Сейчас в теме
Конечно плюс! В НДФЛ-1 весь расчет налогов как на ладони (компактно и информативно)! Налоговый регистр - это извращение.
5. Sanych22 (Sanych22) 10.05.11 11:06 Сейчас в теме
Вообще то 1-НДФЛ не убрали совсем, а перенесли в подменю "Старые формы"
Достаточно было подправить модуль обработки 1-НДФЛ (добавить год 2011)
6. JER MARK (JER_MARK) 27.12.11 16:38 Сейчас в теме
Автору плюс - просто объяснил и показал. Мне пришлось делать тоже - любят бухи эту форму, да и я уже тоже. Регистр это просто неразбериха какая-то.
7. JER MARK (JER_MARK) 12.02.12 08:46 Сейчас в теме
Эх, а с новыми вычетами что делать....
8. Илья (gucci76) 341 12.02.12 20:41 Сейчас в теме
че, есть желание использовать 1НДФЛ?