gifts2017

Заполнение инвентаризации товаров на складе УПП 1.3 по типу цен (обработка по заполнению табличной части)

Опубликовал rusrus rusrus (rusrus) в раздел Обработки - Обработка документов

Заполняет инвентаризацию товаров на складе по выбранной категории цен.

Ни для кого не будет откровением, что у ГБ своя правда. Это может быть и правильно, ведь как объяснить материально-ответственным лицам, что стоимость ватрушки в инвентаризации всего 30 коп., потому что.....

В общем, заполняем по установленным типам цен и взыскиваем разницу Smile шутка.

p.s. Если сообщество напишет, что такое уже есть- удалю.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Обработка
.epf 8,56Kb
11.05.11
105
.epf 8,56Kb 105 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Койчин Дияз (el_diaz) 18.05.11 14:09
Спасибо! пригодилось бы месяца 2 назад. Мне для этих целей пришлось переписывать документ инвентаризации :(
2. sound sound (sound) 18.05.11 17:18
3. rusrus rusrus (rusrus) 23.05.11 13:54
sound пишет:

Случайно не тоже самое, что у меня http://infostart.ru/public/84764/ ?

Нет, у Вас фиксированным значением заполнение идет. У меня идет обращение к регистру сведений цен и пересчитывается сумма для учетных и фактических показателей. Посмотрел другие универсальные- там пользователям предлагается с бубном потанцевать.
5. Александр Медведев (anig99) 18.10.11 09:23
Есть пара претензий:
- запрос по ценам не учитывает коэффициенты
- управленческая валюта равна бухгалтерской

таким образом обработка узко специализирована.
Вот. Лень-стайл.

Процедура Инициализировать (Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт

	мВалютаРегламентированногоУчета = Константы.ВалютаРегламентированногоУчета.Получить();
	мВалютаУпрУчета 				= Константы.ВалютаУправленческогоУчета.Получить();
	СтруктураКурса             		= МодульВалютногоУчета.ПолучитьКурсВалюты(мВалютаУпрУчета, Объект.Дата);
	мКурсУпрУчета              		= СтруктураКурса.Курс;
	мКратностьУпрУчета        		= СтруктураКурса.Кратность;
	
	СпособЗаполненияЦен = Перечисления.СпособыЗаполненияЦен.ПоЦенамНоменклатуры;

	ОбъектФальшивка 	 = Документы.ОприходованиеТоваров.СоздатьДокумент();
	ЗаполнитьЗначенияСвойств(ОбъектФальшивка, Объект);
	Для Каждого стр из Объект[ИмяТабличнойЧасти] Цикл
		стр1 = ОбъектФальшивка[ИмяТабличнойЧасти].Добавить();
		ЗаполнитьЗначенияСвойств(стр1, стр);
	КонецЦикла;
	
	// Задать набор реквизитов для редактирования.
	СтруктураРеквизитовДокумента = Ценообразование.ПолучитьСтруктуруРеквизитовДокументаДляЦенообразования(ОбъектФальшивка);

	// Вызов общей формы "Цены и валюта" и пересчеты по результатам выбора в этой форме.
	СтруктураЗначений = Ценообразование.ОткрытьФормуЦеныИВалюта(ОбъектФальшивка, СтруктураРеквизитовДокумента, мВалютаРегламентированногоУчета,
	                                            , "Товары");
	Если СтруктураЗначений <> Неопределено Тогда
		ЗаполнениеДокументов.ИзменитьЦеныВалюту(ОбъектФальшивка, СпособЗаполненияЦен, СтруктураРеквизитовДокумента, , ИмяТабличнойЧасти, мВалютаРегламентированногоУчета, , СтруктураЗначений);
	КонецЕсли;
	
	Номер = 0;
	Для Каждого стр из ОбъектФальшивка[ИмяТабличнойЧасти] Цикл
		СтрокаТабличнойЧасти = Объект[ИмяТабличнойЧасти][Номер];
		СтрокаТабличнойЧасти.Цена = стр.Цена;
		ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
		СтрокаТабличнойЧасти.СуммаРегл        = МодульВалютногоУчета.ПересчитатьИзВалютыВВалюту(СтрокаТабличнойЧасти.Сумма, мВалютаУпрУчета, 
								мВалютаРегламентированногоУчета, мКурсУпрУчета, 1, мКратностьУпрУчета, 1);
		Номер = Номер + 1;
	КонецЦикла;

	ОбъектФальшивка = Неопределено;
КонецПроцедуры
...Показать Скрыть
6. Геннадий Малюков (bes-kkm) 14.08.12 09:46
Объясните пожалуйста поподробнее, если я правильно понимаю, то в документе инвентаризация заполняются цены, которые мы сами выберем ( розничные, закупочные и.т.д.), а не как в стандартном документе цены - это себестоимость.
7. Геннадий Малюков (bes-kkm) 14.08.12 09:48
Будет работать с управлением торговли 8.2 (10.3)?
8. Геннадий Малюков (bes-kkm) 15.08.12 08:21
Выдает Ошибка загрузки документа. Внешняя обработка не может быть прочитана текущей версией программы.
9. Геннадий Малюков (bes-kkm) 15.08.12 08:34
Теперь выдает: {Форма.Форма.Форма(32)}: Значение не является значением объектного типа (Дата)
КурсВал = МодульВалютногоУчета.ПолучитьКурсВалюты(Константы.ВалютаУправленческогоУчета.Получить(), Докум.Дата);
10. Геннадий Малюков (bes-kkm) 15.08.12 10:34
Извиняюсь, все заработало, подключила к документу Инвентаризация и из документа все работает
11. Геннадий Малюков (bes-kkm) 15.08.12 10:35
Спасибо автору, очень хорошая обработка!!!
12. Irina Bondarenko (iris_reda) 13.03.15 03:57
13. Denis Chernyaev (denplintus) 01.10.15 16:37
Подскажите пожалуйста, на комбинации "платформа 8.3.6.2041, конф.УПП 1.3.67.3" будет работать? Очень надо такую обработку!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа