gifts2017

Ошибка Выгрузки проводок из ЗиК 311 в Бухгалтерию бюджетного учреждения

Опубликовал RUSLAN (RUS63) в раздел Обмен - Перенос данных из 1С7.7 в 1C8.X

При формировании свода проводок и  выгрузке проводок из ЗиК 311 в Бухгалтерию бюджетного учр. используется как  "новый" 401.20 так и "старый" счет 401.01 ( там собираются "копейки").
Бухгалтерия ред6.2 отказывается грузить такие проводки.

В файле также реализована форма 1-ндфл для 2011г.

Скачать файлы

Наименование Файл Версия Размер
Зик311md 44
.rar 5,84Mb
09.08.13
44
.rar 5,84Mb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Anthon Sahrahninn (Anthon) 08.06.11 18:51
проблема копеек исправляется раз и навсегда двумя вкраплениями в процедуру глПроводкиЗаПериод2011

ТаблицаКорреспонденцийПрошлыхПериодов="";
//Anthon -<
ТаблицаНеокругленная = СоздатьОбъект("ТаблицаЗначений");
ТаблицаКорреспонденций.Выгрузить(ТаблицаНеокругленная);
ТаблицаКорреспонденций.Свернуть("Шаблон,ШаблонРБП", "Сумма,Количество,БазаНалога,СуммаЕСН_ФБ,СуммаДопТариф,СуммаФСС,СуммаФФОМС,СуммаТФОМС,СуммаПФР_страх,СуммаПФР_нак,СуммаФСС_НС");
//Anthon ->

Если (ТолькоНачисления=0) Тогда

и

глСтатусСтрока(Форма,"Обработка данных о проводках ");
//Anthon -<
ТаблицаНеокругленная.Выгрузить(ТаблицаКорреспонденций);
//Anthon ->


ТаблицаКорреспонденций.НоваяКолонка("СчетДебета","Справочник.ПланСчетов");


вы до сих пор с ними мучаетесь?
2. RUSLAN (RUS63) 09.06.11 09:16
Да, но особых стаданий не испытываю. Просто я столько пользовался халявой на инфостарте, что захотелось что-то сделать для других. На нобелескую премию не претендую. Глобальным поиском нашел "ручные" счета 40101, заменил. если про 1-Ндфл, то была статья http://infostart.ru/public/84753/. Все слепил готовое предоставил.
3. Anthon Sahrahninn (Anthon) 09.06.11 13:01
Это ведь косяк 1С. Кстати, проверьте, сработает у вас или нет? А то у меня в конфиге больше тысячи исправлений, может, еще что надо будет... Кстати, иногда есть смысл исправления прям текстом выкладывать, чтобы народ мог оценить степень испорченности конфиги, если, конечно, их не очень много. Иногда качать мд лень, некогда или запрещено. Но все равно спасибо за инфу.
4. Anthon Sahrahninn (Anthon) 29.06.11 19:44
сразу видно, что вы не программист. даже не смотрите, что код делает.

Если Счета.НайтиПоКоду("401.20.1") = 1 Тогда
СчетПрочихДоходов = Счета.ТекущийЭлемент();
СчетПрочихРасходов= СчетПрочихДоходов;
КонецЕсли;

это, по-вашему, правильно? вы хоть новый план счетов изучали? я так и думал, что вы тупо замену сделали. это любой дурак сможет сделать...
такой код более корректный:

Если Счета.НайтиПоКоду("401.01.1") = 1 Тогда
СчетПрочихДоходов = Счета.ТекущийЭлемент();
СчетПрочихРасходов= СчетПрочихДоходов;
КонецЕсли;
//Anthon -<
Если Константа.ПрограммаБухучета = Перечисление.БухгалтерскиеПрограммы.Бюджетная62 Тогда
Если Счета.НайтиПоКоду("401.10.1") = 1 Тогда
СчетПрочихДоходов = Счета.ТекущийЭлемент();
КонецЕсли;
Если Счета.НайтиПоКоду("401.20.1") = 1 Тогда
СчетПрочихРасходов = Счета.ТекущийЭлемент();
КонецЕсли;
КонецЕсли;
//Anthon ->
Иначе //это "старые" бюджетные конфигурации


наверное, вы и файл правил переноса из зарплаты в бухгалтерию 6.2 PR2_AB61.XML тоже просто переименовали, да?
5. Татьяна Цепулина (tene) 20.10.11 15:13
Это пост очень здорово помог, были проблемы на тот момент у клиента. Насколько знаю, позже этот косяк был устранен.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа