gifts2017

Анализ счета, ОСВ и ОСВ по счету. ББУ 7.7

Опубликовал Alexei Kochkun (alexolder) в раздел Отчеты - Бухгалтерские

Хоть 7-ка, может быть, уже никому не нужна, предлагаю для ознакомления слегка измененные стандартные отчеты. Уже не помню, с какой редакции ББУ 6.1 переношу их, несколько лет. Думаю, подойдет к любой бюджетной конфигурации. Комментарии к изменениям вроде стоят.

Суть изменений:

1. ОСВ. При выборе источника финансирования не дублируются в отчете счета с нулем впереди. То есть, если выбрали 2-ку, то на печать вылезет только 2-ка без загромождения дублирующими строчками. И бумагу экономим, и наглядность в несколько раз выше.
2. Анализ счета: То же, что и в 1. Плюс выводятся названия счетов. Считаю, что нагляднее, чем в стандартной поставке. Но убрана валюта. Пришлось "пожертвовать".
3. В оборотке по счету изменен состав видов субконто, отображаемых по умолчанию!  Следущие субконто по умолчанию в режиме "не учитывать":

  • фкр
  • ОГС
  • Договоры
  • ВидыДвиженийНФА

И упрощенный вывод при нажатой галке "только количество"

-=-=-=-=-=-=-=-

Принцип публикации: как есть. Нравится - используйте. Не нравится - сделайте сами :)

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Конфигурация с ОСВ, ОСВ по счету и Анализом счета
.MD 262,00Kb
08.06.11
32
.MD 262,00Kb 32 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Alexei Kochkun (alexolder) 29.09.11 18:33
Хоть 7-ка, может быть, уже никому не нужна, предлагаю для ознакомления слегка измененные стандартные отчеты. Уже не помню, с какой редакции ББУ 6.1 переношу их, несколько лет. Думаю, подойдет к любой бюджетной конфигурации. Комментарии к изменениям вроде стоят.


Перейти к публикации

1. Ирина Нечаева (Arin) 29.09.11 18:33
2. Alexei Kochkun (alexolder) 29.09.11 19:59
И вам спасибо, за отзыв.
Мои подопечные к этим отчетам привыкли и даже не знают, не помнят про стандартные, неизмененные.
А еще они не любят документы с множеством закладок. Я всегда им переделываю РКО, ПКО и платежки так, чтобы все видно было сразу на одной, первой закладке. Очень ускоряет ввод данных и наглядность.
В ПКО, РКО автоматизирую заполнение КОСГУ (по хвостам счетов 208/206/302).
И повышаю наглядность в журналах.
Теперь потихоньку осваиваю 8-ку и переношу "лакомства" туда.
3. Артур Карелин (atb123) 03.10.11 23:26
4. Alexei Kochkun (alexolder) 04.10.11 01:37
Например автоматом ЭКР в расходнике (РКО)

Процедура ПриВыбореСчетаДебет()
Если КорСчет.Выбран()=0 Тогда
Возврат;
КонецЕсли;
Если КорСчет.Забалансовый=1 Тогда
Предупреждение("Корреспондирующий счет не может быть забалансовым!");
КорСчет="";
Возврат;
КонецЕсли;

Если ПустоеЗначение(ГрСчКредит)=0 Тогда
ДлГрСч=СтрДлина(СокрП(ГрСчКредит));
Если Лев(КорСчет.Код,ДлГрСч)<>СокрП(ГрСчКредит) Тогда
Предупреждение("Корреспондирующий счет не соответствует хозоперации!");
КорСчет="";
Возврат;
КонецЕсли;
КонецЕсли;

СписокКБК="";
Если глДопустимыеКБКСчета(ВыбраннаяФирма,КорСчет,КорСчет.ИсточникФинансирования,СписокКБК)=1 Тогда
Если СписокКБК.Принадлежит(ФКР)=0 Тогда
ФКР="";
КонецЕсли;
Иначе
ФКР="";
КонецЕсли;

УстановитьСубконтоКорСчета();
//Изменения
Ог = СоздатьОбъект("Справочник.ОГС"); Ксч = Лев(КорСчет.Код, 6);
Если Ксч = "205.03" Тогда Если ОГ.НайтиПоКоду(130, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "205.10" Тогда Если ОГ.НайтиПоКоду(130, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.04" Тогда Если ОГ.НайтиПоКоду(221, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.05" Тогда Если ОГ.НайтиПоКоду(222, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.06" Тогда Если ОГ.НайтиПоКоду(223, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.07" Тогда Если ОГ.НайтиПоКоду(224, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.08" Тогда Если ОГ.НайтиПоКоду(225, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.09" Тогда Если ОГ.НайтиПоКоду(226, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.18" Тогда Если ОГ.НайтиПоКоду(290, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.19" Тогда Если ОГ.НайтиПоКоду(310, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "208.22" Тогда Если ОГ.НайтиПоКоду(340, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "210.03" Тогда Если ОГ.НайтиПоКоду(130, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.01" Тогда Если ОГ.НайтиПоКоду(211, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.02" Тогда Если ОГ.НайтиПоКоду(212, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.03" Тогда Если ОГ.НайтиПоКоду(213, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.04" Тогда Если ОГ.НайтиПоКоду(221, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.05" Тогда Если ОГ.НайтиПоКоду(222, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.06" Тогда Если ОГ.НайтиПоКоду(223, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.07" Тогда Если ОГ.НайтиПоКоду(224, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.08" Тогда Если ОГ.НайтиПоКоду(225, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.09" Тогда Если ОГ.НайтиПоКоду(226, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.18" Тогда Если ОГ.НайтиПоКоду(290, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.19" Тогда Если ОГ.НайтиПоКоду(310, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "302.22" Тогда Если ОГ.НайтиПоКоду(340, 0) = 1 Тогда КонецЕсли;
ИначеЕсли Ксч = "401.01" Тогда Если ОГ.НайтиПоКоду(130, 0) = 1 Тогда КонецЕсли;
КонецЕсли;
ОГС = Ог.ТекущийЭлемент();
Если ПустоеЗначение(Огс) = 0 Тогда ЭКР = ОГС; ПриВыбореЭКР(); КонецЕсли;
ПриВыбореЭКР();
//КонецИзменения
ПриВыбореЭКР();

КонецПроцедуры
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа